고유 값 필터링 또는 중복 값 제거

적용 대상
Microsoft 365용 Excel Excel 2024 Excel 2021 Excel 2019 Excel 2016

Excel에서는 고유 값을 필터링하거나 중복 값을 제거하는 여러 가지 방법을 사용할 수 있습니다.

  • 고유 값을 필터링하려면 데이터 > 정렬 & > 필터 고급을 선택합니다.
    필터 고급
  • 중복 값을 제거하려면 Data > Data Tools > 중복 제거를 선택합니다.
    중복된 항목 제거
  • 고유 또는 중복 값을 강조 표시하려면 홈 탭의 스타일 그룹에서 조건부 서식 명령을 사용합니다.

고유 값 필터링 또는 중복 값 제거에 대해 알아보기

고유 값 필터링 및 중복 값 제거는 고유 값 목록을 표시하는 것이 목적이므로 유사한 두 작업입니다. 그러나 중요한 차이점이 있습니다. 고유 값을 필터링하면 중복 값이 일시적으로만 숨겨집니다. 그러나 중복 값을 제거한다는 것은 중복 값이 영구적으로 삭제된다는 것을 의미합니다.

중복 값은 적어도 한 행의 모든 값이 다른 행의 모든 값과 동일한 값입니다. 중복 값 비교는 셀에 저장된 기본 값이 아니라 셀에 나타나는 내용에 따라 달라집니다. 예를 들어 서로 다른 셀에 동일한 날짜 값이 있는 경우 하나는 "3/8/2006"으로 서식이 지정되고 다른 하나는 "Mar 8, 2006"으로 지정되어 있으면 값이 고유합니다.

중복 제거 전에 확인: 중복 값을 제거하기 전에 먼저 고유한 값을 필터링하거나 조건부 서식을 지정하여 예상한 결과를 얻을 수 있는지 확인하는 것이 좋습니다.

고유 값 필터링

단계

  1. 셀 범위를 선택하거나 표에 활성 셀이 있는지 확인합니다.

  2. 정렬 & 필터 그룹에서 데이터 고급을 선택합니다 > .
    필터 고급

  3. 고급 필터 팝업 상자에서 다음 중 하나를 수행합니다.

    • 셀 또는 표 범위를 현재 위치에서 필터링하려면

      • 목록 필터링을 선택합니다.
    • 필터 결과를 다른 위치에 복사하려면 다음을 수행합니다.

      • 다른 위치에 복사를 선택합니다.
      • 복사 위치 상자에 셀 참조를 입력합니다.
      • 또는 대화 상자 축소축소 단추 를 선택하여 팝업 창을 일시적으로 숨기고 워크시트에서 셀을 선택한 다음 확장,확장을 선택합니다.
      • 고유 레코드만 선택한 다음 확인을 선택합니다.
    • 범위의 고유 값이 새 위치로 복사됩니다.

중복 값 제거

중복 값을 제거하면 셀 또는 표 범위의 값에만 영향이 적용됩니다. 셀이나 표의 범위 밖에 있는 다른 값은 변경되거나 이동되지 않습니다. 중복을 제거하면 목록에서 값의 첫 번째 항목은 유지되지만 다른 동일한 값은 삭제됩니다. 

데이터를 영구적으로 삭제하므로 중복 값을 제거하기 전에 원래 셀 범위나 표를 다른 워크시트나 통합 문서에 복사하는 것이 좋습니다.

단계

  1. 셀 범위를 선택하거나 표에 활성 셀이 있는지 확인합니다.

  2. 데이터 탭에서 데이터 도구 그룹에서 중복 제거를 선택합니다.

    doubles 제거

  3. 다음 중 하나 이상을 실행합니다.

    • 열에서 하나 이상의 열을 선택합니다.

    • 모든 열을 빠르게 선택하려면 모두 선택을 선택합니다.

    • 모든 열을 빠르게 지우려면 모두 선택 취소를 선택합니다.
      셀 범위 또는 표에 열이 많은데 몇 개의 열만 선택하려는 경우 모두 선택 취소를 선택한 다음 열 아래에서 해당 열을 선택하는 것이 더 쉬울 수 있습니다.

      참고

      이 단계에서 모든 열을 선택하지 않더라도 모든 열에서 데이터가 제거됩니다. 예를 들어 Column1과 Column2를 선택하고 Column3을 선택하지 않으면 중복을 찾는 데 사용되는 "키"는 BOTH Column1 & Column2의 값이 됩니다. 해당 열에서 중복이 발견되면 테이블 또는 범위의 다른 열을 포함하여 전체 행이 제거됩니다.

  4. 확인을 선택하면 제거된 중복 값 수 또는 남아 있는 고유 값의 수를 나타내는 메시지가 나타납니다. 확인 을 선택하여 이 메시지를 해제합니다.

  5. 실행 취소를 선택하거나 키보드에서 Ctrl+Z를 눌러 변경 내용을 실행 취소합니다.

개요 또는 부분합 데이터에서 중복 제거 문제

개요가 표시되거나 부분합이 있는 개요 데이터에서는 중복 값을 제거할 수 없습니다. 중복 항목을 제거하려면 윤곽선과 부분합을 모두 제거해야 합니다. 자세한 내용은 워크시트의 데이터 목록 개요 및부분합 제거를 참조하세요.

고유 값 또는 중복 값에 조건부 서식 지정

참고

피벗 테이블 보고서의 값 영역에 있는 필드는 고유 값이나 중복 값을 기준으로 조건부 서식을 지정할 수 없습니다.

팁

"중복 값" 서식 규칙을 사용할 때 "Office 작성 언어 및 언어 교정" 설정이 일본어와 같은 DBCS(더블바이트 문자 집합) 인코딩을 사용하는 언어로 설정된 경우 반자 및 전자는 동일하게 처리됩니다. 이 둘을 구분해야 하는 경우 COUNTIF 수식과 함께 "수식을 사용하여 이 수식에 맞는지 확인" 규칙 유형을 사용할 수 있습니다. 예를 들어 A2:A400 범위에서 중복 값을 식별하려면 조건부 서식에 "=COUNTIF($A$2:$A$400,A2)> 1" 수식을 적용합니다.

빠른 서식 지정

단계

  1. 범위, 표 또는 피벗 테이블 보고서에서 한 개 이상의 셀을 선택합니다.
  2. 홈 탭의 스타일 그룹에서 조건부 서식에 대한 작은 화살표를 선택한 다음 셀 강조 규칙을 선택하고 중복 값을 선택합니다.
    빠른 서식 지정
     
  3. 사용할 값을 입력하고 서식을 선택합니다.

고급 서식 지정

단계

  1. 범위, 표 또는 피벗 테이블 보고서에서 한 개 이상의 셀을 선택합니다.

  2. 홈 탭의 스타일 그룹에서 조건부 서식 화살표를 선택한 다음 규칙 관리를 선택하여 조건부 서식 규칙 관리자 팝업 창을 표시합니다.
    규칙 관리

  3. 다음 중 하나를 실행합니다.

    • 조건부 서식을 추가하려면 새 규칙을 선택하여 새 서식 규칙 팝업 창을 표시합니다.
    • 조건부 서식을 변경하려면 서식 규칙 표시 목록에서 적절한 워크시트 또는 표가 선택되어 있는지 먼저 확인합니다. 필요한 경우 선택 축소 축소 단추 팝업 창에서 축소 버튼을 일시적으로 숨깁니다. 워크시트에서 새 셀 범위를 선택한 다음 팝업 창 을 다시 확장 합니다. 규칙을 선택한 다음 규칙 편집 을 선택하여 서식 규칙 편집 팝업 창을 표시합니다.
  4. 규칙 유형 선택에서 고유 또는 중복 값만 서식을 지정합니다.

  5. 규칙 설명 편집의 모두 서식 목록에서 고유 또는 중복을 선택합니다.

  6. 서식을 선택하여 셀 서식 팝업 창을 표시합니다.

  7. 셀 값이 조건을 만족할 때 적용할 숫자, 글꼴, 테두리 또는 채우기 서식을 선택한 다음 확인을 선택합니다. 여러 개의 서식을 선택할 수 있습니다. 선택한 서식이 [미리 보기] 패널에 표시됩니다.

추가 지원

언제든지 Excel 기술 커뮤니티의 전문가에게 문의하거나 커뮤니티에서 지원을 받을 수 있습니다.

참고 항목

중복 값이 있는 범위에서 고유 값 개수 계산