다양한 데이터 원본에서 Excel로 데이터를 가져올 수 있으며 다음 섹션에서 방법을 보여 줍니다. 데이터를 가져온 후 데이터로 수행할 작업에 대한 자세한 내용은 Excel을 통해 데이터가 이동하는 방식을 참조하세요.
테이블/범위에서
현재 통합 문서의 Excel 표, 명명된 범위 또는 동적 배열에서 쿼리를 만들 수 있습니다. 선택한 데이터가 단순 범위인 경우 표로 변환됩니다. 동적 배열을 가져오려면 Microsoft 365 구독이 필요합니다. 동적 배열에 대한 자세한 내용은 동적 배열 수식 및 분산 배열 동작을 참조하세요.
데이터 범위 내에서 아무 셀이나 선택합니다.
테이블/범위에서데이터를> 선택합니다.
이 명령은테이블/범위의다른 원본>의 데이터>에서도 사용할 수 있습니다.
메시지가 표시되면 테이블 만들기 대화 상자에서 범위 선택 단추를 선택하여 데이터 원본으로 사용할 특정 범위를 선택할 수 있습니다.
테이블 또는 데이터 범위에 열 머리글이 있는 경우 내 테이블에 머리글이 있음을 선택합니다. 머리글 셀은 쿼리의 열 이름을 정의하는 데 사용됩니다.
확인을 선택합니다.
자세한 내용은 Excel 표에서 가져오기를 참조하세요.
파일: Excel 통합 문서
- 데이터> 선택Excel 통합 문서의파일>에서데이터를> 가져옵니다.
- Excel 찾아보기 대화 상자에서 쿼리할 파일의 경로를 찾거나 입력합니다.
- 열기를 선택합니다.
원본 통합 문서에 이름이 지정된 범위가 있는 경우 범위의 이름을 데이터 집합으로 사용할 수 있습니다.
고급 연결선 옵션에 대한 자세한 내용은 Excel 통합 문서를 참조하세요.
파일: 텍스트/CSV
다음 절차에서는 기본 단계를 보여줍니다. 자세한 내용은 텍스트(.txt 또는 .csv) 파일 가져오기 또는 내보내기를 참조하세요.
- 데이터> 선택텍스트/CSV의파일>에서데이터를> 가져옵니다.
- 쉼표로 구분된 값 찾아보기 대화 상자에서 쿼리할 파일의 경로를 찾거나 입력합니다.
- 열기를 선택합니다.
참고
CSV 파일에서 데이터를 가져오는 경우 파워 쿼리는 열 이름 및 형식을 포함하여 열 구분 기호를 자동으로 검색합니다. 예를 들어 아래 예제 CSV 파일을 가져온 경우 파워 쿼리는 자동으로 첫 번째 행을 열 이름으로 사용하고 각 열 데이터 형식을 변경합니다.
예제 CSV 파일
파워 쿼리는 각 열 데이터 형식을 자동으로 변경합니다.
- 주문 ID가 숫자로 변경됨
- 현재까지 주문 날짜 변경
- 범주는 텍스트로 유지됩니다(기본 열 형식).
- 제품 이름은 텍스트로 유지됩니다(기본 열 형식).
- 매출이 숫자로 변경
고급 커넥터 옵션에 대한 자세한 내용은 텍스트/CSV를 참조하세요.
파일: XML
다음 절차에서는 데이터를 가져오는 기본 단계를 보여줍니다. 자세한 내용은 XML 데이터 가져오기를 참조하세요.
- XML의파일에서 데이터>>가져오기를 선택합니다>.
- XML 찾기 대화 상자에서 파일을 가져오거나 연결할 파일 URL을 찾거나 입력합니다.
- 열기를 선택합니다.
연결에 성공하면 탐색기 창을 사용하여 XML 파일의 항목 컬렉션을 표 형식으로 찾아보고 미리 볼 수 있습니다.
고급 커넥터 옵션에 대한 자세한 내용은 XML을 참조하세요.
파일: JSON
- 데이터를> 선택하세요.JSON의파일>에서데이터를> 가져옵니다. 데이터 가져오기대화 상자가 나타납니다.
- JSON 파일을 찾아 열기를 선택합니다 .
고급 커넥터 옵션에 대한 자세한 내용은 JSON을 참조하세요.
파일: PDF
중요
PDF 파일을 가져오려고 할 때 "이 커넥터를 사용하려면 하나 이상의 추가 구성 요소를 설치해야 합니다."라는 PDF 메시지가 나타날 수 있습니다. PDF 커넥터를 사용하려면 컴퓨터에 .NET Framework 4.5 이상이 설치되어 있어야 합니다. 여기에서 최신 .NET Framework를 다운로드할 수있습니다.
데이터> 선택PDF의파일>에서데이터> 가져오기.
PDF 파일을 선택한 다음 열기를 클릭합니다. 탐색기 대화 상자에서 PDF가 열리고 사용 가능한 테이블이 표시됩니다.
가져올 테이블을 선택하고 다음 중 하나를 수행합니다.
- Excel에서 직접 데이터를 보려면로드 로드를 선택>하거나 가져오기 대화 상자를 보려면 로드로드를선택합니다>.
- 먼저 파워 쿼리의 데이터로 작업하려면 데이터 변환을 선택합니다.
고급 커넥터 옵션에 대한 자세한 내용은 PDF를 참조하세요.
파일: 폴더
폴더에서 비슷한 스키마와 형식을 가진 여러 파일에서 데이터를 가져올 수 있습니다. 그런 다음 데이터를 하나의 테이블에 추가할 수 있습니다.
- 데이터>폴더의파일>에서데이터> 가져오기를 선택합니다.
- 찾아 보기 대화 상자에서 폴더를 찾은 다음 열기를 선택합니다.
- 자세한 단계는 여러 파일이 있는 폴더에서 데이터 가져오기를 참조하세요.
고급 커넥터 옵션에 대한 자세한 내용은 폴더를 참조하세요.
파일: SharePoint 폴더
SharePoint 라이브러리에서 비슷한 스키마와 형식을 가진 여러 파일에서 데이터를 가져올 수 있습니다. 그런 다음 데이터를 하나의 테이블에 추가할 수 있습니다.
- SharePoint>폴더의파일>에서데이터> 가져오기를 선택합니다.
- SharePoint 폴더 대화 상자에서 라이브러리에 대한 참조가 포함되지 않은 SharePoint 사이트의 루트 URL을 입력한 다음 라이브러리로 이동합니다.
- 자세한 단계는 여러 파일이 있는 폴더에서 데이터 가져오기를 참조하세요.
고급 커넥터 옵션에 대한 자세한 내용은 SharePoint 폴더를 참조하세요.
데이터베이스: SQL Server
SQL Server 데이터베이스의데이터베이스>에서데이터> 가져오기를 선택합니다>.
SQL Server 데이터베이스 대화 상자의 서버 상자에 연결할 SQL Server를 지정합니다. 필요에 따라 데이터베이스 도 지정할 수 있습니다.
기본 데이터베이스 쿼리를 사용하여 데이터를 가져오려는 경우 SQL 문 상자에 쿼리를 지정합니다. 자세한 내용은 기본 데이터베이스 쿼리를 사용하여 데이터베이스에서 데이터 가져오기를 참조하세요.
확인을 선택합니다.
인증 모드를 선택하여 SQL Server 데이터베이스에 연결합니다.
- 윈도우 이것이 기본 선택 항목입니다. Windows 인증으로 연결하려면 이 옵션을 선택합니다.
- 데이터베이스 SQL Server 인증을 사용하여 연결하려면 이 옵션을 선택합니다. 이 옵션을 선택한 후 사용자 이름과 암호를 지정하여 SQL Server instance에 연결합니다.
기본적으로 연결 암호화 검사란은 파워 쿼리가 암호화된 연결을 사용하여 데이터베이스에 연결됨을 나타내기 위해 선택됩니다. 암호화된 연결을 사용하여 연결하지 않으려면 이 검사 상자의 선택을 취소한 다음 연결을 클릭합니다.
암호화된 연결을 사용하여 SQL Server에 대한 연결을 설정하지 않은 경우 파워 쿼리는 암호화되지 않은 연결을 사용하여 연결하라는 메시지를 표시합니다. 메시지에서 확인 을 클릭하여 암호화되지 않은 연결을 사용하여 연결합니다.
고급 커넥터 옵션에 대한 자세한 내용은 SQL Server 데이터베이스를 참조하세요.
데이터베이스: Microsoft Access
- Microsoft>Access 데이터베이스의데이터베이스에서데이터> 가져오기를 > 선택합니다.
- 데이터 가져오기 대화 상자에서 Access 데이터베이스 파일(.accdb)을 찾아 찾습니다.
- 파일을 선택한 다음, 열기를 선택합니다. 탐색기(Navigator) 대화 상자가 나타납니다.
- 왼쪽 창에서 테이블 또는 쿼리를 선택하여 오른쪽 창에서 데이터를 미리 봅니다.
- 테이블과 쿼리가 많은 경우 검색 상자를 사용하여 개체를 찾거나 새로 고침 단추와 함께 표시 옵션을 사용하여 목록을 필터링합니다.
- 로드 또는 변환을 선택합니다.
고급 커넥터 옵션에 대한 자세한 내용은 Access 데이터베이스를 참조하세요.
데이터베이스: Analysis Services
노트 SQL Server Analysis Services 데이터베이스에 연결된 통합 문서를 사용하는 경우 MDX(다차원 식)에 대한 참조 정보 또는 OLAP(온라인 분석 처리) 서버의 구성 절차와 같은 특정 제품 질문에 답하기 위해 추가 정보가 필요할 수 있습니다.
Analysis Services의데이터베이스에서데이터> 가져오기를 >선택합니다>. 데이터 연결 마법사의 첫 번째 페이지가 나타납니다. 해당 제목은 데이터베이스 서버에 연결입니다.
서버 이름 상자에 OLAP 데이터베이스 서버의 이름을 입력합니다.
팁
연결하려는 오프라인 큐브 파일의 이름을 알고 있는 경우 전체 파일 경로, 파일 이름 및 확장명을 입력할 수 있습니다.
로그온 자격 증명에서 다음 중 하나를 수행한 후 다음을 클릭합니다.
현재 Windows 사용자 이름과 암호를 사용하려면 Windows 인증 사용을 클릭합니다.
데이터베이스 사용자 이름 및 암호를 입력하려면 다음 사용자 이름 및 암호 사용을 클릭한 후 해당 사용자 이름 및 암호 상자에 사용자 이름과 암호를 입력합니다.
보안 참고 사항- 대문자, 소문자, 숫자 및 기호를 결합하는 강력한 암호를 사용합니다. 약한 암호의 경우 이러한 요소를 혼합하지 않습니다. 예를 들어 Y6dh!et5는 강력한 암호이고 House27은 약한 암호입니다. 암호는 8자 이상이어야 합니다. 암호를 14자 이상 사용하는 것이 좋습니다.
- 암호는 반드시 기억해야 합니다. 암호를 잊은 경우 Microsoft에서 사용자의 암호를 다시 찾을 수 없습니다. 따라서 암호를 따로 기록한 후 안전한 장소에 보관해 두세요.
다음을 선택하여 두 번째 마법사 화면으로 이동합니다. 제목은 데이터베이스 및 테이블 선택입니다.
데이터베이스의 특정 큐브 파일에 연결하려면 특정 큐브 또는 테이블에 연결을 선택한 다음 목록에서 큐브를 선택합니다.원하는 데이터가 포함된 데이터베이스 선택 상자에서 데이터베이스를 선택하고 다음을 클릭합니다.
다음을 클릭하여 세 번째 마법사 화면으로 이동합니다. 데이터 저장 연결 파일 및 완료라는 제목입니다.
파일 이름 상자에서 필요에 따라 기본 파일 이름을 수정합니다(선택 사항).
찾아보기를 클릭하여 내 데이터 원본의 기본 파일 위치를 변경하거나 기존 파일 이름을 검사합니다.
설명,식별 이름 및 검색 키워드 상자에 파일 설명, 식별 이름 및 일반 검색어(모두 선택 사항)를 입력합니다.
피벗 테이블을 새로 고칠 때 연결 파일이 사용되도록 하려면 항상 이 파일을 사용하여 이 데이터를 새로 고치도록 시도를 클릭합니다.
이 검사 상자를 선택하면 연결 파일을 사용하는 모든 통합 문서에서 연결 파일 업데이트가 항상 사용됩니다.통합 문서를 Excel Services에 저장하고 Excel Services를 사용하여 열 경우 피벗 테이블에 액세스하는 방법을 지정할 수 있습니다.
참고
인증 설정은 Microsoft Office Excel이 아닌 Excel Services에서만 사용됩니다. Excel 또는 Excel Services에서 통합 문서를 열든 관계없이 동일한 데이터에 액세스하도록 하려면 Excel의 인증 설정이 동일한지 확인합니다.
인증 설정을 선택하고 다음 옵션 중 하나를 선택하여 데이터 원본에 로그온합니다.
Windows 인증 현재 사용자의 Windows 사용자 이름과 암호를 사용하려면 이 옵션을 선택합니다. 가장 안전한 방법이지만 사용자가 많을 경우 성능에 영향을 줄 수 있습니다.
SSO Single Sign On을 사용하려면 이 옵션을 선택한 다음 SSO ID 텍스트 상자에 적절한 식별 문자열을 입력합니다. 사이트 관리자는 사용자 이름과 암호를 저장할 수 있는 Single Sign On 데이터베이스를 사용하도록 SharePoint 사이트를 구성할 수 있습니다. 이 방법은 사용자가 많을 때 가장 효율적일 수 있습니다.
없음 연결 파일에 사용자 이름과 암호를 저장하려면 이 옵션을 선택합니다.
중요
데이터 원본에 연결할 때는 로그온 정보를 저장하지 마세요. 이 정보는 일반 텍스트로 저장될 수 있으며 악의적인 사용자가 정보에 액세스하여 데이터 원본의 보안을 손상시킬 수 있습니다.
확인을 선택합니다.
마침을 선택하여 데이터 연결 마법사를 닫습니다. 데이터 가져오기대화 상자가 나타납니다.
데이터를 가져올 방법을 결정한 후 확인을 선택합니다. 이 대화 상자 사용에 대한 자세한 내용을 보려면 물음표(?)를 선택하세요.
데이터베이스: SQL Server Analysis Services(가져오기)
Excel 통합 문서와 SQL Server Analysis Services OLAP(온라인 분석 처리) 데이터베이스 서버 간에 동적 연결을 만든 다음 데이터가 변경될 때마다 해당 연결을 새로 고칠 수 있습니다. 특정 오프라인 큐브 파일이 데이터베이스 서버에 생성된 경우 해당 파일에 연결할 수 있습니다. Excel에서 데이터를 테이블 또는 피벗 테이블 보고서로 가져올 수도 있습니다.
데이터>SQL Server Analysis Services 데이터베이스의데이터베이스>에서데이터> 가져오기(가져오기)를 선택합니다.
서버 이름을 입력한 다음 확인을 선택합니다.
탐색기 창에서 데이터베이스를 선택한 다음 연결하려는 큐브 또는 테이블을 선택합니다.
로드를 클릭하여 선택한 테이블을 워크시트에 로드하거나, 편집을 클릭하여 로드하기 전에 Power Query 편집기에서 추가 데이터 필터 및 변환을 수행합니다.
고급 커넥터 옵션에 대한 자세한 내용은 SQL Server Analysis Services를 참조하세요.
데이터베이스: Oracle
참고
파워 쿼리를 사용하여 Oracle 데이터베이스에 연결하기 전에 모든 필수 구성 요소가 충족되는지 확인하세요.
데이터> OracleDatabase의데이터베이스>에서데이터> 가져오기를 선택합니다.
Oracle 데이터베이스 대화 상자의 서버 이름에 연결할 Oracle 서버를 지정합니다. SID가 필요한 경우 "ServerName/SID" 형식으로 지정할 수 있습니다.
네이티브 데이터베이스 쿼리를 사용하여 데이터를 가져오려면 SQL 문 상자에 쿼리를 지정합니다. 자세한 내용은 네이티브 데이터베이스 쿼리를 사용하여 데이터베이스에서 데이터 가져오기를 참조하세요.
확인을 선택합니다.
Oracle 서버에 데이터베이스 사용자 자격 증명이 필요한 경우:
- 데이터베이스 액세스 대화 상자에서 사용자 이름과 암호를 입력합니다.
- 연결을 클릭합니다.
고급 커넥터 옵션에 대한 자세한 내용은 Oracle Database를 참조하십시오.
데이터베이스: IBM DB2
경고
- IBM Db2 데이터베이스에 연결하려면 IBM DB2 Data Server Driver 가 컴퓨터에 설치되어 있어야 합니다(최소 요구사항은 IBM Data Server Driver 패키지(DS Driver)임). 파워 쿼리 설치(32비트 또는 64비트)와 일치하는 드라이버를 선택합니다.
- Windows 8에 IBM DB2 데이터 서버 드라이버를 설치하는 IBM에서 보고한 알려진 문제가 있습니다. Windows 8을 사용 중이고 파워 쿼리를 사용하여 IBM DB2에 연결하려면 추가 설치 단계를 수행해야 합니다. Windows 8의 IBM DB2 데이터 서버 드라이버에 대한 자세한 정보를 찾으십시오.
IBM>Db2 데이터베이스의데이터베이스>에서데이터> 가져오기를 선택하십시오.
IBM Db2 데이터베이스 대화상자의 서버 이름에 연결할 IBM Db2 데이터베이스 서버를 지정하십시오.
네이티브 데이터베이스 쿼리를 사용하여 데이터를 가져오려면 SQL 문 상자에 쿼리를 지정합니다. 자세한 내용은 네이티브 데이터베이스 쿼리를 사용하여 데이터베이스에서 데이터 가져오기 단원을 참조하십시오.
확인을 선택합니다.
IBM DB2 서버에 데이터베이스 사용자 신임 정보가 필요한 경우:
- 데이터베이스 액세스 대화 상자에서 사용자 이름과 암호를 입력합니다.
- 연결을 클릭합니다.
고급 커넥터 옵션에 대한 자세한 정보는 IBM DB2 데이터베이스를 참조하십시오.
데이터베이스: MySQL
참고
"이 커넥터를 사용하려면 하나 이상의 추가 구성 요소를 설치해야 합니다."라는 메시지가 표시되면 여기에서 MySQL에 적합한 ODBC 드라이버를 Windows 디바이스에 다운로드해야 합니다. 자세한 내용은 MySQL 커넥터를 참조하세요.
데이터> MySQL 데이터베이스의 데이터베이스>에서데이터> 가져오기를 선택합니다.
MySQL 데이터베이스 대화 상자의 서버 이름에서 연결할 MySQL 데이터베이스 서버를 지정합니다.
네이티브 데이터베이스 쿼리를 사용하여 데이터를 가져오려면 SQL 문 상자에 쿼리를 지정합니다. 자세한 내용은 네이티브 데이터베이스 쿼리를 사용하여 데이터베이스에서 데이터 가져오기 단원을 참조하십시오.
확인을 선택합니다.
MySQL 서버에 데이터베이스 사용자 자격 증명이 필요한 경우:
- 데이터베이스 액세스 대화 상자에서 사용자 이름과 암호를 입력합니다.
- 연결을 클릭합니다.
고급 커넥터 옵션에 대한 자세한 내용은 MySQL 데이터베이스를 참조하세요.
데이터베이스: PostgreSQL
참고
파워 쿼리에서 PostgreSQL 데이터베이스에 연결하려면 PostgreSQL용 Ngpsql 데이터 공급자가 컴퓨터에 설치되어 있어야 합니다. 사용 중인 Office 버전(32비트 또는 64비트)과 일치하는 드라이버를 선택합니다. 자세한 내용은 사용 중인 Office 버전 확인 을 참조하세요. 또한 장치의 최신 .NET 버전과 일치하는 공급자가 컴퓨터 구성에 등록되어 있는지 확인합니다.
PostgreSQL> 데이터베이스의데이터베이스에서데이터> 가져오기를 > 선택합니다.
PostgreSQL 데이터베이스 대화 상자의 서버 이름 섹션에서 연결하려는 PostgreSQL 데이터베이스 서버를 지정합니다.
네이티브 데이터베이스 쿼리를 사용하여 데이터를 가져오려면 SQL 문 상자에 쿼리를 지정합니다. 자세한 내용은 네이티브 데이터베이스 쿼리를 사용하여 데이터베이스에서 데이터 가져오기 단원을 참조하십시오.
확인을 선택합니다.
PostgreSQL 서버에 데이터베이스 사용자 자격 증명이 필요한 경우:
- 데이터베이스 액세스 대화 상자에서 사용자 이름과 암호를 입력합니다.
- 연결을 선택합니다.
고급 커넥터 옵션에 대한 자세한 내용은 PostgreSQL을 참조하세요.
데이터베이스: Sybase
참고
SAP SQL Anywhere 데이터베이스에 연결하려면 컴퓨터에 SAP SQL Anywhere 드라이버 가 설치되어 있어야 합니다. Excel 설치(32비트 또는 64비트)와 일치하는 드라이버를 선택합니다.
- 데이터>Sybase 데이터베이스에서데이터베이스에서데이터> 가져오기를 > 선택합니다.
- Sybase 데이터베이스 대화 상자의 서버 상자에서 연결할 Sybase 서버를 지정합니다. 필요에 따라 데이터베이스 도 지정할 수 있습니다.
- 네이티브 데이터베이스 쿼리를 사용하여 데이터를 가져오려는 경우 SQL 문 상자에 쿼리를 지정합니다. 자세한 내용은 네이티브 데이터베이스 쿼리를 사용하여 데이터베이스에서 데이터 가져오기 단원을 참조하십시오.
- 확인을 선택합니다.
- 기본적으로 연결 암호화 검사란은 파워 쿼리가 간단한 암호화된 연결을 사용하여 데이터베이스에 연결하도록 선택됩니다.
- 연결을 선택합니다.
자세한 내용은 Sybase 데이터베이스를 참조하십시오.
데이터베이스: Teradata
참고
Teradata 데이터베이스에 연결하려면 컴퓨터에 .NET Data Provider for Teradata 가 있어야 합니다.
데이터>Teradata 데이터베이스의데이터베이스에서데이터> 가져오기를 > 선택합니다.
Teradata 데이터베이스 대화 상자의 서버 이름에 연결할 Teradata 서버를 지정합니다.
네이티브 데이터베이스 쿼리를 사용하여 데이터를 가져오려면 SQL 문 상자에 쿼리를 지정합니다. 자세한 내용은 네이티브 데이터베이스 쿼리를 사용하여 데이터베이스에서 데이터 가져오기 단원을 참조하십시오.
확인을 선택합니다.
Teradata 서버에 데이터베이스 사용자 자격 증명이 필요한 경우:
- 데이터베이스 액세스 대화 상자에서 사용자 이름과 암호를 입력합니다.
- 저장을 클릭합니다.
자세한 내용은 Teradata 데이터베이스를 참조하십시오.
데이터베이스: SAP HANA
참고
- 이 기능은 Office 2019 이상 또는 Microsoft 365 구독이 있는 경우에만 Windows용 Excel에서 사용할 수 있습니다. Microsoft 365 구독자인 경우 최신 Office 버전을 보유하고 있는지 확인합니다.
- 파워 쿼리를 사용하여 SAP HANA 데이터베이스에 연결하려면 컴퓨터에 SAP HANA ODBC 드라이버가 있어야 합니다. 파워 쿼리 설치(32비트 또는 64비트)와 일치하는 드라이버를 선택합니다.
- 웹 사이트에 로그인하고 드라이버를 다운로드하려면 SAP 계정이 필요합니다. 확실하지 않은 경우 organization의 SAP 관리자에게 문의하십시오.
SAP HANA 데이터베이스에 연결하려면 다음을 수행합니다.
데이터>SAP HANA 데이터베이스의데이터베이스에서데이터> 가져오기를 > 클릭합니다.
SAP HANA 데이터베이스 대화 상자에서 연결할 서버를 지정합니다. 서버 이름은 ServerName:Port 형식을 따르야 합니다.
원한다면 기본 데이터베이스 쿼리를 사용하여 데이터를 가져오려면 고급 옵션을 선택한 다음 SQL 문 상자에 쿼리를 입력합니다.
확인을 선택합니다.
SAP HANA 서버에 데이터베이스 사용자 자격 증명이 필요한 경우 SAP HANA 데이터베이스 액세스 대화 상자에서 다음을 수행합니다.
- 데이터베이스 탭을 클릭하고 사용자 이름과 암호를 입력합니다.
- 연결을 클릭합니다.
고급 커넥터 옵션에 대한 자세한 내용은 SAP HANA 데이터베이스를 참조하세요.
Azure: Azure SQL Database
Azure SQL Database는 클라우드용으로 빌드되고 중요 업무상 중요한 애플리케이션에 사용되는 고성능 완전 관리형 확장 가능한 관계형 데이터베이스입니다. 자세한 내용은 Azure SQL이란?를 참조하세요.
데이터> 선택Azure>에서데이터> 가져오기 Azure SQL Database에서.
SQL Server 데이터베이스 대화 상자의 서버 상자에서 연결할 SQL Server를 지정합니다. 필요에 따라 데이터베이스 도 지정할 수 있습니다.
네이티브 데이터베이스 쿼리를 사용하여 데이터를 가져오려는 경우 SQL 문 상자에 쿼리를 지정합니다. 자세한 내용은 기본 데이터베이스 쿼리를 사용하여 데이터베이스에서 데이터 가져오기를 참조하세요.
확인을 선택합니다.
인증 모드를 선택하여 SQL Server 데이터베이스에 연결합니다.
- 윈도우 이것이 기본 선택 항목입니다. Windows 인증으로 연결하려면 이 옵션을 선택합니다.
- 데이터베이스 SQL Server 인증을 사용하여 연결하려면 이 옵션을 선택합니다. 이 옵션을 선택한 후 사용자 이름과 암호를 지정하여 SQL Server instance에 연결합니다.
기본적으로 연결 암호화 검사란은 파워 쿼리가 암호화된 연결을 사용하여 데이터베이스에 연결됨을 나타내기 위해 선택됩니다. 암호화된 연결을 사용하여 연결하지 않으려면 이 검사 상자의 선택을 취소한 다음 연결을 클릭합니다.
암호화된 연결을 사용하여 SQL Server에 대한 연결을 설정하지 않은 경우 파워 쿼리는 암호화되지 않은 연결을 사용하여 연결하라는 메시지를 표시합니다. 메시지에서 확인 을 클릭하여 암호화되지 않은 연결을 사용하여 연결합니다.
고급 커넥터 옵션에 대한 자세한 내용은 Azure SQL Database를 참조하세요.
Azure: Azure Synapse Analytics
Azure Synapse Analytics는 Apache Spark를 사용하여 빅 데이터 도구와 관계형 쿼리를 결합하여 Azure 데이터 서비스 및 Power Platform에 연결합니다. 수백만 개의 행을 즉시 로드할 수 있습니다. 그러면 쿼리에 친숙한 SQL 구문을 사용하여 표 형식 데이터로 작업할 수 있습니다. 자세한 내용은 Azure Synapse Analytics(docs.com)란 무엇인가요?
데이터> 선택Azure>에서데이터> 가져오기From Azure Synapse Analytics.
SQL Server 데이터베이스 대화 상자의 서버 상자에 연결할 SQL Server를 지정합니다. 필요에 따라 데이터베이스 도 지정할 수 있습니다.
네이티브 데이터베이스 쿼리를 사용하여 데이터를 가져오려는 경우 SQL 문 상자에 쿼리를 지정합니다. 자세한 내용은 기본 데이터베이스 쿼리를 사용하여 데이터베이스에서 데이터 가져오기를 참조하세요.
확인을 선택합니다.
인증 모드를 선택하여 SQL Server 데이터베이스에 연결합니다.
- 윈도우 이것이 기본 선택 항목입니다. Windows 인증으로 연결하려면 이 옵션을 선택합니다.
- 데이터베이스 SQL Server 인증을 사용하여 연결하려면 이 옵션을 선택합니다. 이 옵션을 선택한 후 사용자 이름과 암호를 지정하여 SQL Server instance에 연결합니다.
기본적으로 연결 암호화 검사란은 파워 쿼리가 암호화된 연결을 사용하여 데이터베이스에 연결됨을 나타내기 위해 선택됩니다. 암호화된 연결을 사용하여 연결하지 않으려면 이 검사 상자의 선택을 취소한 다음 연결을 클릭합니다.
암호화된 연결을 사용하여 SQL Server에 대한 연결을 설정하지 않은 경우 파워 쿼리는 암호화되지 않은 연결을 사용하여 연결하라는 메시지를 표시합니다. 메시지에서 확인 을 클릭하여 암호화되지 않은 연결을 사용하여 연결합니다.
고급 커넥터 옵션에 대한 자세한 내용은 Azure Synapse Analytics를 참조하세요.
Azure: Azure HDInsight
Azure HDInsight는 많은 양의 데이터를 처리해야 하는 경우 빅 데이터 분석에 사용됩니다. 데이터 웨어하우징 및 기계 학습을 지원합니다. 데이터 흐름 엔진으로 생각할 수 있습니다. 자세한 내용은 Azure HDInsight란?를 참조하세요.
- 데이터> 선택 Azure HDInsight(HDFS)에서Azure>에서데이터> 가져오기.
- HDInsight 클러스터와 연결된 Microsoft Azure Blob Storage 계정의 계정 이름 또는 URL을 입력한 다음 확인을 선택합니다.
- Microsoft Azure HDInsight 액세스 대화 상자에서 계정 키를 입력하고 연결을 클릭합니다.
- 탐색기 대화 상자에서 클러스터를 선택한 다음 콘텐츠 파일을 찾아 선택합니다.
- 로드를 선택하여 선택한 테이블을 로드하거나, 편집을 선택하여 로드하기 전에 추가 데이터 필터 및 변환을 수행합니다.
고급 커넥터 옵션에 대한 자세한 내용은 Azure HDInsight를 참조하세요.
Azure: Azure Blob Storage
Microsoft Azure Blob Storage는 HTTP 또는 HTTPS를 통해 전 세계 어디에서나 액세스할 수 있는 이미지, 비디오, 오디오 및 문서와 같은 대량의 비정형 데이터를 저장하는 서비스입니다. Azure Blob Storage 서비스에 대한 자세한 내용은 Blob Storage 사용 방법을 참조하세요.
데이터> 선택Azure>에서데이터> 가져오기From Azure Blob Storage.
Azure Blob Storage 대화 상자에서 Microsoft Azure Storage 계정 이름 또는 URL을 입력한 다음 확인을 선택합니다.
Blob 저장소 서비스에 처음 연결하는 경우 저장소 액세스 키를 입력하고 저장하라는 메시지가 표시됩니다. Microsoft Azure Blob Storage 액세스 대화 상자의 계정 키 상자에 스토리지 액세스 키를 입력하고 저장을 클릭합니다.
참고
스토리지 액세스 키를 검색해야 하는 경우 Microsoft Azure 포털로 이동하여 스토리지 계정을 선택한 다음 페이지 아래쪽에 있는 액세스 키 관리 아이콘을 선택합니다. 기본 키 오른쪽에 있는 복사 아이콘을 선택한 다음 계정 키 상자에 값을 붙여넣습니다.
쿼리 편집기는 Microsoft Azure Blob Storage에서 사용 가능한 모든 컨테이너를 나열합니다. 탐색기에서 데이터를 가져올 컨테이너를 선택한 다음 적용 & 닫기를 선택합니다.
자세한 내용은 Azure Blob Storage를 참조하세요.
Azure: Azure Table Storage
Azure Storage는 다양한 데이터 개체에 대한 스토리지 서비스를 제공합니다. 테이블 저장소 구성 요소는 키/특성 쌍으로 저장된 NoSQL 데이터를 대상으로 합니다. 자세한 내용은 테이블 스토리지 소개를 참조하세요.
- 데이터>데이터 가져오기>Azure테이블 저장소에서Azure> 선택합니다.
- Microsoft Azure Table Storage 계정의 계정 이름 또는 URL을 입력한 다음 확인을 선택합니다.
고급 커넥터 옵션에 대한 자세한 내용은 Azure Table Storage를 참조하세요.
Azure: Azure Data Lake Storage Gen 1
중요
Azure Data Lake Storage Gen 1은 사용 중지됩니다. 자세한 내용은 작업 필요: 2024년 2월 29일까지 Azure Data Lake Storage Gen2로 전환을 참조하세요.
데이터>Azure에서데이터> 가져오기를 선택합니다. Azure> Data Lake Storage에서.
Microsoft Azure Data Lake Storage 계정의 계정 이름 또는 URL을 입력한 다음 확인을 선택합니다.
예: swebhdfs://contoso.azuredatalake.net/
필요에 따라 페이지 크기(바이트) 상자에 값을 입력합니다.
자세한 내용은 Azure Data Lake Storage를 참조하세요.
Azure: Azure Data Lake Storage Gen 2
Azure Data Lake Storage Gen 2는 서로 다른 데이터 웨어하우스를 하나의 저장된 환경으로 결합합니다. 차세대 쿼리 도구를 사용하여 페타바이트 단위의 데이터를 사용하여 데이터를 탐색하고 분석할 수 있습니다. 자세한 내용은 Azure Data Lake Storage를 참조하세요.
Azure Data Lake Storage Gen2 대화 상자에서 계정 URL을 제공합니다. Data Lake Storage Gen2의 URL에는 다음과 같은 패턴이 있습니다.
https://< accountname.dfs.core.windows.net/>< container>/<subfolder>
예를 들면 다음과 같습니다 https://contosoadlscdm.dfs.core.windows.net/파일 시스템 보기 또는 CDM(일반 데이터 모델) 폴더 보기를 사용할지 여부를 선택합니다.
확인을 선택합니다.
인증 방법을 선택해야 할 수 있습니다.
예를 들어 조직 계정 방법을 선택하는 경우 로그인 을 선택하여 스토리지 계정에 로그인합니다. 해당 organization의 로그인 페이지로 리디렉션됩니다. 메시지에 따라 계정에 로그인합니다. 성공적으로 로그인한 후 연결을 선택합니다.
탐색기 대화 상자에서 정보를 확인한 다음 데이터 변환을 선택하여 파워 쿼리의 데이터를 변환하거나 로드를 선택하여 데이터를 로드합니다.
자세한 내용은 Azure Data Lake Storage를 참조하세요.
Azure: Azure Data Explorer
Azure Data Explorer는 로그 및 원격 분석 데이터를 위한 빠르고 확장성이 뛰어난 데이터 탐색 서비스입니다. 웹 사이트, 애플리케이션, IoT 장치 등과 같은 모든 데이터 소스에서 대량의 다양한 데이터를 처리할 수 있습니다. 자세한 내용은 Azure Data Explorer란을 참조하세요.
데이터>Azure>Azure Data Explorer에서데이터> 가져오기를 선택합니다.
Azure Data Explorer(Kusto) 대화 상자에서 적절한 값을 입력합니다.
각 프롬프트는 프로세스를 안내하는 유용한 예제를 제공합니다.
확인을 선택합니다.
Power Platform: Power BI에서(<테넌트 이름>)
Power BI organization 창에서 데이터 세트를 선택한 다음 새 워크시트에 피벗 테이블을 만들어 적절한 권한이 있는 데이터 세트를 가져올 수 있습니다.
- 데이터> 선택Power BI(Microsoft)의Fabric & Power Platform>에서데이터> 가져오기. Power BI 데이터 세트 창이 나타납니다. <테넌트 이름>은 organization에 따라 다릅니다(예: Power BI(Contoso)).
- 많은 데이터 세트를 사용할 수 있는 경우 검색 상자를 사용합니다. 검색 대상 버전 및 환경에 대한 키워드(keyword) 필터를 표시하려면 상자 옆에 있는 화살표를 선택합니다.
- 데이터 집합을 선택하고 새 워크시트에서 피벗 테이블을 만듭니다. 자세한 내용은 피벗 테이블 및 피벗 차트 개요를 참조하세요.
Power BI에 대한 자세한 내용은 Power BI 데이터 세트에서 피벗 테이블 만들기 및 Office 365용 Power BI 도움말의 데이터 관리 환경을 참조하세요.
Power Platform: 데이터 흐름에서
데이터 흐름은 Microsoft Dataverse 환경, Power BI 작업 영역 또는 Azure 데이터 레이크에 데이터를 수집, 변환 및 로드할 수 있는 데이터 준비 기술입니다. 데이터가 항상 최신 상태로 유지되도록 요청 시 또는 일정에 따라 자동으로 데이터 흐름을 트리거할 수 있습니다.
데이터>흐름에서Fabric & Power Platform>에서데이터> 가져오기를 선택합니다.
메시지가 표시되면 필요한 자격 증명을 입력하거나 다른 사용자로 로그인합니다. 탐색기 창이 나타납니다.
왼쪽 창에서 데이터 흐름을 선택하여 오른쪽 창에서 미리 봅니다.
다음 중 하나를 실행합니다.
- 워크시트에 데이터를 추가하려면 로드를 선택합니다.
- Power Query 편집기에 데이터를 추가하려면 데이터 변환을 선택합니다.
자세한 내용은 Microsoft Power Platform의 데이터 흐름 개요를 참조하세요.
Power Platform: Dataverse에서
Dataverse를 사용하여 클라우드에서 데이터를 안전하게 저장하고 관리합니다. organization과 관련된 사용자 지정 테이블을 만들거나 가져오고 파워 쿼리를 사용하여 데이터로 채운 다음 Power Apps 또는 Microsoft Access를 사용하여 풍부한 비즈니스 응용 프로그램을 빌드할 수 있습니다.
Dataverse의Fabric & Power Platform>에서데이터> 가져오기를 선택합니다>.
메시지가 표시되면 필요한 자격 증명을 입력하거나 다른 사용자로 로그인합니다. 탐색기 창이 나타납니다.
왼쪽 창에서 데이터를 선택하여 오른쪽 창에서 미리 봅니다.
다음 중 하나를 실행합니다.
- 워크시트에 데이터를 추가하려면 로드를 선택합니다.
- Power Query 편집기에 데이터를 추가하려면 데이터 변환을 선택합니다.
자세한 내용은 Microsoft Dataverse란?
온라인 서비스: SharePoint Online 목록
SharePoint Online 목록에서온라인 서비스>에서데이터> 가져오기를 선택합니다>.
SharePoint Online 목록 대화 상자에서 라이브러리에 대한 참조를 포함하지 않은 SharePoint 사이트의 루트 URL을 입력한 다음 라이브러리로 이동합니다.
고급 옵션을 사용하도록 설정하는 2.0 SharePoint 구현을 선택하여 보기 모드를 선택할 수 있습니다.
모두 SharePoint 목록에서 모든 열을 검색합니다.
기본값 SharePoint 목록의 기본 보기 에 설정된 열을 검색합니다.2.0 대신 이전 버전의 SharePoint에 해당하는 1.0을 선택할 수 있습니다.
고급 커넥터 옵션에 대한 자세한 내용은 SharePoint Online 목록을 참조하세요.
온라인 서비스: Microsoft Exchange Online
- Microsoft Exchange Online에서온라인 서비스에서데이터> 가져오기를 선택합니다>.
- Microsoft Exchange 대화 상자에 alias@<organization> 형식으로 <전자 메일 주소를 입력합니다.com>
- 개체가 많은 경우 검색 상자를 사용하여 개체를 찾거나 새로 고침 단추와 함께 표시 옵션을 사용하여 목록을 필터링합니다.
- 대화 상자 아래쪽에 있는 오류가 있는 파일 건너뛰 기 확인란을 선택하거나 선택 취소합니다.
- 원하는 테이블을 선택합니다. Calendar, Mail, Meeting Requests, People 및 Tasks.
- 다음 중 하나를 실행합니다.
- 쿼리를 만든 다음 워크시트에 로드하려면로드 로드를 선택합니다>.
- 쿼리를 만든 다음 데이터 가져오기 대화 상자를 표시하려면 로드>로드를 선택합니다.
- 쿼리를 만든 다음 Power Query 편집기를 시작하려면 데이터 변환을 선택합니다.
고급 커넥터 옵션에 대한 자세한 내용은 Microsoft Exchange Online을 참조하세요.
온라인 서비스: Dynamics 365(온라인)
연결할 환경을 선택합니다.
메뉴에서 설정 아이콘 > 고급 사용자 지정> 개발자리소스를 선택합니다.
인스턴스 Web API 값을 복사합니다.
참고
- URL 형식은 다음과 같습니다.
https://<tenant>.crm.dynamics.com/api/data/v9.0. - 연결하는 데 사용할 URL의 정확한 형식은 거주 지역 및 사용 중인 앱용 CDS 버전에 따라 다릅니다. 자세한 내용은 웹 API URL 및 버전을 참조하세요.
- URL 형식은 다음과 같습니다.
데이터>Dynamics 365(온라인)의온라인 서비스>에서데이터> 가져오기를 선택합니다.
대화 상자에서 기본 옵션을 선택한 상태에서 CDS for Apps 연결에 대한 Web API URL 을 입력하고 확인을 클릭합니다.
- 고급 옵션을 선택하면 쿼리에 특정 추가 매개 변수를 추가하여 반환되는 데이터를 제어할 수 있습니다. 자세한 내용은 웹 API를 사용하여 데이터 쿼리를 참조하세요.
조직 계정을 선택합니다.
- Dataverse for Apps에 액세스하는 데 사용하는 Microsoft 회사 또는 학교 계정을 사용하여 로그인하지 않은 경우 로그인을 선택하고 계정 사용자 이름 및 암호를 입력합니다.
연결을 선택합니다.
탐색기 대화 상자에서 검색할 데이터를 선택합니다.
데이터가 올바른지 확인한 다음 로드 또는 편집을 선택하여 Power Query 편집기를 엽니다.
온라인 서비스: Salesforce 개체
- 데이터> 선택Salesforce 개체의온라인 서비스>에서데이터> 가져오기. Salesforce 개체 대화 상자가 나타납니다.
- 프로덕션 또는 사용자 지정을 선택합니다. 사용자 지정을 선택하는 경우 사용자 지정 instance의 URL을 입력합니다.
- 관계 포함 열을 선택하거나 선택 취소합니다.
- 확인을 선택합니다.
고급 커넥터 옵션에 대한 자세한 내용은 Salesforce 개체를 참조하십시오.
온라인 서비스: Salesforce 보고서
Salesforce 보고서에는 각 보고서에 대해 처음 2,000행만 검색하는 API 제한이 있으므로 필요한 경우 Salesforce 개체 커넥터를 사용하여 이 제한을 해결하는 것이 좋습니다.
- 데이터> 선택Salesforce 보고서의온라인 서비스>에서데이터> 가져오기. Salesforce 보고서 대화 상자가 나타납니다.
- 프로덕션 또는 사용자 지정을 선택합니다. 사용자 지정을 선택하는 경우 사용자 지정 instance의 URL을 입력합니다.
- 관계 포함 열을 선택하거나 선택 취소합니다.
- 확인을 선택합니다.
고급 커넥터 옵션에 대한 자세한 내용은 Salesforce 보고서를 참조하세요.
온라인 서비스: Adobe Analytics
최신 버전의 Adobe Analytics 커넥터가 있는지 확인합니다. 자세한 내용은 Power BI Desktop에서 Adobe Analytics에 연결을 참조하십시오.
- Adobe Analytics의온라인 서비스>에서데이터> 가져오기를 선택합니다>.
- 계속을 선택합니다. Adobe 계정 대화 상자가 나타납니다.
- Adobe Analytics 조직 계정으로 로그인한 다음 연결을 선택합니다.
고급 커넥터 옵션에 대한 자세한 내용은 Adobe Analytics를 참조하십시오.
기타 원본: 테이블/범위
자세한 내용은 테이블/범위에서를 참조하십시오.
기타 원본: 웹
중요
- 웹에서 데이터를 가져오려고 하면 다음 메시지가 나타날 수 있습니다. "이 커넥터를 사용하려면 하나 이상의 추가 구성 요소를 설치해야 합니다." 웹 커넥터를 사용하려면 컴퓨터에 WebView 2 Framework가 설치되어 있어야 합니다.
- 여기에서 다운로드할 수 있습니다.
- 이 업데이트는 볼륨 라이선스 버전(예: 영구 상용)에는 적용되지 않습니다.
절차
데이터를> 선택하고웹에서다른 원본>에서데이터를> 가져옵니다.
웹에서 대화 상자에서 웹 페이지 URL을 입력한 다음 확인을 클릭합니다.
이 경우 다음을 사용하고 있습니다. http://en.wikipedia.org/wiki/UEFA_European_Football_Championship.
웹 페이지에서 사용자 자격 증명을 필요로 하는 경우 다음을 실행합니다.- 고급을 선택한 다음 Access 웹 대화 상자에서 자격 증명을 입력합니다.
- 저장을 선택합니다.
확인을 선택합니다.
탐색기 창에서 다음을 수행합니다.
결과와 같은 테이블 보기를 선택합니다.
테이블을 웹 페이지로 보려면 웹 보기 를 선택합니다.
로드를 선택하여 데이터를 워크시트에 로드합니다.
고급 커넥터 옵션에 대한 자세한 내용은 웹을 참조하세요.
기타 원본: Microsoft Query
Microsoft Query는 오랫동안 사용되었으며 여전히 인기가 있습니다. 여러 면에서 파워 쿼리의 조상입니다. 자세한 내용은 Microsoft Query를 사용하여 외부 데이터 검색을 참조하세요.
기타 원본: SharePoint 목록
SharePoint> 목록에서다른 원본에서데이터> 가져오기를 > 선택합니다.
SharePoint 목록 대화 상자에서 SharePoint 사이트의 URL을 입력합니다.
참고
SharePoint 목록에 연결할 때 목록 URL 대신 사이트 URL을 입력합니다. SharePoint 액세스 대화 상자에서 가장 일반적인 URL을 선택하여 사이트에 대해 올바르게 인증합니다. 기본적으로 가장 일반적인 URL이 선택됩니다.
확인을 선택합니다.
SharePoint 액세스 대화 상자에서 자격 증명 옵션을 선택합니다.
SharePoint Server에 자격 증명이 필요하지 않은 경우 익명 을 선택합니다.
SharePoint Server에 Windows 자격 증명이 필요한 경우 Windows 를 선택합니다.
SharePoint Server에 조직 계정 자격 증명이 필요한 경우 조직 계정을 선택합니다.
연결을 선택합니다.
고급 커넥터 옵션에 대한 자세한 내용은 SharePoint 목록을 참조하세요.
기타 원본: OData 피드
데이터> 선택OData 피드에서다른 원본>의데이터를> 가져옵니다.
OData 피드 대화 상자에서 OData 피드의 URL을 입력합니다.
확인을 선택합니다.
OData 피드에 사용자 자격 증명이 필요한 경우 OData 피드 액세스 대화 상자에서 다음을 수행합니다.
- OData 피드에 Windows 인증이 필요한 경우 Windows를 선택합니다.
- OData 피드에 사용자 이름과 암호가 필요한 경우 기본 을 선택합니다.
- OData 피드에 마켓플레이스 계정 키가 필요한 경우 마켓플레이스 키를 선택합니다. 마켓플레이스 계정 키 가져오기를 선택하여 Microsoft Azure Marketplace OData 피드를 구독할 수 있습니다. OData 피드 액세스 대화 상자에서 Microsoft Azure Marketplace에 등록할 수도 있습니다.
- OData 피드에 페더레이션 액세스 자격 증명이 필요한 경우 조직 계정을 클릭합니다. Windows Live ID의 경우 계정에 로그인합니다.
- 저장을 선택합니다.
참고
OData 피드로 가져오기는 JSON 라이트 데이터 서비스 형식을 지원합니다.
고급 커넥터 옵션에 대한 자세한 내용은 OData 피드를 참조하세요.
기타 원본: HDFS(Hadoop 파일)
HDFS(Hadoop 분산 파일 시스템)는 테라바이트, 심지어 페타바이트 단위의 데이터를 저장하도록 설계되었습니다. HDFS는 데이터 파일이 분산되는 클러스터 내의 컴퓨터 노드를 연결하며 사용자는 이러한 데이터 파일에 하나의 원활한 파일 스트림으로 액세스할 수 있습니다.
- 데이터> 선택HDFS(Hadoop 파일)에서다른 원본>에서데이터를> 가져옵니다.
- 서버 상자에 서버 이름을 입력한 다음 확인을 선택합니다.
고급 커넥터 옵션에 대한 자세한 내용은 HDFS(Hadoop 파일)를 참조하세요.
기타 원본: Active Directory
- 데이터를> 선택하세요.Active Directory의다른 원본>에서데이터> 가져오기.
- Active Directory 대화 상자에 도메인을 입력합니다.
- 도메인의 Active Directory 도메인 대화 상자에서 내 현재 자격 증명 사용을 선택하거나 대체 자격 증명 사용을 선택한 다음 사용자 이름과 암호를 입력합니다.
- 연결을 선택합니다.
- 연결에 성공하면 탐색기 창을 사용하여 Active Directory 내에서 사용 가능한 모든 도메인을 찾은 다음 사용자, 계정 및 컴퓨터를 비롯한 Active Directory 정보로 드릴다운합니다.
고급 커넥터 옵션에 대한 자세한 내용은 Active Directory를 참조하세요.
기타 원본: Microsoft Exchange
- 데이터> 선택Microsoft Exchange의다른 원본>에서데이터> 가져오기.
- Exchange Server 액세스 대화 상자에서 Email 주소와 암호를 입력합니다.
- 저장을 선택합니다.
- Microsoft Exchange 자동 검색 서비스 대화 상자에서 허용을 선택하여 Exchange 서비스가 자격 증명을 신뢰하도록 허용합니다.
고급 커넥터 옵션에 대한 자세한 내용은 Microsoft Exchange를 참조하세요.
ODBC 데이터 원본에 연결
- 데이터> 선택ODBC의다른 원본>에서데이터를> 가져옵니다.
- ODBC에서 대화 상자가 표시되면 DSN(데이터 원본 이름)을 선택합니다.
- 연결 문자열을 입력한 다음, 확인을 선택합니다.
- 다음 대화 상자에서 기본값 또는 사용자 지정, Windows 또는 데이터베이스 연결 옵션 중에서 선택하고 자격 증명을 입력한 다음 연결을 선택합니다.
- 탐색기 창에서 연결할 테이블 또는 쿼리를 선택한 다음 로드 또는 편집을 선택합니다.
고급 커넥터 옵션에 대한 자세한 내용은 ODBC 데이터 원본을 참조하세요.
기타 원본: OLE DB
- 데이터> 선택OLEDB에서다른 원본>에서데이터를> 가져옵니다.
- OLE DB에서 대화 상자에 연결 문자열을 입력한 다음 확인을 선택합니다.
- OLEDB 공급자 대화 상자에서 기본값 또는 사용자 지정, Windows 또는 데이터베이스 연결 옵션 중에서 선택하고 적절한 자격 증명을 입력한 다음 연결을 선택합니다.
- 탐색기 대화 상자에서 연결할 데이터베이스와 테이블 또는 쿼리를 선택한 다음 로드 또는 편집을 선택합니다.
고급 커넥터 옵션에 대한 자세한 내용은 OLE DB를 참조하세요.
기타 원본: 빈 쿼리
빈 쿼리를 만들 수 있습니다. 데이터를 입력하여 일부 명령을 시도하거나 파워 쿼리에서 원본 데이터를 선택할 수 있습니다.
- 자격 증명 또는 개인 정보와 같은 설정을 변경하려면 홈>데이터 원본 설정을 선택합니다. 자세한 내용은 데이터 원본 설정 및 권한 관리를 참조하세요.
- 외부 데이터 원본을 가져오려면 홈>새 원본을 선택합니다. 이 명령은 Excel 리본의 데이터 탭에 있는 데이터 가져오기 명령과 유사합니다.
- 최근 원본을 가져오려면 홈>최근 원본을 선택합니다. 이 명령은 Excel 리본 메뉴의 데이터 탭에 있는 최근 원본 명령과 비슷합니다.
쿼리 결합: 병합
두 개의 외부 데이터 원본을 병합하는 경우 두 테이블 간의 관계를 만드는 두 쿼리를 조인하게 됩니다.
자세한 내용은 쿼리 병합(파워 쿼리),여러 데이터 원본을 결합하는 방법 알아보기(파워 쿼리) 및 쿼리 병합 개요를 참조하세요.
쿼리 결합: 추가
두 개 이상의 쿼리를 추가하면 데이터가 두 테이블의 열 머리글 이름을 기준으로 쿼리에 추가됩니다. 쿼리에 일치하는 열이 없으면 일치하지 않는 열에 null 값이 추가됩니다. 쿼리는 선택한 순서대로 추가됩니다.
자세한 내용은 쿼리 추가(파워 쿼리) 및 쿼리 추가를 참조하세요.
프로그래밍 방식으로 및 함수 사용 데이터 가져오기
개발자인 경우 Excel에서 데이터를 가져오는 데 사용할 수 있는 몇 가지 접근 방식이 있습니다.
- Visual Basic for Applications를 사용하여 외부 데이터 원본에 액세스할 수 있습니다. 데이터 원본에 따라 ActiveX 데이터 개체 또는 데이터 액세스 개체를 사용하여 데이터를 검색할 수 있습니다. 코드에서 연결 정보를 지정하는 연결 문자열을 정의할 수도 있습니다. 연결 문자열을 사용하면 예를 들어 시스템 관리자나 사용자가 연결 파일을 먼저 만들 필요가 없도록 하거나 응용 프로그램 설치를 간소화하려는 경우에 유용합니다.
- SQL Server 데이터베이스에서 데이터를 가져오는 경우 OLE DB와 ODBC 모두에 사용되는 독립 실행형 데이터 액세스 API(응용 프로그래밍 인터페이스)인 SQL Native Client를 사용하는 것이 좋습니다. SQL OLE DB 공급자와 SQL ODBC 드라이버를 하나의 네이티브 DLL(동적 연결 라이브러리)으로 결합하는 동시에 MDAC(Microsoft 데이터 액세스 구성 요소)와는 별도의 새로운 기능을 제공합니다. SQL Native Client를 사용하여 새 응용 프로그램을 만들거나 MARS(다중 활성 결과 집합), UDT(User-Defined 형식) 및 XML 데이터 형식 지원과 같은 최신 SQL Server 기능을 활용할 수 있는 기존 응용 프로그램을 개선할 수 있습니다.
- RTD 함수는 COM 자동화를 지원하는 프로그램에서 실시간 데이터를 검색합니다. 이 함수를 사용하려면 RTD COM 자동화 추가 기능을 만들고 로컬 컴퓨터에 등록해야 합니다.
- The SQL. REQUEST 함수는 외부 데이터 원본과 연결하고 워크시트에서 쿼리를 실행합니다. The SQL. 그러면 매크로 프로그래밍 없이 REQUEST 함수가 결과를 배열로 반환합니다. 이 함수를 사용할 수 없는 경우 Microsoft Excel ODBC 추가 기능 프로그램(XLODBC. XLA). Office.com 에서 추가 기능을 설치할 수 있습니다.
Visual Basic for Applications를 만드는 방법에 대한 자세한 내용은 Visual Basic 도움말을 참조하세요.