통합 문서에서 Excel 또는 연결 파일에 저장된 외부 데이터 원본에 대한 연결을 만들고 편집할 수 있습니다. 현재 쿼리 & 연결 창 또는 통합 문서 연결 대화 상자(이전 버전에서 사용 가능)를 사용하여 이러한 연결을 만들고, 편집하고, 삭제하는 등 이러한 연결을 쉽게 관리할 수 있습니다.

참고: 현재 컴퓨터에서 외부 데이터에 대한 연결을 사용하지 않도록 설정할 수 있습니다. 통합 문서를 열 때 데이터에 연결하려면 보안 센터를 사용하거나 통합 문서를 신뢰할 수 있는 위치에 저장하여 데이터 연결을 설정해야 합니다. 자세한 내용은 파일의 신뢰할 수 있는 위치 추가,제거 또는 수정, 신뢰할 수 있는 게시자 추가,제거 또는 보기 및 보안 센터에서 내 옵션 및 설정 보기를 참조하세요.

통합 문서의 Excel 두 위치에서 올 수 있습니다. 데이터는 통합 문서에 직접 저장되거나 텍스트 파일, 데이터베이스 또는 OLAP(온라인 분석 처리) 큐브와 같은 외부 데이터 원본에 저장될 수 있습니다. 외부 데이터 원본은 데이터 연결을 통해 통합 문서에 연결됩니다. 이는 외부 데이터 원본을 찾고, 로그인하고, 쿼리하고, 액세스하는 방법을 설명하는 정보 집합입니다.

외부 데이터 원본에 연결되어 있는 경우 새로 고침 작업을 수행하여 업데이트된 데이터를 검색할 수도 있습니다. 데이터를 새로 고칠 때마다 데이터가 마지막으로 새로 고쳐진 이후 데이터에 대한 변경 내용을 포함하여 최신 버전의 데이터가 표시됩니다.

연결 Office 정보는 통합 문서 또는 연결 파일(예: ODC) 파일(.odc) 파일(.odc) 또는 UDC(유니버설 데이터 연결) 파일(.udcx)과 같은 연결 파일에 저장할 수 있습니다. 연결 파일은 일관된 기준으로 연결을 공유하고 데이터 원본 관리가 촉진되는 데 특히 유용합니다.

연결 파일을 사용하여 데이터 원본에 Excel 연결 Excel 통합 문서로 복사합니다. 연결 속성 대화 상자를 사용하여 변경하는 경우 연결 파일 속성에 표시되는 파일 이름으로 표시된 연결을 만드는 데 사용된 원래 데이터 연결 파일이 아니라 현재 통합 문서에 Excel 데이터 연결 정보를 편집합니다. 연결 정보(연결 이름 및 연결 설명 속성 제외)를 편집하면 연결 파일에 대한 링크가 제거되고 연결 파일 속성이 지워집니다.

연결 속성 대화 상자 또는 데이터 연결 마법사를 사용하여 Excel ODC(데이터 연결) Office 만들 수 있습니다. 자세한 내용은 ODC와 연결 속성데이터 공유를 참조하세요.

  1. 다음 중 하나를 실행합니다.

  2. 연결 속성 대화 상자의 정의 탭에서 연결 파일 내보내기를 클릭하여 연결 정보를 연결 파일에 저장하여 파일 저장 대화 상자를 표시한 다음 현재 연결 정보를 ODC 파일에 저장합니다.

참고:   쿼리 & 연결 창은 독립 실행형 Microsoft Office 365 Excel Excel 버전 2019 이상에서 사용할 수 있습니다. 독립 실행형 버전 2010, 2013 및 2016에서 사용할 Excel 통합 문서 연결 대화 상자를 대체했습니다.

쿼리 & 연결 창(데이터> 쿼리 & 연결 선택)한 위치에서 외부 데이터로 작업하는 데 필요한 모든 정보와 명령을 얻을 수 있습니다. 이 창에는 두 개의 탭이 있습니다.

  • 쿼리통합 문서에 모든 쿼리를 표시됩니다. 쿼리를 마우스 오른쪽 단추로 클릭하여 사용 가능한 명령을 볼 수 있습니다. 자세한 내용은 쿼리 관리를 참조하세요.

  • 연결    통합 문서에 모든 연결이 표시됩니다. 연결을 마우스 오른쪽 단추로 클릭하여 사용 가능한 명령을 확인합니다. 자세한 내용은 연결 속성을 참조하세요.

참고:   통합 문서 연결 대화 상자는 Excel 독립 실행형 버전 2010, 2013 및 2016에서 사용할 수 있지만 쿼리 Microsoft Office 365 Excel Excel 버전 2019에서 쿼리 연결 창으로 & 대체되었습니다.

통합 문서 연결 대화 상자(데이터 > 연결 선택)를 사용하면 통합 문서의 외부 데이터 원본에 대한 하나 이상의 연결을 관리할 수 있습니다.

통합 문서 연결 대화 상자

이 대화 상자를 사용하여 다음을 할 수 있습니다.

  • 통합 문서에서 사용 중인 연결을 만들고, 편집하고 새로 고치고, 삭제합니다.

  • 예를 들어 다른 사용자가 연결을 정의하기 때문에 외부 데이터가 어디에서 오는지 확인합니다.

  • 현재 통합 문서에서 각 연결이 사용되는 위치를 보여 야 합니다.

  • 외부 데이터에 대한 연결에 대한 오류 메시지를 진단합니다.

  • 다른 서버 또는 데이터 원본으로 연결을 리디렉션하거나 기존 연결에 대한 연결 파일을 바 대체합니다.

  • 기존 연결 대화 상자를 표시하여 새 연결을 만들 수 있습니다. 자세한 내용은 외부 커넥트 (가져오기) 를 참조하세요.

  • 연결 속성 대화 상자를 표시하여 데이터 연결 속성을 수정하고 쿼리를 편집하고 매개 변수를 변경합니다. 자세한 내용은 연결 속성 을 참조하세요.

  • 사용자와 쉽게 연결 파일을 만들고 공유할 수 있습니다.

현재 통합 문서에서 연결을 관리하기 위해 다음 중 하나 이상을 합니다.

연결 식별

대화 상자의 위쪽 부분에서 통합 문서의 모든 연결이 다음 정보와 함께 자동으로 표시됩니다.

메모

Name(이름)

연결 속성 대화 상자에 정의된 연결의 이름입니다.

설명

연결 속성 대화 상자에 정의된 연결에 대한 선택적 설명입니다.

마지막 새로 고침

연결이 마지막으로 새로 고쳐진 날짜 및 시간입니다. 비어 있는 경우 연결이 새로 고쳐진 적이 없습니다.

연결 추가

연결 정보 표시

  • 연결을 선택한 다음 속성을 클릭하여 연결 속성 대화 상자를 표시합니다. 자세한 내용은 연결 속성 을 참조하세요.

외부 데이터 새로 고침

  • 새로 고침 옆의화살표를 클릭한 다음 다음 중 하나를 클릭합니다.

    • 특정 연결을 새로 고치려면 하나 이상의 연결을 선택한 다음 새로 고침을 클릭합니다.

    • 통합 문서의 모든 연결을 새로 고치려면 모든 연결을 지운 다음 모두 새로 고침 을 클릭합니다.

    • 새로 고침 작업에 대한 상태 정보를 얻려면 하나 이상의 연결을 선택한 다음 상태 새로 고침 을 클릭합니다.

    • 현재 새로 고침 작업을 중지하려면 새로 고침 취소를 클릭합니다.

자세한 내용은 에서 외부 데이터 연결 새로 고침을 Excel.

하나 이상의 연결 제거

  • 통합 문서에서 제거할 연결을 하나 이상 선택한 다음 제거를 클릭합니다.

    참고 사항: 

    • 통합 문서가 보호되거나 연결을 사용하는 피벗테이블 보고서와 같은 개체가 보호될 때 이 단추를 사용하지 않도록 설정됩니다.

    • 연결을 제거하면 연결만 제거하고 통합 문서에서 개체 또는 데이터를 제거하지 않습니다.

중요: 연결을 제거하면 데이터 원본에 대한 연결이 끊어지며 다른 수식 결과 및 다른 기능의 가능한 문제와 같은 의도하지 않은 Excel 수 있습니다.

통합 문서에 하나 이상의 연결 위치 표시

  • 하나 이상의 연결을 선택한 다음 이 통합 문서에서 연결이 사용되는 위치 아래에서 링크를클릭하여 선택한 연결이 사용되는 위치를 확인합니다.

    다음 정보가 표시됩니다.

메모

시트

연결이 사용되는 워크시트입니다.

Name(이름)

쿼리 Excel 이름입니다.

위치

셀, 범위 또는 개체에 대한 참조입니다.

셀의 값 또는 셀 범위에 대해 비어 있습니다.

수식

셀의 수식 또는 셀 범위에 대한 수식입니다.

대화 상자 맨 위에 있는 다른 연결을 선택하면 현재 정보 표시가 지워진다.

참고 항목

Excel용 파워 쿼리 도움말

추가 도움이 필요하신가요?

기술 향상
교육 살펴보기
새로운 기능 우선 가져오기
Microsoft Office 참가자 참가

이 정보가 유용한가요?

언어 품질에 얼마나 만족하시나요?
사용 경험에 어떠한 영향을 주었나요?

의견 주셔서 감사합니다!

×