작업 또는 리소스 필터링

적용 대상
Project Online 데스크톱 클라이언트 Project Standard 2024 Project Professional 2021 Project Standard 2021 Project Professional 2019 Project Standard 2019 Project Professional 2016 Project Standard 2016

Project에서는 중요한 작업, 마일스톤 및 가장 중요한 기타 정보만 표시하도록 보기를 필터링할 수 있습니다. 프로젝트에서 작업 또는 리소스를 필터링하는 방법에는 세 가지가 있습니다. 작업 및 리소스의 특정 측면을 보기 위한 미리 정의된 필터를 제공합니다. 이러한 필터 중 요구 사항을 충족하는 필터가 없으면 새 필터를 만들거나 기존 필터를 수정할 수 있습니다.

  • 미리 정의된 필터 프로젝트와 함께 제공되는 필터입니다. 완료되지 않은 작업이나 과도하게 할당된 리소스 등 작업이나 리소스를 빠르게 필터링하는 데 사용됩니다.
  • 사용자 지정 필터 다음은 프로젝트 요구 사항에 맞게 디자인하는 필터입니다.
  • 자동 필터 이 기능을 켜면 시트 보기에서 각 열의 맨 위에 화살표로 표시됩니다. 이를 사용하여 열의 항목을 빠르게 필터링할 수 있습니다.

이 문서의 내용

작업 또는 리소스 필터링

프로젝트에서 특정 유형의 정보만 보려는 경우가 있습니다. 예를 들어 프로젝트의 마일스톤만 보거나 시작되지 않은 작업을 보고 싶을 수 있습니다. 프로젝트에 많은 작업이 있고 많은 리소스가 포함된 경우 필터는 특정 범위의 정보를 보는 데 매우 유용할 수 있습니다. 필터를 사용하면 관심 있는 정보만 표시하고 나머지는 숨길 수 있습니다.

미리 정의된 프로젝트 필터를 사용하여 작업 또는 자원 데이터를 필터링할 수 있습니다. 요구 사항을 충족하는 필터가 없으면 새 필터를 만들거나 기존 필터를 수정할 수 있습니다.

필터 적용 또는 제거

  1. 보기 탭의 데이터 그룹에서 필터 목록에서 필터를 선택합니다.

    필터 명령
    목록에 없는 필터를 적용하려면 기타 필터를 선택하고 다음 중 하나를 수행합니다.

    • 작업 필터를 선택하려면 [Task]를 선택하고 [Filters] 목록에서 필터 이름을 선택한 다음 [Apply]를 선택합니다.

    • 리소스 필터를 선택하려면 [Resource]를 선택하고 [Filters] 목록에서 필터 이름을 선택한 다음 [Apply]를 선택합니다.

      참고

      작업 필터를 리소스 보기에 적용하거나 리소스 필터를 작업 보기에 적용할 수 없습니다.

  2. 대화형 필터를 적용하는 경우 요청된 값을 입력한 다음 확인을 선택합니다.

  3. 필터를 끄려면 필터 목록에서 필터 없음 을 선택합니다.

강조 표시를 사용하여 필터링된 작업에 색 적용

작업 또는 리소스를 필터링할 때 강조 표시를 적용할 수 있습니다. 강조 표시된 작업 또는 리소스는 필터링되지 않은 작업과 함께 표시되지만 색은 다릅니다.

  1. 보기 탭의 데이터 그룹에서 필터 목록에서 필터를 선택한 다음 기타 필터를 선택합니다.
  2. 필터 목록에서 필터를 선택한 다음, 강조 표시를 선택합니다.

팁

강조 표시된 작업에 다른 색을 적용하려면 다른 텍스트 스타일을 사용합니다. 서식 탭을 선택한 다음 텍스트 스타일을 선택합니다. 변경할 항목 목록에서 강조 표시된 작업을 선택한 다음 서식 옵션을 선택합니다.

사용자 지정 필터 만들기

  1. 보기 탭의 데이터 그룹에서 필터 옆에 있는 화살표를 선택한 다음 추가 필터를 선택합니다.
    사용자 지정 필터를 만드는 방법을 보여 주는 Project 리본 메뉴
  2. 작업 또는 리소스(만들려는 필터 유형에 따라 다름)를 선택한 다음 새로 만들기를 선택합니다.
  3. 새 필터의 이름을 입력합니다. 이 필터를 데이터 그룹 목록에 포함하려면 메뉴에 표시를 선택합니다.
  4. 및/또는 열에서 And를 선택하여 둘 이상의 필터 조건을 충족하는 결과를 표시합니다. Or를 선택하여 둘 중 하나와 만나는 행을 표시합니다.
    필터에서 원하는 결과 유형에 따라 그리고/또는 중에서 선택
  5. 필드 이름 열에서 필터링할 필드를 선택합니다.
  6. 테스트 열에서 필드 이름 열에 대해 선택한 항목을 다음 단계의 값 열과 일치시키는 방법을 결정합니다.
  7. 값 열에서 원하는 값을 선택하거나 새 값을 입력합니다.
    테스트 열에서 같음 또는 같지 않음을 선택한 경우 목록에서 옵션을 선택하는 대신 값 열에 와일드카드 문자를 입력할 수 있습니다. 예를 들어 물음표(?)를 입력하면 한 글자를 찾습니다. 별표(*)를 입력하면 원하는 개수를 찾습니다. 와일드카드를 사용하는 경우 필드 이름 열에 숫자(예: 기간) 대신 텍스트(예: 이름)가 포함되어야 합니다.
  8. 필터에 다른 행을 추가하거나 필터링할 다른 필드 이름을 선택하려면 행 삽입을 선택합니다. 빈 행을 추가하여 행을 그룹화할 수 있습니다. 빈 행에 And 또는 Or 를 추가하여 한 그룹을 다른 그룹에 대해 필터링합니다.
  9. 완료되면 저장을 선택합니다.

팁

모든 필터를 빠르게 제거하려면 F3 키를 사용합니다. 작업 필터는 작업 보기에서만 작동하고 리소스 필터는 리소스 보기에서만 작동합니다.

기존 필터 수정

  1. 보기 탭의 데이터 그룹에서 필터 목록을 선택한 다음 추가 필터를 선택합니다.

  2. 다음 중 하나를 실행합니다.

    • 작업 필터를 수정하려면 [Task]를 선택하고 수정할 필터를 선택한 다음 [Edit]를 선택합니다.
    • 리소스 필터를 수정하려면 [Resource]를 선택하고 수정할 필터를 선택한 다음 [Edit]를 선택합니다.
  3. 필터 정의 대화 상자의 컨트롤을 사용하여 필터 설정을 수정합니다.

자동 필터 사용

모든 시트 보기의 필드에 자동 필터를 적용할 수 있습니다. 표준 필터 외에도 Project에서는 시트 보기의 각 열 맨 위에 표시되는 자동 필터를 제공합니다.

자동 필터 적용 및 제거

  1. 보기 탭의 데이터 그룹에서 필터 목록의 화살표를 선택한 다음 자동 필터 표시를 선택합니다.
    필터 명령

  2. 표시하려는 정보가 포함된 열 머리글 옆에 있는 자동 필터 화살표를 선택한 다음 값을 선택하여 테이블을 필터링합니다.
    자동 필터 화살표와 필드 머리글이 파란색으로 바뀝니다.

  3. 다른 열의 값을 기반으로 추가 조건을 적용하려면 다른 열에 대해 2단계를 반복합니다.

  4. 특정 행에 대한 필터링을 제거하려면 해당 필드의 자동 필터 목록에서 모든 필터 지우기를 선택합니다.

  5. 자동 필터를 끄려면 자동 필터 표시를 다시 선택합니다.

    참고

    보기의 행 중 하나에서 정보가 변경되면 화살표를 선택하고 필터링 값을 다시 선택하여 자동 필터 설정을 새로 고칠 수 있습니다.

사용자 지정 자동 필터 만들기

  1. 자동 필터 표시.

  2. 자동 필터 화살표를 선택하고 필터를 가리킨 다음 사용자 지정을 선택합니다.

  3. 첫 번째 상자에서 사용할 연산자를 선택한 다음, 두 번째 상자에서 일치시킬 값을 입력하거나 선택합니다.
    예를 들어 날짜 필드의 특정 날짜를 일치시키려면 첫 번째 상자에서 등수 연산자를 선택한 다음 두 번째 상자에서 일치시킬 날짜를 선택합니다.

  4. 자동 필터에 두 조건을 적용하려면 다음 중 하나를 수행합니다.

    • 보기에서 두 조건을 모두 만족하는 행을 표시하려면 두 번째 상자 행에서 원하는 연산자와 값을 선택한 다음 And(은)를 선택합니다.
    • 보기에서 한 조건이나 다른 조건에 맞는 행을 표시하려면 두 번째 상자 행에서 원하는 연산자와 값을 선택한 다음 Or를 선택합니다.
  5. 자동 필터 설정을 저장하려면 [저장]을 선택합니다.
    보기에 이미 미리 정의된 필터가 적용된 경우 자동 필터에 대해 설정한 조건이 현재 필터에 대한 추가 조건으로 포함됩니다. 자동 필터 설정을 저장하면 필터가 파일의 다른 필터와 함께 저장되며 추가 필터 대화 상자를 통해서만 사용할 수 있습니다.

새 프로젝트에 대해 자동으로 자동 필터 켜기

  1. 파일 탭에서 옵션을 선택합니다.
  2. 고급을 선택한 다음 일반 섹션에서 새 프로젝트에 대한 자동 필터 설정 검사란을 선택합니다.

맨 위로 이동