이 문서는 모든 국가 및 모든 언어 로캘에 대해 Microsoft Dynamics NAV 5.0에 적용됩니다.
증상
Microsoft Dynamics NAV 5.x에서 Microsoft Dynamics NAV 4.x 데이터베이스를 열면 다음 오류 메시지와 유사한 오류 메시지가 표시됩니다.
참고
TableName 테이블을 수정할 수 있는 권한이 없습니다.
참고 TableName 자리 표시자는 테이블의 이름을 나타냅니다.
이 문제는 다음과 같은 경우에 발생합니다.
- 기본 키의 클러스터된 속성은 모든 테이블에 대해 예로 변경됩니다.
- 데이터베이스가 Microsoft Dynamics NAV 5.0으로 업그레이드됩니다.
원인
이 문제는 데이터베이스에 현재 라이선스에 권한이 없는 개체가 포함되어 있기 때문에 발생합니다.
해결 방법
이 문제를 해결하려면 다음과 같이 하십시오.
- Microsoft Dynamics NAV 4.x 데이터베이스의 백업을 만듭니다.
- Microsoft Dynamics NAV 5.x에서 새 데이터베이스를 만듭니다.
- 백업을 복원합니다.
해결 방법
이제 Microsoft에서 지원되는 핫픽스를 사용할 수 있습니다. 핫픽스는 이 문서에 설명된 문제를 해결합니다. 이 특정 문제가 발생하는 시스템에만 핫픽스를 적용합니다.
이 문제를 즉시 resolve 위해 Microsoft Dynamics 및 관련 제품에 대한 기술 지원에 문의하여 핫픽스를 가져옵니다. Microsoft Dynamics 사이트에 로그온하고 새 지원 요청을 만들 수 있습니다. 이렇게 하려면 다음 Microsoft 웹 사이트를 방문하십시오.
https://mbs.microsoft.com/support/newstart.aspx (888) 477-7877에서 전화로 Microsoft Dynamics 및 관련 제품에 대한 기술 지원에 문의할 수도 있습니다.
참고 특별한 경우 Microsoft Dynamics 및 관련 제품에 대한 기술 지원 전문가가 특정 업데이트가 문제를 resolve 판단하는 경우 지원 호출에 대해 일반적으로 발생하는 요금이 취소될 수 있습니다. 일반적인 지원 비용은 문제의 특정 업데이트에 적합하지 않은 추가 지원 질문 및 문제에 적용됩니다.
필수 구성 요소
이 핫픽스를 적용하려면 Microsoft Dynamics NAV 4.0이 설치되어 있어야 합니다.
제거 정보
이 핫픽스는 제거할 수 없습니다.
다시 시작 요구 사항
이 핫픽스를 적용한 후에는 컴퓨터를 다시 시작할 필요가 없습니다.
Microsoft Dynamics NAV 핫픽스를 가져오거나 파일을 업데이트하는 방법
Microsoft Dynamics NAV 핫픽스 또는 Microsoft Dynamics 기술 지원에서 업데이트 파일을 요청하면 전자 메일로 하이퍼링크가 전송됩니다.
전자 메일에는 하이퍼링크와 암호가 포함됩니다. 하이퍼링크를 사용하여 Microsoft Dynamics NAV 핫픽스 또는 업데이트 파일을 다운로드할 수 있습니다. 하이퍼링크를 클릭하면 파일 다운로드 – 보안 경고 대화 상자가 열립니다. 그런 다음, 다운로드를 실행, 저장 또는 취소하라는 메시지가 표시됩니다.
실행을 클릭하면 파일이 다운로드 및 추출 프로세스를 시작합니다. 새 파일의 폴더를 지정한 다음 암호를 제공해야 합니다.
저장을 클릭하면 압축된 파일을 저장할 경로를 지정해야 합니다. 저장한 파일을 열면 파일의 경로를 지정하라는 메시지가 표시됩니다. 그런 다음, 전자 메일에 제공된 암호를 제공해야 합니다.
취소를 클릭하면 다운로드 프로세스가 중지됩니다.
Microsoft Dynamics NAV 핫픽스 또는 업데이트 파일을 설치하는 방법
Microsoft Dynamics NAV 플랫폼 핫픽스 및 업데이트는 단일 파일로 사용할 수 있습니다. Microsoft Dynamics NAV 핫픽스 또는 업데이트를 설치하려면 기존 Microsoft Dynamics NAV 설치 파일을 핫픽스 또는 업데이트 파일로 바꿔야 합니다. 이렇게 하려면 다음 단계를 수행합니다.
Microsoft Dynamics NAV 애플리케이션 서버가 설치된 경우 Microsoft Dynamics NAV 애플리케이션 서버 설치에서 다음 파일을 바꿔야 합니다.
| 파일 이름 | 파일 버전 | 파일 크기 | 날짜 | 시간 | 플랫폼 |
|---|---|---|---|---|---|
| Fin.exe | 5.0.24632.0 | 10,737,104 | 2007년 5월 23일 | 01:30 | x86 |
| Finsql.exe | 5.0.24632.0 | 10,794,448 | 2007년 5월 23일 | 01:30 | x86 |
파일을 바꾸려면 다음 단계를 수행합니다.
- 모든 Microsoft Dynamics NAV 작업을 중지합니다.
- Microsoft Dynamics NAV ODBC(Open Database Connectivity) 드라이버 설치 디렉터리를 찾습니다. Microsoft Dynamics NAV ODBC 드라이버는 일반적으로 다음 디렉터리에 설치됩니다.
C:\Program Files\Common Files\Navision\NODBC\ - 다운로드한 파일을 복사합니다.
- 다운로드한 파일을 Microsoft Dynamics NAV ODBC 드라이버 설치 디렉터리에 붙여넣습니다.
- 예를 클릭하여 디렉터리의 파일을 덮어씁니다.
상태
Microsoft는 이것이 "적용 대상" 섹션에 나열된 Microsoft 제품의 버그임을 확인했습니다.
추가 정보
자세한 내용은 다음 문서 번호를 클릭하여 Microsoft 기술 자료 문서를 참조하세요.
824684 Microsoft를 설명하는 데 사용되는 표준 용어에 대한 설명