증상
사서함 데이터베이스의 논리 인덱스에 문제가 있는 사서함이 있다고 가정합니다. 사서함에서 이동, 복원 또는 복구 작업을 사용하려고 하면 Store Worker 프로세스가 임의로 응답을 중지하고 다음 오류 메시지가 나타납니다.
참고
System.NullReferenceExceptions" at "Microsoft.Exchange.Server.Storage.LazyIndexing.LogicalIndex.. ctor
또한 다음 이벤트가 응용 프로그램 이벤트 로그에 기록됩니다.
참고
로그 이름: 응용 프로그램
출처: MSExchange Common
날짜:
이벤트 ID: 4999
작업 범주: 일반
수준: 오류
키워드: 클래식
사용자: 해당 없음
컴퓨터: XXX
설명:
프로세스 ID: 20056에 대해 Watson 보고서를 보내려고 하며, 매개 변수: E12, c-RTL-AMD64, 15.01.1261.035, M.E.Store.Worker, M.E.S.Storage.LazyIndexing, M.E.S.S.L.LogicalIndex.. ctor, System.NullReferenceException, 1b58-dumptidset, 15.01.1261.035.
ErrorReportingEnabled: False
원인
이 문제는 사서함의 느린 인덱스를 성공적으로 로드할 수 없기 때문에 발생합니다. 이로 인해 Store Worker 프로세스가 중단됩니다.
노트 이러한 지연 인덱스는 사서함 데이터베이스의 일부이므로 Microsoft Exchange Search Service에서 작성 및 유지 관리하는 컨텍스트 인덱스와 다릅니다.
해결 방법
Exchange Server 2016
이 문제를 resolve 하려면 Exchange Server 2016용 누적 업데이트 9 또는 Exchange Server 2016용 이후의 누적 업데이트를 설치합니다.
상태
Microsoft에서 이는 "적용 대상" 섹션에 나열된 Microsoft 제품에서의 문제임을 확인했습니다.
참조 자료
Microsoft에서 소프트웨어 업데이트를 설명하는 데 사용하는 용어에 대해 알아보세요.