증상
SQLDiag 유틸리티가 Windows 클러스터의 서버에서 실행되고 이 클러스터 그룹에 포함된 컴퓨터 한 대 이상의 이름이 15자 길이의 경우 SQLDiag 유틸리티가 실패합니다. 또한 SQLDiag 출력 로그에서 다음 오류 메시지를 받습니다.
참고
가상 서버를 열거하는 동안 오류가 발생했습니다. SQL Server instance가 클러스터링되어 있나요?
이 컴퓨터에 버전 12의 인스턴스가 없습니다.
기능 결과: 87. 메시지: 매개 변수가 잘못되었습니다.
해결 방법
이 문제는 다음 SQL Server 누적 업데이트에서 처음 해결되었습니다.
권장 사항: SQL Server용 최신 누적 업데이트 설치
SQL Server에 대한 각각의 새로운 누적 업데이트에는 이전 누적 업데이트에 포함된 모든 핫픽스와 모든 보안 수정 사항이 포함되어 있습니다. SQL Server용 최신 누적 업데이트를 다운로드하여 설치하는 것이 좋습니다.
상태
Microsoft에서 이는 "적용 대상" 섹션에 나열된 Microsoft 제품에서의 문제임을 확인했습니다.