KB4101482 - 수정: SQL Server에서 Always On 가용성 그룹을 사용할 때 자동 시딩이 실패함

적용 대상
SQL Server 2017 Developer SQL Server 2017 Enterprise SQL Server 2017 Enterprise Core

증상

SQL Server 2017에서 자동 시드와 함께 Always On 가용성 그룹을 사용한다고 가정합니다. Always On 가용성 그룹에 새 데이터베이스를 추가하고 데이터베이스와 로그 간에 다른 기본 디렉터리를 설정하면 자동 시딩 기능이 실패합니다.

해결 방법

이 해결 방법은 SQL Server 2017용 누적 업데이트 6에 포함되어 있습니다.

SQL Server 2017 빌드 정보

SQL Server 2017의 각 새 빌드에는 이전 빌드의 모든 핫픽스 및 보안 수정 사항이 포함되어 있습니다. SQL Server 2017용 최신 빌드를 설치하는 것이 좋습니다.

해결 방법

이 문제를 해결하려면 다음 중 하나를 수행하세요.

  • Always On 가용성 그룹의 모든 복제본(replica)에 대해 동일한 디렉터리 레이아웃을 사용합니다.
  • 로그 기본 디렉터리를 데이터베이스 기본 디렉터리와 같은 위치로 구성합니다.
  • 수동 시딩을 사용합니다.

상태

Microsoft에서 이는 "적용 대상" 섹션에 나열된 Microsoft 제품에서의 문제임을 확인했습니다.

참조 자료

Always On 가용성 그룹 자동 초기화

Microsoft에서 소프트웨어 업데이트를 설명하는 데 사용하는 표준 용어 에 대해 알아보세요.