KB3016165 - FIX: SQL Server에 게시하기 위해 수동으로 초기화된 구독을 추가할 때 산술 오버플로 오류가 발생합니다.

적용 대상
SQL Server 2012 Developer SQL Server 2012 Enterprise SQL Server 2012 Standard SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use) SQL Server 2014 Web - duplicate (do not use)

증상

Microsoft SQL Server 2012 또는 SQL Server 2014 트랜잭션 복제를 사용한다고 가정합니다. 게시에 대해 '복제 지원만', '백업으로 초기화' 또는 'lsn에서 초기화'로 지정된 구독 @sync\_type 을 추가하려고 할 때 게시 ID가 99보다 큽니다. 다음과 오류 메시지가 나타납니다.

참고

메시지 8115, 수준 16, 상태 2, 절차 sp_MSsetupnosyncsubscriptionwithlsn, 줄 237
식을 데이터 형식 nvarchar로 변환하는 산술 오버플로 오류입니다.

해결 방법

누적 업데이트 정보

이 문제는 다음 SQL Server 누적 업데이트에서 처음 해결되었습니다.

SQL Server의 누적 업데이트 정보

SQL Server에 대한 각각의 새로운 누적 업데이트에는 이전 누적 업데이트에 포함된 모든 핫픽스와 모든 보안 수정 사항이 포함되어 있습니다. SQL Server에 대한 최신 누적 업데이트를 확인하세요.

      

상태

Microsoft에서 이는 "적용 대상" 섹션에 나열된 Microsoft 제품에서의 문제임을 확인했습니다.