KB4023926 - FIX: SQL Server의 P2P 게시에서 저장 프로시저 실행 문서를 삭제할 수 없음

적용 대상
SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use) SQL Server 2014 Service Pack 2 - duplicate (do not use) SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Enterprise Core - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use) SQL Server 2016 Service Pack 1 SQL Server 2017 on Windows (all editions)

증상

Microsoft SQL Server에서 P2P(피어 투 피어) 게시물을 만들고 저장 프로시저 실행 문서를 추가한다고 가정합니다. 저장 프로시저가 게시자에서 실행되면 복제는 구독자에서 해당 프로시저를 실행합니다. 그러나 저장 프로시저 실행 문서를 삭제하려고 하면 다음과 유사한 오류 메시지가 나타날 수 있습니다.

참고

  • ProcedureName 문서를 삭제할 수 없습니다.
  • Transact-SQL 문 또는 일괄 처리를 실행하는 동안 예외가 발생했습니다. (Microsoft.SqlServer.ConnectionInfo)
  • 세션이 kill 상태이므로 실행을 계속할 수 없습니다.
  • 현재 명령에 심각한 오류가 발생했습니다.  결과가 있는 경우 해당 결과를 삭제해야 합니다.
  • 데이터베이스 컨텍스트가 DatabaseName으로 변경되었습니다. (Microsoft SQL Server, 오류: 596)

해결 방법

이 문제는 SQL Server에 대한 다음과 같은 누적 업데이트에서 해결되었습니다.

SQL Server 2017용 누적 업데이트 1

SQL Server 2016 RTM용 누적 업데이트 8

SQL Server 2016 SP1용 누적 업데이트 5

SQL Server 2014 SP2용 누적 업데이트 6

SQL Server용 누적 업데이트 정보:

SQL Server에 대한 각각의 새로운 누적 업데이트에는 이전 누적 업데이트에 포함된 모든 핫픽스와 모든 보안 수정 사항이 포함되어 있습니다. SQL Server에 대한 최신 누적 업데이트를 확인하세요.

SQL Server 2017용 최신 누적 업데이트

SQL Server 2016용 최신 누적 업데이트

SQL Server 2014용 최신 누적 업데이트

상태

Microsoft에서 이는 "적용 대상" 섹션에 나열된 Microsoft 제품에서의 문제임을 확인했습니다.

참조 자료

Microsoft에서 소프트웨어 업데이트를 설명하는 데 사용하는 용어에 대해 알아보세요.