증상
Linux의 Microsoft SQL Server 2019 또는 2017의 호스트에서 원격 관리자 연결을 사용하도록 설정하고 IPV6을 사용하지 않도록 설정하면 SQL Server가 IPV6에서 수신 대기하려고 시도하지만 시작되지 않습니다.
날짜/시간 서버 오류: 26024, 심각도: 16, 상태: 1.
날짜/시간 서버 서버가 'any' <ipv6> 1434를 수신 대기하지 못했습니다. 오류: 0x2742. 계속하려면 시스템 관리자에게 알립니다.
날짜/시간 오류 0x2742 상태 코드: 0x1로 인해 서버 전용 관리자 연결 지원이 시작되지 않았습니다. 이 오류는 일반적으로 이미 사용 중인 포트와 같은 소켓 기반 오류를 나타냅니다.
상태
Microsoft에서 이는 "적용 대상" 섹션에 나열된 Microsoft 제품에서의 문제임을 확인했습니다.
해결 방법
이 문제는 SQL Server에 대한 다음과 같은 누적 업데이트에서 해결되었습니다.
SQL Server용 누적 업데이트 정보:
SQL Server에 대한 각각의 새로운 누적 업데이트에는 이전 누적 업데이트에 포함된 모든 핫픽스와 모든 보안 수정 사항이 포함되어 있습니다. SQL Server에 대한 최신 누적 업데이트를 확인하세요.
참조 자료
Microsoft에서 소프트웨어 업데이트를 설명하는 데 사용하는 용어에 대해 알아보세요.