KB2972463 - 수정: SharePoint 통합 모드에서 SSRS 2012 또는 SSRS 2014를 사용할 때 보고서 캐시가 정리되지 않음

증상

다음 시나리오를 고려하세요.

  • SharePoint 통합 모드에서 Microsoft SQL Server 2012 Reporting Services(SSRS 2012) 또는 SSRS 2014를 사용합니다.
  • 데이터 새로 고침 옵션을 캐시된 데이터 사용으로 설정하고 캐시 옵션을 공유 일정 또는 사용자 지정 일정으로 설정합니다.
  • SSRS가 캐시를 무효화하고 캐시를 플러시하는 일정을 구성합니다.

이 시나리오에서는 다음과 유사한 예외가 기록됩니다.

참고

w3wp!schedule!e!<날짜>-<시간>:: i 정보: 데이터 4248182a-16b1-4c6a-b630-298cd24ae152로 이벤트 CacheInvalidateSchedule 처리.
w3wp!라이브러리!e!<날짜>-<시간>:: i 정보: 일정 591b959d-5754-4dc6-95b6-a988d8c4587a 실행 시간: 04/24/2014 20:30:07.
w3wp!schedule!e!<날짜>-<Time>:: i INFO: 보고서 /{59ee4a21-c7c4-49f7-b812-29f060672d08}/<Item Path>'에 대한 보고서 캐시 무효화
w3wp!라이브러리!e!<날짜>-<Time>:: i INFO: FlushCacheAction()을 호출합니다.
w3wp!라이브러리!e!<날짜>-<시간>:: e 오류: Microsoft.ReportingServices.Diagnostics.Utilities.InvalidItemPathException 발생: , Microsoft.ReportingServices.Diagnostics.Utilities.InvalidItemPathException: 항목 '/{59ee4a21-c7c4-49f7-b812-29f060672d08}</항목 경로>'의 경로가 올바르지 않습니다. 전체 경로는 260자 미만이어야 합니다. 기타 제한 사항이 적용됩니다. 보고서 서버가 기본 모드인 경우 경로는 슬래시로 시작해야 합니다.
w3wp!라이브러리!e!<날짜>-<시간>:: e 오류: 일정 591b959d-5754-4dc6-95b6-a988d8c4587a가 실패했습니다. 오류 Microsoft.ReportingServices.Diagnostics.Utilities.InvalidItemPathException: '/{59ee4a21-c7c4-49f7-b812-29f060672d08}</항목 경로>'의 경로가 올바르지 않습니다. 전체 경로는 260자 미만이어야 합니다. 기타 제한 사항이 적용됩니다. 보고서 서버가 기본 모드인 경우 경로는 슬래시로 시작해야 합니다.

예외가 발생한 후 보고서 캐시가 정리되지 않습니다. 이렇게 하면 데이터베이스 크기가 빠르게 증가하고 정리되지 않습니다.

원인

제품에 알려진 제한 사항이 있기 때문에 문제가 발생합니다.

해결 방법

이 문제는 다음 SQL Server 누적 업데이트에서 처음 해결되었습니다.

SQL Server 2014용 누적 업데이트 4 /en-us/help/2999197

SQL Server 2012 SP2용 누적 업데이트 2 /en-us/help/2983175

SQL Server 2012 SP1용 누적 업데이트 11 /en-us/help/2975396

SQL Server의 누적 업데이트 정보

SQL Server에 대한 각각의 새로운 누적 업데이트에는 이전 누적 업데이트에 포함된 모든 핫픽스와 모든 보안 수정 사항이 포함되어 있습니다. SQL Server에 대한 최신 누적 업데이트를 확인하세요.

      

상태

Microsoft에서 이는 "적용 대상" 섹션에 나열된 Microsoft 제품에서의 문제임을 확인했습니다.