이 문서에서는 Microsoft SQL Server 2014에서 새로운 기능 버퍼 풀 확장을 사용할 때 Microsoft SQL Server 2014 SP1(서비스 팩 1)의 오류 보고 개선 사항에 대해 설명합니다.
추가 정보
SQL Server 2014에서 버퍼 풀 확장 기능을 사용하도록 설정하면 다음과 같은 알려진 문제가 발생할 수 있습니다.
버퍼 풀 확장 기능을 사용하도록 설정하면 해당 크기가 SQL Server 2014 Standard Edition의 최대 서버 메모리 크기의 4배보다 작거나 4배에 가깝습니다. 예를 들어 최대 서버 메모리 크기는 28GB이고 버퍼 풀 확장 크기는 109GB입니다. SQL Server 서비스를 다시 시작하려고 하면 SQL Server를 시작할 수 없으며 SQL Server 오류 로그에 다음 오류 메시지가 표시됩니다.
참고
< 날짜><시간>디스크 이름>:\Windows\Microsoft.NET\Framework64\v4.0.30319\에서 < CLR 버전 v4.0.30319를 사용하여 초기화된 서버 CLR(공용 언어 런타임) 기능입니다.
< 날짜><시간> spid8s 최대 12989098 페이지 디스크립터에 대해 버퍼 풀 확장을 위해 14299819 BUF를 할당하려고 합니다.
< 날짜><시간> spid8s 오류: 864, 심각도: 16, 상태: 1.
< 날짜><시간> spid8s 최대 12989098 페이지 디스크립터에 대해 버퍼 풀 확장을 위해 14299819 BUF를 할당하려고 합니다.SQL Server 2014 SP1(서비스 팩 1)을 적용한 후에는 이 문제 없이 SQL Server를 다시 시작할 수 있습니다.
버퍼 풀 확장 기능을 사용 가능하게 한 후 최대 서버 메모리 크기를 이전에 정의된 버퍼 풀 확장 파일 크기보다 크도록 구성합니다(기본적으로 버퍼 풀 확장 크기는 최대 서버 메모리 크기보다 커야 함). 구성이 성공하고 버퍼 풀 확장이 올바르게 작동합니다. 그러나 SQL Server 서비스를 다시 시작한 후 버퍼 풀 확장을 사용할 수 없으며 SQL Server 오류 로그에 다음 오류 메시지가 표시됩니다.
참고
< 날짜><시간> 서버 버퍼 풀 확장 크기는 실제 메모리 크기 < 인 최대 서버 메모리에서 지정된> MB보다 커야 합니다. 버퍼 풀 확장을 사용할 수 없습니다.
SQL Server 2014 SP1을 적용한 후 SQL 오류 로그의 메시지 외에도 SSMS(SQL Server Management Studio)에서 다음과 같은 경고 메시지가 표시됩니다.
참고
지정된 최대 서버 메모리 - <XXXMB> 가 버퍼 풀 확장 파일 크기( <XXXMB> )보다 큽니다. 다시 시작 시 버퍼 풀 확장이 비활성화됩니다.
충분한 공간이 없는 디스크에 버퍼 풀 확장 파일을 만들면(예: 최대 서버 메모리 크기가 28GB이고 버퍼 풀 확장 크기가 120GB) SQL Server 오류 로그에 다음과 같은 모호한 운영 체제 오류 메시지가 표시됩니다.
참고
< 날짜><시간> spid52 CREATE FILE에서 운영 체제 오류가 발생했습니다. 실제 파일 '파일 경로>'<를 열거나 만들 때 파일 크기 변경에 실패했습니다. BPE'입니다.
SQL Server 2014 SP1을 적용하면 다음과 같은 명확한 오류 메시지가 나타납니다.
참고
운영 체제 오류(디스크에 공간이 부족함)
크기가 매우 큰 버퍼 풀 확장 파일을 구성할 때 다음 오류 메시지가 표시되며 실제 의미를 설명할 수 없습니다.
참고
메시지 864, 수준 16, 상태 1, 줄 1
최대 12800페이지 디스크립터에 대한 버퍼 풀 확장에 25600 BUF를 할당하려고 합니다.SQL Server 2014 SP1이 적용되면 오류 메시지가 다음과 같이 변경됩니다.
참고
크기 <XXX> KB의 버퍼 풀 확장을 초기화하려고 했지만 최대 허용 크기는 XXX> KB입니다<.
일부 오류(예: 지정된 디렉터리가 없는 경우)로 인해 SSD(반도체 드라이브) 확장 파일 생성이 실패하면 SQL Server는 다음 오류 메시지를 출력합니다.
참고
경로 ""에 크기 XXX> MB의 < 버퍼 풀 확장을 만들지 못했습니다.
오류 메시지의 경로가 인쇄되지 않습니다.
SQL Server 2014 SP1을 적용한 후 SSD 파일 생성에 실패했을 때 경로가 올바르게 인쇄됩니다.
서비스 팩 정보
SQL Server 2014용 서비스 팩 1을 다운로드하려면 다음 링크를 참조하세요.
SQL Server 2014 SP1(서비스 팩 1)에 대한 자세한 내용은 SQL Server 2014 서비스 팩 1에서 해결된 버그를 참조하세요.
상태
Microsoft에서 이는 "적용 대상" 섹션에 나열된 Microsoft 제품에서의 문제임을 확인했습니다.