KB4552159-FIX: SQL Server 2019에서 PolyBase 외부 테이블에 보안 정책을 적용 하면 오류가 발생 합니다.

증상

에서 보안 정책을 적용 하려고 할 때 SQL Server 2019의 PolyBase 외부 테이블에서 "보안 조건자는 사용자 테이블 및 스키마 바운드 뷰에만 추가할 수 있습니다." 라는 오류 메시지가 나타날 수 있습니다. 이 해결 방법을 사용 하 여 PolyBase 외부 테이블에 보안 정책을 만들고 RLS (행 수준 보안)를 사용할 수 있습니다.

참고 수정은 기본적으로 사용 되지 않으며, 외부 테이블에 RLS 를 적용 하기 전에 추적 플래그 (TF) 4043을 사용 하도록 설정 해야 합니다.

상태

Microsoft는 "적용 대상" 절에 나열한 Microsoft 제품에서 이 문제를 확인했습니다.

해결 방법

이 문제는 다음과 같은 SQL Server 누적 업데이트에서 해결 되었습니다.

SQL Server의 누적 업데이트 정보:

각각의 새로운 새 누적 업데이트에는 이전 누적 업데이트에 포함 된 모든 핫픽스와 모든 보안 수정 사항이 포함 되어 있습니다. SQL Server에 대 한 최신 누적 업데이트를 확인 하세요.

참조

Microsoft에서 소프트웨어 업데이트를 설명하는 데 사용하는 용어에 대해 알아보세요.

추가 도움이 필요하신가요?

기술 향상
교육 살펴보기
새로운 기능 우선 가져오기
Microsoft Insider 참가

이 정보가 유용한가요?

번역 품질에 얼마나 만족하시나요?

사용 경험에 어떠한 영향을 주었나요?

추가 피드백이 있으신가요? (선택 사항)

소중한 의견에 감사드립니다.

×