Microsoft로 로그인
로그인하거나 계정을 만듭니다.
안녕하세요.
다른 계정을 선택합니다.
계정이 여러 개 있음
로그인할 계정을 선택합니다.

이 문서의 Microsoft Dynamics AX 모든 지역에 적용 됩니다.

증상

ASP.NET 가장 및 클레임 기반 인증을 사용 배포 된 환경에서 Microsoft Dynamics AX 2012 r 2에 대 한 엔터프라이즈 포털을 배포 하는 경우 오류가 발생 합니다. 또한 다음과 같은 오류 메시지가 나타날 있습니다.

Microsoft.Dynamics.Framework.BusinessConnector.Session.Exceptions.NoKernelSessionException

원인

Microsoft SharePoint 제품 및 기술 (BC) Microsoft.NET 비즈니스 커넥터 프록시 계정이 나 Microsoft Dynamics AX에 등록 된 계정을 가장할 수 없습니다 때문에이 문제가 발생 합니다. 클레임 기반 인증을 사용 하는 경우 기본적으로 SharePoint 작업자 프로세스가 Authority\IUSR NT 사용자 계정으로 실행 됩니다. 또한 SharePoint 웹 응용 프로그램 Web.config 파일에 다음 구성 설정:

AllowAnonymousImpersonation = True따라서 Microsoft Dynamics AX 응용 프로그램 개체 server (AOS)는 AOS 액세스 요청을 거부 합니다.

해결 방법

이 문제를 해결 하려면 "핫픽스 정보" 절에 설명 되어 있는 핫픽스를 설치 합니다. 또한 다음 Microsoft 웹 사이트에 설명 된 대로 폼 기반 인증을 사용 하는 클레임 기반 엔터프라이즈 포털 사이트를 배포 해야 합니다.

엔터프라이즈 포털 및 역할 센터 [AX 2012] 배포

핫픽스 정보

지원되는 핫픽스를 Microsoft에서 구할 수 있습니다. 이 기술 자료 문서의 맨 "핫픽스 다운로드 가능" 섹션. 발생 하는 문제 다운로드 한이 핫픽스를 설치 하거나 기타 기술 지원 질문이 있는 경우 상대방에 게 문의 하십시오 또는 Microsoft와 직접 지원 계획에 등록 하는 경우에 Microsoft Dynamics 기술 지원부 문의 고 새 지원 요청을 만들 수 있습니다. 이렇게 하려면 다음 Microsoft 웹 사이트로 이동.

https://mbs.microsoft.com/support/newstart.aspx문의하실 수 있습니다 기술 지원을 위한 Microsoft Dynamics 전화 국가별 전화 번호에 대 한 이러한 링크를 사용 하 여. 이렇게 하려면 다음 Microsoft 웹 사이트 중 하나로 이동.

파트너

https://mbs.microsoft.com/partnersource/support/고객

https://mbs.microsoft.com/customersource/support/information/SupportInformation/global_support_contacts_eng.htm특별 한 경우 일반적으로 호출 취소 될 수도 있습니다 경우 기술 지원 담당자는 Microsoft Dynamics 및 관련 된 제품에 대 한 지원에 따른 비용이 특정 업데이트로 문제를 해결할 수 있다고 결정 합니다. 모든 추가 지원 질문과 특정 업데이트가 필요 하지 않은 문제에는 일반 지원 비용이 적용 됩니다.

설치 정보

하나 이상의 메서드나이 핫픽스에 의해 영향을 받는 테이블에 대 한 사용자 지정 하는 경우 프로덕션 환경에서 핫픽스를 적용 하기 전에 테스트 환경에서 이러한 변경 내용을 적용 해야 합니다.

이 핫픽스를 설치 하는 방법에 대 한 자세한 내용은 Microsoft 기술 자료의 다음 문서 번호를 클릭 합니다.

893082 Microsoft Dynamics AX 핫픽스를 설치 하는 방법

전제 조건

Microsoft Dynamics AX 2012 R2이이 핫픽스를 적용 하려면 설치 되어 있어야 합니다.

다시 시작 요구 사항

핫픽스를 적용 한 후에 응용 프로그램 개체 Server (AOS) 서비스를 다시 시작 해야 합니다.

이 핫픽스의 글로벌 버전은 파일 특성 (또는 그 이후의 파일 특성) 있는 다음 표에 나열 된. 이러한 파일의 시간과 날짜는 협정 세계시(UTC)로 나열되었습니다. 파일 정보를 볼 때는 로컬 시간으로 변환됩니다. UTC와 로컬 시간의 시차는 제어판의 날짜 및 시간 항목에서 표준 시간대 탭을 사용하여 찾을 수 있습니다.

파일 이름

파일 버전

파일 크기

날짜

시간

플랫폼

서비스 분기

Aximpactanalysis.exe

해당 없음

61,136

13-Dec-2012

02:19

x86

해당 없음

Axupdate.exe

해당 없음

61,120

13-Dec-2012

02:19

x86

해당 없음

Dynamicsax2012r2-kb2824690-foundation.axmodel

6.2.1000.619

61,784

08-Mar-2013

03:43

해당 없음

해당 없음

Dynamicsax2012r2-kb2824690-syplabels.axmodel

6.2.1000.619

1,010,008

08-Mar-2013

03:43

해당 없음

해당 없음

Clientoba32.msp

해당 없음

19,017,728

20-Mar-2013

01:52

해당 없음

해당 없음

Clientoba64.msp

해당 없음

19,185,664

20-Mar-2013

01:52

해당 없음

해당 없음

Commercedataexchangereal-timeservice.msp

해당 없음

49,152

20-Mar-2013

01:52

해당 없음

해당 없음

Commercedataexchangesynchservice32.msp

해당 없음

122,880

20-Mar-2013

01:52

해당 없음

해당 없음

Commercedataexchangesynchservice64.msp

해당 없음

122,880

20-Mar-2013

01:52

해당 없음

해당 없음

Components32.msp

해당 없음

16,834,560

20-Mar-2013

01:52

해당 없음

해당 없음

Components64.msp

해당 없음

34,217,984

20-Mar-2013

01:53

해당 없음

해당 없음

Objectserver32.msp

해당 없음

6,782,976

20-Mar-2013

01:52

해당 없음

해당 없음

Objectserver64.msp

해당 없음

14,688,256

20-Mar-2013

01:55

해당 없음

해당 없음

Retaildatabaseutility.msp

해당 없음

524288

20-Mar-2013

01:52

해당 없음

해당 없음

Retailheadquarters32.msp

해당 없음

2,752,512

20-Mar-2013

01:52

해당 없음

해당 없음

Retailheadquarters64.msp

해당 없음

2,752,512

20-Mar-2013

01:52

해당 없음

해당 없음

Retailonlinechannel.msp

해당 없음

2,736,128

20-Mar-2013

01:55

해당 없음

해당 없음

Retailpos.msp

해당 없음

4,280,320

20-Mar-2013

01:55

해당 없음

해당 없음

Retailposplugins.msp

해당 없음

47,906,816

20-Mar-2013

01:55

해당 없음

RETAILPOSP

Setupsupport32.msp

해당 없음

6,086,656

20-Mar-2013

01:55

해당 없음

해당 없음

Setupsupport64.msp

해당 없음

13,348,864

20-Mar-2013

01:55

해당 없음

해당 없음

Axsetupsp.exe

6.2.139.8316

1,390,784

13-Dec-2012

02:19

x86

해당 없음

Axutillib.dll

6.2.120.0

929,560

20-Mar-2013

02:20

x86

해당 없음

Microsoft.dynamics.servicing.operations.dll

6.2.73.8303

37,168

19-Nov-2012

10:17

x86

해당 없음

Axsetupsp.resources.dll

6.2.147.8303

387,368

20-Mar-2013

02:20

x86

해당 없음

Axsetupsp.resources.dll

6.2.147.8303

375,080

20-Mar-2013

02:20

x86

해당 없음

Axsetupsp.resources.dll

6.2.147.8303

375,080

20-Mar-2013

02:20

x86

해당 없음

Axsetupsp.resources.dll

6.2.147.8303

379,176

20-Mar-2013

02:20

x86

해당 없음

Axsetupsp.resources.dll

6.2.147.8303

379,176

20-Mar-2013

02:20

x86

해당 없음

Axsetupsp.resources.dll

6.2.147.8303

370,984

20-Mar-2013

02:20

x86

해당 없음

Axsetupsp.resources.dll

6.2.147.8303

375,080

20-Mar-2013

02:20

x86

해당 없음

Axsetupsp.resources.dll

6.2.147.8303

383,272

20-Mar-2013

02:20

x86

해당 없음

Axsetupsp.resources.dll

6.2.147.8303

395,560

20-Mar-2013

02:20

x86

해당 없음

Axsetupsp.resources.dll

6.2.147.8303

375,080

20-Mar-2013

02:20

x86

해당 없음

Axsetupsp.resources.dll

6.2.147.8303

379,176

20-Mar-2013

02:20

x86

해당 없음

Axsetupsp.resources.dll

6.2.147.8303

387,368

20-Mar-2013

02:20

x86

해당 없음

Axsetupsp.resources.dll

6.2.147.8303

375,080

20-Mar-2013

02:20

x86

해당 없음

Axsetupsp.resources.dll

6.2.147.8303

375,080

20-Mar-2013

02:20

x86

해당 없음

Axsetupsp.resources.dll

6.2.147.8303

375,080

20-Mar-2013

02:20

x86

해당 없음

Axsetupsp.resources.dll

6.2.147.8303

379,176

20-Mar-2013

02:20

x86

해당 없음

Axsetupsp.resources.dll

6.2.147.8303

379,176

20-Mar-2013

02:20

x86

해당 없음

Axsetupsp.resources.dll

6.2.147.8303

379,176

20-Mar-2013

02:20

x86

해당 없음

Axsetupsp.resources.dll

6.2.147.8303

395,560

20-Mar-2013

02:20

x86

해당 없음

Axsetupsp.resources.dll

6.2.147.8303

375,080

20-Mar-2013

02:20

x86

해당 없음

Axsetupsp.resources.dll

6.2.147.8303

416,040

20-Mar-2013

02:20

x86

해당 없음

Axsetupsp.resources.dll

6.2.147.8303

370,984

20-Mar-2013

02:20

x86

해당 없음


상태

Microsoft는 이 문제가 '적용 대상' 섹션에 나열된 Microsoft 제품의 문제임을 확인했습니다.

참고: 이 문서는 Microsoft 지원 부서 내에서 직접 작성한 "빠른 게시" 문서입니다. 여기에 포함된 정보는 신흥 문제에 대한 응답으로 제공되었습니다. 신속히 사용할 수 있도록 작성되었으므로, 자료 입력 오류가 포함될 수 있으며 언제든지 예고없이 개정될 수 있습니다. 다른 고려 사항은 사용 약관을 참조하십시오.

도움이 더 필요하세요?

더 많은 옵션을 원하세요?

구독 혜택을 살펴보고, 교육 과정을 찾아보고, 디바이스를 보호하는 방법 등을 알아봅니다.

커뮤니티를 통해 질문하고 답변하고, 피드백을 제공하고, 풍부한 지식을 갖춘 전문가의 의견을 들을 수 있습니다.

이 정보가 유용한가요?

언어 품질에 얼마나 만족하시나요?
사용 경험에 어떠한 영향을 주었나요?
제출을 누르면 피드백이 Microsoft 제품과 서비스를 개선하는 데 사용됩니다. IT 관리자는 이 데이터를 수집할 수 있습니다. 개인정보처리방침

의견 주셔서 감사합니다!

×