You cannot install Unified Communications Managed API Redistributable and receive an unclear error message

Symptoms

You have a computer that has the Microsoft Visual C++ 2008 Service Pack 1 Redistributable Package version 9.0.30729 installed. If you try to install Microsoft Unified Communications Managed API Redistributable (UCMARedist.msi), the installation process fails. Additionally, you receive the following error message:

Microsoft Unified Communications Managed API 2.0 Core Redist installation or uninstallation requires that VC++ 2008 Redistributable is already installed.

This error message is not clear because it does not indicate that a specific version of Visual C++ 2008 Redistributable package is required.

Resolution

To resolve the problem of failing to install the Microsoft Unified Communications Managed API Redistributable, download and install the Microsoft Visual C++ 2008 Redistributable Package version 9.0.21022 from the following Microsoft Web site:

Download Microsoft Visual C++ 2008 Redistributable Package version 9.0.21022

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about the Microsoft Unified Communications Managed API Redistributable (UCMARedist.msi), visit the following Microsoft Knowledge Base article:

976657 Description of the cumulative update for Office Communications Server 2007 R2, Unified Communications Managed API 2.0 Core Redist 64-bit: April 2010

Vai nepieciešama papildu palīdzība?

Paplašiniet savas prasmes
Iepazīties ar apmācību
Esiet pirmais, kas saņem jaunās iespējas
Pievienoties Microsoft Insider

Vai šī informācija bija noderīga?

Paldies par jūsu atsauksmēm!

Paldies par atsauksmēm! Šķiet, ka jums varētu būt noderīgi sazināties ar kādu no mūsu Office atbalsta speciālistiem.

×