Kjent problem for 3098779 og 3097997-sikkerhetsoppdateringer for .NET Framework 4.5.1 og 4.5.2 når du har installert .NET Framework 4.6 på Windows 8.1, RT 8.1 for Windows og Windows Server 2012 R2

VIKTIG: Denne artikkelen ble oversatt med maskinoversettelsesprogramvare fra Microsoft og muligens redigert av Microsoft Community via CTF-teknologi i stedet for av en oversetter. Microsoft tilbyr både menneskelig oversatte og maskinoversatte/Community-redigerte artikler, slik at du får tilgang til alle artiklene i vår Knowledge Base på ditt eget språk. En maskinoversatt eller Community-redigert artikkel er imidlertid ikke alltid perfekt. Den kan inneholde feil i vokabular, syntaks eller grammatikk, mye likt en fremmedspråklig som forsøker å snakke språket ditt. Microsoft har ikke ansvar for unøyaktige opplysninger, feil eller skade forårsaket av feilaktig oversettelse av innholdet eller kundenes bruk av informasjonen. Microsoft oppdaterer jevnlig maskinoversettelsesprogramvaren og -verktøyene for å forbedre redigering av maskinoversatte tekster.

Den engelske versjonen av denne artikkelen er den følgende: 3118750
Sammendrag
Kunder som oppgraderer fra i .NET Framework 4.5.1 eller 4.5.2 til .NET Framework 4.6 eller som installerer Visual Studio-2015 når de installerer oppdateringer 3098779 og 3097997 kan oppstå problemer når de kjører .NET Framework-programmer.

Kunder som bruker et system som har Microsoft for .NET Framework installert 4.6 og som gjelder sikkerhetsoppdateringer 3098779 og 3097997 for Microsoft for .NET Framework 4.5.1 og 4.5.2 på Windows 8.1, RT 8.1 for Windows og Windows Server 2012 R2 manuelt kan også oppstå problemer når de kjører .NET Framework-programmer.

Obs! Eldre operativsystemer som har .NET Framework 4.5.1 eller 4.5.2 installert berøres ikke av dette problemet fordi sikkerhetsoppdateringene 3098779 og 3097997 ikke gjelder for dem.
Symptom

Scenario 1

  • Du bruker i .NET Framework 4.5.1 eller 4.5.2 på Windows 8.1, Windows RT 8.1 eller Windows Server 2012 R2.
  • Du har installert alle de siste oppdateringene for .NET Framework 4.5.1 og 4.5.2. Dette inkluderer oppdateringer 3098779 og 3097997.
  • Du kan laste ned og installere .NET Framework 4.6 eller du har installert Microsoft Visual Studio-2015.
I dette tilfellet deler av .NET Framework 4.6 oppgraderes ikke som forventet, eller noen .NET Framework-programmer starter ikke eller vil ikke fungere riktig.

Scenario 2

  • Du bruker .NET Framework 4.6 på Windows 8.1, Windows RT 8.1 eller Windows Server 2012 R2.
  • Bruke oppdateringer manuelt 3098779 og 3097997 eller andre oppdateringer som ikke er beregnet for .NET Framework 4.6, selv om disse oppdateringene er beregnet for .NET Framework 4.5.1 og 4.5.2.

    Obs!Dette er et scenario som ikke støttes. Hvis du vil ha mer informasjon om hvordan du fastslår det riktige programmet for en oppdatering for Microsoft .NET Framework, kan du se Microsoft Knowledge Base-artikkel 3136092.
I dette scenariet noen .NET Framework-programmer starter ikke eller vil ikke fungere riktig.
Løsning

Oppløsning for scenario 1

Kunder kan løse disse problemene ved å oppgradere til .NET Framework 4.6.1 fra følgende webområder for Microsoft Download Center:

Kunder kan eventuelt avinstallere oppdateringene 3098779 og 3097997 hvis de har oppgradert sine systemer til .NET Framework 4.6 eller har installert Visual Studio-2015 fra et fullstendig oppdatert .NET 4.5.1 eller 4.5.2 system som er 3098779 og 3097997 som er installert.

Kunder bør deretter Skann Windows Update og laste ned og installere oppdateringer 3098785 og 3098000. Dette er den tilsvarende Microsofts sikkerhetsbulletin MS15-118 oppdateringer for .NET Framework 4.6 på Windows 8.1, Windows RT 8.1 eller Windows Server 2012 R2. Denne handlingen vil rette de manglende versjonssamsvar.

Oppløsning for scenario 2

Kunder som bruker manuelt oppdateringer 3098779 og 3097997 på systemer som har .NET Framework 4.6 installert bør være oppmerksom på at dette ikke er et scenario som støttes. Disse oppdateringene gjelder ikke for .NET Framework 4.6.

Kunder som bruker .NET Framework 4.6 bør derfor avinstallere 3098779 og 3097997. Kunder bør deretter Skann Windows Update og installerer bare oppdateringer som gjelder for .NET Framework 4.6. Denne handlingen vil rette de manglende versjonssamsvar.

På samme måte kan bør kunder som bruker 4.5.1 eller 4.5.2 for .NET sørge for at det er ingen oppdateringer som gjelder for alle andre .NET Framework-versjonen installert på sine systemer. Oppdateringer som er ment for .NET Framework 4.6 bør for eksempel ikke brukes på systemer som har 4.5.1 eller 4.5.2 som er installert i .NET. Hvis du vil ha mer informasjon om hvordan på å finne det riktige programmet for Microsoft for .NET Framework 4.6 og 4.6.1 oppdateringene, Base-artikkel seeMicrosoftKnowledge 3136092.
Status
Microsoft har bekreftet at dette er et problem i Microsoft-produktene som er oppført i delen "Gjelder for".

Gjelder

Denne artikkelen gjelder for følgende:

  • Microsoft for .NET Framework 4.6 når den brukes med:

    • Windows Server 2012 R2
    • Windows 8.1
    • Windows RT 8.1
  • Microsoft .NET Framework 4.5.2 når den brukes med:

    • Windows Server 2012 R2
    • Windows 8.1
    • Windows RT 8.1
  • Microsoft .NET Framework 4.5.1 når den brukes med:

    • Windows Server 2012 R2
    • Windows 8.1
    • Windows RT 8.1

Advarsel: Denne artikkelen er autooversatt

Egenskaper

Artikkel-ID: 3118750 – Forrige gjennomgang: 01/15/2016 08:35:00 – Revisjon: 4.0

Microsoft .NET Framework 4.6, Microsoft .NET Framework 4.5.2, Microsoft .NET Framework 4.5.1

  • atdownload kbbug kbexpertiseinter kbfix kbsecbulletin kbsecurity kbsecvulnerability kbmt KB3118750 KbMtno
Tilbakemelding