Når du skriver inn en matriseformel, bruker du oftest et celleområde i regnearket, men du trenger ikke gjøre det. Du kan også bruke matrisekonstanter, verdier du bare skriver inn i formellinjen i klammeparenter: {}. Deretter kan du gi navn til konstanten slik at den blir enklere å bruke igjen.

Du kan bruke konstanter i matriseformlene eller alene.

  1. I matriseformelen skriver du inn en innledende parente, verdiene du vil bruke, og en avsluttende parente. Her er et eksempel: =SUMMER(A1:E1*{1;2;3;4;5})

    Konstanten er inni klammeparenteparenter ({)}, og ja, du skriver inn disse klammeparenteparenstene manuelt.

  2. Skriv inn resten av formelen, og trykk CTRL+SKIFT+ENTER.

    Formelen vil se omtrent ut som {=SUMMER(A1:E1*{1;2;3;4;5})}},og resultatene vil se slik ut:


    En matrisekonstant nestet i en SUMMER-formel

    Formelen multiplisert A1 med 1 og B1 med 2 og så videre, slik at du ikke trenger å plassere 1,2,3,4,5 i celler i regnearket.

Bruke en konstant til å skrive inn verdier i en kolonne

Hvis du vil skrive inn verdier i én enkelt kolonne, for eksempel 3 celler i kolonne C, gjør du følgende:

  1. Merk cellene du vil bruke.

  2. Skriv inn et likhetstegn og konstanten. Skill verdiene i konstanten med semikolon, ikke komma, og hvis du skriver inn tekst, omslutter du den med doble anførselstegn. Eksempel: ={"Kvartal 1";" Kvartal2";" Kvartal 3"}

  3. Trykk CTRL+SKIFT+ENTER. Konstanten ser slik ut:

    En loddrett matrisekonstant som bruker tekst

    I nerdete termer er dette en endimensjonal loddrett konstant.

Bruke en konstant til å skrive inn verdier i en rad

Hvis du raskt vil skrive inn verdier i én rad, for eksempel celle F1, G1 og H1, gjør du følgende:

  1. Merk cellene du vil bruke.

  2. Skriv inn et likhetstegn og konstanten, men denne gangen skiller du verdiene med semikolon, ikke semikolon. Eksempel: ={1,2,3,4,5}

  3. Trykk CTRL+SKIFT+ENTER, og konstanten ser slik ut:

    En endimensjonal vannrett matrisekonstant

    I nerdete termer er dette en endimensjonal vannrett konstant.

Bruke en konstant til å skrive inn verdier i flere kolonner og rader

  1. Merk cellene du vil bruke.

    Kontroller at antall rader og kolonner du velger, samsvarer med antall verdier i konstanten. Hvis for eksempel konstanten skriver data til fire kolonner og tre rader, merker du så mange kolonner og rader.

  2. Skriv inn et likhetstegn og konstanten. I dette tilfellet skiller du verdiene i hver rad med komma, og bruker et semikolon på slutten av hver rad. For eksempel:

    ={1\2\3\4.5\6\7\8.9\10\11\12}

  3. Trykk CTRL+SKIFT+ENTER, og:

    En todimensjonal matrisekonstant

    I nerde-termer er dette en todimensjonal konstant fordi den fyller kolonner og rader. Hvis du lurer på det, kan du ikke opprette en tredimensjonal konstant, noe som betyr at du ikke kan neste en konstant i en annen.

Bruke en konstant i en formel

Nå som du er kjent med matrisekonstanter, er dette et fungerende eksempel.

  • Skriv inn (eller kopier og lim inn) denne formelen i en tom celle, og trykk deretter CTRL+SKIFT+ENTER:

    =SUM(A1:E1*{1\2\3\4\5})

    Verdien 85 vises i celle A3.

    Hva skjedde? Du multiplisert verdien i A1 med 1, verdien i celle B2 med 2 og så videre, og deretter la SUMMER-funksjonen til disse resultatene. Du kan også skrive inn formelen som =SUMMER(A1*1;B1*2;C1*3;D1*4;E1*5)

Hvis du vil, kan du angi begge verdisettene som matrisekonstanter:

=SUMMER({3\4\5\6\7}*{1\2\3\4\5})

Hvis du vil prøve dette, kopierer du formelen, merker en tom celle og limer inn formelen på formellinjen, og deretter trykker du CTRL+SKIFT+ENTER. Du ser det samme resultatet.

Obs!: Se etter disse problemene hvis konstantene ikke fungerer:

  • Kontroller at du skiller verdiene med riktig tegn. Hvis du utelater et komma eller semikolon, eller hvis du setter et komma eller semikolon på feil sted, kan det hende matrisekonstanten ikke ser riktig ut, eller det kan hende du ser en advarsel.

  • Du kan ha merket et celleområde som ikke samsvarer med antall elementer i konstanten. Hvis du for eksempel merker en kolonne med seks celler for bruk med en femcellet konstant, vises #N/A-feilen i den tomme cellen. Hvis du ikke merker nok celler, Excel utelater du verdiene som ikke har en tilsvarende celle.

  • Hvis du vil ha mer informasjon om matriseformler:

Til toppen av siden

Trenger du mer hjelp?

Utvid ferdighetene dine
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Microsoft Office Insider-deltakere

Var denne informasjonen nyttig?

Hvor fornøyd er du med kvaliteten på oversettelsen?
Hva påvirket opplevelsen din?

Takk for tilbakemeldingen!

×