Du kan bruke HVISFEIL-funksjonen til å overtrykke og håndtere feil i en formel. HVISFEIL returnerer en verdi du angir hvis en formel evalueres til en feil. Ellers returneres resultatet av formelen.

Syntaks

HVISFEIL(verdi;verdi_hvis_feil)

Syntaksen for funksjonen HVISFEIL har følgende argumenter:

  • verdi    Obligatorisk. Argumentet som er kontrollert for en feil.

  • value_if_error    Obligatorisk. Verdien som skal returneres hvis formelen evalueres til en feil. Følgende feiltyper evalueres: #N/A, #VALUE!, #REF!, #DIV/0!, #NUM!, #NAME?, eller #NULL!.

Merknader

  • Hvis verdi eller value_if_error er en tom celle, behandler HVIS.FEIL den som en tom strengverdi ("").

  • Hvis verdi er en matriseformel, returnerer HVIS.FEIL en matrise med resultater for hver celle i området som er angitt i verdi. Se det andre eksemplet nedenfor.

Eksempler

Kopier eksempeldataene i tabellen nedenfor, og lim dem inn i celle A1 i et nytt Excel-regneark. Hvis du vil at formlene skal vises resultater, merker du dem, trykker på F2 og deretter ENTER.

Kvote

Solgte enheter

210

35

55

0

23

Formel

Beskrivelse

Resultat

=HVISFEIL(A2/B2; "Feil i beregning")

Kontrollerer om det er en feil i formelen i det første argumentet (del 210 med 35), finner ingen feil, og returnerer deretter resultatet av formelen

6

=HVISFEIL(A3/B3; "Feil i beregning")

Kontrollerer om det er en feil i formelen i det første argumentet (del 55 med 0), finner en deling med 0 feil, og returnerer deretter verdi_hvis_feil

Feil i beregning

=HVISFEIL(A4/B4; "Feil i beregning")

Kontrollerer om det er en feil i formelen i det første argumentet (del "" med 23), finner ingen feil, og returnerer deretter resultatet av formelen.

0

Eksempel 2

Kvote

Solgte enheter

Forhold

210

35

6

55

0

Feil i beregning

23

0

Formel

Beskrivelse

Resultat

=C2

Kontrollerer om det er en feil i formelen i det første argumentet i det første elementet i matrisen (A2/B2 eller del 210 med 35), finner ingen feil, og returnerer deretter resultatet av formelen

6

=C3

Kontrollerer om det er en feil i formelen i det første argumentet i det andre elementet i matrisen (A2/B2 eller del 55 med 0), finner en deling med 0 feil, og returnerer deretter verdi_hvis_feil

Feil i beregning

=C4

Kontrollerer om det er en feil i formelen i det første argumentet i det tredje elementet i matrisen (A4/B4 eller del "" med 23), finner ingen feil, og returnerer deretter resultatet av formelen

0

Obs! Hvis du har en gjeldende versjon av Microsoft 365, kan du skrive inn formelen i cellen øverst til venstre i utdataområdet, og deretter trykke ENTER for å bekrefte formelen som en dynamisk matriseformel. Ellers må formelen angis som en eldre matriseformel ved først å merke utdataområdet, skrive inn formelen i cellen øverst til venstre i utdataområdet, og deretter trykke CTRL+SKIFT+ENTER for å bekrefte den. Excel setter inn klammeparenteser i begynnelsen og slutten av formelen for deg. Hvis du vil ha mer informasjon om matriseformler, kan du se retningslinjer og eksempler på matriseformler.

Trenger du mer hjelp?

Du kan alltid spørre en ekspert i Excels tekniske fellesskap eller få hjelp i Svar-fellesskapet.

Trenger du mer hjelp?

Utvid ferdighetene dine
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Microsoft Insiders

Var denne informasjonen nyttig?

Hvor fornøyd er du med kvaliteten på oversettelsen?

Hva påvirket opplevelsen din?

Har du ytterligere tilbakemeldinger? (valgfritt)

Takk for tilbakemeldingen!

×