Symptomer
Når du starter en Microsoft Windows Server 2003-server som er en domenekontroller, kan du få følgende feilmelding:
Lsass.exe-systemet feil: initialisering av Sikkerhetskontobehandling mislyktes på grunn av følgende feil: kan ikke starte tjenesten Directory. Feilstatus: 0xc00002e1. Klikk OK for å avslutte dette systemet og startes på nytt i gjenopprettingsmodus for katalogtjenester, se hendelsesloggen for mer detaljert informasjon.
Hvis du bruker Hendelsesliste, kan du se følgende hendelse logges:
Årsak
Dette problemet kan oppstå hvis Active Directory-katalogtjenesten inneholder dupliserte kryssreferanse objekter, og disse objektene representerer domenene som vises i beholderen partisjoner. Hvis det finnes like kryssreferanse objekter, Windows Server 2003 kan ikke initialisere Security Accounts Manager (SAM) og Active Directory kan ikke starte. Følgende: Eksempler på hvordan du kan opprette et duplisert kryssreferanse objekt
-
Overtas hovedrollen for domenenavngiving operasjoner mens Active Directory er brutt i en lang periode.
-
Overvåker av domenenavngiving operasjoner rollen overtas. Deretter utføre en autoritativ gjenoppretting for Active Directory fra en sikkerhetskopi som ble opprettet før du har tatt hovedrollen for domenenavngiving.
Obs! Microsoft Windows 2000-domenekontrollere kan ikke bekrefte alle kryssreferanser. Derfor, Windows 2000-domenekontrollere ikke oppleve dette problemet.
Løsning
Informasjon om hurtigreparasjon
En støttet hurtigreparasjon er tilgjengelig fra Microsoft. Denne hurtigreparasjonen er imidlertid ment å løse problemet som er beskrevet i denne artikkelen. Bruk denne hurtigreparasjonen bare på systemer som har dette bestemte problemet. Denne hurtigreparasjonen kan gjennomgå ytterligere testing. Hvis du ikke er alvorlig påvirket av dette problemet, anbefaler vi derfor at du venter på neste programvareoppdatering som inneholder denne hurtigreparasjonen.
Hvis hurtigreparasjonen er tilgjengelig for nedlasting, ligger den under delen "Hotfix Download Available" øverst i denne Knowledge Base-artikkelen. Hvis denne delen ikke vises, kan du kontakte Microsofts kundeservice og kundestøtte for å få hurtigreparasjonen.
Obs! Hvis det oppstår andre problemer, eller hvis feilsøkingstips, må du kanskje opprette en separat forespørsel om. Vanlige kundestøttekostnader gjelder for ytterligere kundestøttespørsmål og problemer som ikke dekkes av denne oppdateringen. For en fullstendig liste over telefonnumre for Microsofts kundeservice og kundestøtte eller opprette en separat forespørsel om, kan du gå til følgende Microsoft-webområde:
http://support.microsoft.com/contactus/?ws=supportObs! Hotfix Download Available-skjemaet viser språkene som hurtigreparasjonen er tilgjengelig på. Hvis du ikke ser språket ditt, er det fordi en hurtigreparasjon ikke er tilgjengelig for dette språket.
Forutsetninger
Det kreves ingen forutsetninger.
Krav om omstart
Du må starte datamaskinen på nytt etter at du har installert denne hurtigreparasjonen.
Informasjon om erstatning av hurtigreparasjoner
Denne hurtigreparasjonen erstatter ikke andre hurtigreparasjoner.
Filinformasjon
Den engelskspråklige versjonen av denne hurtigreparasjonen har filattributtene (eller senere) som er oppført i følgende tabell. Datoene og klokkeslettene for disse filene er oppført i coordinated universal time (UTC). Når du viser filinformasjonen, konverteres den til lokal tid. Hvis du vil finne forskjellen mellom UTC og lokal tid, bruker du kategorien tidssone i dato og klokkeslett-verktøyet i Kontrollpanel.
Date Time Version Size File name Platform
-------------------------------------------------------------------
15-Oct-2003 22:36 5.2.3790.92 1,520,128 Ntdsa.dll x86
15-Oct-2003 23:37 5.2.3790.92 4,008,960 Ntdsa.dll IA-64
Denne hurtigreparasjonen gjør det mulig for Active Directory for å starte, slik at du kan fjerne dupliserte kryssreferanse-objekter. Når du har installert denne hurtigreparasjonen, må du fjerne like kryssreferanse-objekter fra Active Directory. Microsoft anbefaler at du kontakter Microsofts kundestøttetjenester for å få hjelp. Hvis du vil kontakte Microsofts kundestøttetjenester, kan du gå til følgende Microsoft-webområde:
http://support.Microsoft.com/default.aspx?scid=fh; EN-US; CNTACTMS
Status
Microsoft har bekreftet at dette er et problem i Microsoft-produktene som er oppført i delen "Gjelder for".
Referanser
Hvis du vil ha mer informasjon om kryssreferansen objekter, kan du gå til følgende Microsoft-webområde:
http://technet.microsoft.com/en-us/library/cc978018.aspxHvis du vil ha mer informasjon om hvordan du konfigurerer diagnostic hendelseslogging for Active Directory, kan du klikke følgende artikkelnummer for å vise artikkelen i Microsoft Knowledge Base:
314980 hvordan du konfigurerer Active Directory-diagnostikk for hendelseslogging i Windows 2000
Hvis du vil ha mer informasjon om Microsoft-programvare terminologi for programvareoppdatering, klikker du følgende artikkelnummer for å vise artikkelen i Microsoft Knowledge Base:
824684 beskrivelse av standardterminologien som brukes til å beskrive oppdateringer av Microsoft-programvare