Korriger: Et alltid på sekundære replika går inn i en disconnecting tilstand

Symptomer

Når du bruker SQL Server alltid på tilgjengelighetsgrupper, kan alltid på sekundære replikaen gå inn i en disconnecting tilstand. I tillegg er følgende feilmelding logget i SQL Server-feilloggen:

Det oppstod et tidsavbrudd under forsøk på å opprette en tilkobling til tilgjengelighet replika availability_replica_name med id availability_replica_id. Problem for et nettverk eller en brannmur, eller du får Endepunktsadressen replikaen.


Når du prøver å gjenopprette forbindelsen, kan du få følgende feilmelding:

Sekundær replikaen er ikke koblet til den primære replikaen. Tilkoblingsstatusen er koblet fra.


Når dette skjer, løses ikke problemet inntil du starter SQL Server-tjenester på den sekundære replikaen. I en sjelden scenario kan du må starte SQL Server-tjenester på den primære replikaen til gjenoppta alltid på flytting av data.

Obs! Dette problemet kan oppstå bare på datamaskiner som er svært kraftig og SQL Server er opptatt. For eksempel i et scenario, dette problemet oppstod på en opptatt system med 24 kjerner.

Årsak

Problemet oppstår på grunn av en intern kappløpssituasjon.

Løsning

Dette problemet ble løst i følgende kumulative oppdateringer for SQL Server.


Hver nye kumulative oppdateringen for SQL Server inneholder alle hurtigreparasjonene og alle sikkerhetsreparasjoner som fulgte med den forrige kumulative oppdateringen. Sjekk ut de nyeste kumulative oppdateringene for SQL Server:

Nyeste kumulative oppdateringen for SQL Server-2016

Nyeste kumulative oppdateringen for SQL Server-2014

Nyeste kumulative oppdateringen for SQL Server 2012 SP3

Status

Microsoft har bekreftet at dette er et problem i Microsoft-produktene som er oppført i delen "Gjelder for".

Referanser

Lær mer om terminologien som Microsoft bruker til å beskrive oppdateringer av programvare.

Trenger du mer hjelp?

Utvid ferdighetene dine
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Microsoft Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×