De fout #WAARDE! corrigeren in de functies GEMIDDELDE of SOM

Als gemiddelde of som verwijst naar cellen die #VALUE bevatten! fouten, de formules resulteren in een #VALUE! fout.

Fout #WAARDE! in GEMIDDELDE

Om de foutwaarden te negeren, maken we een formule die de fouten in het bereik van de verwijzing negeert tijdens de berekening van het gemiddelde met de resterende 'normale' waarden.

Om dit scenario te omzeilen, gebruiken we een combinatie van GEMIDDELDE in combinatie met ALS en ISFOUT om te bepalen of het opgegeven bereik een fout bevat. Voor dit specifieke scenario is een matrixformule vereist:

=GEMIDDELDE(ALS(ISFOUT(B2:D2);"";B2:D2))

Dit is een matrixformule. Daarom moet u op Enter drukken (alleen als u Microsoft 365 ) of CTRL + SHIFT + ENTER in de formule gebruikt.

Opmerking: Als u een huidige versie van Microsoft 365hebt, kunt u de formule gewoon in de cel met de uitvoer invoeren en vervolgens op Enter drukken om de formule te bevestigen als een dynamische matrixformule. Anders moet de formule als een verouderde matrixformule worden ingevoerd door eerst de uitvoermap te selecteren, de formule in de uitvoermap te typen en vervolgens op CTRL + SHIFT + ENTER te drukken om deze te bevestigen. In Excel worden de accolades aan het begin en het einde van de formule voor u ingevoegd. Zie Richtlijnen en voorbeelden van matrixformules voor meer informatie over matrixformules.

Matrix functie in gemiddelde voor het oplossen van de #VALUE! corrigeren

Opmerking: De bovenstaande functie werkt niet alleen voor #WAARDE!, maar ook voor #N/B, #LEEG!, #DEEL/0! en meer.

U kunt SOM ook op dezelfde manier gebruiken:

=SOM(ALS(ISFOUT(B2:D2);"";B2:D2))

Hebt u een vraag over een bepaalde functie?

Stel een vraag op het forum van de Excel-community

Meer hulp nodig?

U kunt altijd uw vraag stellen aan een expert in de Excel Tech Community, ondersteuning vragen in de Answer-community of een nieuwe functie of verbetering voorstellen in Excel User Voice.

Zie ook

De fout #WAARDE! corrigeren

GEMIDDELDE, functie

SOM, functie

Overzicht van formules in Excel

Fouten opsporen in formules

Alle Excel-functies (alfabetisch)

Alle Excel-functies (per categorie)

Opmerking:  Deze pagina is automatisch vertaald en kan grammaticale fouten of onnauwkeurigheden bevatten. Wij hopen dat deze inhoud nuttig voor je is. Wil je ons laten weten of deze informatie nuttig is? Hier is het Engelstalige artikel ter referentie.

Uw Office-vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Office Insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagenten.

×