Een fout #VERW! corrigeren

Een fout #VERW! corrigeren

De fout #VERW! wordt weergegeven wanneer een formule verwijst naar een cel die niet geldig is. Dit gebeurt meestal wanneer cellen zijn verwijderd waarnaar door formules wordt verwezen, of als er andere celinhoud overheen is geplakt.

Voorbeeld-#REF! fout veroorzaakt doordat er een kolom is verwijderd

In het volgende voorbeeld wordt de formule=SOM(B2;C2;D2) in kolom E gebruikt.

Een formule waarin naar expliciete cellen wordt verwezen zoals =SOM(B2,C2,D2) kan een fout #VERW! veroorzaken als een kolom wordt verwijderd.

Als u kolom B, C of D zou verwijderen, treedt er een #VERW!-fout op. In dit geval verwijderen we kolom C (Verkoop 2007). De formule ziet er nu als volgt uit =SOM(B2;#VERW!;C2). Wanneer u expliciete celverwijzingen zoals deze gebruikt (waarin u naar elke cel afzonderlijk verwijst, gescheiden door een komma) en vervolgens een rij of kolom verwijdert, kan Excel de formule niet toepassen, zodat de fout #VERW! optreedt. Dit is de belangrijkste reden waarom expliciete celverwijzingen in functies niet worden aanbevolen.

Voorbeeld van een fout #VERW! veroorzaakt doordat er een kolom is verwijderd

Oplossing

  • Als u rijen of kolommen per ongeluk verwijdert, kunt u direct op de knop Ongedaan maken op de werkbalk Snelle toegang klikken (of op Ctrl+Z drukken) om ze te herstellen.

  • Pas de formule zodanig aan dat deze gebruikmaakt van een bereikverwijzing in plaats van afzonderlijke cellen, zoals = som (B2: D2). U kunt nu een kolom binnen het bereik van de som verwijderen en in Excel wordt de formule automatisch aangepast. U kunt ook = som (B2: B5) gebruiken voor een som van rijen.

Voorbeeld: VERT.ZOEKEN met onjuiste bereikverwijzingen

In het volgende voorbeeld wordt de formule vert. zoeken (A8, a2: D5, 5, onwaar) als resultaat #REF gegeven. een fout veroorzaakt doordat er een waarde is die moet worden opgehaald uit kolom 5, maar het bereik van de verwijzing is A:D, wat slechts 4 kolommen zijn.

Voorbeeld van een formule met VERT.zoeken met een onjuiste bereik.  Formule = VLOOKU(A8,A2:D5,5,FALSE).  Is er geen vijfde kolom in het bereik van VERT.zoeken, dus 5 een #REF treedt! als resultaat.

Oplossing

Maak het bereik groter of verlaag de kolomzoekwaarde zodat deze overeenkomt met het bereik van de verwijzing. =VERT.ZOEKEN(A8;A2:E5;5;ONWAAR) zou een geldig bereik kunnen zijn, evenals = VERT.ZOEKEN(A8;A2:D5;4;ONWAAR).

Voorbeeld: INDEX met onjuiste verwijzing voor rijen of kolommen

In dit voorbeeld wordt met de formule = INDEX (B2: E5; 5; 5) een #REF als resultaat gegeven. fout: het INDEX bereik bevat vier rijen met 4 kolommen, maar de formule vraagt de inhoud van de rij 5e en vijfde kolom te retourneren.

Voorbeeld van een INDEX-formule met een verwijzing naar een ongeldig bereik.  Formule is =INDEX(B2:E5,5,5) maar het bereik is alleen 4 rijen bij 4 kolommen.

Oplossing

Pas de verwijzingen naar de rij of kolom aan zodat ze in het opzoekbereik INDEX vallen. =INDEX(B2:E5;4;4) zou een geldig resultaat opleveren.

Voorbeeld: naar een gesloten werkmap verwijzen met INDIRECT

In het volgende voorbeeld wordt een functie INDIRECT gebruikt om te verwijzen naar een werkmap die is gesloten, waardoor een #REF! weergegeven.

Voorbeeld van een fout #VERW! veroorzaakt omdat INDIRECT verwijst naar een gesloten werkmap.

Oplossing

Open de werkmap waarnaar wordt verwezen. U ontvangt dezelfde fout als u verwijst naar een gesloten werkmap met een dynamische matrix functie.

Problemen met OLE

Als u een OLE-koppeling (object linking and Embedding) hebt gebruikt die een #REF als resultaat geeft. en start het programma dat door de koppeling wordt aangeroepen.

Opmerking: OLE is een technologie die u kunt gebruiken om gegevens tussen programma's te delen.

Problemen met DDE

Als u een DDE-onderwerp (Dynamic Data Exchange) hebt gebruikt dat een #REF als resultaat geeft. fout, Controleer eerst of u naar het juiste onderwerp verwijst. Als u nog steeds een #REF ontvangt! fout, Controleer de instellingen voor het Vertrouwenscentrum voor externe inhoud, zoals wordt beschreven in externe inhoud in Office-documenten blokkeren of deblokkeren.

Opmerking: DDE (Dynamic Data Exchange)is een opgezet protocol voor de uitwisseling van gegevens tussen Microsoft Windows-Programma's.

Problemen met macro 's

Als met een macro een functie wordt toegevoegd aan het werkblad die naar een cel boven de functie verwijst en de cel met de functie in rij 1 staat, geeft de functie de fout #VERW! als resultaat omdat boven rij 1 geen cellen staan. Controleer of de functie een argument bevat dat verwijst naar een ongeldige cel of een ongeldig cellenbereik. Wellicht moet de macro dan in VBE (Visual Basic Editor) worden bewerkt, zodat er met deze situatie rekening wordt gehouden.

Meer hulp nodig?

U kunt altijd uw vraag stellen aan een expert in de Excel Tech Community, ondersteuning vragen in de Answer-community of een nieuwe functie of verbetering voorstellen in Excel User Voice.

Zie ook

Overzicht van formules in Excel

Niet-werkende formules voorkomen

Fouten opsporen in formules

Excel-functies (alfabetisch)

Excel-functies (per categorie)

Meer hulp nodig?

Uw Office-vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Office Insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagenten.

×