AD-replicatie mislukt met een RPC-probleem nadat u een statische poort hebt ingesteld voor NTDS in een omgeving met Windows-domeinen

Symptomen


Stel dat u een statische TCP-poort definieert waarmee de NTDS-service luistert en reageert op inkomende, externe RPC's (Rremote Procedure Calls). In deze situatie kan Active Directory-replicatie mislukken met een RPC-probleem. Dit probleem kan leiden tot alle symptomen in en .

Opmerkingen

  • Klik voor meer informatie over het beperken van replicatieverkeer van Active Directory en RPC-verkeer van clients naar een specifieke poort, op het volgende artikelnummer in de Microsoft Knowledge Base:

    Replicatieverkeer beperken van Active Directory en RPC-verkeer van clients naar een specifieke poort

  • De NTDS-interface is ook bekend als de DRS-interface. Bij gebruik van een statische poort kan de beheerder de communicatie beperken van een activiteit (zoals Active Directory-replicatie) naar een bekende poort. Zo kunt u firewalls zodanig configureren dat alleen verkeer naar die poort is toegestaan.


Oorzaak

Wanneer de statische poort voor de NTDS-service is geregistreerd bij de eindpunt-mapper, wordt ook een dynamische poort geregistreerd. De statische poort wordt echter niet altijd als eerste geretourneerd door de eindpunt-mapper. Als er een dynamische poort wordt geretourneerd en deze ook wordt geblokkeerd door de firewall, kan het probleem optreden dat is beschreven in de sectie 'Symptomen'.

Oplossing

U kunt dit probleem in Windows 8.1 of Windows Server 2012 R2 oplossen door update 2955164 te installeren. Klik voor meer informatie over update 2955164 op het volgende artikelnummer in de Microsoft Knowledge Base:

Updatepakket voor Windows RT 8.1, Windows 8.1 en Windows Server 2012 R2: mei 2014 U kunt dit probleem in Windows 7 of Windows Server 2008 R2 oplossen door de hotfix te installeren die wordt beschreven in dit artikel.

Informatie over hotfixes

Een ondersteunde hotfix is beschikbaar bij Microsoft. Deze hotfix is echter alleen bedoeld als oplossing van het probleem dat in dit artikel wordt beschreven. Voer deze hotfix alleen uit op systemen waarop dit specifieke probleem zich voordoet. Deze hotfix moet mogelijk extra worden getest. Als u geen ernstige problemen ondervindt, raadt Microsoft u daarom aan te wachten op de volgende update waarin deze hotfix is opgenomen.

Als de hotfix kan worden gedownload, is aan het begin van dit Knowledge Base-artikel een sectie Hotfix kan worden gedownload opgenomen. Als deze sectie niet aanwezig is, kunt u de hotfix aanvragen bij de klantondersteuning van Microsoft.

Opmerking Als er nog andere problemen optreden of als er oplossingen vereist zijn, moet u mogelijk een afzonderlijk serviceverzoek indienen. De normale ondersteuningskosten gelden voor extra ondersteuningsvragen die niet in aanmerking komen voor deze specifieke hotfix. Ga naar de volgende Microsoft-website voor een volledige lijst met telefoonnummers van de klantenservice van Microsoft of om een afzonderlijke serviceaanvraag op te stellen:

Opmerking Op het formulier 'Hotfix kan worden gedownload' zijn de talen vermeld waarvoor de hotfix beschikbaar is. Als uw taal daar niet bij staat, is de hotfix niet voor die taal beschikbaar.

Vereisten

U kunt deze hotfix alleen toepassen als Windows 7 Service Pack 1 (SP1) of Windows Server 2008 R2 SP1 op de computer wordt uitgevoerd.

Als u meer informatie wilt over het verkrijgen van een servicepack voor Windows 7 of voor Windows Server 2008 R2, klikt u op het volgende artikelnummer in de Microsoft Knowledge Base:

Informatie over Service Pack 1 voor Windows 7 en Windows Server 2008 R2

Registerinformatie

Wanneer u deze hotfix wilt toepassen, hoeft u geen wijzigingen aan te brengen in het register.

Computer opnieuw opstarten

Nadat u deze hotfix hebt toegepast, moet u de computer opnieuw opstarten.

Vervanging van hotfixes

Deze hotfix vervangt geen eerder uitgebrachte hotfix.

Met de algemene versie van deze hotfix worden de bestanden geïnstalleerd met de kenmerken die in de volgende tabellen zijn opgenomen. De datums en tijden voor deze bestanden worden weergegeven in Coordinated Universal Time (UTC). De datums en tijden voor deze bestanden worden op uw lokale computer weergegeven in uw lokale tijd, waarbij rekening wordt gehouden met zomer- en wintertijd. De datums en tijden kunnen wijzigen wanneer u bepaalde bewerkingen op de bestanden uitvoert.

Opmerkingen over bestandsinformatie in Windows Server 2008 R2

  • Of bestanden betrekking hebben op een specifiek product, specifieke mijlpaal (RTM, SPn) of specifieke servicestructuur (LDR, GDR), kunt u controleren aan de hand van het nummer van de bestandsversie in de volgende tabel:

  • De MANIFEST-bestanden (.MANIFEST) en MUM-bestanden (.MUM) die in afzonderlijke omgevingen zijn ge├»nstalleerd, worden afzonderlijk vermeld in de sectie Aanvullende bestandsinformatie voor Windows Server 2008 R2. MUM- en MANIFEST-bestanden zijn, met de bijbehorende beveiligingscatalogusbestanden (.CAT), van cruciaal belang voor het statusbeheer van het bijgewerkte onderdeel. De beveiligingscatalogusbestanden, waarvan de kenmerken niet worden vermeld, zijn ondertekend met een digitale handtekening van Microsoft.

Status

Microsoft heeft bevestigd dat dit probleem zich kan voordoen in de Microsoft-producten die worden vermeld in de sectie Van toepassing op.

Meer informatie

Klik op het volgende artikelnummer in de Microsoft Knowledge Base voor meer informatie over terminologie met betrekking tot software-updates:

Beschrijving van de standaardterminologie die wordt gebruikt om software-updates van Microsoft te beschrijven

Extra bestandsinformatie

Meer hulp nodig?

Uw vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Microsoft insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagenten.

×