BUG #: 120793 (Contentbeheer)BUG #: 718934 (Dev10)
Symptomen
Wanneer u Microsoft Commerce Server 2009 installeert op een computer waarop Windows Server 2008 R2 wordt uitgevoerd probeert, mislukt de installatie. Bovendien wordt het volgende foutbericht weergegeven:
.NET framework 3.5 met SP1 is op de computer aanwezig. Met SP1 om door te gaan met deze installatie moet u .NET Framework 3.5 installeren.
Opmerking Dit probleem treedt op zelfs als het .NET Framework 3.5 Service Pack 1 (SP1) of hogere versies van .NET Framework is geïnstalleerd.
Oorzaak
Tijdens de installatie van Commerce Server 2009 het installatieprogramma zoekt naar een specifieke registersleutel vinden van .NET Framework 3.5 SP1. De versie van .NET Framework dat is geïntegreerd in Windows Server 2008 R2 beschikt echter niet over de desbetreffende registersleutel. Daarom wordt in het installatieprogramma reageert niet meer.
Oplossing
U lost dit probleem, moet u de volgende hotfix toepassen op de computer waarop Windows Server 2008 R2 wordt uitgevoerd, voordat u Commerce Server 2009 installeert.
Deze hotfix wordt niet bijgewerkt voor alle bestanden op uw computer. Deze hotfix maakt de registervermeldingen die door het installatieprogramma van Commerce Server 2009 nodig zijn. Als de vereiste registervermeldingen bestaat, wordt het volgende bericht weergegeven:U hoeft niet deze patch toepassen op deze computer.Het wordt aangeraden dat u deze hotfix verwijderen nadat u Commerce Server 2009 hebt geïnstalleerd. U kunt de hotfix verwijderen via het onderdeel programma's en onderdelen in het Configuratiescherm.
Informatie over de hotfix
Een ondersteunde hotfix is beschikbaar bij Microsoft. Deze hotfix is echter alleen bedoeld voor het probleem dat wordt beschreven in dit artikel. Voer deze hotfix alleen uit op systemen waarop dit specifieke probleem zich voordoet.
Als de hotfix gedownload kan worden, is er een sectie 'Hotfix downloaden' aan het begin van dit Knowledge Base-artikel. Als deze sectie niet wordt weergegeven, dien dan een verzoek in bij Microsoft Customer Service and Support om de hotfix te verkrijgen. Opmerking Als er andere problemen optreden of als probleemoplossing is vereist, moet u wellicht een apart serviceverzoek indienen. De normale ondersteuningskosten gelden voor extra ondersteuningsvragen en problemen die niet in aanmerking komen voor deze specifieke hotfix. Voor een volledige lijst met Microsoft Customer Service and Support telefoonnummers of een afzonderlijk serviceverzoek maken, gaat u naar de volgende Microsoft-website:-http://support.microsoft.com/contactus/?ws=supportOpmerking Het formulier 'Hotfix kan worden gedownload' geeft de talen weer waarvoor de hotfix beschikbaar is. Als uw taal niet wordt weergegeven, is dit omdat een hotfix niet voor die taal beschikbaar is.
Vereisten
U moet Windows Server 2008 R2 zijn geïnstalleerd om deze hotfix te kunnen hebben.
Opnieuw opstarten
U hoeft de computer niet opnieuw op te starten nadat u deze hotfix hebt toegepast.
Informatie over het vervangen van hotfixes
Deze hotfix vervangt geen andere hotfixes.
Status
Microsoft heeft bevestigd dat dit probleem kan optreden in de Microsoft-producten die worden vermeld in de sectie 'Van toepassing op'.
Meer informatie
Ondersteuning is beschikbaar voor het uitvoeren van de volgende versies van Commerce Server in Windows Server 2008 R2:
-
Commerce Server 2009
-
Commerce Server 2007 servicepack 2 (SP2)
Wanneer u een upgrade van Windows Server 2008 naar Windows Server 2008 R2 uitvoert, werken Microsoft Commerce Server 2007 SP2 en Commerce Server 2009 zoals verwacht.