Symptomen

Wanneer u het standaardbedrijf voor een gebruiker probeert te wijzigen, ontvangt u het volgende foutbericht:

Internet Explorer-scriptfout Er is een fout opgetreden in het script op deze pagina. Regel: 127 char: 3 Error: Access is denied Code: 0 URL: http://XXX/businessportal/portal/administration/AC_DefaultCompany.aspx? UserID=GUID

In dit foutbericht staat GUID voor de GUID van de gebruiker voor wie u het standaardbedrijf hebt proberen te wijzigen.Dit probleem treedt op in Business Portal 3.0 in Microsoft Dynamics GP, in Business Portal 3.0 in Microsoft Dynamics SL en in Microsoft Business Solutions Business Portal 2.5.Opmerking U ontvangt dit foutbericht alleen wanneer u probeert het standaardbedrijf te wijzigen van een gebruiker die de rol Beheerder niet heeft toegewezen.

Oorzaak

Dit probleem treedt op omdat het veld Standaardbedrijf een door de gebruiker gedefinieerd veld is en niet een door de beheerder gedefinieerd veld. Daarom kunt u het standaardbedrijf van die gebruiker niet wijzigen op het tabblad Site Instellingen in Business Portal 3.0 of in Microsoft Business Portal 2.5 omdat de gebruiker niet aan de rol Beheerder is toegewezen.

Oplossing

Gebruik een van de volgende methoden om dit probleem op te lossen.

Methode 1: De gebruiker het standaardbedrijf laten wijzigen

De individuele gebruiker kan zijn of haar standaardbedrijf wijzigen met de optie Mijn Instellingen in Business Portal 3.0, in Microsoft Business Portal 2.5 of in het Microsoft Business Portal 2.5-functiepakket.

Methode 2: De rol Beheerder tijdelijk toewijzen aan de gebruiker

Belangrijk Deze stappen kunnen uw beveiligingsrisico verhogen. Deze stappen kunnen uw computer of het netwerk ook kwetsbaarder maken voor aanvallen door kwaadwillende gebruikers of door schadelijke software zoals virussen. Microsoft adviseert gebruik te maken van het proces dat in dit artikel wordt beschreven om programma's te laten werken zoals deze zijn bedoeld, of om specifieke programmafuncties te implementeren. Voordat u deze wijzigingen aanbrengt, is het raadzaam om de risico's te evalueren die zijn gekoppeld aan de implementatie van dit proces in uw specifieke omgeving. Als u ervoor kiest om dit proces te implementeren, voert u de juiste aanvullende stappen uit om het systeem te beschermen. Het is raadzaam dit proces alleen uit te voeren als dat echt noodzakelijk is.Als u het standaardbedrijf voor een niet-administratieve gebruiker wilt wijzigen, volgt u de volgende stappen:

  1. Wijs de rol Beheerder toe aan de gebruiker voor wie u het standaardbedrijf wilt wijzigen:

    1. Meld u aan bij Business Portal 3.0 of bij Microsoft Business Portal 2.5.

    2. Klik op Site Instellingenen klik vervolgens onder Gebruikers en machtigingen op Zakelijke portalgebruikersbeheren.

    3. Klik in de gebruikerslijstop de niet-administratieve gebruiker voor wie u het standaardbedrijf wilt wijzigen.

    4. Klik in het deelvenster Gebruikerseigenschappen op Wijzigen naast de lijst Portalrollen.

    5. Klik in het dialoogvenster Rollen wijzigen - webpagina dat wordt weergegeven op om het selectievakje Beheerder in te selecteren en klik vervolgens op OK.

  2. Wijzig het standaardbedrijf voor die gebruiker in Business Portal 3.0 of in Microsoft Business Portal 2.5.

  3. Verwijder de rol Beheerder van deze gebruiker.

Meer informatie

Stappen om het gedrag te reproduceren

  1. Meld u aan bij Business Portal 3.0 of bij Microsoft Business Portal 2.5.

  2. Klik op het tabblad Site Instellingen en klik vervolgens op Zakelijke portalgebruikers beheren.

  3. Klik op een niet-administratieve gebruiker en probeer vervolgens het standaardbedrijf voor die gebruiker te wijzigen.

U ontvangt het foutbericht dat wordt vermeld in de sectie 'Symptomen'.

Meer hulp nodig?

Meer opties?

Verken abonnementsvoordelen, blader door trainingscursussen, leer hoe u uw apparaat kunt beveiligen en meer.