Symptomen

In een omgeving met Microsoft Exchange Server 2016 nadat u Windows PowerShell 2.0 versie verwijderen en installeer een nieuwere versie van PowerShell in plaats daarvan, de Exchange Management Shell met succes kan niet worden geopend en het volgende foutbericht Bericht:

Nieuwe PSSession: [servernaam] verwerkingsgegevens uit externe server servernaam is mislukt
het volgende foutbericht weergegeven: [ClientAccessServer =ServerName, BackEndServer =ServerName, RequestIdRequestId, TimeStamp =DateTime=]
[AuthZRequestId=AuthZRequestId][FailureCategory=AuthZ-SetupVersionInformationCorruptException]
Kan niet vaststellen van de geïnstalleerde versie van de registersleutel
'HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PowerShell\1\PowerShellEngine'. Zie voor meer informatie de
about_Remote_Troubleshooting Help-onderwerp.
Op regel 1: char: 1
+ "$ConnectionUri" nieuwe-PSSession - ConnectionURI - ConfigurationName Micr...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo: OpenError: (System.Manageme... RemoteRunspace:RemoteRunspace) [nieuw-PSSession], PSRemotin
gTransportException
+ FullyQualifiedErrorId: IncorrectProtocolVersion, PSSessionOpenFailed

Ook de volgende vermelding van gebeurtenislogboek geregistreerd:

Log naam: toepassing
Bron: MSExchange RBAC
Datum: datum/tijd
Gebeurtenis-ID: 258
Categorie taak: RBAC
Niveau: fout
Trefwoorden: klassiek
Gebruiker: n.v.t.
Computer: computernaam
Beschrijving:
(Proces 8820, PID w3wp.exe)"RemotePS openbare API Func-GetApplicationPrivateData genereert een uitzondering Microsoft.Exchange.Diagnostics.SetupVersionInformationCorruptException: kan niet vaststellen van de geïnstalleerde versie van de registersleutel ' HKEY_ LOCAL_MACHINE\SOFTWARE\Microsoft\PowerShell\1\PowerShellEngine'.

Oorzaak

Dit probleem treedt op omdat het registerpad van de latere versie van PowerShell is gewijzigd.

Tijdelijke oplossing

U kunt toevoegen het register HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PowerShell\1\PowerShellEngine sleutel terug nadat u Windows PowerShell 2.0 verwijderen. De snelste manier is om aan te trekken van het register -bestand van het Microsoft TechNet Gallery: https://gallery.technet.microsoft.com/Exchange-2016-CU1-7c843cb0.

Oplossing

U kunt dit probleem oplossen door cumulatieve Update 9 voor 2016 van Exchange Server of een latere cumulatieve update voor Exchange Server 2016te installeren.

Status

Microsoft heeft bevestigd dat dit probleem kan optreden in de Microsoft-producten die worden vermeld in de sectie 'Van toepassing op'.

Referenties

Meer informatie over de terminologie die door Microsoft wordt gebruikt om software-updates te beschrijven.

Meer hulp nodig?

Uw vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Microsoft insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

×