Symptomen
Gebruikers kunnen zich niet aanmelden bij webversie van Outlook (OWA) of het Exchange Configuratiescherm (ECP) nadat u de beveiligingsupdate van juli 2021 of een latere update voor Microsoft Exchange Server 2019, 2016 of 2013 hebt geïnstalleerd.
Oorzaak
De volgende voorwaarden treden op na de installatie van de update.
Oorzaak 1
De OWA- of ECP-Exchange Server aanmelding mislukt en retourneert het volgende foutbericht als het OAuth-certificaat (OAuth) ontbreekt of is verlopen:
ASSERT: HMACProvider.GetCertificates:protectionCertificates.Length<1
Zie 'Resolutie 1'.
Oorzaak 2
Gebruikers zien een lege webpagina nadat ze zich proberen aan te melden of het aanmeldingsproces verloopt in een lus. Dit gebeurt als gebruikers toegang hebben tot de servers via een load balancer en niet alle servers in de groep worden bijgewerkt naar ten minste de beveiligingsupdate van juli 2021. Deze voorwaarde kan ertoe leiden dat gebruikers worden omgeleid naar de aanmeldingspagina wanneer ze OWA of ECP gebruiken.
Zie 'Resolutie 2'.
Oplossing
Resolutie 1
Als u het probleem wilt oplossen dat wordt beschreven in de sectie 'Oorzaak 1', volgt u de stappen in dit artikel om het autorisatiecertificaat Exchange Server verlengen.
Resolutie 2
Het probleem dat wordt beschreven in de sectie 'Oorzaak 2' moet stoppen na de su van juli 2021 of een latere update is geïnstalleerd op alle servers die worden verwerkt door de load balancer.
U kunt alle niet-bijgewerkte servers in de groep tegelijk bijwerken. U kunt ze ook in batches bijwerken door niet-bijgewerkte servers uit de groep te verwijderen, de juli-SE of de meest recente update toe te passen en vervolgens deze servers te wisselen voor andere servers die nog niet zijn bijgewerkt.Tijdelijke oplossing
U kunt het probleem dat wordt beschreven in de sectie 'Oorzaak 2' oplossen door de persistentie in te stellen op 'bron-ip' in de configuratie van de load balancer.