U af en toe om referenties wordt gevraagd of time-outs optreden wanneer u verbinding met Services geverifieerd maken

Symptomen

U kunt een of meer van de volgende symptomen kan optreden. Deze symptomen mogelijk intermitterende of continue. Deze symptomen zijn vaker en meer omvattend 'hoog gebruik van' momenten, zoals aan het begin van een bedrijf bij het verdelen van grotere client plaatsvindt op de servers in de omgeving.

Treden de volgende problemen in een web services-scenario: treden de volgende problemen in een web proxyscenario: treden de volgende problemen in een Exchange-client scenario: treedt het volgende probleem in elk scenario in welke NTLM-verificatie wordt gebruikt voor toepassingen:

Lijn van het bedrijf of aangepaste toepassingen die gebruikmaken van NTLM-verificatie mislukt. Bovendien kunnen er verschillende foutberichten die met tussenpozen en eventueel 'toegang geweigerd'Het volgende probleem in een extern bestand toegang kunnen optreden:

Windows-clients ' toegang geweigerd ' ontvangen of uitgesteld reacties van de server.Treedt het volgende probleem in elk scenario waarbij Kerberos-overdracht in een middle-tier-service wordt gebruikt:

De clients toegang is in eerste instantie maar verliest vervolgens toegang tot dezelfde bronnen. Bovendien herhaaldelijk gevraagd om referenties of 'toegang geweigerd'-fouten optreden.Opmerkingen

Oorzaak

Dit probleem treedt op wanneer een hoog volume van NTLM-verificatie of Kerberos PAC validatie transacties (of beide) optreden op een Windows-server en dat volume groter is dan het volume dat tegelijkertijd kan worden verwerkt door de server of de domeincontrollers die verificatie biedt. Met andere woorden, wordt dit veroorzaakt door een resource verificatie knelpunt.

NTLM-verificatie en validatie van PAC worden uitgevoerd door specifieke threads in het proces Lsass.exe op Windows-computers. Er is een maximum aantal deze threads die beschikbaar zijn voor het verwerken van deze aanvragen op hetzelfde moment, en als de aanvragen groter is dan de beschikbaarheid van de threads en de aanvragen kunnen niet langer wachten, treedt dit probleem.

Werkstations hebben een van de threads beschikbaar voor gebruik en lidservers hebben twee threads beschikbaar voor gebruik. Domeincontrollers hebben één beschikbare thread per beveiligingskanaal met vertrouwde domeinen. Dit maximum aantal threads die zijn toegewezen aan dit doel 'Maxconcurrentapi' wordt genoemd en kan worden geconfigureerd.

Oplossing

Gebruik een of meer van de volgende methoden het probleem op te lossen:

  • De volgende hotfix geïnstalleerd en vervolgens de stappen die worden beschreven in de sectie 'registerinformatie'. Nadat u deze hotfix op Windows Vista, Windows Server 2008, Windows 7 of Windows Server 2008 R2, de maximumlimit van gelijktijdige verbindingen tussen een clientcomputer en een andere server installeert of een domeincontroller voor NTLM-verificatie of PAC validatie kan maximaal 150 worden gewijzigd. Moet dit gebeuren op alle servers die Perfmon Netlogon vertonen 'semafoor time-out' in hun prestatielogboeken of die aanduidingen zijn de ' NlpUserValidateHigher: Client-API-sleuf kan niet toewijzen ' tekst in de Netlogon-logboeken voor foutopsporing.

  • Voor toepassingen en services die van NTLM gebruikmaken, net configureert om Kerberos-verificatie te gebruiken. De methoden om te doen die uniek zijn voor deze toepassingen.

Opmerking Om te bepalen welke waarde in te stellen voor de MaxConcurrentApi instelling in uw omgeving verwijzen naar het Knowledge Base-artikelen.

hoe het afstemmen van prestaties voor NTLM-verificatie met behulp van de instelling MaxConcurrentApi

Informatie over de hotfix

Een ondersteunde hotfix is beschikbaar bij Microsoft. Deze hotfix is echter alleen bedoeld voor het probleem dat wordt beschreven in dit artikel. Deze hotfix alleen uit op systemen waarop het probleem dat in dit artikel wordt beschreven zich voordoet. Deze hotfix moet wellicht extra worden getest. Als u geen ernstige hinder ondervindt van dit probleem, is het daarom raadzaam te wachten op de volgende update waarin deze hotfix is opgenomen.

Als de hotfix gedownload kan worden, is er een sectie 'Hotfix downloaden' aan het begin van dit Knowledge Base-artikel. Als deze sectie niet wordt weergegeven, neem dan contact op met Microsoft Customer Service and Support om de hotfix te verkrijgen.

Opmerking Als er andere problemen optreden of als probleemoplossing is vereist, moet u wellicht een apart serviceverzoek indienen. De normale ondersteuningskosten gelden voor extra ondersteuningsvragen en problemen die niet in aanmerking komen voor deze specifieke hotfix. Voor een volledige lijst met telefoonnummers van Microsoft Customer Service and Support of om een afzonderlijk serviceverzoek aan te maken, gaat u naar de volgende Microsoft-website:

Opmerking Het formulier 'Hotfix kan worden gedownload' geeft de talen weer waarvoor de hotfix beschikbaar is. Als uw taal niet wordt weergegeven, is dit omdat een hotfix niet voor die taal beschikbaar is.

Vereisten

Deze hotfix moet Windows 7, Windows Server 2008 R2, Windows Vista Service Pack 2 of Windows Server 2008 Service Pack 2 worden uitgevoerd op uw computer.

Informatie over het register

Belangrijk Deze sectie, methode of taak bevat stappen voor het wijzigen van het register. Echter, er kunnen ernstige problemen optreden als u het register onjuist bewerkt. Daarom is het belangrijk de volgende stappen zorgvuldig te volgen. Als extra beveiliging maakt u een back-up van het register voordat u wijzigingen aanbrengt. Vervolgens kunt u het register herstellen als er een probleem optreedt. Voor meer informatie over hoe u een back-up van het register kunt maken en terugzetten, klikt u op het volgende artikel in de Microsoft Knowledge Base:

het back-up maken en het register terugzetten in WindowsNadat u de hotfix hebt geïnstalleerd, een hogere waarde een hogere waarde op alle servers die Perfmon Netlogon "semafoor time-out" aanduidingen in de Performance logs of Maxconcurrentapi ' NlpUserValidateHigher: Client-API-sleuf kan niet toewijzen ' tekst in de Netlogon-logboeken voor foutopsporing. Ga hiervoor als volgt te werk:notities

Opnieuw opstarten

Nadat u deze hotfix hebt geïnstalleerd, moet u de computer opnieuw opstarten.

Informatie over het vervangen van hotfixes

Deze hotfix vervangt geen eerder uitgebrachte hotfix.

Bestandsinformatie

De Engelse (Verenigde Staten) versie van deze hotfix installeert bestanden met de bestandskenmerken die in de volgende tabellen worden weergegeven. De datums en tijden voor deze bestanden worden weergegeven in Coordinated Universal Time (UTC). De datums en tijden voor deze bestanden op uw lokale computer worden weergegeven in uw lokale tijd samen met het huidige verschil met de zomertijd (DST). Bovendien kunnen de datums en tijden veranderen wanneer u bepaalde bewerkingen op de bestanden uitvoert.

  • De MANIFEST-bestanden (.manifest) en MUM-bestanden (.mum) die zijn geïnstalleerd voor elke omgeving worden afzonderlijk vermeld in de sectie 'Aanvullende bestandsinformatie voor Windows Vista en Windows Server 2008 '. MUM- en MANIFEST-bestanden- en de bijbehorende beveiligingscatalogusbestanden (.cat)-bestanden zijn zeer belangrijk voor het behoud van de status van het bijgewerkte onderdeel. De beveiligingscatalogusbestanden, waarvan de kenmerken niet worden vermeld, zijn ondertekend met een digitale handtekening van Microsoft.

Bestandsgegevens voor Windows Vista en Windows Server 2008

Bestandsgegevens voor x86-versies van Windows Server 2008 en Windows Vista

Meer hulp nodig?

Uw vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Microsoft insiders

Was deze informatie nuttig?

Hoe tevreden bent u met de vertaalkwaliteit?

Wat heeft uw ervaring beïnvloed?

Hebt u aanvullende feedback? (Optioneel)

Bedankt voor uw feedback.

×