Streszczenie
Na komputerze z systemem operacyjnym wymienionych w sekcji Stosuje się do tworzenia lub rozszerzania woluminu. Rozmiar woluminu jest wielokrotnością liczby 8 gigabajtów (GB). Na przykład rozmiar woluminu jest 8 192 megabajt (MB), 16 384 MB, 32 768 MB itd (Uwaga: 1 GB jest równy 1 024 MB).
Objawy
Może wystąpić jeden lub kilka z następujących problemów
-
Po uruchomieniu narzędzia ChkDsk.exe na objętość w trybie tylko do odczytu (bez przełączników) pojawi się komunikat o błędzie podobny do jednego z następujących czynności:
-
Mapa bitowa woluminu jest niepoprawna.
System Windows znalazł problemy z systemem plików. -
Wykryto błąd w indeksie $I30 dla pliku 5.
pozycje indeksu < liczba > przetwarzane.
Ukończono weryfikację indeksów. -
Znaleziono błędy. Program CHKDSK nie może kontynuować w trybie tylko do odczytu.
-
-
Przywracanie ustawień komputera z Przywracanie systemu punktu powoduje rozruch systemu operacyjnego lub uszkodzonych plików.
-
Przywracanie plików z woluminu dokonane przy użyciu karty "Poprzednie wersje" może skutkować przywracane pliki w stanie uszkodzenia.
-
Korzystając z kopii zapasowej aplikacji, która korzysta z funkcji kopii w tle woluminu VSS systemu Windows do tworzenia migawek podczas tworzenia kopii zapasowej, jeden lub więcej plików znajdują się uszkodzony po przywróceniu.
Uwaga NTBackup, narzędzie Kopia zapasowa systemu Windows Server, System Center danych Protection Manager (DPM) lub wszelkich innych firm kopii zapasowej kopii zapasowej danych aplikacji może mieć negatywny wpływ. Więcej informacji w sekcji na naprawienie tego z Microsoft DPM lub skontaktuj się z producentem tworzenia kopii zapasowych innych firm, aby ustalić, czy są one korzysta z funkcji kopii w tle woluminu VSS systemu Windows do tworzenia ich kopii zapasowych.
Przyczyna
Kopia w tle woluminu VSS jest wywoływana na woluminach rozszerzonych, mapy bitowej woluminu używany do śledzenia wykorzystania klastra może nie dokładnie odzwierciedlać klastry, które są używane przez przypadające na granicy 8GB plików systemu plików. W związku z tym dane odczytywane lub kopiowane z kopii w tle może niedokładnie przedstawiać dane pliku. Dane są zapisywane do miejsca docelowego, jest zapisywany w stanie uszkodzenia.
Rozwiązanie
Firma Microsoft wykrył, że jest błąd w produkcie i naprawił problem w dodatku service pack lub poprawek, w zależności od systemu operacyjnego, skąd pochodzi woluminu.
Poprawka jest dostępna dla następujących systemów operacyjnych:
-
Windows Server 2003 z dodatkiem Service Pack 2 (SP2)
-
Dodatek Service Pack 1 (SP1) dla systemu Windows Vista
-
Windows Vista z dodatkiem Service Pack 2 (SP2)
-
Windows Server 2008
-
Windows Server 2008 Service Pack 2 (SP2)
-
Windows 7
-
Windows Server 2008 R2
Poprawka jest zawarta w następujących dodatków service Pack:
-
Windows 7 Service Pack 1 (SP1)
-
Windows Server 2008 R2 Service Pack 1 (SP1)
Informacje o dodatku SP1 dla powyższego można znaleźć na:
Informacje o poprawce
Ważne Ta poprawka została ponownie wydana do rozwiązania problemu w którym podpis cyfrowy w plikach produkowane i podpisane przez firmę Microsoft wygaśnie przedwcześnie, zgodnie z opisem w .
Obsługiwana poprawka jest udostępniana przez firmę Microsoft. Jednak ta poprawka jest przeznaczona tylko do usunięcia problemu opisanego w tym artykule. Zastosuj poprawkę tylko w systemach, w których występuje problem opisany w tym artykule. Ta poprawka może być wciąż w fazie testowania. Jeśli dany system nie jest poważnie narażony na ten problem, firma Microsoft zaleca, aby poczekać na następną aktualizację oprogramowania zawierającą tę poprawkę.
Jeśli poprawka jest dostępna do pobrania, pojawi się sekcja "Poprawka dostępna do pobrania" na początku tego artykułu z bazy wiedzy Knowledge Base. Jeśli nie ma tej sekcji, skontaktuj się z Obsługą i Wsparciem Klienta Microsoft w celu uzyskania poprawki.
Uwaga Jeśli wystąpią dodatkowe błędy lub konieczność rozwiązania problemu, być może trzeba będzie utworzyć osobne zlecenie usługi. Zwykłe koszty obsługi będą zastosowane do dodatkowych pytań i problemów, których nie można rozwiązać przy użyciu określonej poprawki. Aby uzyskać pełną listę numerów telefonów pomocy technicznej i obsługi klienta firmy Microsoft lub utworzyć osobne zlecenie usługi, odwiedź następującą witrynę firmy Microsoft w sieci Web:
Uwaga "Poprawka dostępna do pobrania" zawiera listę języków, dla których dostępna jest poprawka. Jeśli odpowiedni język nie jest widoczny, to dlatego, że poprawka nie jest dostępna dla danego języka.
Wymagania wstępne
Aby zastosować tę poprawkę, komputer musi działać jeden z następujących systemów operacyjnych Windows:
-
Windows Server 2003 z dodatkiem Service Pack 2 (SP2)
-
Dodatek Service Pack 1 (SP1) dla systemu Windows Vista
-
Windows Vista z dodatkiem Service Pack 2 (SP2)
-
Windows Server 2008
-
Windows Server 2008 Service Pack 2 (SP2)
-
Windows 7
-
Windows Server 2008 R2
Aby uzyskać więcej informacji dotyczących sposobu uzyskiwania dodatku service pack dla systemu Windows Server 2003 kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
jak uzyskać najnowszy dodatek service pack dla systemu Windows Server 2003
Aby uzyskać więcej informacji dotyczących sposobu uzyskiwania dodatku service pack dla systemu Windows Vista, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
jak uzyskać najnowszy dodatek service pack dla systemu Windows Vista
Aby uzyskać więcej informacji dotyczących sposobu uzyskiwania dodatku service pack dla systemu Windows Server 2008, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
jak uzyskać najnowszy dodatek service pack dla systemu Windows Server 2008
Informacje dotyczące rejestru
Aby użyć poprawki w tym pakiecie, nie trzeba wprowadzać żadnych zmian w rejestrze.
Wymagania dotyczące ponownego uruchomienia
Po zastosowaniu tej poprawki należy ponownie uruchomić komputer.
Informacje dotyczące zastępowania poprawek
Ta poprawka nie zastępuje wcześniej wydanej poprawki.
Informacje o plikach
Wersja angielskojęzyczna (Stany Zjednoczone) tej poprawki instaluje pliki, których atrybuty wymieniono w poniższych tabelach. Daty i godziny odpowiadające tym plikom są podane w formacie uniwersalnego czasu koordynowanego (UTC, Coordinated Universal Time). Daty i godziny odpowiadające tym plikom na komputerze lokalnym są wyświetlane w formacie czasu lokalnego, wraz z Twoim bieżącym bias czasu letniego (DST). Dodatkowo, daty mogą ulec zmianie podczas wykonywania pewnych operacji na plikach.
Informacje o plikach w systemie Windows Server 2003
-
Oprócz plików wymienionych w poniższych tabelach ta poprawka instaluje skojarzony z nimi plik wykazu (KB976329.cat) podpisany za pomocą podpisu cyfrowego firmy Microsoft.