Za pomocą dodatku Power Query & (o nazwie Pobierz i przekształć dane w poprzednich wersjach programu Excel) możesz importować lub łączyć się z danymi zewnętrznymi, a następnie kształtować te dane, na przykład usuwać kolumny, zmieniać typ danych lub scalać tabele w sposób spełniający Twoje potrzeby. Następnie możesz załadować zapytanie do programu Excel w celu utworzenia wykresów i raportów. Okresowo możesz odświeżać dane, aby być na bieżąco.

Korzystanie z dodatku Power Query jest dostępne w czterech fazach.

Power Query common steps

  1. Połącz    Nakieruj połączenia z danymi w chmurze, w usłudze lub lokalnie

  2. Przekształcanie    Kształtowanie danych w celu zaspokojenia potrzeb, a oryginalne źródło danych pozostaje bez zmian

  3. Łączenie    Integrowanie danych z wielu źródeł w celu uzyskania unikatowego widoku danych

  4. Załaduj   Dokończ zapytanie i załaduj je do arkusza lub modelu danych i okresowo je odświeżaj.

Przyjrzyjmy się dokładniej każdej z faz. Ostatnia sekcja zawiera historię dodatku Power Query w programie Excel. Aby uzyskać podsumowanie wszystkich tematów pomocy dotyczących dodatku Power Query, zobacz Power Query dla programu Excel - Pomoc.

Za pomocą dodatku Power Query można zaimportować dane do jednego źródła danych, takiego jak skoroszyt programu Excel, albo do wielu baz danych, źródeł danych lub usług w chmurze. Źródła danych obejmują dane z sieci Web, plików, baz danych, platformy Azure, a nawet tabel   programu Excel w bieżącym skoroszycie. Za pomocą dodatku Power Query możesz następnie ze sobą zesłać wszystkie te źródła danych przy użyciu własnych unikatowych przekształceń i kombinacji, aby odkryć wnioski, które nie byłyby widoczne dla Ciebie. 

Po zaimportowaniu możesz odświeżyć dane, aby dodać dodatki, zmiany i usunąć dane z zewnętrznego źródła danych. Aby uzyskać więcej informacji, zobacz Odświeżanie połączenia danych zewnętrznych w programie Excel.  

Importowanie poleceń w interfejsie użytkownika

Przekształcanie danych oznacza ich modyfikowanie w sposób sposób spełniający wymagania analizy danych. Można na przykład usunąć kolumnę, zmienić typ danych lub filtrować wiersze. Każda z tych operacji jest przekształceniem danych. Ten proces stosowania przekształceń (i łączenia) do jednego lub większej liczby zestawów danych jest również nazywany kształtowaniem danych.

Przemyśl to w ten sposób. Wazon zaczyna się ryczałt, że jeden kształt w coś praktycznego i pięknego. Dane są takie same. Należy kształtować tabelę, która jest odpowiednia do Twoich potrzeb i udostępnia atrakcyjne raporty i pulpity nawigacyjne.

W dodatku Power Query do obsługi i wyświetlania przekształceń danych jest używane specjalne okno, Edytor dodatku Power Query. Możesz otworzyć Edytor dodatku Power Query, wybierając pozycję Uruchom Edytor zapytań w poleceniu Pobierz dane w grupie Przekształcanie danych w dodatku &, ale jest on także otwierany po nawiązania połączenia ze źródłem danych, utworzeniu nowego zapytania lub załadowaniu zapytania.

Interfejs użytkownika ustawień kwerendy

Edytor dodatku Power Query śledzi wszystkie czynności, które robisz z danymi, rejestrując i przetwarzając wszystkie przekształcenia i kroki, które stosujesz do danych. Niezależnie od tego, czy przekształcenie dotyczy połączenia danych, usunięcia kolumny, scalenia, czy zmiany typu danych, można wyświetlić i zmodyfikować każde przekształcenie w sekcji ZASTOSOWANE KROKI w okienku Ustawienia zapytania.

W interfejsie użytkownika można dokonać wielu przekształceń. Każda transformacja jest rejestrowana jako krok w tle. Możesz nawet zmodyfikować i napisać własne kroki przy użyciu języka M dodatku Power Query w Edytorze zaawansowanym.

Wszystkie przekształcenia stosowane zbiorczo do połączeń danych stanowią zapytanie, które jest nową reprezentacją pierwotnego (i niezmienionego) źródła danych. Po odświeżeniu zapytania każdy krok jest uruchamiany automatycznie. Zapytania zastępują konieczność ręcznego łączenia i kształtowania danych w programie Excel.

W skoroszycie programu Excel można połączyć wiele zapytań, dołączając je lub scalając. Operacje Dołączanie i scalanie są wykonywane w przypadku wszelkich zapytań o kształtach tabelarowych i są niezależne od źródeł danych, z których pochodzą dane.

Dołączanie   Operacja dołączania tworzy nowe zapytanie, które zawiera wszystkie wiersze z pierwszego zapytania, a następnie wszystkie wiersze z drugiego zapytania. Można wykonywać dwa typy operacji dołączania:

  • Dołączanie pośrednie    Tworzy nowe zapytanie dla każdej operacji dołączania.

  • Dołączanie w tekście    Dołącza dane do istniejącego zapytania, aż dotrzesz do wyniku końcowego.

Koncepcja dołączania zapytań

Scal    Operacja scalania tworzy nowe zapytanie z dwóch istniejących zapytań. To jedno zapytanie zawiera wszystkie kolumny z podstawowej tabeli, przy której jedna kolumna stanowi łącze nawigacji do powiązanej tabeli. Powiązana tabela zawiera wszystkie wiersze zgodne z każdym wierszem wspólnej wartości kolumny w podstawowej tabeli. Ponadto można rozwijać lub dodawać kolumny z powiązanej tabeli do podstawowej tabeli.

Pojęcie scalania zapytań

Istnieją dwa główne sposoby ładowania zapytań do skoroszytu:

  • W Edytorze dodatku Power Query można używać poleceń Zamknij i Załaduj w grupie Zamykanie na karcie Narzędzia główne.

  • W okienku Zapytania skoroszytu programu Excel (wybierz zapytania & połączeń)możesz kliknąć zapytanie prawym przyciskiem myszy i wybrać polecenie Załaduj do.

Opcje ładowania można także dostosować przy użyciu okna dialogowego Opcje kwerendy (wybierz pozycję Plik > Opcje i ustawienia > Opcje kwerendy), aby wybrać sposób wyświetlania danych i miejsce ładowania danych — w arkuszu lub w modelu danych (które jest relacyjnych źródeł danych wielu tabel w skoroszycie). 

Integracja dodatku Get & Transform Data (obecnie: Power Query) z programem Excel przeszło wiele zmian na przestrzeni lat. 

Excel 2010 i 2013 dla systemu Windows

W programie Excel 2010 dla systemu Windows po raz pierwszy wprowadzono dodatek Power Query i był on dostępny jako bezpłatny dodatek, który można pobrać tutaj: Pobierz dodatek Power Query. Po włączeniu funkcja dodatku Power Query była dostępna na karcie Power Query na wstążce.

Excel 2013 Power Query Ribbon

Microsoft 365

Zaktualizowaliśmy program Power Query, aby był podstawowym doświadczeniem w programie Excel w zakresie importowania i czyszczenia danych. Dostęp do kreatorów i narzędzi importowania danych dodatku Power Query można uzyskać z grupy & Przekształcanie danych na karcie Dane na wstążce programu Excel.

Excel 2016 Power Query Ribbon

To środowisko obejmowało ulepszone funkcje importowania danych, ponownie rozmieszczone polecenia na karcie Dane, nowe okienko boczne Zapytania & Połączenie oraz możliwość zaawansowanego kształtowania danych przez sortowanie, zmienianie typów danych, dzielenie kolumn, agregowanie danych i tak dalej.

To nowe środowisko zastąpiło również starszych, starszych kreatorów importu danych w obszarze polecenia Dane w grupie Pobierz dane zewnętrzne. Jednak nadal można uzyskać do nich dostęp z okna dialogowego Opcje programu Excel (wybierz pozycję Plik > Opcje > dane > Pokaż starszych kreatorów importu danych).

Excel 2016 i 2019 dla systemu Windows

Dodaliśmy to samo środowisko & Przekształcanie danych oparte na technologii Power Query co usługa Microsoft 365.

Excel dla Microsoft 365 dla komputerów Mac

W 2019 roku rozpoczęliśmy podróż do obsługi dodatku Power Query w programie Excel dla komputerów Mac. Od tego czasu dodano możliwość odświeżania zapytań dodatku Power Query z plików TXT, CSV, XLSX, JSON i XML. Dodano również możliwość odświeżania danych z serwera SQL i tabel & zakresów w bieżącym skoroszycie.

W październiku 2019 r. dodaliśmy możliwość odświeżania istniejących zapytań dodatku Power Query oraz używania VBA do tworzenia i edytowania nowych zapytań.

W styczniu 2021 r. dodaliśmy obsługę odświeżania zapytań dodatku Power Query ze źródeł źródeł OData i SharePoint.

Aby uzyskać więcej informacji, zobacz Używanie dodatku Power Query w programie Excel dla komputerów Mac.

Uwaga    Nie ma obsługi dodatku Power Query w programach Excel 2016 i Excel 2019 dla komputerów Mac.

Data Catalog deprecation

Wykaz danych umożliwia wyświetlanie zapytań udostępnionych, a następnie ich wybieranie w celu ładowania, edytowania lub innego użycia w bieżącym skoroszycie. Ta funkcja była stopniowo przestarzała:

  • 1 sierpnia 2018 r. zaprzestaliśmy dobierania nowych klientów do wykazu danych.

  • 3 grudnia 2018 r. użytkownicy nie mogli udostępniać nowych ani zaktualizowanych zapytań w wykazie danych.

  • 4 marca 2019 r. wykaz danych przestał działać. Po tej dacie zalecamy pobranie zapytań udostępnionych, aby można było nadal ich używać poza wykazem danych, używając opcji Otwórz z wykazu danych Moje zapytania dotyczące wykazu okienko zadań.

Cofanie infeksowania dodatku Power Query

Na początku lata 2019 roku oficjalnie wycofaliśmy dodatek Power Query, który jest wymagany dla programu Excel 2010 i 2013 dla systemu Windows. Dzięki uprzejmości możesz nadal korzystać z dodatku, ale może się to zmienić w późniejszym terminie.

Wycofany łącznik danych serwisu Facebook

Importowanie i odświeżanie danych z serwisu Facebook w programie Excel przestało działać w kwietniu 2020 r. Żadne połączenia z serwisu Facebook utworzone przed tym dniem nie będą już działać. Zalecamy jak najszybciej poprawić lub usunąć wszelkie istniejące zapytania dodatku Power Query, które korzystają z łącznika serwisu Facebook, aby uniknąć nieoczekiwanych wyników.

Potrzebna dalsza pomoc?

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów firmy Microsoft

Czy te informacje były pomocne?

Jak zadowalająca jest jakość tłumaczenia?
Co wpłynęło na Twoje wrażenia?

Dziękujemy za opinię!

×