JEŻELI.BŁĄD, funkcja

Funkcji JEŻELI.BŁĄD można użyć do przechwytowania i obsługi błędów w formule. Funkcja JEŻELI.BŁĄD zwraca wartość podaną w przypadku, gdy wynikiem formuły jest błąd. w przeciwnym razie zwraca wynik formuły.

Składnia

JEŻELI.BŁĄD(wartość;wartość_jeżeli_błąd)

W składni funkcji JEŻELI.BŁĄD występują następujące argumenty:

  • wartość    Argument wymagany. Argument sprawdzany w poszukiwaniu błędu.

  • value_if_error    Argument wymagany. Wartość zwracana w przypadku zwrócenia błędu przez formułę. Sprawdzane są następujące typy błędów: #N/A, #VALUE!, #REF!, #DIV/0!, #NUM!, #NAME? lub #NULL!.

Spostrzeżenia

  • Jeśli wartość lub value_if_error jest pustą komórką, to jeżeli.BŁĄD potraktuje ją jako wartość ciągu pustego ("").

  • Jeśli wartość jest formułą tablicową, funkcja JEŻELI.BŁĄD zwraca tablicę wyników dla każdej komórki w zakresie określonym w wartości. Zobacz drugi przykład poniżej.

Przykłady

Skopiuj przykładowe dane z poniższej tabeli i wklej je w komórce A1 nowego arkusza programu Excel. Aby formuły wyświetlały wyniki, zaznacz je, naciśnij klawisz F2, a następnie naciśnij klawisz Enter.

Przydział

Liczba sprzedanych sztuk

210

35

55

0

23

Formuła

Opis

Wynik

=JEŻELI.BŁĄD(A2/B2;"Błąd w obliczeniach")

Sprawdza pierwszy argument formuły w poszukiwaniu błędu (dzielenie 210 przez 35), nie znajduje błędu, a następnie zwraca wynik formuły.

6

=JEŻELI.BŁĄD(A3/B3;"Błąd w obliczeniach")

Sprawdza pierwszy argument formuły w poszukiwaniu błędu (dzielenie 55 przez 0), znajduje błąd dzielenia przez 0, a następnie zwraca wartość argumentu wartość_jeżeli_błąd.

Błąd w obliczeniach

=JEŻELI.BŁĄD(A4/B4;"Błąd w obliczeniach")

Sprawdza pierwszy argument formuły w poszukiwaniu błędu (dzielenie "" przez 23), nie znajduje błędu, a następnie zwraca wynik formuły.

0

Przykład 2

Przydział

Liczba sprzedanych sztuk

Stosunek

210

35

6

55

0

Błąd w obliczeniach

23

0

Formuła

Opis

Wynik

=C2

Sprawdza pierwszy argument formuły w pierwszym elemencie tablicy w poszukiwaniu błędu (A2/B2, czyli dzielenie 210 przez 35), nie znajduje błędu, a następnie zwraca wynik formuły.

6

=C3

Sprawdza pierwszy argument formuły w drugim elemencie tablicy w poszukiwaniu błędu (A3/B3, czyli dzielenie 55 przez 0), znajduje błąd dzielenia przez 0, a następnie zwraca wartość argumentu wartość_jeżeli_błąd.

Błąd w obliczeniach

=C4

Sprawdza pierwszy argument formuły w trzecim elemencie tablicy w poszukiwaniu błędu (A4/B4, czyli dzielenie "" przez 23), nie znajduje błędu, a następnie zwraca wynik formuły.

0

Uwaga: Jeśli masz bieżącą wersję platformy Microsoft 365,możesz wprowadzić formułę w lewej górnej komórce zakresu wyjściowego, a następnie nacisnąć klawisz ENTER, aby potwierdzić formułę jako dynamiczną formułę tablicową. W przeciwnym razie należy wprowadzić formułę jako starszą formułę tablicową, najpierw wybierając zakres wyjściowy, wprowadź formułę w lewej górnej komórce zakresu wyjściowego, a następnie naciśnij klawisze CTRL+SHIFT+ENTER, aby ją potwierdzić. Program Excel wstawi na początku i końcu formuły nawiasy klamrowe. Aby uzyskać więcej informacji na temat formuł tablicowych, zobacz Wskazówki i przykłady dotyczące formuł tablicowych.

Potrzebujesz dodatkowej pomocy?

Zawsze możesz zadać pytanie ekspertowi w społeczności technicznej programu Excel, uzyskać pomoc techniczną w społeczności witryny Answers bądź zasugerować nową funkcję lub ulepszenie w witrynie UserVoice dotyczącej programu Excel.

Potrzebna dalsza pomoc?

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×