Podstawowe zadania w programie Access 2010

Świadczenie pomocy technicznej dla pakietu Office 2010 zakończono 13 października 2020 r.

Uaktualnij do platformy Microsoft 365, aby pracować w dowolnym miejscu, z dowolnego urządzenia i nadal uzyskiwać pomoc techniczną.

Zaktualizuj teraz

Oto kilka podstawowych zadań związanych z bazą danych, które możesz wykonać, aby dowiedzieć się, jak używać aplikacji Microsoft Access 2010.

 

W tym artykule

Co to jest program Access?

Access 2010 to narzędzie do projektowania i wdrażania aplikacji bazy danych, za pomocą których można śledzić ważne informacje. Możesz przechowywać dane na komputerze lub publikować w sieci Web — aby inne osoby mogą korzystać z bazy danych za pomocą przeglądarki sieci Web.

Wiele osób zaczyna korzystać z programu Access, gdy program, z którym korzysta, do śledzenia czegoś stopniowo staje się mniej odpowiedni do zadania. Załóżmy na przykład, że jesteś terminarzem wydarzenia i chcesz śledzić wszystkie szczegóły potrzebne do pomyślnego zarządzania wydarzeniami. Jeśli do tego używasz edytora tekstu lub programu arkusza kalkulacyjnego, możesz łatwo mieć problemy ze zduplikowanymi i niespójnymi danymi. Możesz używać oprogramowania do kalendarzy, ale śledzenie informacji finansowych w kalendarzu nie jest dobrym rozwiązaniem.

Relacyjne bazy danych w programie Access

Czasem do śledzenia takich informacji jest potrzebna relacyjnych baza danych — magazyn danych, które zostały podzielone na mniejsze zbiory danych (nazywanych tabelami), aby wyeliminować nadmiarowość, a następnie powiązane ze sobą na podstawie typowych informacji (nazywanych polami). Na przykład relacyjnych baz danych planowania zdarzeń może zawierać tabelę z informacjami o klientach, tabelę z informacjami o dostawcach oraz tabelę z informacjami o zdarzeniach. Tabela z informacjami o zdarzeniu może zawierać pole do powiązać je z tabelą klientów, a pole do powiązać je z tabelą dostawcy. Dzięki temu, na przykład w przypadku zmiany numeru telefonu dostawcy, informacje te mogą zostać zmienione raz w tabeli dostawcy, a nie we wszystkich zdarzeniach, w których uczestniczył dostawca.

Program Access to narzędzie, za pomocą których można szybko i łatwo tworzyć relacyjne aplikacje baz danych, które ułatwiają zarządzanie informacjami. Bazę danych można utworzyć, aby ułatwić śledzenie informacji dowolnego rodzaju, takich jak zapasy, kontakty zawodowe lub procesy biznesowe. Program Access zawiera szablony, za pomocą których można od razu śledzić różnorodne informacje, co ułatwia korzystanie nawet z usług początkujących.

Po otwarciu programu Access

Po uruchomieniu programu Access 2010 zostanie wyświetlony widok Backstage pakietu Microsoft Office, w którym możesz uzyskać informacje o bieżącej bazie danych, utworzyć nową bazę danych, otworzyć istniejącą bazę danych i wyświetlić polecaną zawartość z Office.com.

Widok Backstage w programie Access 2010

Widok Backstage zawiera również wiele innych poleceń, za pomocą których można dostosowywać, konserwować i udostępniać bazy danych. Polecenia w widoku Backstage zazwyczaj dotyczą całych baz danych, a nie obiektów w bazie danych.

Uwaga: Do widoku Backstage możesz przejść w dowolnym momencie, klikając kartę Plik.

Początek strony

Znajdowanie i stosowanie szablonu

Program Access udostępnia wiele różnych szablonów, których można użyć do przyspieszenia procesu tworzenia bazy danych. Szablon to gotowa do użycia baza danych zawierająca wszystkie tabele, zapytania, formularze i raporty potrzebne do wykonania określonego zadania. Istnieją na przykład szablony, za pomocą których można śledzić problemy, zarządzać kontaktami lub rejestrować wydatki. Niektóre szablony zawierają kilka przykładowych rekordów, które pomagają w pokazie ich użycia. Bazy danych szablonów mogą być używane w stanie, w jaki są, lub można je dostosować do swoich potrzeb.

Aby znaleźć i zastosować szablon do bazy danych, wykonaj następujące czynności:

  1. Na karcie Plik kliknij pozycję Nowy.

  2. W obszarze Dostępne szablonywykonaj jedną z następujących czynności:

    • Aby ponownie użyć ostatnio używanego szablonu, kliknij pozycję Ostatnio używane szablony,a następnie wybierz szablon.

    • Aby użyć szablonu, który został już zainstalowany, kliknij pozycję Mojeszablony, a następnie wybierz szablon.

    • Aby znaleźć szablon w usłudze Office.com, w obszarze Szablony programu Office.comkliknij kategorię szablonów, wybierz szablon, którego chcesz użyć, a następnie kliknij pozycję Pobierz, aby pobrać szablon z witryny Office.com na komputer.

      Możesz również wyszukiwać szablony na Office.com z poziomu programu Access. W polu Office.com wyszukaj szablony wpisz co najmniej jeden wyszukiwany termin, a następnie kliknij przycisk strzałki, aby wyszukać.

  3. Opcjonalnie kliknij ikonę folderu obok pola Nazwa pliku, aby przejść do lokalizacji, w której chcesz utworzyć bazę danych. Jeśli nie wskażesz określonej lokalizacji, program Access utworzy bazę danych w domyślnej lokalizacji wyświetlanej poniżej pola Nazwa pliku.

  4. Kliknij przycisk Utwórz.

Program Access utworzy bazę danych i otworzy ją do użycia.

Początek strony

Tworzenie bazy danych od podstaw

Aby uzyskać bardziej szczegółowe wprowadzenie do pojęć związanych z tworzeniem bazy danych za pomocą programu Access, zobacz artykuł Podstawowe informacje o projekcie bazy danych.

Jeśli żaden z szablonów nie odpowiada Twoim potrzebom lub jeśli masz dane w innym programie, którego chcesz użyć w programie Access, możesz podjąć decyzję o utworzeniu bazy danych od podstaw. W programie Access 2010 masz do wyboru: standardową bazę danych dla komputerów stacjonarnych lub bazę danych sieci Web.

Aby uzyskać więcej informacji na temat baz danych sieci Web, zobacz artykuł Tworzenie bazy danych do udostępnienia w sieci Web.

Aby utworzyć nową bazę danych, wykonaj następujące czynności:

  1. Uruchom program Access.

  2. Na karcie Nowy w widoku Backstage kliknij pozycję Pusta baza danych lub Pusta baza danych sieci Web.

    Ważne: Wybór tej opcji będzie określać, jakie funkcje są dostępne w bazie danych. Bazy danych dla komputerów stacjonarnych nie mogą być publikowane w sieci Web, a bazy danych sieci Web nie obsługują niektórych funkcji klasycznych, takich jak zapytania sum.

  3. Po prawej stronie wpisz nazwę bazy danych w polu Nazwa pliku.

    Aby zmienić lokalizację, w której tworzysz plik, kliknij przycisk Przeglądaj tekst alternatywny obok pola Nazwa pliku, przejdź do nowej lokalizacji i wybierz ją, a następnie kliknij przycisk OK.

  4. Kliknij przycisk Utwórz.

    Program Access utworzy bazę danych, a następnie otworzy pustą tabelę (o nazwie Tabela1) widok arkusza danych.

  5. Program Access umieści kursor w pierwszej pustej komórce w kolumnie Kliknij, aby dodać nową tabelę.

    Aby dodać dane, zacznij pisać — lub możesz wkleić dane z innego źródła, zgodnie z opisem w sekcji Wklejanie danych z innego źródła do tabeli programu Accessw dalszej części tego artykułu.

    Uwagi: 

    • Wprowadzanie danych w widoku arkusza danych jest bardzo podobne do wprowadzania danych w arkuszu programu Excel. Głównym ograniczeniem jest to, że dane muszą być wprowadzane w sąsiadujących wierszach i kolumnach, począwszy od lewego górnego rogu arkusza danych. Nie należy formatować danych, uwzględniając puste wiersze lub kolumny tak jak w arkuszu programu Excel, ponieważ spowoduje to marnowanie miejsca w tabeli. Tabela zawiera jedynie Twoje dane. Cała wizualna prezentacja tych danych zostanie wykonana w formularzach i raportach, które zaprojektowasz później.

    • Struktura tabeli jest tworzona podczas wprowadzania danych. Za każdym razem, gdy dodajesz nową kolumnę do arkusza danych, w tabeli jest definiowane nowe pole. Program Access typ danych typ pola na podstawie typu wprowadzanych danych. Jeśli na przykład masz kolumnę, w której wprowadzono tylko wartości dat, program Access ustawi typ danych tego pola na wartość Data/Godzina. Jeśli później spróbujemy wprowadzić w tym polu wartość nie-datową (taką jak nazwa lub numer telefonu), program Access wyświetli komunikat informujący, że wartość nie jest taka sama jak typ danych kolumny. Jeśli to możliwe, należy zaplanować tabelę tak, aby każda kolumna zawierała ten sam typ danych, zarówno tekst, daty, liczby, jak i dane innego typu. Znacznie ułatwia to tworzenie zapytań, formularzy i raportów w celu wybrania tylko wybranych danych.

Jeśli nie chcesz jeszcze wprowadzać danych, kliknij przycisk Zamknij Obraz przycisku .

Uwaga: Program Access usunie tabelę Tabela1, jeśli zamkniesz ją bez zapisywania.

Początek strony

Otwieranie istniejącej bazy danych programu Access

Porada: Aby szybko otworzyć jedną z kilku ostatnio otwieranych baz danych, na karcie Plik kliknij pozycję Ostatnie,a następnie kliknij nazwę pliku.

  1. Na karcie Plik kliknij pozycję Otwórz.

  2. Kliknij skrót w oknie dialogowym Otwieranie lub w polu Szukaj w kliknij dysk lub folder zawierający nazwę bazy danych.

  3. Na liście folderów klikaj dwukrotnie foldery, aż otworzysz folder zawierający bazę danych.

  4. Po odnalezieniu bazy danych wykonaj jedną z następujących czynności:

    • Aby otworzyć bazę danych w domyślnym trybie otwierania, kliknij ją dwukrotnie.

    • Aby otworzyć bazę danych w celu uzyskania dostępu udostępnionego w środowisku z wieloma użytkownikami, dzięki czemu Ty i inni użytkownicy możecie jednocześnie odczytywać i zapisywać w bazie danych, kliknij przycisk Otwórz.

    • Aby otworzyć bazę danych w celu uzyskania dostępu tylko do odczytu, dzięki czemu będzie można ją wyświetlać, ale nie edytować, kliknij strzałkę obok przycisku Otwórz, a następnie kliknij pozycję Otwórz tylko do odczytu.

    • Aby otworzyć bazę danych z wyłącznym dostępem, tak aby nikt inny nie miał możliwości jej otwarcia, kliknij strzałkę obok przycisku Otwórz, a następnie kliknij pozycję Otwórz z wyłączności.

    • Aby otworzyć bazę danych w celu uzyskania dostępu tylko do odczytu, kliknij strzałkę obok przycisku Otwórz, a następnie kliknij pozycję Otwórz z wyłącznym dostępem do odczytu Inni użytkownicy nadal mogą otwierać bazę danych, ale mają dostęp tylko do odczytu.

Jeśli nie możesz znaleźć bazy danych, którą chcesz otworzyć    

  1. W oknie dialogowym Otwieranie kliknij skrót Mój komputer lub w polu Szukaj w kliknij pozycję Mój komputer.

  2. Na liście dysków kliknij prawym przyciskiem myszy dysk, który może zawierać bazę danych, a następnie kliknij polecenie Wyszukaj.

  3. Wprowadź kryteria wyszukiwania, a następnie naciśnij klawisz ENTER, aby wyszukać bazę danych.

  4. Jeśli baza danych zostanie znaleziona, otwórz ją, klikając ją dwukrotnie w oknie dialogowym Wyniki wyszukiwania.

    Ponieważ wyszukiwanie zostało zainicjowane z okna dialogowego Otwieranie, przed otwarciem bazy danych należy kliknąć przycisk Anuluj w tym oknie dialogowym.

Plik danych można otworzyć bezpośrednio w formacie pliku zewnętrznego (takim jak dBASE, Paradox, Microsoft Exchange lub Excel). Możesz również bezpośrednio otworzyć dowolne źródło danych ODBC, takie jak Microsoft SQL Server lub Microsoft FoxPro. Program Access automatycznie utworzy nową bazę danych programu Access w tym samym folderze, w którym znajduje się plik danych, i doda linki do każdej tabeli w zewnętrznej bazie danych.

Początek strony

Wprowadzenie do korzystania z nowej bazy danych

W zależności od użytego szablonu może być konieczne wprowadzenie do nowej bazy danych, co najmniej jednej z następujących czynności:

  • Jeśli program Access wyświetli okno dialogowe Logowanie z pustą listą użytkowników, aby rozpocząć, skorzystaj z poniższej procedury:

    1. Kliknij pozycję Nowy użytkownik.

    2. Wypełnij formularz Szczegóły użytkownika.

    3. Kliknij przycisk Zapisz i zamknij.

    4. Zaznacz wprowadzoną właśnie nazwę użytkownika i kliknij przycisk Zaloguj.

  • Jeśli program Access wyświetli pusty arkusz danych, możesz rozpocząć wpisywanie danych bezpośrednio w tym arkuszu danych lub kliknąć inne przyciski i karty, aby eksplorować bazę danych.

  • Jeśli w programie Access zostanie wyświetlona strona Wprowadzenie, możesz kliknąć na tej stronie linki, aby dowiedzieć się więcej o bazie danych, lub kliknąć inne przyciski i karty, aby eksplorować bazę danych.

  • Jeśli na pasku komunikatów w programie Access zostanie wyświetlony komunikat Ostrzeżenie o zabezpieczeniach, a źródło szablonu jest zaufane, kliknij pozycję Włącz zawartość. Jeśli baza danych wymaga zalogowania się, konieczne będzie ponowne zalogowanie się.

W przypadku baz danych dla komputerów stacjonarnych i baz danych sieci Web warto również rozpocząć od jednej z poniższych czynności:

Początek strony

Dodawanie tabeli

Możesz dodać nową tabelę do istniejącej bazy danych, korzystając z narzędzi w grupie Tabele na karcie Tworzenie.

Grupa Tabele na karcie Tworzenie

Uwaga: W bazie danych sieci Web w grupie Tabele jest dostępne tylko polecenie Tabela.

Niezależnie od widoku, w którym rozpoczynasz, zawsze możesz przełączyć się do innego widoku za pomocą przycisków widoku na pasku stanu w oknie programu Access.

Tworzenie pustej tabeli w widoku arkusza danych    W widoku arkusza danych można od razu wprowadzać dane i pozwolić programowi Access na tworzenie struktury tabeli w tle. Nazwy pól są przypisywane cyfrowo (Pole1, Pole2 i tak dalej), a program Access ustawia typ danych pola na podstawie typu wprowadzanych danych.

  1. Na karcie Tworzenie w grupie Tabele kliknij pozycję Tabela Obraz przycisku .

  2. Program Access utworzy tabelę, a następnie umieść kursor w pierwszej pustej komórce w kolumnie Kliknij, aby dodać.

  3. Aby dodać dane, zacznij wpisywać tekst w pierwszej pustej komórce — lub możesz wkleić dane z innego źródła, jak opisano w dalszej części tego artykułu.

    • Aby zmienić nazwę kolumny (pola), kliknij dwukrotnie nagłówek kolumny, a następnie wpisz nową nazwę.

      Porada: Nadaj każdemu polu zrozumiałą nazwę, aby można było stwierdzić, co zawiera, bez konieczności spojrzenia na dane.

    • Aby przenieść kolumnę, zaznacz ją, klikając nagłówek kolumny, a następnie przeciągnij w odpowiednie miejsce. Możesz również zaznaczyć kilka sąsiadujących kolumn i przeciągnąć je wszystkie razem w nowe miejsce.

      Aby dodać więcej pól do tabeli, możesz rozpocząć wpisywanie tekstu w kolumnie Kliknij, aby dodać w widoku arkusza danych, lub dodać nowe pola za pomocą poleceń w grupie Dodawanie & Usuwanie na karcie Pola.

Tworzenie tabeli od widoku projektu    W widoku projektu najpierw należy utworzyć strukturę nowej tabeli. Następnie możesz przełączyć się do widoku arkusza danych, aby wprowadzić dane, lub wprowadzić dane inną metodą, na przykład za pomocą formularza.

Widok projektu nie jest dostępny w przypadku tabel w bazie danych sieci Web.

  1. Na karcie Tworzenie w grupie Tabele kliknij pozycję Projekt tabeli. Obraz przycisku

  2. Dla każdego pola w tabeli wpisz nazwę w kolumnie Nazwa pola, a następnie wybierz typ danych z listy Typ danych.

  3. Możesz wprowadzić dodatkowe informacje dla każdego pola w kolumnie Opis. Wprowadzany opis jest wyświetlany na pasku stanu, gdy punkt wstawiania znajduje się w tym polu, i jest używany jako tekst paska stanu dla wszelkich utworzonych kontrolek przez przeciągnięcie pola z okienka Lista pól do formularza lub raportu, a także dla wszelkich kontrolek utworzonych dla tego pola przez Kreatora formularzy lub Kreatora raportów.

  4. Po dodaniu wszystkich pól zapisz tabelę:

    • Na karcie Plik kliknij przycisk Zapisz.

  5. W dowolnym momencie możesz rozpocząć wprowadzanie danych w tabeli, przełączając się do widoku arkusza danych, klikając pierwszą pustą komórkę i wpisując tekst. Możesz również wkleić dane z innego źródła, jak opisano w następnej sekcji.

Tworzenie tabeli na podstawie listy programu SharePoint    W przypadku listy programu SharePoint twoje dane mogą być używane przez osoby, które nie mają programu Access. Ponadto dane listy są przechowywane na serwerze, co na ogół zapewnia lepszą ochronę przed utratą danych niż pliki przechowywane na komputerze stacjonarnym. Możesz rozpocząć od nowej listy lub utworzyć link do istniejącej listy. Musisz mieć wystarczające uprawnienia do witryny programu SharePoint, w której chcesz utworzyć listę. może to różnić się w zależności od witryny, więc skontaktuj się z administratorem programu SharePoint, aby uzyskać szczegółowe informacje na temat dostępnych opcji.

Ta funkcja nie jest dostępna w bazie danych sieci Web.

  1. Na karcie Tworzenie w grupie Tabele kliknij pozycję Listy SharePoint.

  2. Za pomocą jednego z szablonów list można utworzyć standardową listę programu SharePoint, taką jak Kontakty lub Zdarzenia.

    Możesz także utworzyć listę niestandardową albo utworzyć połączenie z istniejącą listą lub zaimportować ją. Kliknij odpowiednią opcję.

  3. Jeśli wybierzesz dowolny z szablonów list lub utworzysz listę niestandardową, zostanie otwarte okno dialogowe Tworzenie nowej listy, które poprowadzi Cię przez ten proces. Jeśli zdecydujesz się użyć istniejącej listy, zostanie otwarte okno dialogowe Pobierz dane zewnętrzne.

Aby uzyskać więcej informacji o tabelach, zobacz artykuł Wprowadzenie do tabel.

Początek strony

Wklejanie danych z innego źródła do tabeli programu Access

Jeśli dane są obecnie przechowywane w innym programie, takim jak Excel, możesz je skopiować i wkleić do tabeli programu Access. Na ogół działa to najlepiej, jeśli dane są już rozdzielone na kolumny, tak jak w arkuszu programu Excel. Jeśli dane są w edytorze tekstu, należy najpierw rozdzielić kolumny danych za pomocą kart lub przekonwertować dane na tabelę w edytorze tekstu, a następnie skopiować dane. Jeśli dane będą wymagały edytowania lub manipulowania (na przykład rozdzielenia imion i nazwisk na imiona i nazwiska), warto to zrobić przed skopiowanie danych, szczególnie jeśli nie znasz programu Access.

Podczas wklejania danych do pustej tabeli program Access ustawia typy danych poszczególnych pól zgodnie z tym, jakiego rodzaju dane tam się znajduje. Jeśli na przykład wklejone pole zawiera tylko wartości dat, program Access stosuje do tego pola typ danych Data/Godzina. Jeśli wklejone pole zawiera tylko wyrazy "tak" i "nie", program Access stosuje do tego pola typ danych Tak/Nie.

Program Access nazwij pola w zależności od tego, co znajdzie w pierwszym wierszu wklejonych danych. Jeśli pierwszy wiersz wklejonych danych jest podobny do następującego po nich wiersza, program Access ustali, że pierwszy wiersz stanowi część danych, i przypisze do pól ogólne nazwy (Pole1, Pole2 itd.). Jeśli pierwszy wiersz wklejonych danych nie jest podobny do wierszy, które po nich są, program Access używa pierwszego wiersza jako nazw pól i wyklucza pierwszy wiersz w danych rzeczywistych.

Jeśli program Access przypisze ogólne nazwy pól, należy jak najszybciej zmienić nazwy pól, aby uniknąć zamieszania. Wykonaj następujące kroki:

  1. Na karcie Plik kliknij przycisk Zapisz, aby zapisać tabelę.

  2. W widoku arkusza danych kliknij dwukrotnie każdy nagłówek kolumny, a następnie wpisz nazwę kolumny.

  3. Zapisz ponownie tabelę.

Początek strony

Importowanie lub łączenie danych z innego źródła

Być może zbierasz dane w innym programie, których chcesz użyć w programie Access. Być może pracujesz z osobami, które przechowują swoje dane w innych programach, i chcesz pracować z ich danymi w programie Access. Być może masz wiele różnych źródeł danych i potrzebujesz "lądowiska", gdzie możesz ze sobą pomóc w bardziej dogłębnej analizie.

Program Access ułatwia importowanie lub łączenie danych z innych programów. Dane można uzyskać z arkusza programu Excel, z tabeli w innej bazie danych programu Access, z listy programu SharePoint lub z różnych innych źródeł. Proces wygląda nieco inaczej w przypadku różnych źródeł danych, ale zacznij od wykonania następujących instrukcji:

  1. Na karcie Dane zewnętrzne w grupie & importowania kliknij polecenie dla typu pliku, z których importujesz dane.

    Jeśli na przykład importujesz dane z arkusza programu Excel, kliknij pozycję Excel. Jeśli nie widzisz właściwego typu programu, kliknij pozycję Więcej.

    Uwaga: Jeśli nie możesz znaleźć właściwego typu formatu w grupie Importowanie & Link, może być konieczne uruchomienie programu, w którym pierwotnie utworzono dane, a następnie zapisanie danych w formacie pliku, który jest przez program Access obsługujący (na przykład rozdzielany plik tekstowy ), a następnie zaimportowanie lub połączenie danych.

  2. W oknie dialogowym Pobierz dane zewnętrzne kliknij przycisk Przeglądaj, aby przejść do źródłowego pliku danych, lub wpisz pełną ścieżkę źródłowego pliku danych w polu Nazwa pliku.

  3. Kliknij opcję, którą chcesz wybrać, w obszarze Określ sposób i miejsce przechowywania danych w bieżącej bazie danych. Możesz utworzyć nową tabelę przy użyciu zaimportowanych danych lub utworzyć tabelę połączoną z linkiem do źródła danych.

  4. Kliknij przycisk OK.

    W zależności od wybranej opcji zostanie otwarte okno dialogowe Łączenie obiektów lub okno dialogowe Importowanie obiektów.

  5. Użyj okna dialogowego, aby zakończyć proces. Dokładna procedura, która należy wykonać, zależy od wybranej opcji importowania lub łączenia.

  6. Na ostatniej stronie kreatora kliknij przycisk Zakończ.

    Jeśli wybrano importowanie, program Access zapyta, czy chcesz zapisać szczegóły właśnie ukończonej operacji importowania.

  7. Jeśli uważasz, że ta sama operacja importowania zostanie ponownie wykonać, kliknij pozycję Zapisz kroki importowania,a następnie wprowadź szczegóły.

    Następnie możesz łatwo odtworzyć operację importowania, klikając pozycję Zapisane importowanie w grupie Importowanie na karcie Dane zewnętrzne, klikając specyfikację importu, a następnie klikając przycisk Uruchom.

  8. Jeśli nie chcesz zapisywać szczegółów operacji, kliknij przycisk Zamknij.

Program Access zaim importuje dane do nowej tabeli, a następnie wyświetla tabelę w obszarze Tabele w okienku nawigacji.

Aby dowiedzieć się więcej na temat importowania danych do programu Access, skorzystaj z linków w sekcji Zobacz też w tym artykule.

Początek strony

Następne kroki

Pozostała część procesu projektowania różni się w zależności od twoich celów, ale prawdopodobnie chcesz rozważyć utworzenie zapytań, formularzy, raportów i makr. Ten artykuł nie zawiera informacji na temat tworzenia dodatkowych obiektów bazy danych.

Aby uzyskać więcej informacji, zobacz następujące artykuły:

Początek strony

Importowanie danych z arkusza kalkulacyjnego lub innego programu

Jeśli znasz inne programy baz danych lub arkuszy kalkulacyjnych, prawdopodobnie wiesz, jak działają te aplikacje i do jakich baz danych są używane. Program Access różni się od wielu innych aplikacji baz danych, umożliwiając tworzenie relacyjnych baz danych, a dodatkowo różni się od większości programów arkuszy kalkulacyjnych, oferując narzędzia do tworzenia zaawansowanych zapytań, formularzy i raportów. Program Access udostępnia również wiele opcji do pracy z innymi programami baz danych, takimi jak program SQL Server.

Importowanie arkusza programu Excel do programu Access

Wiele osób zaczyna korzystać z programu Access po pierwszym sbudowania listy w programie Excel. Program Excel to doskonałe miejsce na rozpoczęcie listy, ale w miarę powiększania się listy trudniej jest ją uporządkować i aktualizować. Przeniesienie listy do programu Access jest zwykle następnym logicznym krokiem.

Tabela bazy danych ma strukturę podobną do arkusza, w związku z tym dane są przechowywane w wierszach i kolumnach. W efekcie importowanie arkusza do tabeli bazy danych jest zwykle łatwe. Główną różnicą między przechowywaniem danych w arkuszu a przechowywaniem ich w bazie danych jest sposób ich zorganizowania. Zwykłe zaimportowanie całego arkusza jako nowej tabeli w bazie danych nie rozwiąże problemów związanych z organizowaniem i aktualizowaniem danych, szczególnie jeśli arkusz zawiera nadmiarowe dane. Aby rozwiązać te problemy, należy podzielić dane arkusza kalkulacyjnego na osobne tabele z każdą tabelą zawierającą powiązane dane. Aby uzyskać więcej informacji na temat rozmieszczania danych w tabelach, zobacz artykuł Podstawowe informacje o projekcie bazy danych.

Program Access zawiera Kreatora Analizatora tabel, który może ułatwić ukończenie tego procesu. Po zaimportowaniu danych do tabeli kreator pomaga podzielić tabelę na osobne tabele, z których każda zawiera dane, które nie są zduplikowane w żadnej z pozostałych tabel. Kreator utworzy także niezbędne relacje między tabelami.

Początek strony

Importowanie arkusza programu Excel jako tabeli w nowej bazie danych

  1. Na karcie Plik kliknij pozycję Nowy,a następnie kliknij pozycję Pusta baza danych.

  2. Wpisz nazwę nowej bazy danych w polu Nazwa pliku, a następnie kliknij przycisk Utwórz.

    Zostanie otwarta nowa baza danych, a program Access utworzy nową pustą tabelę Tabela1.

  3. Zamknij tabelę1.

    Gdy zostanie pytanie, czy chcesz zapisać zmiany w projekcie tabeli Tabela1, kliknij przycisk Nie.

  4. Na karcie Dane zewnętrzne w grupie Importowanie i & kliknij pozycję Excel. Obraz przycisku

  5. W oknie dialogowym Pobierz dane zewnętrzne kliknij przycisk Przeglądaj.

  6. Użyj okna dialogowego Otwieranie pliku, aby zlokalizować plik.

  7. Zaznacz plik, a następnie kliknij pozycję Otwórz.

  8. W oknie dialogowym Pobierz dane zewnętrzne upewnij się, że opcja Importuj dane źródłowe do nowej tabeli w bieżącej bazie danych jest zaznaczona.

  9. Kliknij przycisk OK.

    Zostanie uruchomiony Kreator importowania arkuszy kalkulacyjnych, który zada Ci kilka pytań dotyczących danych.

  10. Postępuj zgodnie z instrukcjami, klikając przycisk Dalejlub Wstecz, aby przechodzić między stronami. Na ostatniej stronie kreatora kliknij przycisk Zakończ.

    Uwaga: Program Access zapyta, czy chcesz zapisać szczegóły właśnie ukończonej operacji importowania. Jeśli uważasz, że ta sama operacja importowania zostanie ponownie w wykonaniu, kliknij przycisk Tak,a następnie wprowadź szczegóły. Następnie możesz łatwo odtworzyć operację w przyszłości, klikając pozycję Zapisane importowanie w grupie Importowanie na karcie Dane zewnętrzne. Jeśli nie chcesz zapisywać szczegółów operacji, kliknij przycisk Zamknij.

Program Access zaim importuje dane do nowej tabeli, a następnie wyświetla je w obszarze Wszystkie tabele w okienku nawigacji.

Początek strony

Organizowanie danych za pomocą Kreatora analizatora tabel

Po zaimportowaniu danych do tabeli programu Access można za pomocą Kreatora analizatora tabel szybko zidentyfikować nadmiarowe dane. Następnie kreator udostępnia prosty sposób organizowania danych w osobne tabele, dzięki czemu są one przechowywane w najbardziej efektywny sposób. Program Access zachowuje oryginalną tabelę jako kopię zapasową, a następnie tworzy nowe tabele, których można użyć jako podstawy dla aplikacji bazy danych.

  1. Otwórz bazę danych programu Access zawierającą tabelę, którą chcesz przeanalizować.

  2. Na karcie Narzędzia bazy danych w grupie Analizowanie kliknij przycisk Analizuj tabelę.

    Zostanie uruchomiony Kreator analizatora tabel.

    Pierwsze dwie strony kreatora zawierają krótki samouczek z przyciskami, które możesz kliknąć, aby zobaczyć przykłady. Jeśli nie widzisz stron wprowadzenia, ale zamiast tego widzisz pole wyboru Pokaż strony wprowadzenia?Zaznacz to pole wyboru, a następnie kliknij przycisk Wstecz dwa razy, aby zobaczyć wprowadzenie. Jeśli nie chcesz ponownie wyświetlać stron wprowadzenia po przeczytaniu wprowadzenia, możesz wyczyścić pole wyboru Pokaż strony wprowadzenia?

  3. Na stronie Która tabela zawiera pola z wartościami, które są powtarzane w wielu rekordach? zaznacz tabelę, którą chcesz przeanalizować, a następnie kliknij przycisk Dalej.

  4. Możesz pozwolić kreatorowi zdecydować, które pola mają się znaleźć w jakich tabelach, lub podjąć tę decyzję samodzielnie. Jeśli użytkownik będzie postępować zgodnie z sugestiami kreatora, nadal będzie można wprowadzać zmiany w układzie tabeli na następnej stronie kreatora.

    Uwaga: Jeśli pozwolisz kreatorowi zdecydować, które pola umieścić w jakich tabelach, jego wybory mogą nie zawsze być odpowiednie dla Twoich danych, szczególnie jeśli masz niewiele danych do pracy. Wyniki kreatora należy dokładnie sprawdzić. Z drugiej strony kreator może zaproponować bardziej wydajną organizację niż ta, o która myślisz, więc warto przynajmniej raz wypróbować decyzje kreatora. Jeśli nie podobają Ci się sugestie, nadal możesz zmienić rozmieszczenie pól ręcznie. Zawsze możesz kliknąć pozycję Wstecz i samodzielnie rozmieścić wszystkie pola.

  5. Kliknij pozycję Dalej. Na tej stronie możesz określić, które tabele zawierają pola. Jeśli kreator zdecyduje, że ma zostać wyświetlonych wiele tabel połączonych liniami relacji. W przeciwnym razie program Access utworzy tylko jedną tabelę zawierającą wszystkie pola. W obu przypadkach możesz wprowadzić zmiany na tej stronie.

    • Możesz przeciągnąć pola z tabeli do pustego obszaru strony, aby utworzyć nową tabelę zawierającą te pola. Program Access wyświetli monit o nazwę tabeli.

    • Możesz przeciągać pola z jednej tabeli do drugiej, jeśli uważasz, że będą one przechowywane w tej tabeli wydajniej.

    • Większość tabel będzie mieć identyfikator lub pole Wygenerowany unikatowy identyfikator. Aby dowiedzieć się więcej o polach identyfikatorów, kliknij pozycję Porady w prawym górnym rogu kreatora.

    • Aby cofnąć zmianę, kliknij przycisk Cofnij.

    • Aby zmienić nazwę tabeli, kliknij dwukrotnie jej pasek tytułu, wpisz nową nazwę, a następnie kliknij przycisk OK.

  6. Po rozmieszczeniu pól w sposób, w jaki chcesz, kliknij przycisk Dalej.

  7. Jeśli kreator znajdzie rekordy o bardzo podobnych wartościach, zidentyfikuje te wartości jako możliwe błędy typograficzne i przedstawi ekran, na którym można potwierdzić, co z nimi zrobić. Przewiń listę, aby znaleźć wartości w kolumnie Korekta, a następnie kliknij odpowiedni element na liście rozwijanej. Wybierz pozycję (Pozostaw bez zmian), aby kreator nie wprowadzał żadnych zmian w wartości. Po zakończeniu kliknij przycisk Dalej.

  8. Kreator zapyta, czy chcesz utworzyć zapytanie przypominające pierwotną tabelę. Jeśli masz już formularze i raporty oparte na oryginalnej tabeli, dobrym pomysłem jest utworzenie takiego zapytania. Jeśli wybierzesz pozycję Tak,utwórz zapytanie, kreator zmieni nazwę oryginalnej tabeli, dołączając do nazwy tabeli nazwę "_OLD", a następnie nazwa nowego zapytania przy użyciu nazwy oryginalnej tabeli. Formularze i raporty oparte na tabeli używają teraz zapytania dla swoich danych i działają tak jak wcześniej.

  9. Kliknij przycisk Zakończ.

    Kreator utworzy nowe tabele zgodnie z określonej wartością, a następnie je otworzy. Zamknij je po zakończeniu sprawdzania wyników.

Początek strony

Praca z danymi z innych programów

Program Access 2010 udostępnia funkcje do pracy z danymi przechowywanymi w innych programach.

Tworzenie nowej bazy danych programu Access, która łączy się z danymi w innym formacie pliku    Za pomocą programu Access można otworzyć plik w innym formacie pliku, takim jak tekst, program dBASE lub arkusz kalkulacyjny. Program Access automatycznie utworzy bazę danych programu Access i automatycznie utworzy link do pliku.

  1. Uruchom program Access.

  2. Na karcie Plik kliknij pozycję Otwórz.

  3. W oknie dialogowym Otwieranie kliknij na liście typ pliku, który chcesz otworzyć. Jeśli nie masz pewności co do typu pliku, kliknij pozycję Wszystkie pliki (*.*).

  4. W razie potrzeby przejdź do folderu zawierającego plik, który chcesz otworzyć. Po odnalezieniu pliku kliknij go dwukrotnie, aby go otworzyć.

  5. Wykonaj instrukcje kreatora. Na ostatniej stronie kreatora kliknij przycisk Zakończ.

Importowanie lub łączenie danych z istniejącą bazą danych programu Access    Dane z innych źródeł i programów można zaimportować do tabel programu Access, aby dane znajdowały się w pliku programu Access, lub utworzyć połączenie z danymi z programu Access, aby dane znajdowały się w oryginalnym pliku (poza plikiem programu Access).

  1. Na karcie Dane zewnętrzne w grupie & importowania kliknij format, w którym są przechowywane dane.

    Możesz zaimportować lub połączyć dane z następujących źródeł:

    • Excel    Dane z arkusza lub nazwanego zakresu można uzyskać w skoroszycie programu Excel. Każdy arkusz lub nazwany zakres należy zaimportować lub połączyć oddzielnie.

    • Access    Jest to bardzo przydatne do oddzielenia procesu od danych, tworzenia podzielonej bazy danych. Oznacza to, że za pomocą jednej bazy danych można przechowywać wszystkie formularze, raporty i makra oraz przechowywać dane w innej bazie danych. Następnie możesz opracować ulepszenia bez przerywania pracy innych osób. Dane z wielu różnych baz danych programu Access można też łączyć w jednej, co ułatwia podsumowywane dane z różnych działów lub między partnerami biznesowymi.

    • baza danych ODBC    Ten format jest obsługujący wiele programów, w tym wiele serwerów baz danych. Ułatwia to tworzenie baz danych "lądowiska", w których można łączyć dane z różnych systemów.

    • Plik tekstowy    Możesz połączyć się z prostym plikiem tekstowym, a nawet za pomocą programu Access zmienić zawartość tego pliku. Może to ułatwić uzyskiwanie dostępu do danych w wielu programach.

    • Plik XML    Format ten zapewnia również zgodność z wieloma innymi programami, w tym z niektórymi serwerami sieci Web.

    • Lista programu SharePoint    Dzięki temu można korzystać z danych za pomocą przeglądarki internetowej, co jest standardowym sposobem używania listy programu SharePoint.

    • Usługi danych    Możesz łączyć się z usługami danych sieci Web w przedsiębiorstwie.

    • Dokument HTML    

    • Folder programu Outlook    Możesz łączyć się z folderami programu Outlook, aby łatwiej zintegrować swoje informacje kontaktowe z pozostałymi danymi.

    • Plik programu dBase    dBase to popularny alternatywny system bazy danych obsługiwany przez program Access

      Zostanie wyświetlone okno dialogowe Pobierz dane zewnętrzne.

  2. Postępuj zgodnie z instrukcjami wyświetlanymi w oknie dialogowym.

    Program Access zaimportuje lub połączy dane z bazą danych. W przypadku większości formatów należy określić lokalizację danych, a następnie wybrać sposób przechowywania danych w bazie danych.

Początek strony

Używanie bazy danych starszej wersji w kilku wersjach programu Access

Jeśli baza danych programu Access lub projekt programu Access utworzono w programie Access 2000 lub nowszym, można używać tej bazy danych lub projektu w wersji programu Access, w której została utworzona, lub w dowolnej nowszej wersji — nawet jeśli dla pliku włączono zabezpieczenia. Plików programu Access 2000 można na przykład używać w programach Access 2000, Access 2002, Access 2003, Access 2007 i Access 2010.

Może się jednak okazać, że chcesz zachować dane we wcześniejszej wersji programu Access, ale użytkownicy korzystający z nowszej wersji programu Access będą chcieli połączyć się z danymi, ale nadal będą korzystać z niektórych funkcji z nowszej wersji programu. Rozwiązaniem jest utworzenie w nowszej wersji nowej "frontonu" bazy danych (zawierającej formularze, raporty, zapytania, makra, ale bez tabel) i połączenie jej z tabelami we wcześniejszej wersji pliku. Skorzystaj z jednej z poniższych procedur w zależności od tego, czy baza danych znajduje się w jednym pliku, czy jest już podzielona na aplikacja zewnętrzna/wewnętrzna.

Używanie pliku bazy danych programu Access w kilku wersjach programu Access

Jeśli wszystkie tabele, formularze i inne obiekty bazy danych programu Access starszej wersji znajdują się w jednym pliku i chcesz używać bazy danych w kilku wersjach programu Access, możesz utworzyć nową bazę danych frontodanową w nowszej wersji i połączyć ją z oryginalnym plikiem. Użytkownicy, którzy mają wcześniejszą wersję programu Access, nadal mogą korzystać z oryginalnej bazy danych. Użytkownicy, którzy mają nowszą wersję, mogą używać nowej frontodanowej bazy danych do łączenia się z tym samymi danymi. Jeśli jest konieczne uwzględnianie wielu wersji programu Access, można utworzyć kilka wersji frontoronowych.

Początek strony

Krok 1. Kopiowanie istniejącej bazy danych i zapisywanie jej w nowym formacie

Aby przekonwertować bazę danych na dowolny z trzech najnowszych formatów: Access 2000, Access 2002–2003 lub Access 2007, skorzystaj z poniższej procedury. To polecenie zachowuje oryginalną bazę danych w oryginalnym formacie i tworzy kopię w formacie, który został określony przez użytkownika.

  1. Zamknij plik programu Access. Jeśli plik jest wielodostępną bazą danych programu Access znajdującą się na serwerze lub w folderze udostępnionym, upewnij się, że nikt inny nie ma jej otwartej.

  2. Uruchom program Access 2010.

  3. Na karcie Plik kliknij pozycję Otwórz.

  4. Przejdź do lokalizacji pliku, który chcesz przekonwertować, a następnie kliknij go dwukrotnie, aby go otworzyć.

    Jeśli zostanie wyświetlone okno dialogowe Rozszerzenie bazy danych z pytaniem, czy baza danych ma zostać ulepszeń, kliknij przycisk Nie.

  5. Jeśli po uruchomieniu bazy danych zostanie otwarty formularz, zamknij go.

  6. Na karcie Plik kliknij pozycję Zapisz bazę danych jako.

  7. W oknie dialogowym Zapisywanie jako wpisz nazwę nowej bazy danych.

    Uwaga: O ile nie zapiszemy nowej bazy danych w innej lokalizacji, jej nazwa musi być inna niż nazwa oryginalnej bazy danych. W obu przypadkach najlepiej użyć innej nazwy, aby można było łatwo odróżnić bazę danych frontodanową od bazy danych typu Back-End. Jeśli jednak format jest konwertowany na format programu Access 2007, rozszerzenie nazwy pliku zmienia się z mdb na accdb, dzięki czemu można użyć tej samej nazwy pliku.

  8. Kliknij przycisk Zapisz.

Początek strony

Krok 2. Podziel kopię bazy danych i użyj oryginalnego pliku jako bazy danych back-end

Przekonwertowaną bazę danych można podzielić, korzystając z następującej procedury:

  • Na karcie Narzędzia bazy danych w grupie Przenoszenie danych kliknij pozycję Baza danych programu Access. Obraz przycisku

  • W oknie dialogowym Podział bazy danych kliknij pozycję Podziel bazę danych.

    Jeśli chcesz, możesz utworzyć kopię zapasową, ale możesz też utworzyć ją ponownie przy użyciu oryginalnej bazy danych.

  • Wpisz nazwę dla bazy danych, a następnie kliknij przycisk Podziel.

Początek strony

Krok 3. Połączenie nowego frontoronu z oryginalną bazą danych

  1. Usuń bazę danych utworzoną przez narzędzie Podział bazy danych— uważaj, aby nie usunąć oryginalnej bazy danych.

  2. Połącz nową zewnętrzną bazę danych z tabelami w oryginalnej bazie danych: Na karcie Dane zewnętrzne w grupie Importowanie & kliknij pozycję Menedżer tabel połączonych. Obraz przycisku

  3. Kliknij pozycję Zaznacz wszystko,a następnie zaznacz pole wyboru Zawsze monituj o nową lokalizację.

  4. Kliknij przycisk OK,przejdź do bazy danych starszej wersji, a następnie kliknij ją dwukrotnie.

    Jeśli wszystko się posunie, w programie Access zostanie wyświetlony komunikat informujący, że wszystkie wybrane tabele połączone zostały pomyślnie odświeżone.

Teraz można ulepszyć nową frontodanową bazę danych, aby obsługiwać nowe funkcje dla użytkowników, którzy mają nowsze wersje programu Access. Użytkownicy, którzy mają wcześniejsze wersje, mogą nadal korzystać z wcześniejszej wersji bazy danych.

Początek strony

Korzystanie z aplikacji front end/back-end w kilku wersjach programu Access

Jeśli baza danych programu Access jest już aplikacja zewnętrzna/wewnętrzna pliku, można przekonwertować front end na nowy format pliku. W przypadku back-endowej bazy danych nie są wymagane żadne zmiany.

W poniższej procedurze przedstawiono sposób konwertowania frontodanowej bazy danych na dowolny z trzech najnowszych formatów: Access 2000, Access 2002–2003 lub Access 2007 za pomocą polecenia Zapisz bazę danych. To polecenie zachowuje oryginalną bazę danych w oryginalnym formacie i tworzy kopię w formacie, który jest określony przez użytkownika.

  1. Zamknij frontoronową bazę danych. Jeśli plik jest wielodostępną bazą danych programu Access znajdującą się na serwerze lub w folderze udostępnionym, upewnij się, że nikt inny nie ma jej otwartej.

  2. Uruchom program Access 2010.

  3. Na karcie Plik kliknij pozycję Otwórz.

  4. Przejdź do lokalizacji frontodanowej bazy danych, a następnie kliknij ją dwukrotnie, aby ją otworzyć.

    Jeśli zostanie wyświetlone okno dialogowe Rozszerzenie bazy danych z pytaniem, czy baza danych ma zostać ulepszeń, kliknij przycisk Nie.

  5. Jeśli po otwarciu bazy danych zostanie wyświetlony formularz, zamknij go.

  6. Na karcie Plik kliknij pozycję Zapisz bazę danych jako.

  7. W oknie dialogowym Zapisywanie jako wpisz nazwę nowej bazy danych.

  8. Kliknij przycisk Zapisz.

Teraz można ulepszyć nową frontodanową bazę danych, aby obsługiła nowe funkcje.

Początek strony

Potrzebna dalsza pomoc?

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×