Tworzenie, ładowanie i edytowanie zapytania w programie Excel (Power Query)

Dodatku Power Query można tworzyć i ładować zapytania dodatku Power Query do skoroszytu na kilka sposobów. Możesz również ustawić domyślne ustawienia ładowania zapytania w oknie Opcje zapytania.   

Porada      Aby stwierdzić, czy dane w arkuszu są w kształcie przez dodatku Power Query, zaznacz komórkę danych i jeśli zostanie wyświetlona karta kontekstowa zapytanie na wstążce, oznacza to, że dane załadowano z dodatku Power Query. 

Selecting a cell in a query to reveal the Query tab

Wiesz, w którym środowisku jesteś Program Power Query jest dobrze zintegrowany z interfejsem użytkownika programu Excel, zwłaszcza w przypadku importowania danych, pracy z połączeniami i edytowania tabel przestawnych, tabel Excel i nazwanych zakresów. Aby uniknąć zamieszania, w dowolnym momencie należy wiedzieć, w którym środowisku obecnie się znajdujesz Excel lub dodatku Power Query.

Znany arkusz Excel, wstążka i siatka

Wstążka Edytora dodatku Power Query i podgląd danych 

Typowy Excel arkusza Typowy widok Edytora dodatku Power Query

Na przykład manipulowanie danymi w arkuszu Excel znacznie się różni od dodatku Power Query. Ponadto połączone dane, które są Excel arkusza, mogą, ale nie muszą, działać w tle przez dodatku Power Query w celu kształtowania danych. Dzieje się tak tylko wtedy, gdy dane są ładowane do arkusza lub modelu danych z dodatku Power Query.

Zmienianie nazw kart arkusza    Warto zmieniać nazwy kart arkuszy w zrozumiały sposób, szczególnie jeśli jest ich wiele. Szczególnie istotne jest wyjaśnienie różnicy między arkuszem danych a arkuszem załadowanym z Edytora dodatku Power Query. Nawet jeśli masz tylko dwa arkusze, jeden z tabelą programu Excel o nazwie Arkusz1,a drugi został utworzony przez zaimportowanie tej tabeli programu Excel o nazwie Tabela1,można to łatwo pomylić. Warto zawsze zmienić domyślne nazwy kart arkuszy na bardziej sensowne. Na przykład zmień nazwę Arkusza1 na Tabela Danych, a Tabela1 na Tabela Zapytania. Teraz nie ma wątpliwości, która karta zawiera dane, a która zawiera zapytanie.

Możesz utworzyć zapytanie na pomocą zaimportowanych danych lub utworzyć puste zapytanie.

Tworzenie zapytania na pomocą zaimportowanych danych

Jest to najpopularniejszy sposób tworzenia zapytania.

  1. Zaimportuj niektóre dane. Aby uzyskać więcej informacji, zobacz Importowanie danych z zewnętrznych źródeł danych.

  2. Zaznacz komórkę w danych, a następnie wybierz pozycję Zapytanie> Edytuj.

Tworzenie pustego zapytania

Możesz zacząć od podstaw. Można to zrobić na dwa sposoby.

  • Wybierz pozycję> pobierz dane > z innych źródeł > puste zapytanie.

  • Wybierz pozycję Dane> pozycję Pobierz dane > Uruchom Edytor dodatku Power Query.

Na tym etapie możesz ręcznie dodać kroki i formuły, jeśli znasz dobrze język formuł M dodatku Power Query.

Możesz też wybrać pozycję Narzędzia główna, a następnie wybrać polecenie w grupie Nowe zapytanie. Wykonaj jedną z poniższych czynności:

  • Wybierz pozycję Nowe źródło, aby dodać źródło danych. To polecenie jest podobne do polecenia Pobierz >dane na wstążce Excel dane.

  • Wybierz pozycję Ostatnio wybrane źródła, aby wybrać źródło danych, z które pracujesz. To polecenie jest podobne do polecenia Dane >ostatnio źródła na wstążce Excel wstążce.

  • Wybierz pozycję Wprowadź dane, aby ręcznie wprowadzić dane. To polecenie można wybrać, aby wypróbować Edytor dodatku Power Query niezależnie od zewnętrznego źródła danych.

Przy założeniu, że zapytanie jest prawidłowe i nie zawiera błędów, można załadować je z powrotem do arkusza lub modelu danych.

Ładowanie zapytania z Edytora dodatku Power Query

W Edytorze dodatku Power Query wykonaj jedną z następujących czynności:

  • Aby załadować do arkusza, wybierz pozycję Narzędzia> Zamknij & Załaduj > Zamknij & Załaduj.

  • Aby załadować do modelu danych, wybierz pozycję Narzędzia> Zamknij & Załaduj > Zamknij & Załadujdo.

    W oknie dialogowym Importowanie danych wybierz pozycję Dodaj te dane do modelu danych.

Porada   Czasami polecenie Załaduj do jest wyszarzone lub wyłączone. Może się tak zdarzyć podczas tworzenia zapytania w skoroszycie po raz pierwszy. W takim przypadku wybierz pozycję Zamknij & Załaduj, w nowym arkuszu wybierz pozycję Dane > Zapytania & Połączenia >Zapytania, kliknij zapytanie prawym przyciskiem myszy, a następnie wybierz polecenie Załaduj do . Ewentualnie na wstążce Edytora dodatku Power Query wybierz pozycję Zapytanie> Załaduj do.

Ładowanie zapytania z okienka Zapytania i połączenia 

W Excel można załadować zapytanie do innego arkusza lub modelu danych.

  1. W Excel wybierz pozycję Dane> zapytania & połączeń, a następnie wybierz kartę Zapytania.

  2. Na liście zapytań znajdź zapytanie, kliknij je prawym przyciskiem myszy, a następnie wybierz pozycję Załaduj do. Zostanie wyświetlone okno dialogowe Importowanie danych.

  3. Wybierz sposób importowania danych, a następnie wybierz przycisk OK. Aby uzyskać więcej informacji na temat korzystania z tego okna dialogowego, wybierz znak zapytania (?).

Istnieje kilka sposobów edytowania zapytania załadowanego do arkusza.

Edytowanie zapytania z danych w Excel arkusza

  • Aby edytować zapytanie, znajdź wcześniej załadowaną komórkę w Edytorze dodatku Power Query, zaznacz komórkę w danych, a następnie wybierz pozycję Zapytanie i> Edytuj.

Edytowanie zapytania w okienku Zapytania & połączeń

Okienko Zapytania i & jest wygodniejsze w przypadku, gdy masz wiele zapytań w jednym skoroszycie i chcesz je szybko znaleźć.

  1. W Excel wybierz pozycję Dane> zapytania & połączeń, a następnie wybierz kartę Zapytania.

  2. Na liście zapytań znajdź zapytanie, kliknij je prawym przyciskiem myszy, a następnie wybierz pozycję Edytuj.

Edytowanie zapytania z okna dialogowego Właściwości zapytania

  • W programie Excel wybierz pozycję Dane> Data & Connections > Queries (Zapytania sieci >), kliknij zapytanie prawym przyciskiem myszy i wybierz polecenie Właściwości,wybierz kartę Definicja w oknie dialogowym Właściwości, a następnie wybierz pozycję Edytujzapytanie.

Porada    Jeśli jesteś w arkuszu z zapytaniem, wybierz pozycję Dane >Właściwości,wybierz kartę Definicja w oknie dialogowym Właściwości, a następnie wybierz pozycję Edytuj zapytanie. 

Model danych zazwyczaj zawiera kilka tabel rozmieszczonych w relacji. Zapytanie można załadować do modelu danych, używając polecenia Załaduj do w celu wyświetlenia okna dialogowego Importowanie danych, a następnie zaznaczając pole wyboru Dodaj te dane do trybu danych l. Aby uzyskać więcej informacji o modelach danych, zobacz Informacje o źródłach danych używanych w modelu danych skoroszytu ,Tworzenie modelu danych w programie Exceli Tworzenie tabeli przestawnej za pomocą wielu tabel.

  1. Aby otworzyć model danych, wybierz pozycję Power Pivot > Zarządzanie.

  2. U dołu okna dodatku Power Pivot wybierz kartę arkusza dla wybranej tabeli.

    Potwierdź, że wyświetlana jest właściwa tabela. Model danych może mieć wiele tabel.

  3. Zanotuj nazwę tabeli.

  4. Aby zamknąć okno dodatku Power Pivot, wybierz pozycję Plik > Zamknij. Odzyskanie pamięci może potrwać kilka sekund.

  5. Wybierz pozycję Dane > połączenia & właściwości > na karcie Zapytania, kliknij zapytanie prawym przyciskiem myszy, a następnie wybierz pozycję Edytuj.

  6. Po zakończeniu dokonywania zmian w Edytorze dodatku Power Query wybierz pozycję Plik> Zamknij, & załaduj.

Wynik

Zapytanie w arkuszu i tabela w modelu danych zostaną zaktualizowane.

Jeśli zauważysz, że ładowanie zapytania do modelu danych trwa znacznie dłużej niż ładowanie do arkusza, sprawdź w procedurach dodatku Power Query, czy filtrowanie kolumny tekstu lub kolumny listy strukturalnej przy użyciu operatora Zawiera. Ta akcja powoduje Excel wyliczać ponownie przez cały zestaw danych dla każdego wiersza. Ponadto Excel w praktyce korzystać z wykonywania wielowątkowego. Aby obejść ten problem, spróbuj użyć innego operatora, takiego jak Równa się lub Zaczyna się od.

Firma Microsoft wie o tym problemie i jest w trakcie badania.

Możesz załadować dodatku Power Query:

  • Do arkusza. W Edytorze dodatku Power Query wybierz pozycję Narzędzia> Zamknij & załaduj > zamknij & ładowanie.

  • Do modelu danych. W Edytorze dodatku Power Query wybierz pozycję Narzędzia> Zamknij & i załaduj > zamknij & Załaduj do

    Domyślnie podczas ładowania jednego zapytania do nowego arkusza w dodatku Power Query jest ładowanych wiele zapytań, a do modelu danych jest ładowanych wiele zapytań jednocześnie.  Możesz zmienić domyślne zachowanie dla wszystkich skoroszytów lub tylko dla bieżącego skoroszytu. Ustawienie tych opcji w dodatku Power Query nie powoduje zmiany wyników zapytania w arkuszu ani danych modelu danych i adnotacjach.

    Możesz także dynamicznie zastąpić ustawienia domyślne zapytania za pomocą okna dialogowego Importowanie, które jest wyświetlane po wybraniu przycisku Zamknij & Załadujdo. 

Ustawienia globalne stosowane do wszystkich skoroszytów

  1. W Edytorze dodatku Power Query wybierz pozycję Opcje > i ustawienia > opcje zapytania.

  2. W oknie dialogowym Opcje kwerendy po lewej stronie w sekcji GLOBALwybierz pozycję   Ładowanie danych.

  3. W sekcji Ładowanie zapytania domyślnego Ustawienia wykonaj następujące czynności:

    • Wybierz pozycję Użyj standardowych ustawień ładowania

    • Wybierz pozycję Określ niestandardowe domyślne ustawienia ładowania, a następnie zaznacz lub wyczyść pole wyboru Załaduj do  arkusza lub Załaduj do modelu danych.

Porada    U dołu okna dialogowego możesz wybrać pozycję Przywróć domyślne, aby wygodnie wrócić do ustawień domyślnych.

Ustawienia skoroszytu, które mają zastosowanie tylko do bieżącego skoroszytu

  1. W oknie dialogowym Opcje kwerendy po lewej stronie w sekcji CURRENT WORKBOOK (BIEŻĄCY SKOROSZYT) wybierz pozycję Data Load (Ładowanie danych).

  2. Wykonaj co najmniej jedną z następujących czynności:

    • W obszarze Wykrywanie typuzaznacz lub wyczyść pole wyboru Wykryj typy kolumni nagłówki dla źródeł bez struktury .

      Zachowaniem domyślnym jest ich wykrywanie. Wyczyść tę opcję, jeśli wolisz samodzielnie kształtować dane.

    • W obszarze Relacjezaznacz lub wyczyść pole wyboru Utwórz relacje między tabelami podczas dodawania do modelu danych po raz pierwszy.

      Przed załadowaniem do modelu danych domyślnym zachowaniem jest znalezienie istniejących relacji między tabelami, na przykład kluczy obcych w relacyjnej bazie danych, i zaimportowanie ich do danych. Wyczyść tę opcję, jeśli wolisz to zrobić samodzielnie.

    • W obszarze Relacjezaznacz lub wyczyść pole wyboru Aktualizuj relacje podczas odświeżania zapytań załadowanych do modelu danych.

      Domyślnie relacje nie są aktualizowane. Podczas odświeżania zapytań załadowanych już do modelu danych w dodatku Power Query są odnajdowane istniejące relacje między tabelami, takie jak klucze obce w relacyjnej bazie danych, i aktualizuje je. Może to spowodować usunięcie relacji utworzonych ręcznie po zaimportowaniu danych lub wprowadzenie nowych relacji. Jeśli jednak chcesz to zrobić, wybierz tę opcję.

    • W obszarze Dane wtle zaznacz lub wyczyść pole wyboru Zezwalaj na pobieranie podglądów danych w tle.

      Domyślnym zachowaniem jest pobieranie podglądów danych w tle. Wyczyść tę opcję, jeśli chcesz od razu wyświetlić wszystkie dane.

Zobacz też

Dodatek Power Query dla programu Excel — pomoc

Zarządzanie zapytaniami w programie Excel

Potrzebna dalsza pomoc?

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów Microsoft Office

Czy te informacje były pomocne?

Jaka jest jakość tłumaczenia?
Co wpłynęło na Twoje wrażenia?

Dziękujemy za opinię!

×