Tworzenie i uruchamianie makr

W programie Word Możesz zautomatyzować często używane zadania przez tworzenie i uruchamianie makr. Makro to seria poleceń i instrukcji, które grupują się razem jako pojedyncze polecenie w celu automatycznego wykonania zadania.

Aby zaoszczędzić czas na często wykonywanych zadaniach, połącz odpowiednie czynności w makro. Najpierw musisz zarejestrować makro. Następnie możesz je uruchomić, klikając przycisk na pasku narzędzi Szybki dostęp lub naciskając kombinację klawiszy. Zależy to od konfiguracji makra.

  1. Kliknij pozycję Widok > Makra > Zarejestruj makro.

    Polecenie Zarejestruj makro

  2. Wpisz nazwę makra.

    Pole Nazwa makra

  3. Aby móc korzystać z tego makra we wszystkich nowo tworzonych dokumentach, dla pola Przechowaj makro w ustaw opcję Wszystkie dokumenty (Normal.dotm).

    Pole służące do wyboru miejsca przechowywania makra

  4. Aby makro było uruchamiane po kliknięciu przycisku, kliknij pozycję Przycisk.

    Kliknij, aby przypisać makro do przycisku

  5. Kliknij nowe makro (o nazwie Normal.NewMacros.<nazwa Twojego makra>) i kliknij pozycję Dodaj.

    Makro i przycisk Dodaj

  6. Kliknij pozycję Modyfikuj.

    Przycisk Modyfikuj w oknie Dostosowywanie paska narzędzi Szybki dostęp

  7. Wybierz obraz przycisku, wpisz odpowiednią nazwę i kliknij dwa razy przycisk OK.

    Opcje przycisku w oknie Modyfikowanie przycisku

  8. Zarejestruj teraz czynności. Kliknij polecenia lub naciśnij klawisze dla każdej czynności w zadaniu. Program Word zarejestruje te kliknięcia i sekwencje klawiszy.

    Uwaga: Aby zaznaczyć tekst podczas rejestrowania makra, użyj klawiatury. W makrach nie są rejestrowane zaznaczenia wskaźnikiem myszy.

  9. Aby zatrzymać rejestrowanie, kliknij pozycję Widok > Makra > Zatrzymaj rejestrowanie.

    Polecenie Zatrzymaj rejestrowanie

Przycisk makra pojawi się na pasku narzędzi Szybki dostęp.

Przycisk makra na pasku narzędzi Szybki dostęp

Aby uruchomić makro, kliknij ten przycisk.

  1. Kliknij pozycję Widok > Makra > Zarejestruj makro.

    Polecenie Zarejestruj makro

  2. Wpisz nazwę makra.

    Pole Nazwa makra

  3. Aby móc korzystać z tego makra we wszystkich nowo tworzonych dokumentach, dla pola Przechowaj makro w ustaw opcję Wszystkie dokumenty (Normal.dotm).

    Pole służące do wyboru miejsca przechowywania makra

  4. Aby makro było uruchamiane po naciśnięciu skrótu klawiaturowego, kliknij pozycję Klawiatura.

    Kliknij, aby przypisać makro do skrótu klawiaturowego

  5. W polu Naciśnij nowy klawisz skrótu wpisz kombinację klawiszy.

  6. Sprawdź, czy ta kombinacja nie jest już przypisana do czegoś innego. Jeśli ta kombinacja jest już przypisana, spróbuj użyć innej kombinacji.

  7. Aby móc korzystać z tego skrótu klawiaturowego we wszystkich nowo tworzonych dokumentach, upewnij się, że dla pola Zapisz zmiany w jest ustawiona opcja Normal.dotm.

  8. Kliknij pozycję Przypisz.

  9. Zarejestruj teraz czynności. Kliknij polecenia lub naciśnij klawisze dla każdej czynności w zadaniu. Program Word zarejestruje te kliknięcia i sekwencje klawiszy.

    Uwaga: Aby zaznaczyć tekst podczas rejestrowania makra, użyj klawiatury. W makrach nie są rejestrowane zaznaczenia wskaźnikiem myszy.

  10. Aby zatrzymać rejestrowanie, kliknij pozycję Widok > Makra > Zatrzymaj rejestrowanie.

    Polecenie Zatrzymaj rejestrowanie

Aby uruchomić makro, naciśnij klawisze skrótu klawiaturowego.

Aby uruchomić makro, kliknij odpowiedni przycisk na pasku narzędzi Szybki dostęp, naciśnij skrót klawiaturowy lub skorzystaj z listy Makra.

  1. Kliknij pozycję Widok > Makra > Wyświetl makra.

    Polecenie Wyświetl makra

  2. Na liście w obszarze Nazwa makra kliknij nazwę makra, które chcesz uruchomić.

  3. Kliknij przycisk Uruchom .

Aby udostępnić makro z jednego dokumentu we wszystkich nowych dokumentach, dodaj je do szablonu Normal.dotm.

  1. Otwórz dokument zawierający makro.

  2. Kliknij pozycję Widok > Makra > Wyświetl makra.

    Polecenie Wyświetl makra

  3. Kliknij przycisk Organizator .

    Przycisk Organizator w oknie Makra

  4. Kliknij makro, które chcesz dodać do szablonu Normal.dotm, a następnie kliknij przycisk Kopiuj.

  1. Kliknij pozycję Plik > Opcje > Dostosowywanie Wstążki.

  2. W obszarze Wybierz polecenia z kliknij pozycję Makra.

  3. Kliknij odpowiednie makro.

  4. W obszarze Dostosowywanie wstążki kliknij kartę i grupę niestandardową, do których chcesz dodać makro.

Jeśli nie masz grupy niestandardowej, kliknij pozycję Nowa grupa. Następnie kliknij pozycję Zmień nazwę i wpisz nazwę grupy niestandardowej.

  1. Kliknij przycisk Dodaj.

  2. Kliknij pozycję Zmień nazwę, aby wybrać obraz makra i wpisać odpowiednią nazwę.

  3. Kliknij przycisk OK dwa razy.

  1. Na karcie Deweloper w grupie Kod kliknij przycisk Makra.

  2. W polu Nazwa makra wpisz nazwę makra.

    Uwaga: Jeśli nowe makro będzie miało taką samą nazwę jak wbudowane makro w programie Word, to nowe akcje makr zastąpią wbudowane makro. Aby wyświetlić listę wbudowanych makr, kliknij pozycję polecenia programu Word na liście makra na liście.

  3. Na liście makra na kliknij szablon lub dokument, w którym chcesz zapisać makro.

    Aby udostępnić makro we wszystkich dokumentach, należy kliknąć pozycję Normal. dotm.

  4. Kliknij pozycję Utwórz , aby otworzyć Edytor Visual Basic.

Po otwarciu edytora Visual Basic możesz chcieć uzyskać więcej informacji na temat pracy z językiem Visual Basic for Applications. Aby uzyskać więcej informacji, kliknij pozycję Microsoft Visual Basic — Pomoc w menu Pomoc lub naciśnij klawisz F1.

Możesz nagrać sekwencję akcji lub można napisać makro od podstaw, wprowadzając w Edytor Visual Basic kod w języku Visual Basic for Applications.

Uwaga: Aby pracować z makrami w Office Word 2007, należy wyświetlić kartę deweloper .

  1. Kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij pozycję Opcje programu Word.

  2. Kliknij pozycję Popularne.

  3. W obszarze najczęściej używane opcje w pracy z programem Wordzaznacz pole wyboru Pokaż kartę Deweloper na Wstążce .

    Uwaga: Wstążka to element udostępniany przez interfejs użytkownika Microsoft Office Fluent.

  1. Na karcie Deweloper w grupie Kod kliknij przycisk Zarejestruj makro.

    Grupa Kod na karcie Deweloper
  2. W polu Nazwa makra wpisz nazwę makra.

    Uwaga: Jeśli nowe makro będzie miało taką samą nazwę jak wbudowane makro w Office Word 2007, to nowe akcje makr zastąpią wbudowane makro. Aby wyświetlić listę wbudowanych makr, na karcie deweloper w grupie kod kliknij przycisk makra. Na liście makra na kliknij pozycję polecenia programu Word.

  3. W polu przechowuj makro w kliknij szablon lub dokument, w którym chcesz zapisać makro.

    Ważne: Aby udostępnić makro we wszystkich dokumentach, należy kliknąć pozycję Normal. dotm.

  4. W polu Opis wpisz opis makra.

  5. Wykonaj jedną z następujących czynności:

    • Rozpocznij nagrywanie    Aby rozpocząć rejestrowanie makra bez przypisywania go do przycisku na pasku narzędzi Szybki dostęp lub do klawisza skrótu, kliknij przycisk OK.

    • Tworzenie przycisku    Aby przypisać makro do przycisku na pasku narzędzi Szybki dostęp, wykonaj następujące czynności:

      1. Kliknij przycisk.

      2. W obszarze Dostosuj pasek narzędzi Szybki dostępZaznacz dokument (lub wszystkie dokumenty), dla którego chcesz dodać makro do paska narzędzi Szybki dostęp.

        Ważne: Aby udostępnić makro we wszystkich dokumentach, należy kliknąć pozycję Normal. dotm.

      3. W oknie dialogowym Wybierz polecenia z kliknij makro, które chcesz nagrać, a następnie kliknij przycisk Dodaj.

      4. Aby dostosować przycisk, kliknij przycisk Modyfikuj.

      5. W obszarze symbolkliknij symbol, którego chcesz użyć jako przycisku.

      6. W polu Nazwa wyświetlana wpisz nazwę makra, które chcesz wyświetlić.

      7. Kliknij dwukrotnie przycisk OK , aby rozpocząć rejestrowanie makra.

        Wybrany symbol zostanie wyświetlony na pasku narzędzi Szybki dostęp. Wpisana nazwa jest wyświetlana po wskazaniu symbolu.

    • Przypisywanie skrótu klawiaturowego    Aby przypisać makro do skrótu klawiaturowego, wykonaj następujące czynności:

      1. Kliknij pozycję Klawiatura.

      2. W polu polecenia kliknij zarejestrowane makro.

      3. W polu naciśnij nowy klawisz skrótu wpisz odpowiednią sekwencję klawiszy, a następnie kliknij przycisk Przydziel.

      4. Kliknij przycisk Zamknij , aby rozpocząć rejestrowanie makra.

  6. Wykonaj czynności, które chcesz uwzględnić w makrze.

    Uwaga: Gdy rejestrujesz makro, możesz kliknąć myszą, aby kliknąć polecenia i opcje, ale nie zaznaczać tekstu. Aby zaznaczyć tekst, należy użyć klawiatury. Aby uzyskać więcej informacji na temat zaznaczania tekstu za pomocą klawiatury, zobacz Zaznaczanie tekstu.

  7. Aby zatrzymać rejestrowanie akcji, kliknij pozycję Zatrzymaj rejestrowanie w grupie kod .

Zmienianie skrótu klawiaturowego makra

  1. Kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij pozycję Opcje programu Word.

  2. Kliknij pozycję Dostosuj.

  3. Obok pozycji skróty klawiaturowekliknij przycisk Dostosuj.

  4. Na liście Kategorie kliknij pozycję makra.

  5. Na liście makra kliknij makro, które chcesz zmienić.

  6. W polu naciśnij nowy klawisz skrótu wpisz kombinację klawiszy, którą chcesz wybrać.

  7. Zaznacz pole bieżące klawisze , aby upewnić się, że nie przypiszesz kombinacji klawiszy, która jest już używana do wykonywania innego zadania.

  8. Na liście Zapisz zmiany w kliknij opcję odpowiadającą miejscu, w którym chcesz uruchomić makro.

    Ważne: Aby udostępnić makro we wszystkich dokumentach, należy kliknąć pozycję Normal. dotm.

  9. Kliknij pozycję Zamknij.

  1. Na karcie Deweloper w grupie Kod kliknij przycisk Makra.

    Grupa Kod na karcie Deweloper

  2. Na liście w obszarze Nazwa makrakliknij makro, które chcesz uruchomić.

  3. Kliknij przycisk Uruchom .

  1. Na karcie Deweloper w grupie Kod kliknij przycisk Makra.

    Grupa Kod na karcie Deweloper

  2. W polu Nazwa makra wpisz nazwę makra.

    Uwaga: Jeśli nowe makro będzie miało taką samą nazwę jak wbudowane makro w Office Word 2007, to nowe akcje makr zastąpią wbudowane makro. Aby wyświetlić listę wbudowanych makr, kliknij pozycję polecenia programu Word na liście makra na liście.

  3. Na liście makra w kliknij szablon lub dokument, w którym chcesz zapisać makro.

    Aby udostępnić makro we wszystkich dokumentach, należy kliknąć pozycję Normal. dotm.

  4. Kliknij pozycję Utwórz , aby otworzyć Edytor Visual Basic.

Po otwarciu edytora Visual Basic możesz chcieć uzyskać więcej informacji na temat pracy z językiem Visual Basic for Applications. Aby uzyskać więcej informacji, kliknij pozycję Microsoft Visual Basic — Pomoc w menu Pomoc lub naciśnij klawisz F1.

Aby szybko pracować nad często wykonywanymi zadaniami, w klasycznej wersji programu Word możesz powiązać te kroki z makrami uruchamianymi jednym kliknięciem. W Word dla sieci Web należy ręcznie przełączać się między tymi zadaniami.

Jeśli masz program Word, najpierw kliknij pozycję Otwórz w programie Word , aby otworzyć dokument w programie Word.

Obraz polecenia Otwórz w programie Word w aplikacji Word Online

Następnie postępuj zgodnie z instrukcjami dla klasycznej wersji programu Word.

Po uruchomieniu makra w programie Word i zapisaniu dokumentu wyniki działania makra będą widoczne po ponownym otwarciu dokumentu w programie Word dla sieci Web.

Uwaga:  Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Czy możesz dać nam znać, czy te informacje były pomocne? Oto angielskojęzyczny artykuł do wglądu.

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×