Symptomy
W Microsoft Office 365 skrzynki pocztowe nie są automatycznie mapowane razem z profilem programu Microsoft Outlook po przeniesieniu skrzynki pocztowej do innego lasu we wdrożeniu hybrydowym.
Przyczyna
Przyczyn może być kilka:
-
Użytkownik używa starszej wersji programu Outlook.
-
Wartości atrybutów usługi Active Directory (AD) nie istnieją, aby włączyć automatyczne mapowanie.
Rozwiązanie
Uwaga Funkcja automatycznego mapowania jest dostępna tylko dla Microsoft Exchange Online użytkowników.
Omówienie automatycznego mapowania
W przypadku wdrożenia nie hybrydowego automatyczne mapowanie jest włączane automatycznie, gdy użytkownik otrzymuje uprawnienia Pełny dostęp do skrzynki pocztowej przy użyciu polecenia cmdlet Add-MailboxPermission lub centrum administracyjnego programu Exchange. Po dodaniu tych uprawnień do użytkownika jest dodawana jedna wartość, a druga do skrzynki pocztowej w celu połączenia obiektów.
-
Skrzynka pocztowa, która ma uprawnienia: msExchDelegateListLink
-
Użytkownik, któremu przyznano uprawnienia: msExchDelegateListBL
Te właściwości można wyświetlać lokalnie za pomocą narzędzia usługi Active Directory, takiego jak LDP lub Edytor interfejsów usługi Active Directory (Edytuj ADSI). Te właściwości nie są wyświetlane jako atrybuty przy użyciu poleceń cmdlet programu Exchange PowerShell.Automatyczne mapowanie można wyłączyć za pomocą parametru AutoMapping w poleceniu cmdlet Add-MailboxPermission . Aby uzyskać więcej informacji na temat parametru Automapping, zobacz Add-MailboxPermission.
Scenariusze automatycznego mapowania hybrydowego
W niektórych scenariuszach hybrydowych do działania automatycznego mapowania są wymagane dodatkowe kroki.Scenariusz 1: Uprawnienia obowiązują przed przeniesieniem użytkownika lub skrzynki pocztowej do chmury Przykład: Jan ma uprawnienia pełnego dostępu do skrzynki pocztowej Sprzedaż. Skrzynka pocztowa Jana jest przenoszona do chmury.Opis: Atrybuty automatycznego mapowania (msExchDelegateListLink/BL) zostaną zsynchronizowane przez Azure synchronizacji usługi Active Directory (AAD Sync) z chmurą przed przeniesieniem. Usługa replikacji skrzynek pocztowych programu Microsoft Exchange (MRS) również przeniesie wszystkie uprawnienia podczas przenoszenia do chmury.Wymóg: Jan musi mieć uruchomiony program Outlook 2013 w wersji 15.0.4719.1002 (maj 2015 r.) lub nowszej. Informacje o aktualizacji programu Outlook są dostępne w programie Outlook Aktualizacje. Scenariusz 2: Uprawnienia są dodawane po przeniesieniu użytkownika lub skrzynki pocztowej do chmury Przykład: Jan jest przenoszony do chmury. Po przeniesieniu żąda uprawnień Pełny dostęp do lokalnej skrzynki pocztowej Sprzedaż.Opis: Uprawnienia zostaną dodane do skrzynki pocztowej lokalnej (Sprzedaż) przy użyciu funkcji Add-MailboxPermissions. Ponieważ Jan jest użytkownikiem poczty w środowisku lokalnym, atrybuty automatycznego mapowania (msExchDelegateListLink/BL) nie zostaną dodane. Wymóg:
-
Te atrybuty muszą zostać ręcznie dodane do lokalnego obiektu użytkownika poczty, który ma zostać zsynchronizowany z chmurą przez AAD Sync. Te atrybuty można ustawić ręcznie przy użyciu parametru Add polecenia cmdlet Set-ADUser w module powershell usługi Active Directory. Aby uzyskać więcej informacji na temat tych atrybutów, zobacz Polecenia cmdlet Set-ADUser i Active Directory w Windows PowerShell.
-
Jan musi mieć zainstalowany program Outlook 2013 w wersji 15.0.4719.1002 (maj 2015) lub nowszej. Informacje o aktualizacji programu Outlook są dostępne w programie Outlook Aktualizacje.
Rozwiązywanie problemów z automatycznym mapowaniem
-
Aby skrzynka pocztowa była automatycznie mapowana w profilu, informacje muszą zostać zwrócone do programu Outlook w formacie XML wykrywania automatycznego. Aby to sprawdzić jako użytkownik, którego dotyczy problem, wykonaj następujące czynności:
-
Uruchom program Outlook, a następnie przytrzymaj naciśnięty klawisz Ctrl, klikając prawym przyciskiem myszy ikonę programu Microsoft Outlook w obszarze powiadomień.
-
Wybierz pozycję Przetestuj autokonfigurację poczty e-mail.
-
Wyczyść opcje Użyj przypuszczenia i bezpiecznego uwierzytelniania przypuszczenia, a następnie kliknij pozycję Testuj.
-
Po zakończeniu testu przejrzyj zawartość karty XML . Zwróć uwagę na wartości zawarte w tagu AlternativeMailbox.<>AlternativeMailbox <Wpisz><pełnomocnika /Typ> <displayname>Sales</DisplayName> <LegacyDN>/o=contoso/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=Sales</LegacyDN> <Server>ServerName</Server> </AlternativeMailbox>
Uwaga Archiwum skrzynki pocztowe będą wyświetlane jako alternatywna skrzynka pocztowa typu Archiwum.
-
-
Jeśli skrzynka pocztowa znajduje się na liście w tagu AlternativeMailbox, upewnij się, że użytkownicy, których dotyczy problem, korzystają z programu Outlook 2013 w wersji 15.0.4719.1002 (maj 2015 r.) lub nowszego. Informacje o aktualizacji programu Outlook są dostępne w programie Outlook Aktualizacje.
-
Jeśli skrzynka pocztowa nie jest wymieniona w tagu AlternativeMailbox, przejrzyj lokalnie właściwości msExchDelegateListLink/BL za pomocą narzędzia, takiego jak LDP lub ADSI Edit.
-
Jeśli właściwości istnieją w obiekcie lokalnym, eskaluj do firmy Microsoft, aby uzyskać pomoc. Podaj następujące informacje w eskalacji:
-
Dane wyjściowe z pomoc techniczna firmy Microsoft i Asystenta odzyskiwania (SaRa) od użytkownika, którego dotyczy problem.
-
Dane wyjściowe z usługi lokalna usługa Active Directory, która wyświetla właściwości msExchDelegateListLink/BL dla użytkownika i skrzynki pocztowej.
-