Symptomy
Podczas próby uruchomienia jednej z gier firmy Microsoft wymienionych w sekcji "dotyczy" jest wyświetlany następujący komunikat o błędzie:
Komunikat o błędzie 1
Nie można odnaleźć pliku d3dx9_25. dll.
Komunikat o błędzie 2
Nie można odnaleźć pliku d3dx9_27. dll.
Przyczyna
Ten problem może wystąpić, jeśli plik programu Microsoft DirectX wymieniony w komunikacie o błędzie jest uszkodzony lub nie został poprawnie skopiowany.
Rozwiązanie
Pobieranie i Instalowanie najnowszej wersji programu DirectX
Aby rozwiązać ten problem, Pobierz i zainstaluj najnowszą wersję Instalatora sieci Web programu DirectX End-User Runtime. W tym celu odwiedź następującą witrynę firmy Microsoft w sieci Web:
http://www.microsoft.com/download/details.aspx?FamilyId=2DA43D38-DB71-4C1B-BC6A-9B6652CD92A3&displaylang=en Uwaga Podczas instalacji może zostać wyświetlony następujący komunikat o błędzie:
Instalowane oprogramowanie nie przeszło testów zgodności z systemem Windows w celu zweryfikowania zgodności z tą wersją systemu Windows. (Powiedz mi, dlaczego te testy są ważne).
Aby uzyskać więcej informacji, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
822798 Nie można zainstalować aktualizacji lub programów
Ręczne skopiowanie pliku
Aby rozwiązać ten problem, skopiuj plik D3dx9_25. dll lub plik D3dx9_27. dll z dysku CD/DVD dodatku gier CD/DVD do odpowiedniego folderu gry. Aby to zrobić, wykonaj odpowiednie czynności dotyczące używanej wersji systemu Windows:
Windows 7 lub Windows Vista
-
Włóż dysk CD/DVD dysku 1 do swojej gry do stacji dysków CD/DVD komputera.
-
Kliknij przycisk Start , a następnie kliknij pozycję dokumenty.
-
Zlokalizuj, a następnie kliknij pozycję komputer.
-
Znajdź i kliknij stację dysków CD/DVD.
-
Zlokalizuj i kliknij następujący folder:
CDDrive:\ DirectX9 Uwaga W tej ścieżce CDDrivereprezentuje literę dysku CD.
-
Kliknij dwukrotnie pozycję Apr2005_d3dx9_25_x86. cab, kliknij prawym przyciskiem myszy pozycję D3dx9_25. dll, a następnie kliknij polecenie Kopiuj.
Uwaga Użyj pliku Apr2005_d3dx9_25_x64. cab dla wersji systemu operacyjnego Windows opartego na procesorze x64.
-
Zlokalizuj następujący folder gry:
Dysk: \Program Files\Microsoft Games \tytuł gry Uwaga W tej ścieżce dyskodpowiada literze dysku, na którym zainstalowano grę, a tytuł gry oznacza grę, którą chcesz naprawić.
-
Kliknij prawym przyciskiem myszy folder gier odpowiadający grze zainstalowanej na komputerze, a następnie kliknij polecenie Wklej. Uwaga Jeśli na komputerze zainstalowano więcej niż jeden gracz, powtórz kroki 7and 8 dla innych gier.
Windows XP
-
Włóż dysk CD/DVD dysku 1 do swojej gry do stacji dysków CD/DVD komputera.
-
Kliknij przycisk Start, wskaż pozycję programy, wskaż pozycję akcesoria, a następnie kliknij pozycję Eksplorator Windows.
-
Zlokalizuj i kliknij następujący folder:
CDDrive:\ DirectX9 Uwaga W tej ścieżce CDDrivereprezentuje literę dysku CD.
-
Kliknij dwukrotnie pozycję Apr2005_d3dx9_25_x86. cab, kliknij prawym przyciskiem myszy pozycję D3dx9_25. dll, a następnie kliknij polecenie Kopiuj.
Uwaga Użyj pliku Apr2005_d3dx9_25_x64. cab dla wersji systemu operacyjnego Microsoft Windows dla komputerów z procesorami x64.
-
Zlokalizuj następujący folder gry:
Dysk: \Program Files\Microsoft Games \tytuł gry
Uwaga W tej ścieżce dysk odpowiada literze dysku, na którym jest zainstalowana gra, a tytuł gry przedstawia grę, którą chcesz naprawić.
-
Kliknij prawym przyciskiem myszy folder gier odpowiadający grze zainstalowanej na komputerze, a następnie kliknij polecenie Wklej. Uwaga Jeśli na komputerze zainstalowano więcej niż jeden gracz, powtórz kroki 5 i 6 dla pozostałych gier.
Następne kroki
Jeśli potrzebujesz dodatkowej pomocy, odwiedź witrynę pomocy technicznej firmy Microsoft w sieci Web, aby znaleźć inne rozwiązania. W tej witrynie sieci Web są dostępne następujące usługi:
-
Społeczność firmy Microsoft (http://answers.Microsoft.com/en-us/Windows/default.aspx): interakcja z użytkownikami równorzędnymi oraz firma Microsoft, która jest najbardziej cennymi specjalistami (specjalistom MVP).
-
Centra rozwiązań (http://support.Microsoft.com/SELECT/?TARGET=Hub): wyświetlanie często zadawanych pytań i pomocy technicznej dotyczącej konkretnych produktów.
-
Wyszukiwanie w bazie wiedzy Knowledge Base (http://support.Microsoft.com/Search/?ADV=1): wyszukiwanie informacji pomocy technicznej i narzędzi do samodzielnej pomocy dla produktów firmy Microsoft.
-
Inne opcje pomocy technicznej (http://support.Microsoft.com/default.aspx?PR=csshome): Zadaj pytanie, skontaktuj się z pomocą techniczną firmy Microsoft lub Przekaż Opinie, korzystając z sieci Web.