Podsumowanie
W tym artykule wyjaśniono, jak używać funkcji korespondencji seryjnej w programie Microsoft Word do tworzenia i drukowania listów seryjnych przy użyciu danych z arkusza programu Microsoft Excel.
Podczas korzystania z funkcji korespondencji seryjnej programu Word program Word scala dokument główny z listą adresatów w celu wygenerowania zestawu dokumentów wyjściowych:
Dokument g³ówny zawiera podstawowy tekst, który jest taki sam we wszystkich dokumentach wyjœciowych. Może zawierać nagłówek listowy, tekst oraz instrukcje w polach scalania dotyczące wstawiania tekstu (na przykład imiona i nazwiska i adresy odbiorców), które różnią się w poszczególnych dokumentach wyjściowych.
Lista adresatów jest bazą danych, która zawiera dane, które mają zostać scalone w dokumentach wyjściowych. Lista adresatów może być na przykład plikiem bazy danych programu Microsoft Access lub arkuszem programu Excel.
Ta baza danych jest zazwyczaj listą imion i nazwisk, adresów, numerów telefonów i innych kategorii informacji osobistych.
Dokumenty wyjœciowe sģ¹ wynikiem procesu generowania korespondencji seryjnej. Tekst mo¿e byæ taki sam we wszystkich dokumentach wyjœciowych, jednak mo¿na zastosowaæ formatowanie w odniesieniu do okreœlonych dokumentów.
Krok 1. Przygotowanie pliku danych programu Excel
Przed uruchomieniem Kreatora korespondencji seryjnej upewnij się, że struktura arkusza programu Excel jest odpowiednia do tego celu. Należy pamiętać o spełnieniu następujących wymagań dotyczących tabeli danych:
- Pierwszy wiersz powinien zawierać nazwy pól dla każdej kolumny, na przykład Tytuł, Zwrot grzecznościowy, Imię, Drugie imię, Nazwisko, Adres1 i Adres2.
- Każda nazwa pola powinna być unikatowa.
- Ka¿dy wiersz powinien zawieraæ informacje dotycz¹ce okreœlonego elementu. Na przykład na liście adresowej każdy wiersz może zawierać informacje o określonym adresacie.
- Tabela nie powinna zawierać pustych wierszy.
Utwórz plik danych programu Excel, a następnie rozmieść go przy użyciu pól, których chcesz użyć w liście, jak pokazano w poniższym przykładowym pliku danych.
Po utworzeniu pliku danych programu Excel zapisz go, a następnie zamknij.
Aby uzyskać więcej informacji dotyczących sposobu tworzenia listy adresów korespondencji seryjnej, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Baza wiedzy Microsoft Knowledge Base:
294688 Jak zaprojektować i skonfigurować listę adresów korespondencji seryjnej w programie Word 2002 i nowszych wersjach Word
Krok 2: Przygotowanie dokumentu g³ównego
W programie Microsoft Office Word 2003 i wcześniejszych wersjach programu Word wskaż polecenie Listy i dokumenty wysyłkowe w menu Narzędzia, a następnie kliknij polecenie Kreator korespondencji seryjnej.
W programie Microsoft Office Word 2007 kliknij przycisk Rozpocznij korespondencję seryjną w grupie Rozpoczynanie korespondencji seryjnej na karcie Korespondencja, a następnie kliknij pozycję Kreator tworzenia korespondencji seryjnej krok po kroku.
W obszarze Wybierz typ dokumentu kliknij pozycję Listy.
Aktywny dokument staje się dokumentem głównym. Dokument główny zawiera tekst i grafikę, które są takie same dla każdej wersji scalonego dokumentu. Na przykład adres zwrotny i zwrot grzecznościowy w liście seryjnym są takie same dla każdej wersji.
Kliknij przycisk Dalej: Dokument początkowy.
Użyj jednej z następujących metod:
Rozpocznij od dokumentu, który jest obecnie wyświetlany w oknie dokumentu. Aby to zrobić, kliknij pozycję Użyj bieżącego dokumentu.
Następnie możesz wpisać literę w oknie dokumentu lub poczekać, aż kreator wyświetli monit o zrobienie tego w kolejnym kroku.
Rozpoczynanie pracy od szablonu. W tym celu wykonaj następujące czynności:
Kliknij przycisk Start w szablonie.
Kliknij Wybierz szablon.
Na karcie Korespondencja seryjna wybierz odpowiedni szablon w oknie dialogowym Wybieranie szablonu, a następnie kliknij przycisk OK.
Rozpocznij od istniejącego dokumentu. W tym celu wykonaj następujące czynności:
- Kliknij przycisk Rozpocznij od istniejącego dokumentu.
- W polu Rozpocznij od istniejącego zaznacz żądany dokument, a następnie kliknij przycisk Otwórz.
- Jeśli dokument nie jest widoczny, kliknij przycisk Więcej plików, a następnie kliknij przycisk Otwórz. W oknie dialogowym Otwieranie zlokalizuj odpowiedni dokument, a następnie kliknij przycisk Otwórz.
Kliknij pozycję Następny: Wybierz adresatów.
Krok 3. Określanie źródła danych programu Excel
W obszarze Wybierz adresatów kliknij pozycję Użyj istniejącej listy.
Kliknij pozycję Przeglądaj.
W oknie dialogowym Wybieranie źródła danych zlokalizuj, a następnie kliknij arkusz programu Excel, którego chcesz użyć.
Domyślnie program Word otwiera folder "Moje źródła danych".
Kliknij przycisk Otwórz.
Jeśli arkusz programu Excel zawiera informacje na temat kilku kart, wybierz kartę zawierającą żądane informacje, a następnie kliknij przycisk OK.
Wszystkie wpisy w źródle danych zostaną wyświetlone w oknie dialogowym Adresaci korespondencji seryjnej. W tym miejscu możesz uściślić listę adresatów do uwzględnienia w korespondencji seryjnej.
Krok 4. Wybieranie adresatów
W oknie dialogowym Adresaci korespondencji seryjnej wybierz adresatów, których chcesz uwzględnić. Aby to zrobić, zastosuj jedną z następujących metod:
Użycie pól wyboru do wyznaczenia adresatów.
Ta metoda jest użyteczna, gdy lista jest krótka. Kliknij, aby zaznaczyć pola wyboru obok adresatów, których chcesz uwzględnić, a następnie wyczyść pola wyboru obok adresatów, których chcesz wykluczyć.
Uwaga Aby uwzględnić większość rekordów listy podczas scalania, należy kliknąć przycisk Zaznacz wszystko, a następnie kliknąć, aby wyczyścić określone rekordy. Podobnie, jeśli chcesz uwzględnić tylko kilka rekordów listy, kliknij przycisk Wyczyść wszystko, a następnie zaznacz odpowiednie rekordy.
Sortowanie elementów na liście.
Ta metoda jest użyteczna, jeśli elementy mają być wyświetlane w kolejności alfabetycznej lub numerycznej. Kliknij nagłówek kolumny elementu, według którego chcesz sortować zawartość. Jeśli na przykład chcesz wyświetlić listę alfabetycznie według nazwisk, kliknij nagłówek kolumny Nazwisko.
Filtrowanie elementów listy.
Ta metoda jest użyteczna, jeśli lista zawiera rekordy, których nie chcesz wyświetlać ani uwzględniać przy tworzeniu korespondencji seryjnej. Po przefiltrowaniu listy możesz uwzględnić lub wykluczyć rekordy za pomocą ich pól wyboru w sposób opisany wcześniej. Aby filtrować listę, wykonaj następujące czynności:
Kliknij strzałkę obok nagłówka kolumny elementu, według którego chcesz filtrować.
Kliknij dowolną z następujących opcji:
- (Puste): Ta opcja powoduje wyświetlanie wszystkich rekordów, w których odpowiednie pole jest puste.
- (Niepuste): Ta opcja powoduje wyświetlenie wszystkich rekordów, w których odpowiednie pole zawiera informacje.
- Jeśli źródło danych zawiera rekordy, w których znajdują się te same informacje, a kolumna zawiera najwyżej 10 unikatowych wartości, możesz filtrować dane według konkretnych informacji. Na przykład, jeśli istnieje wiele adresów z krajem Australia, możesz filtrować według Australii.
W oknie dialogowym Adresaci korespondencji seryjnej zostaną wyświetlone tylko wskazane rekordy. Aby wyświetlić ponownie wszystkie rekordy, kliknij pozycję (Wszystkie).
Notatki
- Aby skorzystać z zaawansowanego sortowania i filtrowania, kliknij strzałkę obok nazwy kolumny, a następnie kliknij pozycję (Zaawansowane). Karty Filtrowanie rekordów i Sortowanie rekordów umożliwiają skonfigurowanie odpowiedniej kwerendy sortującej lub filtrującej.
- Jeśli zainstalowano oprogramowanie do sprawdzania poprawności adresów, kliknij przycisk Sprawdź poprawność w oknie dialogowym Adresaci korespondencji seryjnej, aby sprawdzić poprawność adresów odbiorców.
Kliknij przycisk OK, aby wrócić do Kreatora korespondencji seryjnej.
Program Word użyje adresatów wyznaczonych do scalania.
Kliknij przycisk Dalej: Napisz list.
Krok 5. Wypełnianie listu i dodawanie pól korespondencji seryjnej
Jeśli jeszcze tego nie zrobiono, wpisz tekst, który ma być widoczny w każdym liście seryjnym w dokumencie głównym.
Wstawianie pól korespondencji seryjnej
Wstaw pola scalania w lokalizacjach, w których chcesz scalić imiona i nazwiska, adresy oraz inne informacje ze źródła danych. Aby wstawić pola korespondencji seryjnej, wykonaj następujące czynności:
Kliknij w dokumencie g³ównym w miejscu, w którym chcesz wstawiæ pole.
Wstaw dowolne z następujących pól:
Blok adresu z imieniem i nazwiskiem, adresem oraz innymi informacjami:
Kliknij pozycję Blok adresu.
W oknie dialogowym Wstawianie bloku adresu zaznacz odpowiednie elementy adresu i formaty, a następnie kliknij przycisk OK. Aby wyœwietliæ Pomoc dotycz¹c¹ opcji, kliknij znak zapytania, a nastêpnie kliknij opcjê.
Aby wyœwietliæ Pomoc dotycz¹c¹ opcji, kliknij znak zapytania, a nastêpnie kliknij opcjê. Jeśli zostanie wyświetlone okno dialogowe Dopasowywanie pól, będzie to prawdopodobnie oznaczało, że program Word nie może odnaleźć części informacji wymaganych dla bloku adresu. Kliknij strzałkę obok pozycji
(niedostępne), a następnie ze źródła danych wybierz pole zgodne z polem wymaganym do korespondencji seryjnej.
Wiersz pozdrowienia:
Kliknij pozycję Wiersz pozdrowienia.
Wybierz format wiersza pozdrowienia zawierający zwrot grzecznoœciowy, format nazwiska i znaki interpunkcyjne.
Zaznacz tekst, który ma być wyświetlany w przypadkach, gdy program Word nie może zinterpretować nazwy adresata. Na przykład program Word nie może zinterpretować nazwy, jeśli źródło danych nie zawiera imienia ani nazwiska adresata, a jedynie nazwę firmy.
Kliknij przycisk OK.
Jeśli zostanie wyświetlone okno dialogowe Dopasowywanie pól, program Word może nie być w stanie odnaleźć części informacji wymaganych dla wiersza pozdrowienia. Kliknij strzałkę obok pozycji (niedostępne), a następnie wybierz pole ze źródła danych zgodne z polem wymaganym do korespondencji seryjnej.
Inne pola z informacjami:
Kliknij pozycję Więcej elementów.
Użyj jednej z następujących metod:
- Kliknij pozycję Pola adresu, aby wybrać pola adresu, które zostaną automatycznie zamapowane na odpowiadające im pola w źródle danych, nawet jeśli pola źródła danych mają inne nazwy niż pola użytkownika.
- Kliknij pozycję Pola bazy danych, aby wybrać pola, które zawsze pobierają dane bezpośrednio z kolumny w bazie danych.
W oknie dialogowym Pola kliknij wybrane pole.
Kliknij przycisk Wstaw, a następnie kliknij przycisk Zamknij.
Jeśli zostanie wyświetlone okno dialogowe Dopasowywanie pól, program Word może nie być w stanie znaleźć niektórych informacji potrzebnych do wstawienia pola. Kliknij strzałkę obok pozycji (niedostępne), a następnie ze źródła danych wybierz pole odpowiadające polu wymaganemu w korespondencji seryjnej.
Uwaga Jeśli zostanie wstawione pole z listy Pola bazy danych, a następnie nastąpi przełączenie do źródła danych, które nie zawiera kolumny o tej samej nazwie, program Word nie będzie mógł wstawić informacji z tego pola do scalonego dokumentu.
Elektroniczna op³ata pocztowa:
Aby dodaæ elektroniczn¹ op³atê pocztow¹, nale¿y najpierw zainstalowaæ odpowiedni program, który mo¿na zakupiæ u innego dostawcy w sieci Web. Aby skorzystaæ z elektronicznej op³aty pocztowej, wykonaj nastêpuj¹ce kroki:
Kliknij przycisk Elektroniczna opłata pocztowa.
Jeśli nie masz zainstalowanego programu do obsługi elektronicznej opłaty pocztowej, w programie Word zostanie wyświetlony monit o zainstalowanie takiego programu, umożliwiający połączenie się z następującą witryną pakietu Microsoft Office w sieci Web:
Drukuj w trybie online
http://office.microsoft.com/services/service.aspx?sid=2.4Włóż opłatę pocztową zgodnie z instrukcjami programu.
Aby dodaæ elektroniczn¹ op³atê pocztow¹, nale¿y najpierw zainstalowaæ odpowiedni program, który mo¿na zakupiæ u innego dostawcy w sieci Web. Aby skorzystaæ z elektronicznej op³aty pocztowej, wykonaj nastêpuj¹ce kroki:Pocztowy kod kreskowy: Nale¿y wybraæ list lub typ koperty zgodny z kodem kreskowym POSTNET. Aby użyć pocztowego kodu kreskowego, wykonaj następujące kroki:
Kliknij Pocztowy kod kreskowy.
W oknie dialogowym Wstawianie pocztowego kodu kreskowego wybierz odpowiednie pola adresu.
Uwaga Opcja Pocztowy kod kreskowy pojawia się tylko wówczas, gdy używana jest wersja programu Word w języku amerykańskim.
Powtórz kroki a i b dla wszystkich pól, które chcesz wstawić. UWAGI:
- Nie można wpisywać znaków pól scalania (" ") ani wstawiać ich przy użyciu polecenia Symbol z menu Wstaw.
- Jeśli pola korespondencji seryjnej są wyświetlane wewnątrz nawiasów, na przykład { MERGEFIELD Miejscowość }, program Word wyświetla kody pól zamiast wyników pól. Nie wpływa to na scalanie, lecz jeśli wolisz wyświetlać wyniki zamiast kodów, kliknij kod pola prawym przyciskiem myszy, a następnie w menu skrótów kliknij polecenie Przełącz kody pól.
Na przykład korzystając z przedstawionej wcześniej przykładowej bazy danych, list może zawierać pola Blok adresu i WierszPowitania, dlatego pierwsza strona będzie wyglądać podobnie do następującej:
26 lutego 2002 r.Blok adresów
GreetingLine (Wiersz pozdrowienia)
Wpisz tutaj swój list.
Z poważaniem
Wpisz tutaj swoje imię i nazwisko
Uwaga Pasek narzędzi korespondencji seryjnej umożliwia również wstawianie pól korespondencji seryjnej, pracę z dokumentem głównym korespondencji seryjnej lub uruchamianie korespondencji seryjnej. Aby wyświetlić pasek narzędzi korespondencji seryjnej, wskaż polecenie Listy i korespondencja w menu Narzędzia, a następnie kliknij polecenie Pokaż pasek narzędzi korespondencji seryjnej.
Pasek narzędzi Korespondencja seryjna udostępnia dodatkowe polecenia, które nie są dostępne w okienkach zadań Kreatora korespondencji seryjnej. Możesz na przykład użyć menu Wstaw pole programu Word na pasku narzędzi korespondencji seryjnej, aby wstawić pola programu Word w celu sterowania procesem scalania. Można na przykład wstawić pole JEŻELI, które wstawia tekst tylko wtedy, gdy określone pole korespondencji seryjnej ma określoną wartość.
Możesz także kliknąć polecenie Sprawdź błędy, aby program Word uruchomił korespondencję seryjną i zgłosił wszystkie błędy zawarte w dokumencie głównym.
Zmienianie formatu scalanych danych
Aby sformatowaæ scalone dane, nale¿y sformatowaæ pola scalania w dokumencie g³ównym. Nie wolno formatować danych w źródle danych, ponieważ jego formatowanie nie jest zachowywane podczas scalania danych w dokumencie. Aby zmienić format scalanych danych, wykonaj następujące kroki:
W dokumencie g³ównym wybierz pole zawieraj¹ce informacje, które chcesz sformatowaæ, z dotycz¹cymi znakami pól scalania (<<>>).
W programie Word 2003 i wcześniejszych wersjach programu Word kliknij polecenie Czcionka w menu Format, a następnie wybierz odpowiednie opcje.
W programie Word 2007 kliknij odpowiednią opcję w polu Czcionki motywu w grupie Czcionka na karcie Narzędzia główne.
Formatowanie przy u¿yciu kodów pól
Aby sterować innymi aspektami formatowania, należy nacisnąć klawisze ALT+F9 w celu wyświetlenia kodów pól, a następnie dodać przełączniki do pól korespondencji seryjnej. W przypadku pracy z polami przełącznik to specjalna instrukcja powodująca wykonanie określonej akcji. Ogólnie rzecz biorąc, do pola dodawany jest przełącznik służący do modyfikowania wyniku.
Oto przykłady zastosowania przełączników:
- Aby wyświetlić liczbę 34987,89 jako 34 987,89 zł, dodaj przełącznik formatu numerycznego (\#).
- Aby drukować nazwy klientów wielkimi literami, dodaj przełącznik formatu (\*).
- Aby upewnić się, że w przypadku scalonych informacji zastosowano tę samą czcionkę i rozmiar w punktach, co w przypadku pola korespondencji seryjnej, dodaj przełącznik Charformat (\*).
Krok 6. Zapisywanie dokumentu
Po zakończeniu tworzenia dokumentu głównego i wstawieniu wszystkich pól korespondencji seryjnej zapisz dokument przed kontynuowaniem. W tym celu wykonaj następujące czynności:
W programie Word 2003 i wcześniejszych wersjach programu Word kliknij polecenie Zapisz jako w menu Plik.
W programie Word 2007 kliknij przycisk pakietu Microsoft Office, a następnie kliknij polecenie Zapisz jako.
Nadaj dokumentowi nazwę, a następnie kliknij przycisk Zapisz.
Kliknij pozycję Dalej: Podgląd listów.
Krok 7. Wyświetlanie podglądu listów i Fine-Tune listy adresatów
Gdy kreator wyświetli okienko zadań "Krok 5 korespondencji seryjnej", kreator zastąpi każde z pól korespondencji seryjnej w dokumencie głównym, które zawiera rzeczywisty tekst z pierwszego wpisu listy adresatów. Dzięki temu możesz zobaczyć, jak będzie wyglądał Twój pierwszy dokument wyjściowy.
Jeśli na przykład chcesz nadal korzystać z przedstawionej wcześniej przykładowej bazy danych, pierwsza strona powinna przypominać następną, którą przedstawiono po kliknięciu przycisku Dalej: Wyświetlanie podglądu listów:
26 lutego 2002 r.
Andrzeja Fullera
908 W. Capital Way
Tacoma 98401
Szanowny Panie Andrzeju Fuller,
Wpisz tutaj swój list.
Z poważaniem
Wpisz tutaj swoje imię i nazwisko Aby wyświetlić podgląd dodatkowych pozycji, użyj jednej z następujących metod:
- Aby wyświetlić podgląd elementów w odpowiedniej kolejności, kliknij przycisk ze strzałkami w lewo lub w prawo.
- Aby zlokalizować określony element i wyświetlić jego podgląd, kliknij przycisk Znajdź adresata, a następnie wprowadź kryteria wyszukiwania w oknie dialogowym Znajdowanie pozycji.
Jeśli chcesz, dostosuj listę adresatów. Aby to zrobić, zastosuj jedną z następujących metod:
- Aby wykluczyć konkretnego adresata z operacji scalania, kliknij opcję Wyklucz tego adresata.
- Aby zmienić listę adresatów, kliknij pozycję Edytuj listę adresatów, a następnie wprowadź odpowiednie zmiany w oknie dialogowym Adresaci korespondencji seryjnej.
Krok 8. Kończenie scalania
Aby ukończyć scalanie, użyj dowolnej z następujących metod.
Personalizowanie poszczególnych liter
Aby spersonalizować poszczególne elementy, należy zakończyć korespondencję seryjną, a następnie edytować odpowiednie informacje w powstałym scalonym dokumencie. W tym celu wykonaj następujące czynności:
Kliknij pozycję Edytuj poszczególne litery.
W oknie dialogowym Scal z nowym dokumentem wybierz rekordy, które chcesz scalić.
Kliknij przycisk OK.
Program Word utworzy i otworzy nowy scalony dokument. Dokument główny również pozostaje otwarty, więc w razie potrzeby można zmienić wszystkie dokumenty z powrotem do tego dokumentu.
Przewiń do informacji, które chcesz edytować, a następnie wprowadź zmiany.
Wydrukuj lub zapisz dokument, tak jak w przypadku ka¿dego zwyk³ego dokumentu.
Drukowanie listów
Aby wydrukować listy, użyj jednej z następujących metod:
Jeśli elementy zostały spersonalizowane, a scalony dokument jest aktywny, wykonaj następujące kroki:
W programie Word 2003 i wcześniejszych wersjach programu Word kliknij polecenie Drukuj w menu Plik.
W programie Word 2007 kliknij przycisk pakietu Microsoft Office, a następnie kliknij polecenie Drukuj.
Wybierz odpowiednie opcje.
Jeśli chcesz drukować bezpośrednio z Kreatora korespondencji seryjnej, wykonaj następujące czynności:
W kroku 6 Kreatora korespondencji seryjnej (Kończenie scalania) kliknij przycisk Drukuj.
W oknie dialogowym Scalanie na drukarkę użyj jednej z następujących metod, a następnie kliknij przycisk OK:
- Aby wydrukować wszystkie dokumenty, kliknij opcję Wszystkie.
- Aby wydrukować dokument widoczny w oknie dokumentu, kliknij opcję Bieżący rekord.
- Aby wydrukować zakres dokumentów, kliknij opcję Od, a następnie wpisz numery rekordów w polach Od i Do.
W oknie dialogowym Drukowanie wybierz odpowiednie opcje.
Zapisywanie scalonych listów w celu późniejszego użycia
Jeśli chcesz edytować scalone listy lub zapisać je do późniejszego użytku, możesz je zebrać w jeden dokument. W tym celu wykonaj następujące czynności:
Kliknij pozycję Edytuj poszczególne litery.
W oknie dialogowym Scalanie z nowym dokumentem zastosuj jedną z następujących metod, a następnie kliknij przycisk OK:
- Aby scalić wszystkie dokumenty, kliknij opcję Wszystkie.
- Aby scalić tylko dokument widoczny w oknie dokumentu, kliknij opcję Bieżący rekord.
- Aby scalić zakres dokumentów, kliknij pozycję Od, a następnie wpisz numery rekordów w polach Od i Do.
Program Word otworzy pojedynczy nowy dokument zawierający wszystkie pojedyncze litery. Nastêpnie mo¿na zapisaæ dokument w celu ponownego wykorzystania, podobnie jak ka¿dy zwyk³y dokument.
Źródła informacji
Aby uzyskać więcej informacji, kliknij następujące numery artykułów w celu wyświetlenia tych artykułów z bazy wiedzy Baza wiedzy Microsoft Knowledge Base:
318117 Jak używać adresów z arkusza programu Excel do tworzenia etykiet w programie Word
318115 Jak utworzyć list seryjny przy użyciu informacji z bazy danych programu Access w programie Word 2002
318112 Jak używać adresów z bazy danych programu Access 2002 do tworzenia etykiet w programie Word 2002
294686 Jak używać korespondencji seryjnej do tworzenia listy sortowanej według kategorii w Word 2002 i nowszych wersjach Word
290408 Często zadawane pytania dotyczące korespondencji seryjnej w programie Word 2002
294688 Jak zaprojektować i skonfigurować listę adresów korespondencji seryjnej w programie Word 2002 i nowszych wersjach Word
294693 Jak używać korespondencji seryjnej do tworzenia katalogu w Word 2002 i nowszych wersjach Word
294683 Jak używać korespondencji seryjnej do tworzenia listów seryjnych w Word 2002 i nowszych wersjach Word