Przejdź do głównej zawartości
Pomoc techniczna
Zaloguj się przy użyciu konta Microsoft
Zaloguj się lub utwórz konto.
Witaj,
Wybierz inne konto.
Masz wiele kont
Wybierz konto, za pomocą którego chcesz się zalogować.

Ten artykuł dotyczy systemu Microsoft Dynamics NAV 5.0 dla wszystkich krajów i ustawień regionalnych języka.

Objawy

Po otwarciu programu Microsoft Dynamics NAV 4. x bazy danych w programie Microsoft Dynamics NAV 5. x, pojawi się komunikat o błędzie podobny do następującego komunikat o błędzie:

Nie masz uprawnień do modyfikowania tabeli Nazwa_tabeli .

Uwaga Symbol zastępczy TableName reprezentuje nazwę tabeli.

Ten problem występuje, jeśli są spełnione następujące warunki:

  • Klastrowany klucz podstawowy jest zmieniana Tak dla wszystkich tabel.

  • Baza danych jest uaktualniany do systemu Microsoft Dynamics NAV 5.0.

Przyczyna

Ten problem występuje, ponieważ baza danych zawiera obiekty, dla których bieżącej licencji nie ma uprawnień.

Obejście problemu

Aby obejść ten problem, wykonaj następujące kroki:

  1. Zrób kopię zapasową systemu Microsoft Dynamics NAV 4. Baza danych x .

  2. Utwórz nową bazę danych w programie Microsoft Dynamics NAV 5. x.

  3. Przywracanie kopii zapasowej.

Rozwiązanie

Obsługiwana poprawka jest obecnie udostępniana przez firmę Microsoft. Ta poprawka rozwiązuje problem opisany w tym artykule. Tylko w systemach, w których występuje ten problem, należy zastosować poprawkę.

Aby natychmiast rozwiązać ten problem, skontaktuj się z pomocy technicznej dla Microsoft Dynamics i produktów powiązanych w celu uzyskania poprawki. Możesz zalogować się w witrynie Microsoft Dynamics i utworzyć nowe żądanie pomocy technicznej. Aby to zrobić, odwiedź następującą witrynę firmy Microsoft w sieci Web:

https://mbs.microsoft.com/support/newstart.aspxUdzieli pomocy technicznej dotyczącej systemu Microsoft Dynamics i produktów powiązanych telefonicznie pod (888) 477-7877.

Uwaga W wyjątkowych przypadkach opłaty, telefonujący do pomocy technicznej mogą zostać anulowane, jeśli pomocy technicznej dla systemu Microsoft Dynamics i produktów powiązanych Określa, że określonej aktualizacji, można rozwiązać swój problem. Koszty obsługi zwykłych zastosuje się do wszelkich dodatkowych pytań i problemów, których nie można rozwiązać przy użyciu określonej aktualizacji.

Wymagania wstępne

Należy zainstalować tę poprawkę Microsoft Dynamics NAV 4.0.

Informacje dotyczące usuwania

Nie można usunąć tej poprawki.

Wymagania dotyczące ponownego uruchomienia

Nie musisz ponownie uruchomiać komputera po zastosowaniu tej poprawki.

Jak uzyskać poprawkę systemu Microsoft Dynamics NAV lub Aktualizuj moje pliki

Po zażądasz pomocy technicznej dotyczącej systemu Microsoft Dynamics o plik aktualizacji lub poprawek systemu Microsoft Dynamics NAV, hiperłącza będą wysyłane do Ciebie w wiadomości e-mail.


Wiadomość e-mail będzie zawierać hiperłącze i hasło. Hiperłącze można użyć do pobrania plików aktualizacji lub poprawek systemu Microsoft Dynamics NAV. Po kliknięciu hiperłącza zostanie otwarte okno dialogowe Pobieranie pliku — ostrzeżenie o zabezpieczeniach . Następnie monit, aby uruchomić, zapisać lub anulować pobieranie.


Jeśli klikniesz przycisk Uruchom, pliki rozpocznie się pobieranie i wyodrębnianie. Musisz określić folder dla nowych plików, a następnie podaj hasło.


Jeśli klikniesz przycisk Zapisz, należy określić ścieżkę do zapisania pliku skompresowanego. Po otwarciu zapisanego pliku są pojawi się monit, aby określić ścieżkę dla plików. Następnie należy podać hasło przesłane w wiadomości e-mail.


Jeśli klikniesz przycisk Anuluj, proces pobierania zostanie przerwany.

Jak zainstalować plik aktualizacji lub poprawek systemu Microsoft Dynamics NAV


Aktualizacje i poprawki dla systemu Microsoft Dynamics NAV są udostępniane jako pojedyncze pliki. Aby zainstalować aktualizacji lub poprawek systemu Microsoft Dynamics NAV, należy zastąpić istniejące pliki instalacji systemu Microsoft Dynamics NAV z poprawki lub aktualizacji plików. Aby to zrobić, wykonaj następujące kroki.



Jeśli masz zainstalowany program Microsoft Dynamics NAV aplikacji Server musi zastępuje następujące pliki instalacji serwera aplikacji Microsoft Dynamics NAV.

Nazwa pliku

Wersja pliku

Rozmiar pliku

Data

Godzina

Platforma

Fin.exe

5.0.24632.0

10,737,104

23-May-2007

01:30

x86

Finsql.exe

5.0.24632.0

10,794,448

23-May-2007

01:30

x86

Aby zastąpić te pliki, wykonaj następujące kroki:

  1. Zatrzymaj wszystkie działania systemu Microsoft Dynamics NAV.

  2. Zlokalizuj katalog instalacji sterownika Microsoft Dynamics NAV otwarte Database Connectivity (ODBC). Sterownik ODBC systemu Microsoft Dynamics NAV jest zazwyczaj instalowany w następującym katalogu:

    C:\Program Files\Common Files\Navision\NODBC\

  3. Skopiuj pliki, które można pobrać.

  4. Wklej pliki pobrane do katalogu instalacji sterownika ODBC systemu Microsoft Dynamics NAV.

  5. Kliknij przycisk Tak, Aby zastąpić pliki w katalogu.

Stan

Firma Microsoft potwierdziła, że jest to usterka występująca w produktach firmy Microsoft wymienionych w sekcji "Dotyczy".

Więcej informacji

Aby uzyskać więcej informacji, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:

824684 Opis standardowej terminologii używanej do opisywania Microsoft

Potrzebujesz dalszej pomocy?

Chcesz uzyskać więcej opcji?

Poznaj korzyści z subskrypcji, przeglądaj kursy szkoleniowe, dowiedz się, jak zabezpieczyć urządzenie i nie tylko.

Społeczności pomagają zadawać i odpowiadać na pytania, przekazywać opinie i słuchać ekspertów z bogatą wiedzą.

Czy te informacje były pomocne?

Jaka jest jakość języka?
Co wpłynęło na Twoje wrażenia?
Jeśli naciśniesz pozycję „Wyślij”, Twoja opinia zostanie użyta do ulepszania produktów i usług firmy Microsoft. Twój administrator IT będzie mógł gromadzić te dane. Oświadczenie o ochronie prywatności.

Dziękujemy za opinię!

×