Przejdź do głównej zawartości
Pomoc techniczna
Zaloguj się przy użyciu konta Microsoft
Zaloguj się lub utwórz konto.
Witaj,
Wybierz inne konto.
Masz wiele kont
Wybierz konto, za pomocą którego chcesz się zalogować.

Objawy

Podczas próby uruchomienia systemu Microsoft Dynamics SL, program nie uruchamia się. Zamiast tego wyświetlany jest następujący komunikat o błędzie.

Komunikat systemowy 9827 - brak jest niespójność między identyfikatory logowania programu SQL Server i ich haseł przechowywanych w bazie danych systemu Salomona. Poproś administratora systemu, uruchom konserwacji bazy danych i zaktualizować bazę danych przy użyciu scenariusza aktualizacji zsynchronizować wszystkie prawa własności i zabezpieczenia.


Przyczyna

Ten problem występuje, jeśli spełniony jest jeden z następujących warunków:

  • Plik Capicom.dll nie jest zarejestrowany. Patrz metoda 1 w sekcji "Rozwiązanie".

  • Wersja bazy danych i wersję produktu są niezgodne. Ten problem może wystąpić, jeśli pliki programów Microsoft Dynamics SL nie zostały zaktualizowane do wersji zgodnej z wersją bazy danych. Na przykład możesz spróbować umożliwia dostęp do bazy danych, który został utworzony podczas korzystania z systemu Microsoft Business Solutions - 6.0 Salomona pliki programów Microsoft Salomona 6.0 z dodatkiem Service Pack 1 (SP1). Patrz: metoda 2 w sekcji "Rozwiązanie".

  • Master60SP ID użytkownika SQL i nie CD7359B5576446f85EB67E824B4770, nie jest zsynchronizowany z wzorca identyfikator użytkownika w bazie danych systemu Microsoft Salomona 6.0 z dodatkiem Service Pack 1 (SP1). Patrz metoda 3 w sekcji "Rozwiązanie".

  • Bazy danych Microsoft Dynamics SL zostały przeniesione do nowego serwera, ale plik Solomon.ini nadal wskazuje starego serwera. Patrz: metoda 4 w sekcji "Rozwiązanie".

  • Bazy danych Microsoft Dynamics SL są w trybie pojedynczego użytkownika. Patrz: metoda 5 w sekcji "Rozwiązanie".

  • Protokół nazwanych potoków nie jest pierwszym protokołem, który jest wymieniony w Client Network Utility. Ten problem występuje po zalogowaniu się do dodatku Service Pack 1 dla systemu Microsoft Dynamics SL 6.5. Patrz: metoda 6 w sekcji "Rozwiązanie".

  • W pełni kwalifikowaną domeny nazwy (FQDN) jest używany dla serwera, na którym jest uruchomiony program Microsoft SQL Server. Patrz: Metoda 7 w sekcji "Rozwiązanie".

  • Zasady haseł jest wymuszany przeciwko CD7359B5576446f85EB67E824B4770 SQL Identyfikatora konta. Patrz: metoda 8 w sekcji "Rozwiązanie".

  • Możesz zalogować się przy użyciu konta użytkownika domeny systemu Windows, która nie jest skojarzona z kontem użytkownika systemu Microsoft Dynamics SL. Patrz: metoda 9 w sekcji "Rozwiązanie".

  • Tabela domeny zawiera adres IP w polu nazwa_serwera, ale plik Solomon.ini zawiera rzeczywista nazwa serwera (za pomocą znaków). Patrz: metoda 10 w sekcji "Rozwiązanie".

Rozwiązanie

Aby rozwiązać ten problem, użyj odpowiedniej metody.

Metoda 1: Ręcznie zarejestrować plik Capicom.dll. Aby to zrobić, wykonaj następujące kroki:

Uwaga To rozwiązanie nie ma zastosowania do Microsoft Dynamics SL 2011

  1. Zlokalizuj, a następnie otwórz Windows\System32 folder.

  2. Kliknij prawym przyciskiem myszy plik Capicom.dll, a następnie kliknij przycisk Otwórz za pomocą.

  3. W oknie dialogowym systemu Windows kliknij przycisk Wybierz program z listy, a następnie kliknij przycisk OK.

  4. W oknie dialogowym Otwórz za pomocą kliknij przycisk Przeglądaj. Zlokalizuj, a następnie otwórz Windows\System32 folder.

  5. Kliknij dwukrotnie plik Regsvr32.exe, a następnie kliknij przycisk OK. Pojawi się następujący komunikat:

    RegSvr32 - funkcja DllRegisterServer w C:\windows\system32\capicom.dll się.

  6. Kliknij przycisk OK.

Powtórz te kroki na każdym komputerze, na którym zostanie wyświetlony komunikat o błędzie wymieniony w sekcji "Symptomy".

Metoda 2: Sprawdź, czy baza danych i pliki programów mają ten sam numer wersji. Aby to zrobić, wykonaj następujące kroki:

  1. Aby znaleźć wersji bazy danych, uruchom następującą kwerendę w bazie danych aplikacji w programie SQL Query Analyzer.

    SELECT S4Future01 FROM GLSetup
  2. Aby znaleźć wersji plików programu, wykonaj następujące kroki:

    1. Uruchom system Microsoft Dynamics SL.

    2. W oknie dialogowym logowania (98.000.00) kliknij dwukrotnie pusty obszar, który jest bezpośrednio powyżej przycisku Anuluj . Pojawi się okno dialogowe logować .

    3. Uwaga: wersja produktu i numer kompilacji jądra.

    4. Zlokalizuj wersję produktu i numer na liście, które znajdują się w następującym artykule bazy wiedzy Knowledge Base kompilacji jądra:uzyskać więcej informacji dotyczących wersji produktu i kompilacji jądra, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:

      Jak ustalić, wersja, wydanie lub jądra kompilacji Salomona 850447

    5. Sprawdź, czy wersja bazy danych zanotowaną w kroku 1 odpowiada zanotowaną w kroku 2c wersja produktu.

Jeśli masz nieprawidłową wersję programu Microsoft Dynamics SL zainstalowane, należy zainstalować poprawną wersję programu. Alternatywnie można uaktualnić bazy danych do wersji Microsoft Dynamics SL, który został zainstalowany.

Metoda 3: Usuń użytkownika SQL identyfikatory Master60SP i CD7359B5576446f85EB67E824B4770 i mieć Microsoft Dynamics SL, utwórz je ponownie. Aby to zrobić, wykonaj następujące kroki:

  1. Uruchom program SQL Query Analyzer, a następnie uruchom następującą instrukcję wobec wszystkich baz danych systemu Microsoft Dynamics SL.

    sp_changedbowner sa
  2. Uruchom program SQL Server Enterprise Manager.

  3. Rozwiń węzeł Microsoft SQL Servers.

  4. Rozwiń Grupę serwerów SQL.

  5. Rozwiń wystąpienie programu SQL Server.

  6. Rozwiń węzeł Zabezpieczenia.

  7. Kliknij dwukrotnie logowania.

  8. Kliknij prawym przyciskiem myszy Master60Sp (Master80 w systemie Dynamics SL 2011), a następnie kliknij przycisk Usuń.

  9. Kliknij prawym przyciskiem myszy CD7359B5576446f85EB67E824B4770 (CD8359B5576446f85EB67E824B4770 w systemie Dynamics SL 2011), a następnie kliknij przycisk Usuń.

  10. Zamknij Menedżera przedsiębiorstwa.

  11. Użyj konserwacji bazy danych, aby połączyć się z serwerem, na którym jest uruchomiony program Microsoft SQL Server. Aby to zrobić, wykonaj następujące kroki:

    1. Otwórz okno dialogowe Konserwacji bazy danych (98.290.00) .

    2. W polu Nazwa docelowego SQL Server wpisz nazwę serwera.

    3. W polu ID logowania wpisz sa.

    4. W polu hasło wpisz hasło dla użytkownika administrator systemu.

    5. Kliknij przycisk Połącz.

  12. Kliknij kartę Aktualizacja bazy danych .

  13. W polu Nazwa bazy danych kliknij bazę danych systemu.

  14. W kolumnie bazy danych zaznacz bazę danych aplikacji.

  15. W obszarze Scenariuszy aktualizacji wybierz Synchronizuj wszystkie prawa własności i zabezpieczenia.

  16. Kliknij przycisk Aktualizuj bazy danych.

  17. Zamknij okno dialogowe Konserwacji bazy danych (98.290.00) .

  18. Zaloguj się do systemu Microsoft Dynamics SL.

Metoda 4: Zmień nazwę pliku Solomon.ini, który znajduje się na lokalnej stacji roboczej. Aby to zrobić, wykonaj następujące kroki:

  1. Wyszukaj plik Solomon.ini, który znajduje się na lokalnej stacji roboczej. Ten plik jest zazwyczaj znajduje się w jednym z następujących folderów:

    • C:\Windows

    • C:\Winnt

    Ważne Nie zmieniaj nazw pliku Solomon.ini znajdującego się w folderze program files dla systemu Microsoft Dynamics SL.

  2. Kliknij prawym przyciskiem myszy plik, a następnie zmień jej nazwę Solomonini.bak.

  3. Uruchom ponownie system Microsoft Dynamics SL.

Metoda 5: Podjąć baz danych z trybu jednego użytkownika. Aby to zrobić, wykonaj następujące kroki:

  1. Zaloguj się do programu SQL Server Enterprise Manager.

  2. Rozwiń węzeł Microsoft SQL Servers, rozwiń SQL Server Group, rozwiń węzeł odpowiedniego serwera, a następnie rozwiń węzeł bazy danych.

  3. Kliknij prawym przyciskiem myszy odpowiednią bazę danych, a następnie kliknij polecenie Właściwości.

  4. Kliknij kartę Opcje .

  5. W obszarze dostęp wyczyść pole wyboru Ogranicz dostęp , a następnie kliknij przycisk OK.

Uwaga Bazy danych są wprowadzane w trybie pojedynczego użytkownika jako część procesu tworzenia kopii zapasowej i następnie automatycznie zmieniony na tryb normalny po wykonaniu kopii zapasowej. W przypadku kopii zapasowej nie powiodło się, bazy danych może pozostać w trybie jednego użytkownika. W tej sytuacji tryb należy ręcznie zmienić powrót do trybu normalnego.

Metoda 6: Należy Named Pipes pierwszym protokołem, który znajduje się w narzędzie sieciowe klienta. Aby to zrobić, wykonaj następujące kroki:

  1. W grupie programów Microsoft SQL Server zlokalizuj, a następnie otwórz narzędzie sieciowe klienta z grupy programu Microsoft SQL Server.

  2. Na karcie Ogólne odszukaj Nazwanych potoków w obszarze Włączone protokoły w kolejności.

  3. Jeśli nazwanych potoków nie jest pierwszym protokołem, który jest wymieniony w włączone protokoły przez okno dialogowe zamówienia, zaznacz nazwanych potoków, a następnie kliknij strzałkę w górę, aby przenieść potoków Nazwa do początku listy.

  4. Kliknij przycisk OK , aby zaakceptować zmiany.

  5. Uruchom ponownie system Microsoft Dynamics SL.

Metoda 7: Dodaj przyrostek odpowiednią domenę. Aby to zrobić, wykonaj następujące kroki:

  1. Otwórz okno dialogowe Zaawansowane ustawienia TCP/IP . Aby to zrobić, wykonaj następujące kroki:

    1. Zaloguj się do komputera jako Administrator.

    2. Kliknij przycisk Start, wskaż polecenie Panel sterowaniai kliknij ikonę Połączenia sieciowe.

    3. Kliknij prawym przyciskiem myszy połączenie sieci lokalnej, który chcesz zmodyfikować, a następnie kliknij polecenie Właściwości.

    4. W oknie dialogowym to połączenie wykorzystuje następujące składniki kliknij opcję Protokół internetowy (TCP/IP), a następnie kliknij polecenie Właściwości.

    5. Kliknij przycisk Zaawansowane.

  2. Kliknij kartę DNS .

  3. Kliknij przycisk Dołącz te DNS wystarcza, a następnie kliknij przycisk Dodaj.

  4. Dodaj przyrostek odpowiednią domenę. Aby uzyskać więcej informacji skontaktuj się z administratorem sieci.

Metoda 8: Wyczyść pole wyboru Egzekwowania zasad haseł w programie SQL Server Management Studio. Aby zrobić to wykonaj następujące kroki:

  1. Zaloguj się do programu SQL Server Management Studio.

  2. W Eksploratorze obiektów rozwiń węzeł Zabezpieczenia, a następnie rozwiń węzeł logowania.

  3. Kliknij prawym przyciskiem myszy CD7359B5576446f85EB67E824B4770, a następnie kliknij polecenie Właściwości.

  4. Wyczyść pole wyboru Wymuś zasady haseł , a następnie kliknij przycisk OK.

  5. Zakończ pracę programu SQL Server Management Studio.

Uwaga Może zajść potrzeba Powtórz kroki od do e dla konta identyfikator SQL Master60.

Metoda 9: Kojarzenie konta użytkownika domeny systemu Windows przy użyciu konta użytkownika systemu Microsoft Dynamics SL. Aby to zrobić, wykonaj następujące kroki.



Uwaga Czynności te dotyczą tylko systemu Microsoft Dynamics SL 7.0 lub nowsze wersje, które są skonfigurowane do korzystania z uwierzytelniania systemu Windows.

  1. Zaloguj się do systemu Microsoft Dynamics SL jako użytkownik sysadmin.

  2. W okienku nawigacji kliknij pozycję Administracja.

  3. W okienku szczegółów Menedżera systemu kliknij przycisk Obsługa użytkowników w sekcji Zabezpieczenia .

  4. W polu Nazwy użytkownika wpisz odpowiedni identyfikator użytkownika systemu Microsoft Dynamics SL, a następnie naciśnij klawisz TAB.

  5. W polu Nazwa użytkownika systemu Windows , wpisz odpowiedni identyfikator konta użytkownika domeny systemu Windows, a następnie kliknij przycisk Zapisz.

    Uwaga Identyfikator konta użytkownika domeny systemu Windows należy wpisać w następującym formacie:

    Domeny\identyfikator konta użytkownika domeny systemu Windows

Metoda 10: Sprawdź, czy pole nazwa_serwera tabeli domeny zawiera taką samą wartość jak nazwa serwera, który jest zdefiniowany w pliku Solomon.ini. Aby to zrobić, wykonaj następujące kroki.

  1. Zaloguj się do programu SQL Query Analyzer lub SQL Server Management Studio.

  2. Uruchom następujące polecenie w bazie danych systemu Microsoft Dynamics SL:

    Wybierz nazwa_serwera z domeny

  3. Otwórz plik Solomon.ini w edytorze tekstu. W obszarze [System32 bazy danych] , zanotuj wartość po Server =.

  4. Jeśli tabela domeny zawiera adres IP, a plik Solomon.ini zawiera nazwę rzeczywistego serwera (za pomocą znaków), należy zaktualizować tabeli domeny z nazwą rzeczywistego serwera. Aby to zrobić, uruchom następującą instrukcję w bazie danych systemu Microsoft Dynamics SL:

    Aktualizacja domeny zestaw nazwa_serwera = < Nameofserver >W tym poleceniu "< Nameofserver >" jest rzeczywista nazwa serwera, na którym została zanotowana w pliku Solomon.ini.


Metoda 11: Konfigurowanie programu SQL Server, aby zezwolić na połączenia zdalne.

Aby uzyskać więcej informacji dotyczących zezwalania na połączenia zdalne programu SQL Server kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:

914277 jak skonfigurować SQL Server 2005 do zezwalania na połączenia zdalne

Więcej informacji

Kroki prowadzące do odtworzenia problemu

  1. Kliknij przycisk Start, a następnie wskaż polecenie Wszystkie programy.

  2. Kliknij pozycję Microsoft Business Solutions Salomona, a następnie kliknij Salomona.

Zostanie wyświetlony komunikat o błędzie wymieniony w sekcji "Symptomy".

Potrzebujesz dalszej pomocy?

Chcesz uzyskać więcej opcji?

Poznaj korzyści z subskrypcji, przeglądaj kursy szkoleniowe, dowiedz się, jak zabezpieczyć urządzenie i nie tylko.

Społeczności pomagają zadawać i odpowiadać na pytania, przekazywać opinie i słuchać ekspertów z bogatą wiedzą.

Czy te informacje były pomocne?

Jaka jest jakość języka?
Co wpłynęło na Twoje wrażenia?
Jeśli naciśniesz pozycję „Wyślij”, Twoja opinia zostanie użyta do ulepszania produktów i usług firmy Microsoft. Twój administrator IT będzie mógł gromadzić te dane. Oświadczenie o ochronie prywatności.

Dziękujemy za opinię!

×