Przejdź do głównej zawartości
Pomoc techniczna
Zaloguj się przy użyciu konta Microsoft
Zaloguj się lub utwórz konto.
Witaj,
Wybierz inne konto.
Masz wiele kont
Wybierz konto, za pomocą którego chcesz się zalogować.

Ważne Ten artykuł zawiera informacje, które opisują, jak obniżyć poziom zabezpieczeń lub jak wyłączyć funkcje zabezpieczeń na komputerze. Można wprowadzić te zmiany w celu obejścia określonego problemu. Przed wprowadzeniem tych zmian zaleca się dokonanie oceny zagrożenia związanego z zastosowaniem tego obejścia w danym środowisku. Jeżeli zastosujesz to obejście, należy podjąć odpowiednie kroki dodatkowe, aby pomóc w ochronie komputera.

Objawy

Próby dostępu do folderu udostępnionego, który znajduje się na komputerze z systemem Windows 98 z komputera z systemem Windows 7 lub Windows 2000. Musisz podać nazwę użytkownika i hasło. Jednak uwierzytelnianie nie powiedzie się. W związku z tym nie można dostęp do folderu udostępnionego.

Uwaga Ten problem nie występuje, jeśli dostęp do folderu udostępnionego z komputera z systemem Windows XP lub Windows Vista.

Przyczyna

Windows 7 używa protokołu NTLM w wersji 2 (NTLMv2) uwierzytelniania. Domyślnie uwierzytelnianie NTLMv2 nie jest włączone w systemie Windows 2000 lub w systemie Windows 98. W związku z tym ten problem występuje.

Rozwiązanie

Ostrzeżenie: Nieprawidłowa modyfikacja rejestru za pomocą Edytora rejestru lub inną metodą może spowodować poważne problemy. Te problemy mogą wymagać ponownej instalacji systemu operacyjnego. Firma Microsoft nie gwarantuje, że możliwe będzie rozwiązanie tych problemów. Modyfikujesz rejestr na własną odpowiedzialność.

Aby rozwiązać ten problem, należy włączyć uwierzytelnianie NTLMv2 Windows 2000 - lub komputer z systemem Windows 98. Aby to zrobić, wykonaj następujące kroki:

  1. Uruchom Edytor Rejestru. Aby to zrobić, kliknij przycisk Start, kliknij polecenie Uruchom, wpisz polecenie Regediti naciśnij klawisz ENTER.

  2. Zlokalizuj i kliknij następujący podklucz rejestru:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\LSA

  3. Znajdź wartość rejestru LmCompatibilityLevel .



    Jeśli nie ma wartość rejestru, wykonaj następujące kroki, aby go utworzyć:

    1. Wybierz podklucz rejestru, który jest wymieniony w kroku 2.

    2. W menu Edycja wskaż polecenie Nowy, a następnie kliknij polecenie Wartość DWORD.

    3. Wpisz nazwę LmCompatibilityLevel, a następnie naciśnij klawisz ENTER.

  4. Ustaw wartość DWORD na 1. Aby to zrobić, w menu Edycja kliknij polecenie Modyfikuj , wpisz 1 w polu Dane wartości i kliknij przycisk OK.

  5. Zamknij Edytor rejestru, a następnie ponownie uruchom komputer.

Aby uzyskać więcej informacji jak włączyć uwierzytelnianie NTLMv2, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:

239869 jak włączyć obsługę uwierzytelniania NTLM 2


Uwaga Samba 2.x nie obsługuje uwierzytelniania NTLMv2. W związku z tym mogą występować podobne problemy podczas próby dostępu do udostępnionych folderów, które znajdują się w systemach Samba z komputera z systemem Windows 7. Aby obejść ten problem, wykonaj następujące kroki na komputerze z systemem Windows 7:

  1. Uruchom Edytor Rejestru. Aby to zrobić, kliknij polecenie Uruchom Start button , wpisz polecenie Regedit w polu Wyszukaj programy i pliki , a następnie naciśnij klawisz ENTER.

  2. Zlokalizuj i kliknij następujący podklucz rejestru:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\LSA

  3. Znajdź wartość rejestru LmCompatibilityLevel .



    Jeśli nie ma wartość rejestru, wykonaj następujące kroki, aby go utworzyć:

    1. Wybierz podklucz rejestru, który jest wymieniony w kroku 2.

    2. W menu Edycja wskaż polecenie Nowy, a następnie kliknij polecenie Wartość DWORD.

    3. Wpisz nazwę LmCompatibilityLevel, a następnie naciśnij klawisz ENTER.

  4. Ustaw wartość DWORD na 1. Aby to zrobić, w menu Edycja kliknij polecenie Modyfikuj , wpisz 1 w polu Dane wartości i kliknij przycisk OK.

  5. Zamknij Edytor rejestru i uruchom ponownie komputer.

Ostrzeżenie: To obejście może narazić komputer lub sieć na ataki złośliwych użytkowników lub złośliwego oprogramowania, takiego jak wirusy. Firma Microsoft nie zaleca tego obejścia, ale podaje te informacje, aby umożliwić zastosowanie według uznania użytkownika. Stosujesz to obejście na własną odpowiedzialność.

NADAL POTRZEBUJESZ POMOCY?

Jeśli ten artykuł nie odpowie na Twoje pytanie, kliknij ten przycisk, aby zadać pytanie do innych członków społeczności Microsoft Answers:

Zadaj pytanie


Jeśli chcesz zobaczyć odpowiedzi na podobne problemy, kliknij poniższe łącza, aby wyświetlić tematy na forum Microsoft Answers:


Powiązane artykuły

Produkty innych firm omówione w tym artykule są wytwarzane przez producentów niezależnych od firmy Microsoft. Firma Microsoft nie udziela żadnych gwarancji, domniemanych ani żadnego innego rodzaju, odnośnie do wydajności lub niezawodności tych produktów.

Potrzebujesz dalszej pomocy?

Chcesz uzyskać więcej opcji?

Poznaj korzyści z subskrypcji, przeglądaj kursy szkoleniowe, dowiedz się, jak zabezpieczyć urządzenie i nie tylko.

Społeczności pomagają zadawać i odpowiadać na pytania, przekazywać opinie i słuchać ekspertów z bogatą wiedzą.

Czy te informacje były pomocne?

Jaka jest jakość języka?
Co wpłynęło na Twoje wrażenia?
Jeśli naciśniesz pozycję „Wyślij”, Twoja opinia zostanie użyta do ulepszania produktów i usług firmy Microsoft. Twój administrator IT będzie mógł gromadzić te dane. Oświadczenie o ochronie prywatności.

Dziękujemy za opinię!

×