Objawy
Rozważ następujący scenariusz:
-
Używasz oprogramowania opartego na VSAPI narzędzia Microsoft Exchange Virus Scanning API w środowisku Microsoft Exchange Server 2010.
-
Skrzynki pocztowej użytkownika, który jest chroniony przez oprogramowanie antywirusowe zawiera wiele wiadomości.
-
Użytkownik wykonuje operację niektórych skrzynek pocztowych, aby połączyć się z serwerem skrzynki pocztowej. Na przykład użytkownik włącza funkcję Autopodglądu w celu wyświetlania wielu wiadomości przy użyciu programu Microsoft Outlook w trybie online.
W tym scenariuszu istnieje długie opóźnienie odpowiedzi z serwera skrzynki pocztowej. Ponadto ten problem może uniemożliwić połączenie z serwerem Exchange nowych klientów lub może wywołać pracy awaryjnej baz danych, aby serwery w stanie wstrzymania.
Przyczyna
Ten problem występuje, ponieważ operacja wykonana przez użytkownika wyzwala Awansowanie właściwości, która wyzwala antywirusowe żądań dla każdego elementu wiadomości. Jeśli istnieje wiele elementów w kolejce antywirusowe, wszystkie procedury zdalnego wywoływania (procedur RPC) połączeń z serwerem skrzynki pocztowej są wyczerpane, jak nowych klientów czekać na zakończenie operacji skanowania antywirusowego. W związku z tym serwer skrzynki pocztowej nie może odpowiedzieć na wszystkie żądania RPC. Następnie monitorowanie wykryje, że serwer Exchange nie odpowiada i zainicjuje pracy awaryjnej.
Rozwiązanie
Aby rozwiązać ten problem, należy zainstalować następujący pakiet zbiorczy aktualizacji:
2803727 Opis pakietu zbiorczego aktualizacji 1 dla Exchange Server 2010 z dodatkiem Service Pack 3
Stan
Firma Microsoft potwierdziła, że jest to problem występujący w produktach firmy Microsoft wymienionych w sekcji „Dotyczy”.
Więcej informacji
Aby uzyskać więcej informacji dotyczących sposobu włączania funkcji Autopodgląd przejdź do następującej witryny firmy Microsoft:
Wyświetlanie Autopodglądu trzech wierszy wiadomości e-mailAby uzyskać więcej informacji na temat Awansowanie właściwości przejdź do następującej witryny firmy Microsoft: