Przejdź do głównej zawartości
Pomoc techniczna
Zaloguj się przy użyciu konta Microsoft
Zaloguj się lub utwórz konto.
Witaj,
Wybierz inne konto.
Masz wiele kont
Wybierz konto, za pomocą którego chcesz się zalogować.

Objawy

Rozważ następujący scenariusz:

  • Utwórz widok źródła danych w Microsoft SQL Server Analysis Services (SSAS) zawierającego źródło danych programu SQL Server i źródła danych IBM DB2.

  • Źródło danych programu SQL Server znajduje się w systemie zdalnym 64-bitowe programu SQL Server.

  • Microsoft OLE DB Provider dla DB2 4.0 jest zainstalowany na zdalnego wystąpienia programu SQL Server i w systemie, w którym widok źródła danych jest tworzony.


W tym scenariuszu instrukcji kwerendy, która używa widoku źródła danych może się nie powieść komunikat o błędzie podobny do następującego:

Klasa nie jest zarejestrowana

Przyczyna

Dostawca OLE DB dla DB2 4.0 używa ProgID wartość DB2OLEDB.1, gdy 32-bitowego procesu ładowania dostawcy i wartość ProgID DB2OLEDB, gdy 64-bitowego procesu ładowania dostawcy. W tym scenariuszu projektanta SQL Server działa jako 32-bitowy proces. W związku z tym DB2OLEDB.1 przechodzi do zdalnego systemu SQL Server. Proces 64-bitowe programu SQL Server nie może zlokalizować klasy DB2OLEDB.1, ponieważ OLE DB Provider dla DB2 4.0 jest zarejestrowany jako DB2OLEDB. Sytuacja ta powoduje, że kwerenda nie może działać, ponieważ OLE DB Provider dla DB2 4.0 nie może zostać zlokalizowany.

Rozwiązanie

Informacje o poprawce

Obsługiwana poprawka jest udostępniana przez firmę Microsoft. Jednak ta poprawka jest przeznaczona tylko do usunięcia problemu opisanego w tym artykule. Zastosuj poprawkę tylko w systemach, w których występuje problem opisany w tym artykule. Ta poprawka może być wciąż w fazie testowania. Jeśli dany system nie jest poważnie narażony na ten problem, firma Microsoft zaleca, aby poczekać na następną aktualizację oprogramowania zawierającą tę poprawkę.

Jeśli poprawka jest dostępna do pobrania, pojawi się sekcja "Poprawka dostępna do pobrania" na początku tego artykułu z bazy wiedzy Knowledge Base. Jeśli nie ma tej sekcji, skontaktuj się z Obsługą i Wsparciem Klienta Microsoft w celu uzyskania poprawki.

Uwaga Jeśli wystąpią dodatkowe błędy lub konieczność rozwiązania problemu, być może trzeba będzie utworzyć osobne zlecenie usługi. Zwykłe koszty obsługi będą zastosowane do dodatkowych pytań i problemów, których nie można rozwiązać przy użyciu określonej poprawki. Aby uzyskać pełną listę numerów telefonów pomocy technicznej i obsługi klienta firmy Microsoft lub utworzyć osobne zlecenie usługi, odwiedź następujące witryny firmy Microsoft znajdują się:

http://support.microsoft.com/contactus/?ws=supportUwaga "Poprawka dostępna do pobrania" zawiera listę języków, dla których dostępna jest poprawka. Jeśli odpowiedni język nie jest widoczny, to dlatego, że poprawka nie jest dostępna dla danego języka.

Wymagania wstępne

Aby zastosować tę poprawkę, należy najpierw odinstalować istniejącą instalację systemu Microsoft OLE DB Provider dla DB2 4.0. Następnie należy użyć plik msi, który jest wymieniony w sekcji "Informacje o plikach" Aby zainstalować tę poprawkę.

Informacje dotyczące ponownego uruchamiania

Może być konieczne ponowne uruchomienie komputera po zastosowaniu tej poprawki.

Informacje o zastępowaniu

Ta poprawka nie zastępuje żadnych wcześniej wydanych poprawek.

Informacje o plikach

Wersja anglojęzyczna tej poprawki ma atrybuty plików (lub nowsze) wymienione w poniższej tabeli. Daty i godziny odpowiadające tym plikom zostały podane w formacie uniwersalnego czasu koordynowanego (UTC, Coordinated Universal Time). Po wyświetleniu informacji o pliku są konwertowane na czas lokalny. Aby zobaczyć różnicę między czasem UTC i czasem lokalnym, należy użyć z karty Strefa czasowa w aplecie Data i godzina w Panelu sterowania.

Dla dostawcy Microsoft OLE DB dla DB2 4.0

Nazwa pliku

Wersja pliku

Rozmiar pliku

Data

Godzina

Platforma

Db2oledbv4_x64.msi

Nie dotyczy

4,073,472

26-Nov-2013

14:42

Nie dotyczy

Db2oledbv4_x86.msi

Nie dotyczy

2,992,640

26-Nov-2013

14:42

Nie dotyczy


Stan

Firma Microsoft potwierdziła, że jest to problem występujący w produktach firmy Microsoft wymienionych w sekcji „Dotyczy”.

Informacje dotyczące produktów innych firm

Produkty innych firm omówione w tym artykule są wytwarzane przez producentów niezależnych od firmy Microsoft. Firma Microsoft nie udziela żadnych gwarancji, domniemanych ani żadnego innego rodzaju, odnośnie do wydajności lub niezawodności tych produktów.

Potrzebujesz dalszej pomocy?

Chcesz uzyskać więcej opcji?

Poznaj korzyści z subskrypcji, przeglądaj kursy szkoleniowe, dowiedz się, jak zabezpieczyć urządzenie i nie tylko.

Społeczności pomagają zadawać i odpowiadać na pytania, przekazywać opinie i słuchać ekspertów z bogatą wiedzą.

Czy te informacje były pomocne?

Jaka jest jakość języka?
Co wpłynęło na Twoje wrażenia?
Jeśli naciśniesz pozycję „Wyślij”, Twoja opinia zostanie użyta do ulepszania produktów i usług firmy Microsoft. Twój administrator IT będzie mógł gromadzić te dane. Oświadczenie o ochronie prywatności.

Dziękujemy za opinię!

×