Przejdź do głównej zawartości
Pomoc techniczna
Zaloguj się przy użyciu konta Microsoft
Zaloguj się lub utwórz konto.
Witaj,
Wybierz inne konto.
Masz wiele kont
Wybierz konto, za pomocą którego chcesz się zalogować.

PROBLEM

Office 365 lub autonomicznych subskrybentów programu Exchange Online Protection, którzy wcześniej Subskrybenci autonomicznej Forefront Online Protection for Exchange (FOPE) otrzymują raport o błędach synchronizacji katalogów, który identyfikuje następujący konflikt:

Obiekt o tym samym adresie serwera proxy już istnieje w usłudze Active Directory systemu Windows Azure, ale jest niezgodny typ obiektu (klasy obiektów: kontakt, grupy lub użytkownika). Popraw ten problem w lokalnych usługach katalogowych lub w usłudze Active Directory systemu Windows Azure i spróbuj ponownie.

Poniżej przedstawiono przykładowy raport o błędach:alternate text dodatkowe kolumny w raporcie o błędach listy tożsamości i identyfikator obiektu lokalnego dla obiektów powodujących konflikt.

PRZYCZYNA

Ten problem występuje, ponieważ zmigrowane grupy dystrybucyjne i kontakty z autonomicznego FOPE do ochrony online programu Exchange zostały utworzone z niepoprawną klasę obiektu do synchronizacji katalogów miękkie dopasowanie.

ROZWIĄZANIE

Aby rozwiązać ten problem, Usuń użytkowników powodujących konflikt z pakietu Office 365. Aby to zrobić, należy utworzyć listę użytkowników do usunięcia, a następnie uruchom polecenie środowiska Windows PowerShell, aby wykonać proces usuwania. Aby to zrobić, wykonaj następujące kroki:

  1. Połącz się z usługą Azure AD przy użyciu Microsoft Azure Active Directory moduł dla środowiska Windows PowerShell. Aby uzyskać więcej informacji o tym, jak to zrobić, zobacz Zarządzanie usługą Azure AD przy użyciu programu Windows PowerShell.

  2. Zaloguj się do centrum administracyjnego programu Exchange, a następnie ustaw wszystkie domeny, których dotyczy luka, na przekaźnik wewnętrzny, aby upewnić się, że przepływ poczty nie zostanie naruszony podczas interwału korekcji typu obiektu. Aby uzyskać więcej informacji o tym, jak to zrobić, zobacz zarządzane zaakceptowane domeny w programie Exchange Online.

  3. Uruchom następujące polecenie, aby wyeksportować listę wszystkich użytkowników pakietu Office 365 lub programu Exchange Online Protection do pliku users. CSV:

    Get-MsolUser -All | Where {$_.ImmutableID -eq $null -and $_.IsLicensed -eq $false –and $_.ProxyAddresses –ne “”} | Export-CSV C:\users.csvU 
  4. Użyj programu Microsoft Excel lub edytora tekstów, aby otworzyć plik users. csv. Ważne Podczas wykonywania tych kroków nie należy modyfikować ani usuwać górnych dwóch wierszy arkusza kalkulacyjnego, ponieważ zawierają one ważne informacje nagłówka.

    1. W arkuszu kalkulacyjnym Usuń wiersze, które są skojarzone z użytkownikami, których chcesz zachować w pakiecie Office 365.

    2. Zapisz plik jako Modified. csv.

  5. Uruchom następujące polecenie, aby usunąć użytkowników z pakietu Office 365:

    Import-CSV C:\users-modified.csv | Remove-MsolUser –Force 
  6. Wymuszenie synchronizacji katalogów. Aby uzyskać więcej informacji o tym, zobacz synchronizowanie katalogów.

  7. Uruchom następujące polecenie, aby usunąć użytkowników z kosza:

    Import-CSV C:\users-modified.csv | Get-MsolUser -ReturnDeletedUsers | Remove-MsolUser -RemoveFromRecycleBin  –Force 

Nadal potrzebujesz pomocy? Przejdź do witryny Microsoft Community.

Potrzebujesz dalszej pomocy?

Chcesz uzyskać więcej opcji?

Poznaj korzyści z subskrypcji, przeglądaj kursy szkoleniowe, dowiedz się, jak zabezpieczyć urządzenie i nie tylko.

Społeczności pomagają zadawać i odpowiadać na pytania, przekazywać opinie i słuchać ekspertów z bogatą wiedzą.

Czy te informacje były pomocne?

Jaka jest jakość języka?
Co wpłynęło na Twoje wrażenia?
Jeśli naciśniesz pozycję „Wyślij”, Twoja opinia zostanie użyta do ulepszania produktów i usług firmy Microsoft. Twój administrator IT będzie mógł gromadzić te dane. Oświadczenie o ochronie prywatności.

Dziękujemy za opinię!

×