Dotyczy
Exchange Server 2010 Enterprise Exchange Server 2010 Standard Exchange Server 2013 Enterprise Edition Exchange Server 2013 Standard Edition Exchange Server 2016 Enterprise Edition Exchange Server 2016 Standard Edition

Objawy

Rozważ następujący scenariusz:

  • Program Microsoft Outlook jest uruchomiony w trybie Online w środowisku usługi Office 365 lub Exchange Server.

  • Preferowane kodowanie dla wiadomości wychodzącychustawiono opcję w programie Outlook KOI8-R (domyślne kodowanie ustawienie rosyjska wersja programu Outlook).

  • Utwórz wiadomość, która zawiera niektóre znaki rosyjski, a następnie zapisać go jako wersję roboczą.

W tym scenariuszu treść wiadomości jest nieczytelny po wysłaniu tej wersji roboczej.

Przyczyna

Ten problem występuje, ponieważ serwer Exchange nie aktualizuje znaków określonych we właściwości PR_BODY_HTML, gdy serwer zmienia znak, określonych we właściwości PR_INTERNET_CPID. W związku z tym treść wiadomości jest nieczytelny, gdy program Outlook próbuje go wyświetlić.

Rozwiązanie

Skonfiguruj klienta programu Outlook do używania UTF-8 dla opcji Preferowane kodowanie dla wiadomości wychodzących . Aby to zrobić, wykonaj następujące kroki:

  1. W programie Outlook, wybierz polecenie plik>opcji > Zaawansowane.

  2. W sekcji Opcje międzynarodowe ustaw opcję Preferowane kodowanie dla wiadomości wychodzących na UTF-8.

Więcej informacji

Aby uzyskać więcej informacji na temat konwersji zawartości zobacz Konwersja zawartości.Aby uzyskać więcej informacji na temat właściwości kanoniczna PidTagBodyHtml zobacz Właściwości kanoniczna PidTagBodyHtml.Aby uzyskać więcej informacji na temat opcji kodowania wiadomości zobacz Opcje kodowania wiadomości.

Potrzebujesz dalszej pomocy?

Chcesz uzyskać więcej opcji?

Poznaj korzyści z subskrypcji, przeglądaj kursy szkoleniowe, dowiedz się, jak zabezpieczyć urządzenie i nie tylko.