Przejdź do głównej zawartości
Pomoc techniczna
Zaloguj się przy użyciu konta Microsoft
Zaloguj się lub utwórz konto.
Witaj,
Wybierz inne konto.
Masz wiele kont
Wybierz konto, za pomocą którego chcesz się zalogować.

Możesz utworzyć diagram wdrażania UML, aby pokazać architekturę wdrożenia artefaktów oprogramowania w węzłach. Najpierw otwierasz szablon wdrażania UML i wybierasz jedną z czterech opcji szablonu. Następnie zostanie wyświetlony wzornik Wdrażanie UML wraz z kształtami zgodnymi ze standardem UML 2.5.

Wzornik wdrażania UML, przykładowe kształty na stronie

Uruchamianie diagramu wdrażania UML

  1. Uruchom program Visio. Jeśli plik jest już otwarty, kliknij pozycję Plik > Nowy.

  2. Przejdź do tematu Kategorie > wdrażanie oprogramowania i bazy danych > UML.

  3. Wybierz pusty szablon lub jeden z trzech diagramów startowych. Po wybraniu odpowiedniego szablonu kliknij pozycję Utwórz.

  4. Powinno zostać wyświetlone okno Kształty obok diagramu. Jeśli go nie widzisz, przejdź do pozycji Wyświetl > okienkach zadań i upewnij się, że jest zaznaczona pozycja Kształty . Jeśli nadal go nie widzisz, kliknij przycisk Rozwiń okno Kształty Przycisk Rozwiń okno Kształty po lewej stronie.

  5. Na karcie Widok upewnij się, że jest zaznaczone pole wyboru obok pozycji Punkty połączeń . Spowoduje to wyświetlenie punktów połączeń po rozpoczęciu łączenia kształtów.

  6. Teraz przeciągnij kształty, które chcesz uwzględnić w diagramie, z okna Kształty na stronę. Aby zmienić nazwę etykiet tekstowych, kliknij dwukrotnie etykiety.

Uwaga: Tworzenie i edytowanie diagramów UML na Visio dla sieci Web wymaga licencji programu Visio Plan 1 lub Visio Plan 2, która jest kupowana oddzielnie od Microsoft 365. Aby uzyskać więcej informacji, skontaktuj się z administratorem platformy Microsoft 365. Jeśli administrator włączył "samodzielny zakup", możesz samodzielnie kupić licencję programu Visio. Aby uzyskać więcej informacji, zobacz Samoobsługowy zakup — często zadawane pytania.

Uruchamianie diagramu wdrażania UML

  1. Otwórz program Visio dla sieci Web. W prawym górnym rogu wybierz pozycję Więcej szablonów.

  2. W galerii przewiń w dół do wiersza Wdrażanie UML, mniej więcej w połowie strony.

    Pierwszy element w wierszu reprezentuje pusty szablon wraz ze wzornikiem towarzyszącym. Pozostałe elementy w wierszu to przykładowe diagramy, które mają już narysowane kształty ułatwiające szybkie rozpoczęcie pracy.

  3. Kliknij dowolny element, aby wyświetlić większy podgląd.

  4. Po znalezieniu diagramu, którego chcesz użyć, kliknij jego przycisk Utwórz .

    Nowy diagram z powiązanym wzornikiem zostanie otwarty w przeglądarce.

Wystąpienia i artefakty węzłów

Kiedy używać

  1. Użyj kształtów Wystąpienia węzła , jeśli chcesz określić wystąpienie urządzenia obliczeniowego lub fizycznego w czasie wykonywania.

  2. Umieść kształty wystąpienia artefaktu wewnątrz kształtów wystąpienia węzła, aby wdrożyć artefakty.

1 wskazujący kształt Wystąpienie węzła "<<cloud vm>> :MachineInstance" ; 2 wskazujące kształt Artefakt: "<<Artefakt>> Cruncher.py numerów"

Krok 1

Przeciągnij najpierw kształt Wystąpienie węzła na stronę, a następnie zwiększ go, przeciągając uchwyty kształtu.

Kształt Wystąpienie węzła zmień rozmiar na większy

Krok 2

Przeciągnij kształt Wystąpienie artefaktu i umieść go wewnątrz większego kształtu węzła. Po wyświetleniu zielonego wyróżnienia oznacza to, że mniejszy kształt będzie zawarty w większym kształcie węzła. Od tego momentu, gdy kształt węzła zostanie przeniesiony, artefakt wewnątrz również zostanie przeniesiony.

Kształt Artefakt przeciągnięty na wierzchu kształtu Wystąpienie węzła, zielone wyróżnienie

Inne kształty kontenera

We wzorniku wdrażania UML są dostępne inne kształty kontenera. Zachowują się jak kształt Wystąpienie węzła. Oznacza to, że po upuszczeniu kształtów na nie kształty zostaną przyklejone i zostaną przeniesione razem z kontenerem. Oto niektóre z najpopularniejszych kształtów kontenera dla diagramów wdrażania:

Węzły hierarchiczne

Zagnieżdżaj kształty węzłów wewnątrz siebie, jeśli chcesz, aby były wyświetlane hierarchicznie.

Węzeł UserClient zawierający węzeł Przeglądarka zawierający artefakt HTML5

Pakowanie kształtów

Użyj opcji Spakuj kształty, gdy chcesz reprezentować elementy, takie jak folder.

Pakowanie kształtu zawierającego inne wystąpienie węzła i kształty artefaktów

Omówienie diagramu

Użyj kształtu Przegląd diagramu , aby otoczyć wszystkie kształty ramką.

Kształt przegląd diagramu zawierający inne wystąpienie węzła i kształty artefaktów

Porady dotyczące łączników

Prostuj łączniki

Jeśli łącznik zajmuje zbyt wiele zakrętów, kliknij go prawym przyciskiem myszy, a następnie kliknij polecenie Połącz prostyr.

Pokazywanie mnogości

W razie potrzeby kliknij prawym przyciskiem myszy łącznik i wybierz polecenie Pokaż mnożenie. Po zakończeniu zostaną wyświetlone cztery pola tekstowe, w których możesz dodać szczegóły. Jeśli nie potrzebujesz wszystkich pól tekstowych, usuń te, których nie potrzebujesz.

Zmienianie typu łącznika

Typ łącznika można zmienić. Można na przykład zmienić skojarzenie z skojarzenia na skojarzenia kierowane. Kliknij prawym przyciskiem myszy łącznik, a następnie kliknij polecenie Ustaw typ łącznika.

Nawiązywanie połączeń dynamicznych zamiast połączeń punktowych

Jeśli przewidujesz często przenoszenie kształtów, rozważ utworzenie połączenia dynamicznego zamiast połączenia punktowego.

Przenoszenie lub obracanie tekstu na łącznikach

Najprawdopodobniej trzeba będzie obrócić lub przenieść tekst na liniach łączników. Oto jak to zrobić:

  1. Kliknij pusty obszar strony, aby usunąć zaznaczenie niczego, co może zostać zaznaczone.

  2. Na karcie Narzędzia główne w grupie Narzędzia kliknij narzędzie Blok tekstu Przycisk bloku tekstu

  3. Kliknij łącznik zawierający tekst, który chcesz obrócić lub przenieść.

  4. Przeciągnij blok tekstu, aby go przenieść, lub obróć go za pomocą uchwytu obrotu Uchwyt obrotu podczas przeciągania

  5. Po zakończeniu kliknij przycisk Wskaźnik — narzędzie Przycisk wskaźnika

    Po powrocie do przycisku Wskaźnik — narzędzie Przycisk wskaźnikatekst zachowuje tę samą pozycję względem kształtu. Jeśli użyjesz Przycisk wskaźnikanarzędzia Wskaźnik do przeciągnięcia tekstu, kształt również zostanie przeniesiony. Aby przenieść tekst niezależnie od kształtu, wróć do narzędzia Blok tekstu Przycisk bloku tekstu .

Kształty składników

Kiedy używać

Użyj kształtów składników dla każdej jednostki funkcjonalnej w systemie lub aplikacji.

Kształt składnika "Sklep"

Pokazywanie lub ukrywanie stereotypu

Kliknij prawym przyciskiem myszy kształt, aby pokazać lub ukryć etykietę stereotypu.

Menu wyświetlane po kliknięciu prawym przyciskiem myszy, polecenie Pokaż stereotyp, składnik  <<>> etykietę tekstową

Kształty interfejsu

Kiedy używać

  1. Kształt Dostarczony interfejs służy do określania realizacji klasy/interfejsu.

  2. Jeśli chcesz określić zależność od klasy/interfejsu, użyj wymaganego interfejsu .

Dwa połączone interfejsy, 1: Dostarczony kształt interfejsu kończący się okręgiem, 2: Wymagany kształt interfejsu kończący się na gniazdo

Krok 1

Przeciągnij kształt Dostarczony interfejs na stronę i wyrównaj kwadrat portu z punktem połączenia. Wiadomo, że jest ono połączone, gdy wokół punktu połączenia jest widoczne zielone wyróżnienie.

Kształt Interfejs przyklejony do kształtu Składnik

Krok 2

Przeciągnij kształt Wymagany interfejs na stronę i wyrównaj kwadrat portu z punktem połączenia. Wiadomo, że jest ono połączone, gdy wokół punktu połączenia jest widoczne zielone wyróżnienie.

Wymagany kształt interfejsu przyklejony do kształtu składnika

Krok 3

Aby połączyć ze sobą interfejs Dostarczone i Wymagane, najpierw wybierz kształt Wymagany interfejs. Następnie poszukaj żółtego uchwytu.

Żółty uchwyt kształtu Wymagany interfejs

Krok 4

Przeciągnij żółty uchwyt, aby połączyć się za pomocą udostępnionego interfejsu.

Kształt Wymagany interfejs połączony z dostarczonym interfejsem

Zobacz też

Diagramy UML w programie Visio

Tworzenie diagramu składników UML

Tworzenie diagramu komunikacji UML

Tworzenie diagramu sekwencji UML

Potrzebujesz dalszej pomocy?

Chcesz uzyskać więcej opcji?

Poznaj korzyści z subskrypcji, przeglądaj kursy szkoleniowe, dowiedz się, jak zabezpieczyć urządzenie i nie tylko.

Społeczności pomagają zadawać i odpowiadać na pytania, przekazywać opinie i słuchać ekspertów z bogatą wiedzą.

Czy te informacje były pomocne?

Jaka jest jakość języka?
Co wpłynęło na Twoje wrażenia?
Jeśli naciśniesz pozycję „Wyślij”, Twoja opinia zostanie użyta do ulepszania produktów i usług firmy Microsoft. Twój administrator IT będzie mógł gromadzić te dane. Oświadczenie o ochronie prywatności.

Dziękujemy za opinię!

×