Você gostaria de criar um fluxograma do Visio detalhado e requintado automaticamente a partir de uma pasta de trabalho do Excel? Você pode fazer isso usando os modelos de Visualizador de Dados. Cada modelo tem uma pasta de trabalho do Excel associada usada para converter os dados do processo em um fluxograma do Visio. Você também pode usar seu próprio modelo personalizado do Excel, mapear dados do Excel para formas em Criar Diagrama do assistente de Dados e criar automaticamente o diagrama. Você pode ainda adicionar colunas adicionais de dados no Excel que são convertidas em dados no formato do Visio.
O Visio também oferece suporte à sincronização bilateral entre o diagrama do Visio e a pasta de trabalho do Excel. Além de criar o fluxograma, editando dados no Excel e atualizando o diagrama do Visio, você também pode fazer alterações no Diagrama do Visio e atualizar os dados do Excel no diagrama.
A capacidade de usar os modelos do Visualizador de Dados só está disponível com o Visio Plano 2. Se não tiver certeza de qual versão do Visio está usando, selecione Arquivo>Conta>Sobre o Visio. Confira Visio Plano 2 para saber mais sobre a versão de assinatura do Visio.
Caso você não encontre os modelos do Visualizador de Dados ou tenha outras dúvidas sobre como começar, acesse a página Perguntas frequentes do Visualizador de Dados.
Observação
Para usar esse recurso, você deve ter uma assinatura do Microsoft 365. Se você for um assinante do Microsoft 365, certifique-se de ter a versão mais recente do Office. Se você é um profissional de TI que gerencia o processo de atualização do Microsoft 365, marcar a página de lançamentos de canal para saber quais atualizações são fornecidas em cada canal.
Neste artigo
- Criar um diagrama do Visualizador de Dados
- Como colunas do Excel interagem com componentes de fluxograma do Visio
- Usar outros estênceis para criar um diagrama de Visualizador de Dados
- Criar e vincular a diagramas de subprocesso
- Aplicar Gráficos de Dados ao seu diagrama
- Gerenciar a pasta de trabalho do Excel vinculada ao diagrama
- Próximas etapas
Criar um diagrama do Visualizador de Dados
Antes de começar
Reúna suas ideias e elabore-as em formato de rascunho usando uma folha de papel ou a escrita à tinta. Esse rascunho inicial pode ajudá-lo a colocar seu trabalho em movimento e a facilitar as etapas seguintes.
Para criar um diagrama do Visualizador de Dados, você pode trabalhar simultaneamente no Excel e no Visio. Talvez você ache mais fácil trabalhar em duas janelas no seu dispositivo Windows ou em um ambiente com vários monitores. A comparação visual do seu trabalho entre o Excel e o Visio ajuda a confirmar que você está realmente fazendo o que pretende fazer.
Recomendado Assista a este vídeo do Microsoft Office para vê-lo em ação: Visualizador de Dados: Demonstração.
Estágio 1: escolher um modelo do Visualizador de Dados
Abra o Visio ou selecione Arquivo>Novo se estiver editando um diagrama.
Selecione MODELOS.
Escolha Fluxograma.
Selecione Fluxograma Básico - Visualizador de Dados, Fluxograma multifuncional - Visualizador de Dados ou Diagrama de Auditoria - Visualizador de Dados.
Um modelo do Visualizador de dados tem um ícone do Excel no canto superior esquerdo.
Para obter mais informações sobre fluxogramas e suas formas, confira Criar um fluxograma básico e Criar um fluxograma multifuncional.
Estágio 2: criar uma pasta de trabalho do Excel
Na visualização do modelo, selecione Modelo de dados do Excel.
Observação Se você quiser usar os mesmos modelos de amostra do Excel usados para referência neste artigo, baixe-os nos links a seguir:SelecioneSalvar Arquivo>, especifique um computador, servidor de rede ou biblioteca de documentos do SharePoint, insira um nome de arquivo e selecione Salvar.
Para adicionar uma nova planilha, na parte inferior da pasta de trabalho, selecione Nova planilha
.Crie uma tabela do Excel. Para obter mais informações sobre como usar tabelas do Excel, confira Visão geral de tabelas do Excel, Criar ou excluir uma tabela do Excel e Redimensionar uma tabela adicionando ou removendo linhas e colunas.
Adicione colunas e linhas à tabela, que são usadas para criar o diagrama do Visio. Existem requisitos específicos para os cabeçalhos e valores de colunas da tabela do Excel. Use a seção, Como colunas do Excel interagem com componentes de fluxograma do Visio como guia visual.
Estágio 3: adicionar mais dados de forma à tabela do Excel (opcional)
- Examine a guia Mapa de Processos no modelo do Excel. As colunas na tabela do Excel são verdes e azuis. A cor fornece uma pista visual sobre a diferença entre as colunas.
As colunas azuis são usadas para criar o fluxograma no diagrama do Visio. Todas as colunas também são adicionadas como dados de forma. - Para adicionar mais dados de forma, adicione uma ou mais colunas à sua tabela do Excel.
As colunas verdes indicam outros dados de forma que você pode adicionar a cada forma. É possível acrescentar qualquer número de colunas adicionais. Por padrão, esses dados não ficam visíveis no diagrama, a menos que você adicione elementos gráficos de dados. Para ver os dados da forma no diagrama do Visio, selecioneJanela de Dados da Forma de Dados>. Para obter mais informações sobre dados de forma e gráficos de dados, confira Adicionar dados a formas e Visão geral: gráficos de dados.
Estágio 4: criar um diagrama do Visio com o assistente
Retorne ao Visio. Na visualização do modelo, selecione sua unidade de medida e clique em Criar.
Na primeira página do assistente Criar Diagrama a partir de Dados, faça o seguinte:
- Em Qual diagrama você deseja criar a partir dos dados, selecione um modelo: Fluxograma Básico, Fluxograma Multifuncional (horizontal) ou Fluxograma Multifuncional (vertical).
- Em Selecionar a pasta de trabalho do Excel, selecione uma pasta de trabalho na lista das pastas de trabalho usadas mais recentemente ou selecione Procurar para localizar a pasta de trabalho que você criou no Estágio 2.
- Em Selecione uma tabela ou um intervalo personalizado na pasta de trabalho, selecione a tabela que contém seus dados de processos do Excel.
- Selecione Concluir. Essa ação aceita todos os valores padrão preenchidos pelo Visio para as outras páginas do assistente.
Como resultado, o diagrama é criado automaticamente dentro de um contêiner. Páginas adicionais do Visio são adicionadas dependendo do tamanho do fluxograma.
Estágio 5: salvar o diagrama do Visio
- SelecioneSalvar Arquivo>, encontre um local, insira um nome de arquivo e selecione Salvar.
É uma boa ideia manter os arquivos do Excel e do Visio no mesmo local, porque eles trabalham lado a lado.
Estágio 6: sincronizar os dados e o diagrama
Depois de criar um diagrama com o Visualizador de Dados, você pode querer fazer alterações nele. O Visio oferece suporte à sincronização bidirecional entre os dados de origem e o diagrama.
Dica Mantenha os dois arquivos sincronizados e atualizados depois que terminar de trabalhar com eles. Quando você alterar os dados do Excel, atualize o diagrama; quando alterar o conteúdo do diagrama, atualize os dados do Excel.
Para modificar os dados no Excel e atualizar o diagrama
- Faça alterações nos dados da tabela do Excel. Você pode adicionar, atualizar ou excluir linhas.
- Salve a pasta de trabalho do Excel.
- No Visio, clique no contêiner do diagrama para habilitar a guia Design de Ferramentas de Dados na faixa de opções e, em seguida, selecione Atualizar o Diagrama.
Como resultado, as alterações feitas na pasta de trabalho do Excel serão exibidas no diagrama do Visio. Observe o seguinte:
- Se você tiver feito alguma alteração no diagrama que pode se perder após a atualização, o Visio exibe uma caixa de diálogo Atualizar Conflito de Diagrama.
- A ação de atualizar apenas fará alterações nas formas e conexões dentro do contêiner.
- Todas as alterações de formatação feitas nas formas ou nos conectores dentro do contêiner serão preservadas.
- Mantenha todas as formas e linhas conectoras do diagrama dentro do contêiner. Nenhum outro objeto na página, mas fora do contêiner, será afetado. Para saber mais sobre contêineres, confira Esclarecer a estrutura de diagramas usando contêineres e listas.
Para modificar o conteúdo no diagrama e atualizar os dados no Excel
- Faça alterações no diagrama do Visio. Adicione, atualize ou exclua formas e conectores.
- Se a pasta de trabalho do Excel estiver em um computador desktop ou servidor de arquivo de rede, ele deve ser salvo e fechado.
- Clique no contêiner do diagrama para habilitar a guia Design de Ferramentas de Dados na faixa de opções e, em seguida, selecione Atualizar Fonte de Dados.
Como resultado, as alterações feitas no diagrama do Visio são atualizadas na pasta de trabalho do Excel. Em caso de perda de dados no Excel, o Visio exibirá a caixa de diálogo Atualizar Conflito de Fonte de Dados. Para evitar problemas, use as seguintes práticas recomendadas:
- Salve um backup dos dados do Excel antes de substituir as alterações.
- Na pasta de trabalho do Excel, use uma Tabela do Excel como fonte de dados, não um intervalo personalizado. Depois de selecionar Substituir na caixa de diálogo Atualizar Fonte de Dados, o Visio converte o intervalo personalizado em uma tabela do Excel.
- Não use fórmulas na fonte de dados do Excel. Depois de selecionar Substituir na caixa de diálogo Atualizar Fonte de Dados, o Visio converte a fórmula no resultado da fórmula.
- Você criou o diagrama usando a seguinte opção no assistente Criar Diagrama a partir de Dados, onde as colunas de dados são mapeadas para funções e fases: Mapeando>mais opções>Mantenha a ordem dos valores da coluna de seus dados para criar>Selecione a função ou a raia ou selecione a fase ou a linha do tempo. Neste caso, o Visio requer uma coluna adicional nos seus dados para representar a conexão entre formas. Depois de selecionar Substituir na caixa de diálogo Atualizar Fonte de Dados, a coluna adicional será inserida.
- Você criou um diagrama de fluxograma multifuncional com duas raias e fases com base na ordem dos valores dos dados no Excel. Você criou o diagrama usando a seguinte opção no assistente Criar Diagrama a partir de Dados, onde as colunas de dados são conectadas às etapas e atividades do processo: Mapeamento>Especifique como conectar as etapas/atividades> do processoConecte-se sequencialmente. Neste caso, o Visio requer uma coluna adicional nos seus dados para representar a conexão entre formas. Se você alterar a ordem das raias ou fases no diagrama, a ordem será alterada na fonte de dados. Depois de selecionar Substituir na caixa de diálogo Atualizar Fonte de Dados, as raias e fases do diagrama não seguem mais a ordem dos dados na pasta de trabalho do Excel.
Estágio 7: personalizar a interação entre a tabela do Excel e o diagrama do Visio (opcional)
Há momentos em que você pode querer personalizar a criação dos seus diagramas do Visualizador de Dados. Por exemplo, talvez você queira usar formas diferentes para manter a conformidade com os padrões da sua organização ou mapear para nomes de colunas diferentes na tabela do Excel.
- Ao selecionar Criar para inserir o assistente Criar Diagrama a partir de Dados e depois de inserir valores na primeira página (consulte a Fase 4), selecione Avançar ou Voltar para exibir cada página no assistente.
- Selecione Ajuda (?) para obter mais informações sobre como personalizar cada opção na página. Para obter mais informações, confira Usar o assistente Criar Diagrama a partir de Dados.
Como colunas do Excel interagem com componentes de fluxograma do Visio
Use o seguinte passo a passo com imagens para entender como cada coluna do Excel é usada para criar o fluxograma do Visio.
Observe que uma série de "guias" ("ID", "Descrição", "Próxima ID" e assim por diante) são usadas abaixo para ilustrar as várias colunas de uma tabela do Excel. Clique no nome de uma guia para ver a ilustração dessa coluna.
ID da Etapa do ProcessoUm número que identifica cada forma no fluxograma. Essa coluna é necessária, e cada valor na tabela do Excel deve ser exclusivo e não estar em branco. Esse valor não aparece no fluxograma.
Usar outros estênceis para criar um diagrama de Visualizador de Dados
Além de usar os modelos do Visualizador de Dados, você também pode usar estênceis de outros modelos ao criar um diagrama do Visualizador de Dados. Por exemplo, crie diagramas de processo para transações financeiras ou gerenciamento de estoque. Há outros estênceis orientados a processos, incluindo os modelos BPMN Básico e Objetos de Fluxo de Trabalho. Você pode até mesmo adicionar formas personalizadas usando o estêncil Minhas Formas. Para saber mais, confira Criar, salvar e compartilhar estênceis personalizados.
- Abra um diagrama do Visualizador de Dados (Fluxograma Básico ou Fluxograma Multifuncional) que você criou.
- Selecione Criar para entrar no assistente Criar Diagrama a partir de Dados e depois de inserir valores na primeira página, selecione Avançar até exibir a página Mapeamento de Forma no assistente.
- Adicione um ou mais estênceis usando a opção Mais Formas.
- Selecione qualquer forma e mapeie-a para os valores de dados da coluna Tipo de Forma arrastando-os.
Criar e vincular a diagramas de subprocesso
Atualmente, o recurso Visualizador de Dados não oferece suporte à criação de subprocessos a partir de uma única tabela do Excel. No entanto, você pode criar vários diagramas usando tabelas diferentes em um arquivo do Visio e, em seguida, vincular formas como uma solução alternativa.
- No aplicativo da área de trabalho do Visio, selecione um modelo do Visualizador de Dados e, em seguida, selecione o link do modelo de dados do Excel para abrir o Excel. Em seguida, selecione Criar para abrir o modelo do Visio Data Visualizer.
- Use o modelo de dados do Excel para criar tabelas para seus processos e subprocessos. Coloque a tabela de cada subprocesso em uma planilha diferente e salve o arquivo do Excel.
Por exemplo, Planilha 1: Processo principal, Planilha 2: Subprocesso1, Planilha 3: Subprocesso2. - Volte para o aplicativo da área de trabalho do Visio e use o assistente para importar a tabela do Processo Principal para a Página 1 da tela do Visio.
- Abaixo da tela, selecione o ícone + para criar uma Página 2. Na guia Dados, selecione Criar para iniciar o assistente de importação novamente. Escolha importar dados da próxima planilha na pasta de trabalho do Excel e conclua as etapas no assistente.
- Continue a criar novas páginas no Visio e usando o assistente para cada uma das tabelas de dados de subprocesso que você criou.
- Por fim, selecione a página com o diagrama de processo principal e clique com o botão direito do mouse na forma a ser vinculada a um subprocesso. Selecione Hiperlink e vincule-o a qualquer forma em um dos diagramas de subprocesso.
Aplicar Gráficos de Dados ao seu diagrama
É possível melhorar ainda mais seu diagrama adicionando gráficos de dados, que ajudam a visualizar dados de forma no diagrama. Na verdade, é possível transformar seu diagrama em um painel de processos em que os gráficos de dados mostram informações sobre KPIs (indicadores chave de desempenho) usando os ícones de gráficos de dados com base nos seus dados de forma.
- Abra o diagrama do Visualizador de Dados.
Selecione o contêiner ao qual você deseja aplicar os Gráficos de Dados. - Selecione oscampos gráficos de dadosde dados>.
- Selecione os campos de gráficos de dados que você deseja adicionar ao seu diagrama.
Os gráficos de dados são aplicados ao diagrama inteiro. Para ocultar gráficos de dados para certas formas, mantenha os valores da coluna de dados em branco na pasta de trabalho do Excel para essas linhas. - Se desejar, será possível definir opções adicionais na guia Dados. Para saber mais, confira Visão geral: gráficos de dados.
Gerenciar a pasta de trabalho do Excel vinculada ao diagrama
Ocasionalmente, talvez seja necessário vincular novamente ou atualizar a pasta de trabalho do Excel associada. Você pode fazer isso convenientemente no Visio.
Vincular novamente a pasta de trabalho do Excel com o diagrama do Visio
Se a pasta de trabalho do Excel vinculada a um diagrama do Visualizador de Dados for renomeada ou movida para um local diferente, o vínculo entre o diagrama do Visio e a pasta de trabalho do Excel será quebrado. Esse problema também pode ocorrer se você renomear a tabela do Excel.
- Selecione o contêiner para o diagrama do Visualizador de Dados. Isso habilita a guia Design de Ferramentas de Dados na faixa de opções.
- Selecione o Design >de Ferramentas de Dadosvincule novamente os dados de origem.
- Navegue até a pasta de trabalho do Excel renomeada ou movida.
- Selecione uma tabela ou intervalo personalizado na pasta de trabalho.
- Para corrigir o link desfeito, selecione Revincular.
Quando você tenta atualizar o diagrama ou atualizar os dados de origem e o link é interrompido, o Visio também solicita que você vincule novamente.
Importante Não altere os nomes das colunas na tabela do Excel vinculada ao diagrama. Caso contrário, a operação de revinculação falhará.
Abra a pasta de trabalho do Excel vinculada ao diagrama
Você pode alterar o conteúdo vinculado no Excel diretamente do Visio. Por exemplo, talvez você queira adicionar muito conteúdo e achar mais fácil editar os dados em uma planilha.
- No Visio, selecione o contêiner para o diagrama do Visualizador de Dados. Isso habilita a guia Design de Ferramentas de Dados na faixa de opções.
- Selecione Dados, Ferramentas, Design,>Dados de Software Livre.
- Faça suas alterações no Excel e, em seguida, salve e feche a pasta de trabalho.
- Para ver as alterações no diagrama, selecioneDiagrama de Atualização de Design> de Ferramentas de Dados.
Próximas etapas
Veja a seguir algumas tarefas que você pode querer fazer depois de criar um diagrama do Visualizador de Dados.
- Temas Um tema no Visio é um conjunto de cores e efeitos que você pode aplicar a um desenho com um único clique. Temas são uma maneira rápida de dar uma aparência profissional aos seus desenhos. Para obter mais informações, confira Aplicar uma aparência profissional aos seus desenhos com temas.
- de Impressão O Visio tem guias manuais e ferramentas automáticas para ajudar a garantir que as formas em seu diagrama estejam alinhadas e bem espaçadas. Isso ajuda a dar a maior clareza possível para o seu desenho, além de deixá-lo com uma aparência bem organizada. Para obter mais informações, consulte Alinhar e posicionar formas em um diagrama.
- Exportar Exporte um diagrama do Visualizador de Dados e a pasta de trabalho associada do Excel para um pacote de modelo do Visio (.vtpx). Um pacote de modelos do Visio salva as configurações do diagrama, estênceis e dados para que outras pessoas as utilizem como um ponto de partida rápido para criar seu próprio diagrama de Visualizador de Dados. Outros usuários podem instalar e personalizar o pacote de modelos em seus computadores. Confira mais informações em Exportar e instalar um pacote de modelos de Visualizador de Dados.