Um banco de dados bem projetado não só ajuda a garantir a integridade dos dados, mas é mais fácil de manter e atualizar. Um banco de dados do Access não é um arquivo no mesmo sentido que um documento do Microsoft Word ou um conjunto de slides do Microsoft PowerPoint. Em vez disso, é uma coleção de objetos — tabelas, formulários, relatórios, consultas e assim por diante — que devem funcionar juntos para funcionar corretamente.
Os usuários inserem dados principalmente por meio de controles. O que você faz com um determinado controle depende do tipo de dados definido para o campo da tabela subjacente, de quaisquer propriedades definidas para esse campo e propriedades definidas para o controle. Por fim, considere o uso de técnicas adicionais de banco de dados, como validação, valores padrão, listas e pesquisas e atualizações em cascata.
Para obter mais informações sobre a atualização de dados do ponto de vista do usuário, consulte Maneiras de adicionar, editar e excluir registros.
Neste artigo
- Como o design do banco de dados afeta a entrada de dados
- Definir um valor padrão para um campo ou controle
- Usando regras de validação para limitar dados
- Trabalhar com listas de valores e campos Pesquisa
- Excluir os dados de uma lista ou campos de pesquisa
- Como os tipos de dados afetam a maneira como você insere dados
- Como as propriedades do campo da tabela afetam a maneira como você insere dados
- Usar atualizações em cascata para alterar valores de chave primária e estrangeira
- Por que os números de identificação às vezes parecem ignorar um número
- Atualização de dados em massa usando consultas
Como o design do banco de dados afeta a entrada de dados
As informações mantidas em um banco de dados são armazenadas em tabelas que contêm dados sobre um determinado assunto, como ativos ou contatos. Cada registro em uma tabela contém informações sobre um item, como um contato específico. Um registro é composto de campos como nome, endereço e número de telefone. Um registro é comumente chamado de linha e um campo é comumente chamado de coluna. Esses objetos devem aderir a um conjunto de princípios de design ou o banco de dados funcionará mal ou falhará completamente. Por sua vez, esses princípios de design afetam a maneira como você insere dados. Considere o seguinte:
- Tabelas O Access armazena todos os dados em uma ou mais tabelas. O número de tabelas usadas depende do design e da complexidade do banco de dados. Embora você possa exibir dados em um formulário, um relatório ou nos resultados retornados por uma consulta, o Access armazena os dados somente em tabelas e os outros objetos no banco de dados são criados em cima dessas tabelas. Cada tabela deve ser baseada em um assunto. Por exemplo, uma tabela de informações de contato comercial não deve conter informações de vendas. Se isso acontecer, encontrar e editar as informações corretas pode se tornar difícil, se não impossível.
-
Tipos de dados Normalmente, cada um dos campos em uma tabela aceita apenas um tipo de dados. Por exemplo, você não pode armazenar anotações em um campo definido para aceitar números. Se você tentar inserir texto em tal campo, o Access exibirá uma mensagem de erro. No entanto, essa não é uma regra rígida e rápida. Por exemplo, você pode armazenar números (como códigos postais) em um campo definido como o tipo de dados de Texto Curto, mas não pode efetuar cálculos nesses dados porque o Access os considera um trecho de texto.
Com algumas exceções, os campos em um registro devem aceitar apenas um valor. Por exemplo, você não pode inserir mais de um endereço em um campo de endereço. Isso é diferente do Microsoft Excel, que permite inserir qualquer número de nomes, endereços ou imagens em uma única célula, a menos que você configure essa célula para aceitar tipos limitados de dados. - Campos de múltiplos valores O Access fornece um recurso chamado campo de valores múltiplos, para anexar vários dados a um único registro e criar listas que aceitam vários valores. Você sempre pode identificar uma lista de valores múltiplos, pois o Access exibe uma caixa de marca ao lado de cada item da lista. Por exemplo, você pode anexar um conjunto de slides do Microsoft PowerPoint e qualquer número de imagens a um registro do seu banco de dados. Você também pode criar uma lista de nomes e selecionar quantos deles forem necessários. O uso de campos de valores múltiplos pode parecer violar as regras de design de banco de dados, pois você pode armazenar mais de um registro por campo da tabela. Mas o Access aplica as regras "nos bastidores", armazenando os dados em tabelas ocultas especiais.
- Usando formulários Você normalmente cria formulários quando deseja tornar um banco de dados mais fácil de usar e para ajudar a garantir que os usuários insiram dados com precisão. A maneira como você usa um formulário para editar dados depende do design do formulário. Os formulários podem conter vários controles, como listas, caixas de texto, botões e até mesmo folhas de dados. Por sua vez, cada um dos controles do formulário lê dados ou escreve dados em um campo de tabela subjacente.
Para obter mais informações, consulte Noções básicas sobre design de banco de dados e Criar uma tabela e adicionar campos.
Definir um valor padrão para um campo ou controle
Se um grande número de registros compartilhar o mesmo valor para um determinado campo, como uma cidade ou país/região, você poderá economizar tempo definindo um valor padrão para o controle associado a esse campo ou ao próprio campo. Quando você abre o formulário ou tabela para criar um novo registro, seu valor padrão aparece nesse controle ou campo.
Em uma tabela
- Abra a tabela do modo Design.
- Selecione o campo na parte superior da exibição.
- Na parte inferior da exibição, selecione a guia Geral .
- Defina a propriedade Valor Padrão com o valor desejado.
Em um formulário
- Abra o formulário no modo Layout ou Design.
- Clique com o botão direito do mouse no controle com o qual você deseja trabalhar e clique em Propriedades.
- Na guia Dados , defina a propriedade Valor Padrão com o valor desejado.
Usando regras de validação para limitar dados
Você pode validar dados em bancos de dados da área de trabalho do Access ao inseri-los usando regras de validação. As regras de validação podem ser definidas no modo folha de dados de tabela ou design da tabela. Há três tipos de regras de validação no Access:
- Regra de Validação de Campo Você pode usar uma regra de validação de campo para especificar um critério que deve ser atendido por todos os valores de campo válidos. Você não precisa especificar o campo atual como parte da regra, a menos que esteja usando o campo em uma função. As restrições nos tipos de caracteres a serem inseridos em um campo podem ser feitas de modo mais fácil com uma Máscara de Entrada. Por exemplo, um campo de data pode ter uma regra de validação que proíbe valores no passado.
- Regra de Validação de Registro Você pode usar uma regra de validação de registro para especificar uma condição à qual todos os registros válidos devem atender. Você pode comparar valores em diferentes campos usando uma regra de validação de registro. Por exemplo, um registro com dois campos de data pode exigir que os valores de um campo sempre precedam os valores do outro campo (por exemplo, StartDate anterior a EndDate).
- Validação em um formulário Você pode usar a propriedade Regra de Validação de um controle em um formulário para especificar um critério que todos os valores de entrada desse controle devem atender. As propriedades de controle da Regra de Validação funcionam como uma regra de validação de campo. Normalmente você usa uma regra de validação de formulário em vez de uma regra de validação do campo se a regra for específica apenas para esse formulário e não para a tabela, independentemente de onde for usada.
Para obter mais informações, consulte Restringir a entrada de dados usando regras de validação.
Trabalhar com listas de valores e campos Pesquisa
Há dois tipos de dados de lista no Access:
- Listas de valores Eles contêm um conjunto de valores embutido em código que você insere manualmente. Os valores residem na propriedade Origem da Linha do campo.
-
Campo Pesquisa Eles usam uma consulta para recuperar valores de outra tabela. A propriedade Origem da Linha do campo contém uma consulta em vez de uma lista de valores em código embutido. A consulta recupera valores de uma ou mais tabelas em um banco de dados. Por padrão, o campo de pesquisa apresenta esses valores na forma de uma lista. Dependendo de como você definiu o campo de pesquisa, você pode selecionar um ou mais itens dessa lista.
Observação Os campos de pesquisa podem confundir os novos usuários do Access, pois uma lista de itens aparece em um local (a lista que o Access cria a partir dos dados no campo de pesquisa), mas os dados podem residir em outro local (a tabela que contém os dados).
Por padrão, o Access exibe dados de lista em um controle de caixa de combinação, embora você possa especificar um controle de caixa de listagem. Uma caixa de combinação é aberta para apresentar a lista e fecha depois que você faz uma seleção. Uma caixa de listagem, por outro lado, permanece aberta o tempo todo.
Para editar listas, você também pode executar o comando Editar Itens de Lista ou editar os dados diretamente na propriedade Origem da Linha da tabela de origem. Ao atualizar os dados em um campo de pesquisa, você atualiza a tabela de origem.
Se a propriedade Tipo de Origem da Linha da caixa de listagem ou da caixa de combinação estiver definida como Lista de Valores, você poderá editar a lista de valores enquanto o formulário estiver aberto no modo Formulário, evitando a necessidade de alternar para o modo Design ou o modo Layout, abrir a folha de propriedades e editar a propriedade Fonte da Linha do controle sempre que precisar fazer uma alteração na lista. Para editar a lista de valores, a propriedade Permitir Edições da Lista de Valores da caixa de listagem ou da caixa de combinação deverá ser definida como Sim.
Para obter mais informações, consulte Criar uma lista de opções usando uma caixa de listagem ou uma caixa de combinação.
Impedir a edição da lista de valores no modo de exibição Formulário
- Clique com o botão direito do mouse no Painel de Navegação e, em seguida, clique no Modo de Exibição Design ou no Modo de Exibição Layout.
- Clique no controle para selecioná-lo e pressione F4 para exibir a folha de propriedades.
- Na guia Dados da folha de propriedades, defina a propriedade Permitir Edições da Lista de Valores como Não.
- Clique em Arquivo e clique em Salvar ou pressione Ctrl+S
.
Especificar um formulário diferente para a edição da lista de valores
Por padrão, o Access oferece um formulário interno usado para editar a lista de valores. Se você tiver outro formulário que prefira usar para essa finalidade, poderá inserir o nome do formulário na propriedade Formulário de Edição de Itens de Lista, da seguinte maneira:
- Clique com o botão direito do mouse no Painel de Navegação e, em seguida, clique no Modo de Exibição Design ou no Modo de Exibição Layout no menu de atalho.
- Clique no controle para selecioná-lo e pressione F4 para exibir a folha de propriedades.
- Na guia Dados da folha de propriedades, clique na seta suspensa na caixa de propriedades Formulário de Edição de Itens de Lista.
- Clique no formulário que você deseja usar para editar a lista de valores.
- Clique em Arquivo e clique em Salvar ou pressione Ctrl+S
.
Examinar um campo de pesquisa em um formulário
Abra o formulário no modo Layout ou Design.
Clique com o botão direito do mouse na caixa de listagem ou no controle da caixa de combinação e clique em Propriedades.
Na folha de propriedades, clique na guia Todos e localize as propriedades Tipo de Origem da Linha e Origem da Linha . A propriedade Tipo de Origem da Linha deve conter Lista de Valores ou Tabela/Consulta, e a propriedade Fonte da Linha deve conter uma lista de itens separados por ponto-e-vírgula ou uma consulta. Para obter mais espaço, clique com o botão direito do mouse na propriedade e selecione Zoom ou pressione Shift+F2.
Normalmente, as listas de valores usam esta sintaxe básica: "item";" item";" item"
Nesse caso, a lista é um conjunto de itens entre aspas duplas e separados por ponto-e-vírgula.
As consultas selecionadas usam esta sintaxe básica: SELECT [table_or_query_name].[ field_name**] FROM [table_or_query_name]**.
Nesse caso, a consulta contém duas cláusulas (SELECT e FROM). A primeira cláusula refere-se a uma tabela ou consulta e a um campo nessa tabela ou consulta. A segunda cláusula refere-se apenas à tabela ou consulta. Aqui está um ponto importante a ser lembrado: as cláusulas SELECT não precisam conter o nome de uma tabela ou consulta, embora seja recomendável, e devem conter o nome de pelo menos um campo. No entanto, todas as cláusulas FROM devem se referir a uma tabela ou consulta. Portanto, você sempre pode encontrar a tabela de origem ou a consulta de origem para um campo de pesquisa lendo a cláusula FROM.Siga um destes procedimentos:
- Se você estiver usando uma lista de valores, edite os itens na lista. Cerque cada item com aspas duplas e separe cada item com um ponto e vírgula.
- Se a consulta na lista de pesquisa fizer referência a outra consulta, abra essa segunda consulta no Modo Design (clique com o botão direito do mouse na consulta no Painel de Navegação e clique em Modo Design). Anote o nome da tabela que aparece na seção superior do designer de consultas e vá para a próxima etapa.
Caso contrário, se a consulta no campo Pesquisa fizer referência a uma tabela, anote o nome dela e vá para a próxima etapa.
Abra a tabela no modo Folha de Dados e edite os itens da lista conforme necessário.
Examinar um campo de pesquisa em uma tabela
Abra a tabela do modo Design.
Na seção superior da grade de design da consulta, na coluna Tipo de Dados , clique ou coloque o foco em qualquer campo Texto, Número ou Sim/Não.
Na seção inferior da grade de design da tabela, clique na guia Pesquisa e, em seguida, examine as propriedades Tipo de Origem da Linha e Origem da Linha .
A propriedade Tipo de Origem da Linha deve ler Lista deValores ou Tabela/Consulta. A propriedade Origem da Linha deve conter uma lista de valores ou uma consulta.
As listas de valores usam esta sintaxe básica: "item";" item";" item"
Nesse caso, a lista é um conjunto de itens entre aspas duplas e separados por ponto-e-vírgula.
Normalmente, as consultas seleção usam esta sintaxe básica: SELECT [table_or_query_name].[ field_name**] FROM [table_or_query_name]**.
Nesse caso, a consulta contém duas cláusulas (SELECT e FROM). A primeira cláusula refere-se a uma tabela ou consulta e a um campo nessa tabela ou consulta. A segunda cláusula refere-se apenas à tabela ou consulta. Aqui está um ponto importante a ser lembrado: as cláusulas SELECT não precisam conter o nome de uma tabela ou consulta, embora seja recomendável, e devem conter o nome de pelo menos um campo. No entanto, todas as cláusulas FROM devem se referir a uma tabela ou consulta. Portanto, você sempre pode encontrar a tabela de origem ou a consulta de origem para um campo de pesquisa lendo a cláusula FROM.Siga um destes procedimentos:
- Se você estiver usando uma lista de valores, edite os itens na lista. Cerque cada item com aspas duplas e separe cada item com um ponto e vírgula.
- Se a consulta no campo Pesquisa fizer referência a outra consulta, no Painel de Navegação, abra essa segunda consulta no modo Design (clique com o botão direito do mouse na consulta e clique em Modo Design). Anote o nome da tabela que aparece na seção superior do designer de consultas e vá para a próxima etapa.
Caso contrário, se a consulta no campo Pesquisa fizer referência a uma tabela, anote o nome dela e vá para a próxima etapa.
Abra a tabela no modo Folha de Dados e edite os itens da lista conforme necessário.
Excluindo os dados de uma lista de valores ou de um campo de Pesquisa
Os itens de uma lista de valores ficam na mesma tabela que os outros valores de um registro. Por outro lado, os dados em um campo de pesquisa residem em uma ou mais outras tabelas. Para remover dados de uma lista de valores, abra a tabela e edite os itens.
A remoção de dados de uma lista de pesquisa requer etapas adicionais, e essas etapas variam dependendo se a consulta das listas de pesquisa usa os dados de uma tabela ou de outra consulta. Se a consulta da lista de pesquisa for baseada em uma tabela, identifique essa tabela e o campo que contém os dados que aparecem na lista. Em seguida, abra a tabela de origem e edite os dados desse campo. Se a consulta da lista de pesquisa for baseada em outra consulta, abra essa segunda consulta, encontre a tabela de origem e o campo do qual a segunda consulta extrai os dados e altere os valores nessa tabela.
Remover dados de uma lista de valores
- Abra a tabela do modo Design.
- Na seção superior da grade de design, selecione o campo da tabela que contém a lista de valores.
- Na seção inferior da grade, clique na guia Pesquisa e localize a propriedade Fonte de Linha.
Por padrão, aspas duplas envolvem os itens em uma lista de valores e ponto-e-vírgulas separam cada item:"Excellent";"Fair";"Average";"Poor" - Conforme necessário, remova os itens da lista. Lembre-se de excluir as aspas ao redor de cada item excluído. Além disso, não deixe um ponto-e-vírgula no início, não deixe pares de ponto-e-vírgula juntos (;;) e, se você remover o último item na lista, exclua o ponto-e-vírgula final.
Importante Se você excluir um item de uma lista de valores e os registros na tabela já usarem esse item excluído, o item excluído permanecerá como parte do registro até que você o altere. Por exemplo, suponha que sua empresa tenha um depósito na Cidade A, mas vende esse prédio. Se você remover "Cidade A" da lista de depósitos, verá "Cidade A" na sua tabela até que você altere esses valores.
Remover dados de um campo de pesquisa
Abra a tabela do modo Design.
Na seção superior da grade de design, selecione o campo de pesquisa.
Na seção inferior da grade de design, clique na guia Pesquisa e localize as propriedades Tipo de Fonte de Linha e Fonte de Linha.
A propriedade Tipo de Fonte de Linha deve exibir Tabela/Consulta, e a propriedade Fonte de Linha deve conter uma consulta que faz referência a uma tabela ou a outra consulta. As consultas de campos de pesquisa sempre começam com a palavra SELECT.
Normalmente (mas nem sempre), uma consulta seleção usa esta sintaxe básica: SELECT [table_or_query_name].[ field_name*] FROM [table_or_query_name]*.
Nesse caso, a consulta contém duas cláusulas (SELECT e FROM). A primeira cláusula refere-se a uma tabela e um campo dessa tabela; já a segunda cláusula refere-se apenas à tabela. Lembre-se: a cláusula FROM sempre indicará o nome da consulta ou tabela de origem. Cláusulas SELECT nem sempre contêm o nome de uma tabela ou consulta, embora sempre contenham o nome de pelo menos um campo. No entanto, todas as cláusulas FROM devem se referir a uma tabela ou consulta.Siga um destes procedimentos:
- Se a consulta no campo Pesquisa fizer referência a outra consulta, clique no botão Compilar ( na guia Dados da folha de propriedades, clique no
a seguir) para abrir a consulta no modo Design. Anote o nome da tabela que aparece na seção superior do designer de consultas e prossiga para a etapa 5. - Se a consulta no campo Pesquisa fizer referência a uma tabela, anote o nome da tabela e prossiga para a etapa 5.
- Se a consulta no campo Pesquisa fizer referência a outra consulta, clique no botão Compilar ( na guia Dados da folha de propriedades, clique no
Abra a tabela de origem no modo Folha de Dados.
Localize o campo que contém os dados usados na lista de pesquisa e edite esses dados conforme necessário.
Como os tipos de dados afetam a maneira como você insere dados
Ao criar uma tabela de banco de dados, você seleciona um tipo de dados para cada campo dessa tabela, um processo que ajuda a garantir uma entrada de dados mais precisa.
Exibir tipos de dados
Siga um destes procedimentos:
Usar o modo Folha de Dados
- Abra a tabela no Modo Folha de Dados.
- Na guia Campos , no grupo Formatação , examine o valor na lista Tipo de Dados. O valor muda conforme você coloca o cursor nos vários campos da tabela:
Usar o modo Design
- Abra a tabela do modo Design.
- Observe a grade de design. A seção superior da grade mostra o nome e o tipo de dados de cada campo da tabela.
Como os tipos de dados afetam a entrada de dados
O tipo de dados que você define para cada campo da tabela fornece o primeiro nível de controle sobre que tipo de dados é permitido em um campo. Em alguns casos, como um campo de texto longo, você pode inserir os dados que desejar. Em outros casos, como um campo Numeração Automática, a configuração do tipo de dados do campo impede que você insira qualquer informação. A tabela a seguir lista os tipos de dados fornecidos pelo Access e descreve como eles afetam a entrada de dados.
Para obter mais informações, consulte Tipos de dados para bancos de dados da área de trabalho do Access e Modificar ou alterar a configuração de tipo de dados de um campo.
| Tipo de dados | Efeito na entrada de dados |
|---|---|
| Texto Curto | Os campos de texto curto aceitam caracteres numéricos ou de texto, incluindo listas delimitadas de itens. Um campo de texto aceita um número menor de caracteres do que um campo de texto longo, de 0 a 255 caracteres. Em alguns casos, você pode usar funções de conversão para realizar cálculos nos dados em um campo de texto curto. |
| Texto Longo | Você pode inserir grandes quantidades de texto e dados numéricos nesse tipo de campo, com até 64.000 caracteres. Além disso, se você definir o campo para dar suporte à formatação de rich text, poderá aplicar os tipos de formatação que normalmente encontra em programas de processamento de texto, como o Word. Por exemplo, você pode aplicar diferentes fontes e tamanhos de fonte a caracteres específicos no texto e torná-los em negrito ou itálico e assim por diante. Você também pode adicionar marcas HTML aos dados. Para obter mais informações, consulte Inserir ou adicionar um campo rich text. Além disso, os campos de texto longo têm uma propriedade chamada somente acréscimo. Ao habilitar essa propriedade, você pode acrescentar novos dados a um campo de texto longo, mas não pode alterar os dados existentes. O recurso destina-se ao uso em aplicativos como bancos de dados de acompanhamento de problemas, em que talvez seja necessário manter um registro permanente que permaneça inalterável. Quando você coloca o cursor em um campo de Texto Longo com a propriedade Acrescentar Somente habilitada, por padrão, o texto no campo desaparece. Você não pode aplicar formatação ou outras alterações ao texto. Assim como os campos de texto curto, você também pode executar funções de conversão em relação aos dados em um campo de texto longo. |
| Núm | Você pode inserir apenas números nesse tipo de campo e pode realizar cálculos sobre os valores em um campo Número. |
| Número Grande Observe que os tipos de dados Número Grande estão disponíveis apenas na versão de assinatura do Microsoft 365 do Access. |
Você pode inserir apenas números nesse tipo de campo e pode realizar cálculos sobre os valores em um campo Número Grande. Para obter mais informações, consulte Como usar o tipo de dados Número Grande. |
| Data e Hora | Você pode inserir apenas datas e horas nesse tipo de campo. Você pode definir uma máscara de entrada para o campo (uma série de caracteres literais e de espaço reservado que aparecem quando você seleciona o campo), você deve inserir dados nos espaços e no formato que a máscara fornece. Por exemplo, se você vir uma máscara como MMM_DD_YYYY, digite 11 de outubro de 2017 nos espaços fornecidos. Você não pode inserir um nome de mês completo ou um valor de ano de dois dígitos. Para obter mais informações, consulte Controlar formatos de entrada de dados com máscaras de entrada. Se você não criar uma máscara de entrada, poderá inserir o valor usando qualquer formato válido de data ou hora. Por exemplo, você pode digitar 11 de outubro de 2017, 11/10/17, 11 de outubro de 2017 e assim por diante. Você também pode aplicar um formato de exibição ao campo. Nesse caso, se nenhuma máscara de entrada estiver presente, você poderá inserir um valor em praticamente qualquer formato, mas o Access exibirá as datas de acordo com o formato de exibição. Por exemplo, você pode inserir 11/10/2017, mas o formato de exibição pode estar definido para exibir o valor como 11 de outubro de 2017. Para obter mais informações, consulte Inserir a data de hoje. |
| Moeda | Você pode inserir apenas valores de moeda nesse tipo de campo. Além disso, você não precisa inserir manualmente um símbolo monetário. Por padrão, o Access aplica o símbolo de moeda (¥, £, $, etc.) especificado nas configurações regionais do Windows. É possível alterar esse símbolo de moeda para refletir uma moeda diferente, se necessário. |
| Numeração Automática | Você não pode inserir ou alterar os dados nesse tipo de campo em nenhum momento. O Access incrementa os valores em um campo Numeração Automática sempre que você adiciona um novo registro a uma tabela. |
| Calculado | Você não pode inserir ou alterar os dados nesse tipo de campo em nenhum momento. Os resultados desse campo são determinados por uma expressão definida por você. O Access atualiza os valores em um campo calculado sempre que você adiciona ou edita um novo registro em uma tabela. |
| Sim/Não | Quando você clica em um campo definido como esse tipo de dados, o Access exibe uma caixa de marcação ou uma lista suspensa, dependendo de como você formata o campo. Se você formatar o campo para mostrar uma lista, poderá selecionar Sim ou Não, Verdadeiro ou Falso ou Ativado ou Desativado na lista, novamente dependendo do formato aplicado ao campo. Você não pode inserir valores na lista ou alterar os valores na lista diretamente de um formulário ou tabela. |
| Objeto OLE | Esse tipo de campo é usado quando você deseja exibir dados de um arquivo criado com outro programa. Por exemplo, você pode exibir um arquivo de texto, um gráfico do Excel ou um conjunto de slides do PowerPoint em um campo de Objeto OLE. Os anexos fornecem uma maneira mais rápida, fácil e flexível de exibir dados de outros programas. |
| Hiperlink | Você pode inserir qualquer dado nesse tipo de campo e o Access os encapsula em um endereço da Web. Por exemplo, se você digitar um valor no campo, o Access delimitará o texto com http://www.your_text**.com**. Se você inserir um endereço da Web válido, o link funcionará. Caso contrário, o link resultará em uma mensagem de erro. Além disso, a edição de hiperlinks existentes pode ser difícil, pois clicar com o mouse em um campo de hiperlink inicia o navegador e o leva para o site especificado no link. Para editar um campo de hiperlink, selecione um campo adjacente, use a tecla TAB ou as teclas de direção para mover o foco para o campo de hiperlink e pressione F2 para habilitar a edição. |
| Anexo | Você pode anexar dados de outros programas a esse tipo de campo, mas não pode digitar ou inserir dados numéricos ou de texto. Para obter mais informações, consulte Anexar arquivos e gráficos aos registros em seu banco de dados. |
| Assistente de Pesquisa | O Assistente de Pesquisa não é um tipo de dados. Em vez disso, use o assistente para criar dois tipos de listas suspensas: listas de valores e campos de pesquisa. Uma lista de valores usa uma lista delimitada de itens que você insere manualmente ao usar o Assistente de Pesquisa. Esses valores podem ser independentes de quaisquer outros dados ou objetos em seu banco de dados. Por outro lado, um campo de pesquisa usa uma consulta para recuperar dados de uma ou mais das outras tabelas em um banco de dados. Em seguida, o campo de pesquisa exibe os dados em uma lista suspensa. Por padrão, o Assistente de Pesquisa define o campo da tabela como o tipo de dados Número. Você pode trabalhar com campos de pesquisa diretamente em tabelas e também em formulários e relatórios. Por padrão, os valores em um campo de pesquisa aparecem em um tipo de controle de lista chamado caixa de combinação — uma lista que tem uma seta suspensa:
Você também pode usar uma caixa de listagem que exibe vários itens com uma barra de rolagem para ver mais itens:
Dependendo de como você definiu o campo de pesquisa e a caixa de combinação, é possível editar os itens na lista e adicionar itens à lista desativando a propriedade Limitar a Lista do campo de pesquisa. Se não for possível editar diretamente os valores em uma lista, você precisará adicionar ou alterar os dados em sua lista predefinida de valores ou na tabela que serve como fonte para o campo de pesquisa. Por fim, ao criar um campo de pesquisa, você pode, opcionalmente, defini-lo para dar suporte a vários valores. Ao fazer isso, a lista resultante exibirá uma caixa de marca ao lado de cada item da lista, e você poderá marcar ou desmarcar quantos itens forem necessários. Esta figura ilustra uma lista típica de vários valores:
Para obter informações sobre como criar campos de pesquisa de valores múltiplos e usar as listas resultantes, consulte Criar ou excluir um campo de valores múltiplos. |
Como as propriedades do campo da tabela afetam a maneira como você insere dados
Além dos princípios de design que controlam a estrutura de um banco de dados e os tipos de dados que controlam o que você pode inserir em um determinado campo, várias propriedades de campo também podem afetar o modo como você insere dados em um banco de dados do Access.
Exibir propriedades de um campo de tabela
O Access fornece duas maneiras de exibir as propriedades de um campo da tabela.
No modo Folha de Dados
- Abra a tabela no Modo Folha de Dados.
- Clique na guia Campos e use os controles no grupo Formatação para exibir as propriedades de cada campo da tabela.
No modo Design
- Abra a tabela do modo Design.
- Na parte inferior da grade, clique na guia Geral , caso ainda não esteja selecionada.
- Para ver as propriedades de um campo de pesquisa, clique na guia Pesquisa.
Como as propriedades afetam a entrada de dados
A tabela a seguir lista as propriedades que têm o maior impacto na entrada de dados e explica como elas afetam a entrada de dados.
| Propriedade | Local na grade de design da tabela | Valores possíveis | Comportamento ao tentar inserir dados |
|---|---|---|---|
| Tamanho do Campo | Guia Geral | 0-255 | O limite de caracteres se aplica somente aos campos definidos para o tipo de dados de texto. Se você tentar inserir mais do que o número especificado de caracteres, o campo os recortará. |
| Obrigatório | Guia Geral | Sim/Não | Quando ativada, essa propriedade força você a inserir um valor em um campo, e o Access não permitirá que você salve novos dados até que você preencha um campo obrigatório. Quando desativada, o campo aceitará valores nulos, o que significa que o campo pode permanecer em branco. Um valor nulo não é a mesma coisa que um valor zero. Zero é um dígito e "nulo" é um valor ausente, indefinido ou desconhecido. |
| Permitir cadeias de comprimento zero | Guia Geral | Sim/Não | Quando ativada, você pode inserir cadeias de comprimento zero, cadeias de caracteres que não contêm caracteres. Para criar uma cadeia de comprimento zero, insira um par de aspas duplas no campo (""). |
| Indexado | Guia Geral | Sim/Não | Quando você indexa um campo de tabela, o Access impede que você adicione valores duplicados. Você também pode criar um índice em mais de um campo. Se você fizer isso, poderá duplicar os valores em um campo, mas não em ambos os campos. |
| Máscara de entrada | Guia Geral | Conjuntos predefinidos ou personalizados de caracteres literais e de espaço reservado | Uma máscara de entrada força você a inserir dados em um formato predefinido. As máscaras aparecem quando você seleciona um campo em uma tabela ou um controle em um formulário. Por exemplo, suponha que você clique em um campo Data e veja este conjunto de caracteres: MMM-DD-AAAA. Essa é uma máscara de entrada. Ela força você a inserir valores mensais como abreviações de três letras, como OCT, e o valor do ano como quatro dígitos, por exemplo, 15-OCT-2017. As máscaras de entrada controlam apenas como você insere dados, não como o Access armazena ou exibe esses dados. Para obter mais informações, consulte Controlar formatos de entrada de dados com máscaras de entrada e Formatar um campo de data e hora. |
| Limitar à Lista | Guia Pesquisa | Sim/Não | Habilita ou desabilita alterações nos itens em um campo de pesquisa. Às vezes, os usuários tentam alterar os itens em um campo de pesquisa manualmente. Quando o Access impede que você altere os itens em um campo, essa propriedade é definida como Sim. Se esta propriedade estiver ativada e você precisar alterar os itens em uma lista, você deverá abrir a lista (se quiser editar uma lista de valores) ou a tabela que contém os dados de origem da lista (se quiser editar um campo de pesquisa) e alterar os valores lá. |
| Permitir Edições da Lista de Valores | Guia Pesquisa | Sim/Não | Habilita ou desabilita o comando Editar Itens de Lista para listas de valores, mas não para campos de pesquisa. Para habilitar esse comando para campos de pesquisa, insira um nome de formulário válido na propriedade Editar Formulário de Itens da Lista . O comando Permitir Edições da Lista de Valores aparece em um menu de atalho que você abre clicando com o botão direito do mouse em uma caixa de listagem ou controle de caixa de combinação. Quando você executa o comando, a caixa de diálogo Editar Itens da Lista aparece. Como alternativa, se você especificar o nome de um formulário na propriedade Editar Formulário de Itens de Lista , o Access iniciará esse formulário em vez de exibir a caixa de diálogo. Você pode executar o comando Editar Itens de Lista a partir de controles de caixa de listagem e caixa de combinação localizados em formulários e de controles de caixa de combinação localizados em tabelas e conjuntos de resultados de consulta. Os formulários devem ser abertos nos modos Design ou Navegação; As tabelas e os conjuntos de resultados de consultas devem ser abertos no modo Folha de Dados. |
| Formulário de Edição de Itens de Lista | Guia Pesquisa | Nome de um formulário de entrada de dados | Se você inserir o nome de um formulário de entrada de dados como o valor nessa propriedade da tabela, esse formulário será aberto quando um usuário executar o comando Editar Itens da Lista . Caso contrário, a caixa de diálogo Editar Itens da Lista aparecerá quando os usuários executarem o comando. |
Usar atualizações em cascata para alterar valores de chave primária e estrangeira
Às vezes, pode ser necessário atualizar um valor de chave primária. Se você usar essa chave primária como uma chave estrangeira, poderá atualizar automaticamente suas alterações por meio de todas as instâncias filho da chave estrangeira.
Como lembrete, uma chave primária é um valor que identifica exclusivamente cada linha (registro) em uma tabela de banco de dados. Uma chave estrangeira é uma coluna que corresponde à chave primária. Normalmente, as chaves estrangeiras residem em outras tabelas e permitem que você crie uma relação (um link) entre os dados nas tabelas.
Por exemplo, suponha que você use um número de ID de produto como chave primária. Um número de identificação identifica exclusivamente um produto. Você também usa esse número de ID como uma chave estrangeira em uma tabela de dados do pedido. Dessa forma, você pode encontrar todos os pedidos que envolvem cada produto, pois sempre que alguém faz um pedido para aquele produto, o ID passa a fazer parte do pedido.
Às vezes, esses números de ID (ou outros tipos de chaves primárias) mudam. Quando isso acontecer, você poderá alterar o valor da chave primária e fazer com que essa alteração se espalhe automaticamente por todos os registros filho relacionados. Você habilita esse comportamento ativando a integridade referencial e as atualizações em cascata entre as duas tabelas.
Lembre-se destas regras importantes:
- Você pode ativar atualizações em cascata somente para campos de chave primária definidos como tipos de dados Texto ou Número. Não é possível usar atualizações em cascata para campos definidos como o tipo de dados Numeração Automática.
- Você pode habilitar atualizações em cascata somente entre tabelas com uma relação um-para-muitos.
Para obter mais informações sobre como criar relações. confira Guia para relações de tabelas e Criar, editar ou excluir uma relação.
Os procedimentos a seguir explicam como primeiro criar uma relação e, em seguida, habilitar atualizações em cascata para essa relação.
Criar a relação
- Na guia Ferramentas de Banco de dados, no grupo Mostrar/Ocultar, clique em Relações.
- Na guia Design , no grupo Relações , clique em Adicionar Tabelas (Mostrar Tabela no Access).
- Selecione a guia Tabelas , selecione as tabelas a serem alteradas, clique em Adicionar e em Fechar.
Você pode pressionar SHIFT para selecionar várias tabelas ou pode adicionar cada tabela individualmente. Selecione somente as tabelas nos lados "um" e "muitos" da relação. - Na janela Relações , arraste a chave primária da tabela no lado "um" da relação e solte-a no campo Chave estrangeira da tabela no lado "muitos" da relação.
A caixa de diálogo Editar Relações é exibida. A figura a seguir mostra a caixa de diálogo:
- Marque a caixa de marcar Impor Integridade Referencial e clique em Criar.
Habilitar atualizações em cascata em chaves primárias
- Na guia Ferramentas de Banco de dados, no grupo Mostrar/Ocultar, clique em Relações.
- A janela Relações é exibida e exibe as junções (mostradas como linhas de conexão) entre as tabelas no banco de dados. A figura a seguir mostra uma relação típica:
- Clique com o botão direito do mouse na linha de junção entre as tabelas pai e filho e clique em Editar Relação.
A caixa de diálogo Editar Relações é exibida. A figura a seguir mostra a caixa de diálogo:
- Selecione Propagar Atualização dos Campos Relacionados, verifique se a caixa de marca Impor Integridade Referencial está marcada e clique em OK.
Por que os números de identificação às vezes parecem ignorar um número
Quando você cria um campo definido como o tipo de dados Numeração Automática, o Access gera automaticamente um valor para esse campo em cada novo registro. O valor é incrementado por padrão, de modo que cada novo registro obtenha o próximo número sequencial disponível. O objetivo do tipo de dados Numeração Automática é fornecer um valor adequado para uso como uma chave primária. Para obter mais informações , consulte Adicionar, definir, alterar ou remover a chave primária.
Quando você exclui uma linha de uma tabela que contém um campo definido como o tipo de dados Numeração Automática, o valor no campo Numeração Automática para essa linha nem sempre é reutilizado automaticamente. Por esse motivo, o número gerado pelo Access pode não ser o número que você espera ver, e podem aparecer lacunas na sequência de números de ID — isso é intencional. Você deve confiar apenas na exclusividade dos valores em um campo Numeração Automática, e não em sua sequência.
Atualização de dados em massa usando consultas
As consultas Acrescentar, Atualizar e Excluir são maneiras avançadas de adicionar, alterar ou remover registros em massa. Além disso, as atualizações em massa são mais fáceis e eficientes de executar quando você usa bons princípios de design de banco de dados. Usar uma consulta acréscimo, atualização ou exclusão pode economizar tempo, pois você também pode reutilizar a consulta.
Importante Faça backup dos dados antes de usar essas consultas. Ter um backup em mãos pode ajudá-lo a corrigir rapidamente quaisquer erros que você possa cometer inadvertidamente.
Acrescentar consultas Use para adicionar muitos registros a uma ou mais tabelas. Um dos usos mais freqüentes de uma consulta acréscimo é adicionar um grupo de registros de uma ou mais tabelas em um banco de dados de origem a uma ou mais tabelas em um banco de dados de destino. Por exemplo, suponha que você adquira alguns novos clientes e um banco de dados contendo uma tabela de informações sobre esses clientes. Para evitar inserir esses novos dados manualmente, você pode anexá-los à tabela ou tabelas apropriadas em seu banco de dados. Para obter mais informações, consulte Adicionar registros a uma tabela usando uma consulta acréscimo.
Atualizar consultas Use para adicionar, alterar ou excluir parte (mas não todos) dos muitos registros existentes. Veja as consultas atualização como uma forma avançada da caixa de diálogo Localizar e substituir. Você insere um critério de seleção (o equivalente aproximado de uma cadeia de caracteres de pesquisa) e um critério de atualização (o equivalente aproximado de uma cadeia de caracteres de substituição). Ao contrário da caixa de diálogo, as consultas de atualização podem aceitar vários critérios, permitir que você atualize um grande número de registros de uma só vez e alterar registros em mais de uma tabela. Para obter mais informações, consulte Criar e executar uma consulta de atualização.
Excluir consultas Quando você deseja excluir rapidamente muitos dados ou excluir um conjunto de dados regularmente, uma exclusão é útil porque as consultas possibilitam especificar critérios para localizar e excluir os dados rapidamente. Para obter mais informações , consulte Maneiras de adicionar, editar e excluir registros.