Importante
O suporte para o Microsoft InfoPath 2013 terminou em 14 de julho de 2026. Recomendamos migrar formulários e fluxos de trabalho existentes do InfoPath para soluções compatíveis do Microsoft 365. Saiba mais sobre a desativação do InfoPath.
Se os usuários precisarem de dados de um banco de dados do Microsoft Office Access 2007 (formato .accdb) ou de um banco de dados do Access salvo em uma versão anterior (formato .mdb) para preencher um formulário com base em seu modelo de formulário do Microsoft Office InfoPath, você pode adicionar uma conexão de dados secundária ao seu modelo de formulário que consulta um banco de dados do Access.
Você pode adicionar uma conexão de dados secundária, mas essa conexão de dados só pode consultar um banco de dados do Access. Não é possível adicionar uma conexão de dados secundária que envie dados de formulário para um banco de dados do Access.
Se você deseja que seus usuários enviem seus dados de formulário para um banco de dados do Access, você pode criar um modelo de formulário baseado em um banco de dados do Access e, em seguida, habilitar o envio de conexão de dados na conexão de dados principal. Como alternativa, você pode adicionar uma conexão de dados secundária a um serviço Web que funcione com seu banco de dados do Access.
Encontre links para obter mais informações sobre como criar modelos de formulário baseados em um banco de dados do Access e adicionar uma conexão de dados secundária a um serviço Web na seção Consulte também .
Neste artigo
- Visão geral
- Considerações de compatibilidade
- Antes de você começar
- Etapa 1: adicionar uma conexão de dados secundária
- Etapa 2: Configurar o modelo de formulário para usar a conexão de dados
Visão Geral
Uma conexão de dados secundária é uma conexão de dados que você adiciona a um modelo de formulário. Uma conexão de dados secundária é diferente da conexão de dados principal, que você cria ao criar um novo modelo de formulário baseado em um banco de dados ou um serviço Web. A conexão de dados principal de um modelo de formulário pode receber dados de uma fonte de dados externa e também pode enviar dados de formulário para uma fonte de dados externa. No entanto, um modelo de formulário pode ter apenas uma conexão de dados principal.
Você pode adicionar tantas conexões de dados secundárias a um modelo de formulário quantas desejar. Por exemplo, vamos supor que você tenha um banco de dados do Access que contenha uma tabela que armazene dados de funcionários e outra tabela que armazene dados de clientes. Você pode adicionar uma conexão de dados secundária que recupera dados da tabela de funcionários e também pode adicionar outra conexão de dados secundária que recupera dados da tabela cliente no mesmo banco de dados do Access.
Embora seja possível adicionar uma conexão de dados secundária ao seu modelo de formulário que possa enviar dados de formulário para uma fonte de dados externa, como um serviço Web ou uma biblioteca do Windows SharePoint Services, você só pode usar conexões de dados secundárias para recuperar dados de um banco de dados do Access. Não é possível adicionar uma conexão de dados secundária que envie dados de formulário para um banco de dados do Access.
Quando você adiciona uma conexão de dados de consulta a um banco de dados, o InfoPath cria uma fonte de dados secundária que contém campos e grupos de dados que correspondem à maneira como os dados são armazenados no banco de dados. Como a estrutura de dados na fonte de dados secundária deve corresponder à maneira como os dados são armazenados nas tabelas de banco de dados, você não pode modificar os campos ou grupos na fonte de dados secundária.
Você pode configurar cada conexão de dados de consulta para salvar seus resultados para que os usuários tenham acesso aos dados quando o formulário não estiver conectado a uma rede. Dependendo da natureza dos dados, talvez você queira exibir os resultados da consulta somente quando os usuários estiverem conectados a uma rede.
Observação
Se você estiver usando uma conexão de dados secundária para recuperar dados confidenciais de uma fonte de dados externa, convém desabilitar esse recurso para ajudar a proteger os dados contra uso não autorizado em caso de perda ou roubo do computador. Se você desabilitar esse recurso, os dados estarão disponíveis somente se o usuário estiver conectado à rede.
Quando você adiciona uma conexão de dados de consulta a um modelo de formulário, por padrão, os formulários baseados nesse modelo de formulário usam a conexão de dados quando são abertos por um usuário. Você também pode configurar seu modelo de formulário para usar a conexão de dados de consulta de uma das seguintes maneiras:
- Adicionar uma regra Você pode configurar uma regra para usar a conexão de dados de consulta sempre que a condição na regra ocorrer.
- Adicionar um botão Você pode adicionar um botão ao modelo de formulário no qual os usuários podem clicar para obter dados usando a conexão de dados de consulta.
- Usar código personalizado Se não for possível adicionar uma regra ou um botão, você poderá usar um código personalizado para obter dados usando a conexão de dados de consulta. O uso de código personalizado exige que um desenvolvedor crie o código personalizado.
Considerações de compatibilidade
Não é possível adicionar uma conexão de dados a um banco de dados do Access a um modelo de formulário compatível com o navegador.
Antes de começar
Antes de adicionar uma conexão de dados secundária a um banco de dados do Access ao seu modelo de formulário, você precisa das seguintes informações:
O nome e o local do banco de dados.
Observação
Se o banco de dados do Access estiver armazenado em um local de rede, verifique se o banco de dados está acessível aos usuários.
O nome da tabela ou consulta que fornecerá dados aos formulários com base nesse modelo de formulário. Você usará essa tabela ou consulta como a tabela ou consulta primária ao configurar a conexão de dados da consulta.
Os nomes de quaisquer outras tabelas ou consultas que fornecem dados adicionais para a tabela ou consulta primária. Na maioria dos casos, as relações de tabelas já estão estabelecidas no banco de dados. Se você tiver que estabelecer manualmente as relações entre a tabela ou consulta primária e outra tabela ou consulta, precisará dos nomes dos campos relacionados de ambas as tabelas ou consultas.
Etapa 1: adicionar uma conexão de dados secundária
No menu Ferramentas , clique em Conexões de Dados.
Na caixa de diálogo Conexões de Dados , clique em Adicionar.
No Assistente para Conexões de Dados, clique em Criar uma nova conexão com, em Receber dados e em Avançar.
Na próxima página do assistente, clique em Banco de Dados (somente Microsoft SQL Server ou Microsoft Office Access) e, em seguida, clique em Avançar.
Na próxima página do assistente, clique em Selecionar Banco de Dados.
Na caixa de diálogo Selecionar Fonte de Dados , navegue até o local do banco de dados.
Observação
Se o banco de dados estiver armazenado em um local de rede, navegue até o caminho UNC (convenção de nomenclatura universal) do local. Não navegue até o local da rede por meio de uma unidade de rede mapeada. Se você usar uma unidade de rede mapeada, os usuários que criarem formulários com base nesse modelo de formulário pesquisarão o banco de dados em uma unidade de rede mapeada. Se o usuário não tiver uma unidade de rede mapeada, o formulário não encontrará o banco de dados.
Clique no nome do banco de dados e clique em Abrir.
Na caixa de diálogo Selecionar Tabela, clique na tabela ou consulta principal que você deseja usar e clique em OK.
Na próxima página do assistente, marque a caixa Mostrar colunas da tabela marcar.
Por padrão, todos os campos na tabela ou consulta são adicionados à fonte de dados principal do modelo de formulário.Desmarque as caixas de marca dos campos que não deseja incluir na fonte de dados secundária.
Adicione outras tabelas ou consultas à conexão de dados.
Quão?- Clique em Adicionar Tabela.
- Na caixa de diálogo Adicionar Tabela ou Consulta , clique no nome da tabela filho e clique em Avançar. O InfoPath tenta definir as relações fazendo a correspondência de nomes de campo em ambas as tabelas. Se você não quiser usar a relação sugerida, selecione-a e clique em Remover relação. Para adicionar uma relação, clique em Adicionar relação. Na caixa de diálogo Adicionar Relação, clique no nome de cada campo relacionado na respectiva coluna e clique em OK.
- Clique em Concluir.
- Para adicionar outras tabelas filho, repita estas etapas.
Clique em Avançar.
Para disponibilizar os resultados da conexão de dados da consulta quando o formulário não estiver conectado a uma rede, marque a caixa marcar armazenar uma cópia dos dados no modelo de formulário.
Observação
Marcar essa caixa de marcação armazena os dados no computador do usuário quando o formulário usa essa conexão de dados. Se o formulário estiver recuperando dados confidenciais dessa conexão de dados, convém desabilitar esse recurso para ajudar a proteger os dados em caso de perda ou roubo do computador.
Clique em Avançar.
Na próxima página do assistente, digite um nome descritivo para essa conexão de dados secundária e verifique se as informações na seção Resumo estão corretas.
Para configurar o formulário para receber dados automaticamente quando o formulário for aberto, marque a caixa marcar Recuperar dados automaticamente quando o formulário for aberto.
Etapa 2: Configurar o modelo de formulário para usar a conexão de dados
Se quiser que os formulários baseados nesse modelo de formulário usem essa conexão de dados depois que o usuário abrir o formulário, você pode adicionar uma regra ao modelo de formulário que usa essa conexão de dados sob uma determinada condição, ou pode adicionar um botão ao modelo de formulário no qual os usuários podem clicar para usar essa conexão de dados.
Adicionar uma regra
Você pode adicionar uma regra ao modelo de formulário que serve para recuperar dados da conexão de dados da consulta sempre que a condição para a regra for atendida. Por exemplo, você pode adicionar uma caixa de texto ao seu modelo de formulário que um usuário pode preencher para obter dados específicos de uma fonte de dados externa. Em seguida, você pode adicionar uma regra que usa a conexão de dados sempre que um usuário insere dados na caixa de texto.
O procedimento a seguir pressupõe que você tenha criado uma conexão de dados de consulta para seu modelo de formulário e que tenha configurado um controle (diferente de um botão) em seu modelo de formulário para exibir os dados dessa conexão de dados.
- Se o modelo de formulário tiver vários modos de exibição, clique em Nome do modo de exibição no menu Exibir para acessar o modo de exibição com o controle onde você deseja exibir os dados da fonte de dados secundária.
- Clique duas vezes no controle ao qual você deseja adicionar uma regra.
- Clique na guia Dados.
- Em Validação e Regras, clique em Regras.
- Na caixa de diálogo Regras , clique em Adicionar.
- Na caixa Nome , digite um nome para a regra.
- Para especificar uma condição de quando a regra deve ser executada, clique em Definir Condição e insira a condição. A regra será executada quando a condição ocorrer. Se você não definir uma condição, a regra será executada sempre que o usuário alterar o valor no controle e, em seguida, mover o cursor para longe desse controle.
- Clique em Adicionar Ação.
- Na lista Ação , clique em Consulta usando uma conexão de dados.
- Na lista Conexão de dados , clique na conexão de dados da consulta que você deseja usar e clique em OK para fechar cada caixa de diálogo aberta.
- Para testar as alterações, clique Visualizar na barra de ferramentas Padrão ou pressione CTRL+SHIFT+B.
Adicionar um botão
Você pode adicionar um controle de botão ao seu modelo de formulário no qual os usuários podem clicar para obter dados da conexão de dados da consulta.
Se o modelo de formulário tiver vários modos de exibição, clique em Nome do modo de exibição no menu Exibir para acessar o modo de exibição com o controle onde você deseja exibir os dados da fonte de dados secundária.
Se o painel de tarefas Controles não estiver visível, clique em Mais Controles no menu Inserir, ou pressione ALT+I, C.
Arraste um controle de botão até o modelo de formulário.
Clique duas vezes no botão de controle que você acabou de adicionar ao modelo de formulário.
Clique na guia Geral.
Na lista Ação , clique em Atualizar.
Na caixa Rótulo , digite o nome que você deseja que apareça no botão do seu modelo de formulário.
Clique em Configurações.
Na caixa de diálogo Atualizar , siga um destes procedimentos:
- Para receber os dados mais recentes de todas as fontes de dados externas com conexões de dados secundárias para este modelo de formulário, clique em Todas as fontes de dados secundárias.
- Para configurar o botão para receber os dados mais recentes de uma fonte de dados externa com uma conexão de dados secundária com seu modelo de formulário, clique em Uma conexão de dados secundária e, em seguida, clique em uma fonte de dados secundária na lista Escolher a fonte de dados secundária .
Clique em OK para fechar cada caixa de diálogo aberta.
Para testar as alterações, clique Visualizar na barra de ferramentas Padrão ou pressione CTRL+SHIFT+B.