Importante
O suporte para o Microsoft InfoPath 2013 terminou a 14 de julho de 2026. Recomendamos a migração de formulários e fluxos de trabalho existentes do InfoPath para soluções suportadas do Microsoft 365. Saiba mais sobre a descontinuação do InfoPath.
Embora seja verdade que pode utilizar o Microsoft Office Word para criar um documento com um aspeto e funcionalidade de formulário, Word funciona melhor como um programa de processamento de texto e não como um programa de design de formulários. Por outro lado, o Microsoft Office InfoPath foi criado especificamente para projetar e preencher formulários eletrônicos. Se pretender converter documentos Word existentes em modelos de formulário do InfoPath, pode utilizar o Assistente de Importação no InfoPath para o fazer. Em seguida, pode tirar partido das funcionalidades dedicadas do InfoPath para estruturar, publicar e preencher formulários. Por exemplo, num modelo de formulário de relatório de vendas, pode utilizar a formatação condicional para aplicar automaticamente um fundo vermelho quando os números descem abaixo das projeções de vendas. No mesmo modelo de formulário, você pode usar uma regra para permitir que formulários baseados nesse modelo de formulário sejam enviados como um anexo em uma mensagem de email quando alguém clicar em um botão Enviar. Além disso, você pode disponibilizar seu modelo de formulário para um público mais amplo criando um modelo de formulário habilitado para navegador.
Ao converter um documento Word num modelo de formulário do InfoPath, o modelo de formulário resultante será aproximadamente igual ao esquema do documento Word. Além disso, os itens no documento Word que cumprem determinadas condições são automaticamente convertidos nos controlos adequados nos quais os utilizadores podem introduzir dados. Por exemplo, se o documento Word contiver parênteses retos em torno de vários espaços, o InfoPath assume que utilizou essa área com parênteses como um campo de entrada de texto e converte-a num controlo de caixa de texto no modelo de formulário resultante. Todos os campos de formulário Word são convertidos nos controlos correspondentes no InfoPath.
Pode utilizar as definições na caixa de diálogo Opções de Importação para alterar as opções de conversão de um documento Word num modelo de formulário do InfoPath.
Este artigo explica o conceito e o procedimento básicos para converter um documento Word num modelo de formulário do InfoPath, incluindo as funcionalidades e definições que não são suportadas no processo de conversão.
Neste artigo
- Acerca da conversão de um documento Word num modelo de formulário do InfoPath
- Word funcionalidades e definições que não são totalmente suportadas durante a conversão
- Converter um documento do Word em um modelo de formulário do InfoPath
- Alterar uma tabela de esquema para uma tabela de repetição
- Alterar as caixas de seleção para um grupo de botões de opção
- Rever problemas de conversão no painel de tarefas Verificador de Design
Acerca da conversão de um documento Word num modelo de formulário do InfoPath
Quando converte um documento Word num modelo de formulário do InfoPath, o documento é utilizado como um plano para criar um novo modelo de formulário. A estrutura básica do documento é recriada o mais próximo possível no modelo de formulário. Num documento Word, um "campo de formulário" é a localização onde um determinado tipo de dados, como um nome ou endereço, é armazenado. Se optar por incluir Word campos de formulário ao converter o documento, serão adicionados controlos de caixa de texto, caixa de marcar e caixa de lista pendente ao modelo de formulário do InfoPath numa localização que corresponda à localização dos campos no documento Word. Além disso, o InfoPath deteta automaticamente as partes do documento Word que podem funcionar bem como tabelas de repetição e caixas de texto formatado e converte-as nos controlos adequados. Por exemplo, se um documento de relatório de despesas incluir uma área em branco sublinhada na qual os utilizadores possam escrever notas sobre uma despesa específica, o InfoPath irá converter essa área numa caixa de rich text. Em seguida, os utilizadores podem escrever várias linhas de texto na caixa de rich text e formatar esse texto conforme adequado.
Para compreender melhor a relação entre um documento Word que converte com o Assistente de Importação do InfoPath e o modelo de formulário do InfoPath resultante, imagine que nos últimos anos a sua organização tem utilizado um documento Word denominado ExpenseReport.doc para recolher dados do relatório de despesas dos funcionários. O seu departamento de TI quer converter esse documento num modelo de formulário do InfoPath para que os dados de formulário possam ser submetidos como linguagem XML (Extensible Markup Language) para um sistema de Contas a Pagar.
Se você usar o Assistente de Importação para converter ExpenseReport.doc em um modelo de formulário, o InfoPath criará um modelo de formulário chamado ExpenseReport.xsn. No exemplo seguinte, a tabela Detalhes de Despesas no documento Word foi convertida numa tabela de repetição no modelo de formulário do InfoPath resultante. A tabela de repetição permite que os usuários insiram ou removam despesas, conforme necessário, clicando em comandos em um menu de atalho.
Quando o documento Word é convertido em um modelo de formulário do InfoPath, o layout e outros elementos são preservados. Por predefinição, o número de linhas vazias na tabela de repetição do InfoPath corresponde ao número de linhas vazias na tabela Word. No entanto, pode poupar espaço no seu modelo de formulário ao apresentar apenas uma ou duas linhas por predefinição.
Este novo modelo de formulário contém elementos semelhantes aos encontrados no documento Word, como a tabela de recolha de informações de despesas. No entanto, dependendo das configurações escolhidas no Assistente de importação, alguns recursos podem diferir no modelo de formulário resultante:
- Se utilizar o Assistente de Importação para importar o documento Word preservando apenas o esquema O modelo de formulário resultante contém uma tabela de repetição para inserir itens de linha no relatório de despesas. No entanto, todos os campos de formulário do documento original, como a caixa de texto Nome, a lista suspensa Departamento e as caixas marcar Divisão, serão descartados do modelo de formulário resultante.
- Se utilizar o Assistente de Importação para importar o documento Word preservando o esquema e convertendo Word campos do formulário em controlos (predefinição) O modelo de formulário resultante contém uma tabela de repetição para introduzir itens de linha no relatório de despesas. Todos os campos de formulário do documento original, como a caixa de texto Nome, a lista suspensa Departamento e as caixas marcar Divisão, são convertidos nos controles do InfoPath correspondentes.
- Se utilizar o Assistente de Importação para importar a Word documento, preservando o esquema e convertendo campos de formulário em controlos (personalizados), pode decidir exatamente que campos são convertidos quando importa o relatório de despesas. Por exemplo, pode desativar a opção para converter células de tabela vazias no documento em caixas de texto no modelo de formulário resultante.
Word funcionalidades e definições que não são totalmente suportadas durante a conversão
Algumas definições e formatação em documentos Word não são suportadas nos modelos de formulário do InfoPath. Quando converte um documento Word que contém essas definições, o modelo de formulário resultante não irá conter essas funcionalidades ou definições. Por exemplo, se o documento Word tiver marcas de revisão, as marcas de revisão serão descartadas no modelo de formulário resultante porque o InfoPath não oferece suporte a esse recurso.
Pode utilizar o painel de tarefas Verificador de Design no modo de estrutura para detetar quaisquer problemas com a conversão. Em seguida, você pode tomar medidas para corrigir esses problemas.
Segue-se uma lista de funcionalidades e definições que não são preservadas quando converte um documento Word num modelo de formulário do InfoPath. Em alguns casos, a formatação é eliminada mas o texto subjacente é preservado. Por exemplo, se tiver colunas em estilo de newsletter, o InfoPath irá eliminar as colunas, mas importará o texto contido nessas colunas.
- Indicadores
- Texto animado
- Temas
- Marcas-d'água
- Numeração de linha
- Bordas de página
- Notas de rodapé e notas de fim
- Esquemas de coluna em estilo de newsletter
- Anexos de arquivos
- Objetos ligados ou incorporados, tais como folhas de cálculo do Microsoft Office Excel e desenhos do Microsoft Office Visio
- Objetos de desenho (incluindo Formas Automáticas, curvas, linhas e WordArt)
- Espaçamento entre carateres (incluindo dimensionamento, espaçamento expandido ou condensado, posicionamento elevado ou rebaixado do texto e kerning para tipos de letra)
- Controles ActiveX
- Comentários e alterações registadas (incluindo inserções, eliminações e alterações de formatação)
- Algumas funcionalidades específicas do Microsoft Office Word 2007 (incluindo blocos modulares e controlos de conteúdo)
- Algumas definições de impressão (incluindo formatação de carateres mistos nos cabeçalhos e rodapés, cabeçalhos e rodapés pares e ímpares diferentes, cabeçalhos e rodapés diferentes para a primeira página, definições de medianiz, valores negativos para as margens superior e inferior, orientações de página diferentes e definições de secção individuais)
Observação
Alguns Word documentos não podem ser modificados sem uma palavra-passe. Se for este o caso do seu documento, poderá não conseguir importá-lo com êxito para o InfoPath. Para corrigir o problema, tente remover a proteção por palavra-passe do documento antes de o importar. Além disso, alguns documentos restringem os utilizadores a determinados tipos de ações de edição, tais como introduzir dados em campos de formulário. Se for este o caso do seu documento, poderá não conseguir importá-lo com êxito para o InfoPath. Para corrigir este problema, experimente remover as restrições de edição do seu documento antes de o importar.
A lista seguinte explica as funcionalidades e definições parcialmente suportadas quando converte um documento Word num modelo de formulário do InfoPath:
Texto vertical O InfoPath retém formatação de texto vertical num documento Word se o texto vertical estiver dentro de uma célula de tabela. O InfoPath elimina a formatação de texto vertical ao converter um documento Word se o texto vertical for encontrado fora da célula de uma tabela, noutra parte do documento Word.
Caixas de texto Em documentos Word, as caixas de texto são contentores para texto que podem ser posicionados numa página e dimensionados. Se o documento Word contiver uma caixa de texto, essa caixa de texto será convertida numa célula de tabela no modelo de formulário resultante. Qualquer texto na caixa de texto aparecerá na célula da tabela no modelo de formulário resultante.
Texto sublinhado O sublinhado é suportado nos modelos de formulário do InfoPath. No entanto, todos os sublinhados decorativos ou duplos no documento Word são convertidos em sublinhado simples no modelo de formulário resultante.
Hiperligações que fazem referência a protocolos não suportados Todas as hiperligações são convertidas, mas se a hiperligação utilizar um protocolo diferente de HTTP, HTTPS, FILE, FTP ou MAILTO, a hiperligação não funcionará quando um utilizador clicar na ligação no modelo de formulário resultante.
Estilos de carateres e efeitos de texto Os estilos de formatação superior à linha, inferior à linha e rasurado simples são preservados durante o processo de conversão. Outros estilos e efeitos de formatação, incluindo texto delineado, texto oculto e formatação de sombra são eliminados durante o processo de conversão. O texto em relevo ou gravado é convertido em texto cinzento no modelo de formulário resultante.
Definições da secção No Word, as secções são utilizadas para variar o esquema de um documento dentro de uma página ou entre páginas. O InfoPath não suporta estes tipos de secções, que são eliminadas durante o processo de conversão. Quaisquer definições que sejam aplicadas à primeira secção no documento Word serão aplicadas ao modelo de formulário do InfoPath resultante.
Formatação de cabeçalho e rodapé O texto do cabeçalho e rodapé no documento Word será convertido em texto de cabeçalho e rodapé no modelo de formulário do InfoPath resultante. Alguma formatação de carateres pode ser eliminada durante o processo de conversão. Por exemplo, se tiver utilizado as formatações negrito e itálico no cabeçalho de um documento Word, o InfoPath utilizará o primeiro estilo de formatação que encontrar no modelo de formulário resultante e eliminará a formatação restante. Da mesma forma, quaisquer definições que sejam aplicadas à primeira secção de cabeçalho ou rodapé no documento de Word são aplicadas ao texto de cabeçalho ou rodapé resultante no modelo de formulário do InfoPath.
Conversão de tipos de letra Embora o InfoPath importe as fontes de um documento Word ao criar um novo modelo de formulário, se as fontes no documento não estiverem disponíveis no computador onde você faz a importação, fontes alternativas serão selecionadas automaticamente para o modelo de formulário.
Margens de página negativas As margens negativas superior e inferior serão importadas como 0.
Definições de margem, preenchimento e avanço negativos As definições de margem negativa, preenchimento e avanço serão importadas como 0.
Converter um documento do Word em um modelo de formulário do InfoPath
Se o documento Word que pretende importar estiver aberto, feche-o.
No modo de design, no menu Arquivo , clique em Importar Formulário.
No Assistente de Importação, clique em Importador do InfoPath para documentos Word e, em seguida, clique em Avançar.
Clique em Procurar.
Localize e clique no documento Word que pretende converter e, em seguida, clique em Abrir.
Observação
Se estiver a importar um documento Word com permissão restrita, tem de ter acesso de Controlo Total ao documento. Se apenas tiver acesso de Leitura ou Alteração ao documento, verá uma mensagem de erro quando tentar importá-lo.
Para alterar o comportamento de importação predefinido, clique em Opções e, em seguida, selecione as opções pretendidas.
Clique em Concluir.
Alterar uma tabela de esquema para uma tabela de repetição
Se o documento Word incluir uma tabela, o InfoPath poderá convertê-la numa tabela de esquema ou numa tabela de repetição no modelo de formulário resultante. O tipo de tabela escolhido depende das decisões de estrutura que tomou no documento Word. Pode utilizar o procedimento seguinte para alterar rapidamente uma tabela de esquema convertida para uma tabela de repetição.
Pode utilizar tabelas de repetição para oferecer aos seus utilizadores um grau extra de flexibilidade no preenchimento de formulários. Quando utiliza tabelas de repetição, o seu modelo de formulário não tem de apresentar várias linhas em branco quando o utilizador o abre pela primeira vez. Em vez disso, os utilizadores normalmente só veem uma linha e só adicionam mais quando e se precisarem. Isso economiza espaço no formulário e oferece aos usuários um grau extra de personalização.
No modelo de formulário, clique com o botão direito do rato em qualquer parte da tabela de esquema que pretende converter.
No menu de atalho, aponte para Alterar para e, em seguida, clique em Tabela de repetição.
Na caixa de diálogo Alterar para Tabela de Repetição, efetue um ou mais dos seguintes procedimentos:
- Para especificar as linhas de cabeçalho da tabela de repetição, introduza um valor na caixa Número de linhas a manter como cabeçalho de tabela . Normalmente, utiliza a linha de cabeçalho para cabeçalhos de coluna.
- Para especificar as linhas de rodapé para a tabela de repetição, introduza um valor na caixa Número de linhas a manter como rodapé de tabela . Muitas tabelas não incluem linhas de rodapé.
- Para especificar o número de linhas de dados a utilizar, introduza um valor no Número de linhas repetidas a incluir ao preencher a caixa de formulário . A linha de dados é uma linha que pode "repetir" no formulário quantas vezes forem necessárias
No menu Inserir , clique em Mais Controlos ou prima ALT+I, C.
Introduza os controlos pretendidos nas células da tabela.
Alterar as caixas de seleção para um grupo de botões de opção
Se tiver utilizado várias caixas de marcar no documento Word, o InfoPath importa-as como caixas marcar no modelo de formulário do InfoPath resultante. Se preferir utilizar um grupo de botões de opção, siga os passos abaixo para converter as caixas de marcar em botões de opção no seu modelo de formulário.
Pode utilizar um grupo de botões de opção num modelo de formulário do Microsoft Office InfoPath quando quiser que os utilizadores possam fazer apenas uma seleção de um conjunto limitado de opções.
- No modelo de formulário, clique numa das caixas de marcar que pretende converter e, em seguida, mantenha premida a tecla Ctrl e clique em cada caixa de marcar adicional que pretende converter.
- No menu Editar , aponte para Alterar para e, em seguida, clique em Botão de opção.
É agora apresentado um grupo de botões de opção em vez das caixas de marcar no seu modelo de formulário. Cada botão de opção está vinculado ao mesmo campo na origem de dados. Quando um utilizador clica num botão de opção, o valor associado a esse botão de opção é armazenado no campo.
Rever problemas de conversão no painel de tarefas Verificador de Design
Por vezes, os elementos do documento Word original não são apresentados conforme esperado no modelo de formulário do InfoPath resultante ou são removidos durante o processo de conversão. Por exemplo, o InfoPath não suporta a funcionalidade Word WordArt e substitui os objetos WordArt por imagens de marcador de posição no modelo de formulário resultante.
Se o InfoPath detetar problemas durante o processo de conversão, o painel de tarefas do Verificador de Design será aberto automaticamente após fechar o Assistente de Importação. No painel de tarefas, pode rever uma lista dos problemas e tomar as medidas necessárias para os corrigir.
Se o painel de tarefas Verificador de Design não estiver visível, clique em Verificador de Design no menu Ferramentas .
Se existirem problemas com o modelo de formulário, verá as mensagens no painel de tarefas.No painel de tarefas Verificador de Design , clique no texto da mensagem que você deseja revisar.
Uma caixa de diálogo apresenta informações adicionais sobre o problema.Observação
Se o documento Word contiver um objeto que o InfoPath não suporta, como um objeto de desenho Word, o InfoPath adicionará uma imagem de espaço reservado ao modelo de formulário resultante, indicando onde o objeto estava originalmente localizado no documento Word. Para saber mais sobre o objeto, clique com o botão direito do mouse na imagem de espaço reservado no modelo de formulário e clique em Mais detalhes no menu de atalho.
Se necessário, corrija os problemas no modelo de formulário. Por exemplo, poderá querer eliminar todas as imagens do marcador de posição que não se destinam a ser utilizadas no modelo de formulário preenchido.
Observação
Poderá reparar que o painel de tarefas Verificador de Design contém um botão Atualizar . Clicar no botão Atualizar não atualiza as mensagens apresentadas como resultado da importação de um documento Word para o InfoPath. Se pretender remover mensagens importadas do painel de tarefas Verificador de Design, tem de abrir a caixa de diálogo Files de Recursos (menu Ferramentas) e, em seguida, remover o ficheiro com o nome ImportErrors.xml. Este ficheiro é criado automaticamente quando importa um documento Word para o InfoPath. Depois de remover o ficheiro ImportErrors.xml, clique em Atualizar no painel de tarefas Verificador de Design para eliminar permanentemente as mensagens importadas. O ficheiro ImportErrors.xml não é necessário para o modelo de formulário funcionar corretamente. Na verdade, por motivos de segurança, é uma boa prática remover esse arquivo antes de publicar seu modelo de formulário.